0
votes
1answer
28 views

Upgrade PHP-mysql Lib Centos 6 [duplicate]

I just delete all php and mysql and installed it again. but in PHPMyadmin i still get: Your PHP MySQL library version 5.1.69 differs from your MySQL server version 5.5.39. This may cause ...
0
votes
2answers
24 views

Centos Your PHP MySQL library version 1.5.73 differs from your MySQL server version 5.5.39 [duplicate]

I have recently updated my PHP version to 5.4 and my mysql version to 5.5 [root@**** ~]# php -v PHP 5.4.31 (cli) (built: Jul 25 2014 07:41:53) Copyright (c) 1997-2014 The PHP Group Zend Engine ...
1
vote
1answer
32 views

CentOS 5 : error in installing php-imap

can someone please help me with this CentOS 5 question? I am trying to install php-imap, i tried yum install php-imap but I am getting the following output: Loaded plugins: fastestmirror, ...
0
votes
0answers
20 views

Enable Soap for PHP 5.5.x on CentOS 6.5

Unfortunately I have to support soap on my server for the Fedex webservice. I recompiled PHP enabling support and it works via CLI but not PHP-fpm. They both point to the same ini file and both show ...
-1
votes
1answer
67 views

Memory Ram too high in HTTPD processes

I management two dedicated servers. I use Centos 6 with Plesk Panel. Update: I use Apache with mod_php. On the first server I have a site in Wordpress. I have noticed that my httpd processes take ...
0
votes
1answer
52 views

Install mcrypt for php54 on centos 6.5

I'm completely new to VPS and am trying to install php54 on a centos6.5 server. I've updgraded the php version to 5.4 which appears to work. Currently using php5.4.31 However I now need to install ...
1
vote
1answer
19 views

disabling webtatic repo spitting back errors on centos

I installed the "webtatic" repo for PHP and it's caused nothing but trouble. When I try to run yum --disablerepo=webtatic distro-sync it returns this: Transaction Check Error: file ...
0
votes
2answers
40 views

yum install php-devel amongst other commands returning problems

I run yum install php-devel and it returns this. Typically I'd just run it with --skip-broken, but when I do, it still doesn't do the trick. Available: php-common-5.3.3-22.el6.x86_64 ...
0
votes
0answers
25 views

Setup PHP from source and mod_fgcid on CentOS 6, getting permission denied [migrated]

I have compiled PHP from source and installed it to /opt/php/5.5.15/ I have also installed (with yum) httpd, and mod_fcgid. I am trying to configure a virtual host to exec php like this: ...
0
votes
1answer
18 views

Where cURL store files in web server? [closed]

I have a centOS machine using a nginx web server. In my application (php) I use cURL to get a remote file and then send it to the view: $cache_expire = 60*60*24*365; header("Pragma: ...
0
votes
2answers
53 views

Apache web server intermittent stalls

Our SOAP web server is running in PHP on Apache on CentOS and makes heavy use of MySQL. There is heavy demand on the server - most requests are very small and involve only two or three MySQL queries, ...
0
votes
0answers
18 views

plesk 11.5 on centos - unable to set php to fastcgi

I am a complete newb to setting up servers so please be kind. I am trying to configure a VPS with a host. My aim is to install php5.4 - current setup is: centos 6 plesk 11.5 php 5.3 Reading a ...
1
vote
1answer
52 views

PHPmailer won't authenticate on CentOS

I've seen this issue posted before, but haven't found an answer. My phpmailer script works on Wamp, but won't on Centos. I've disabled SELinux and IPtables just in case. I also ran "telnet ...
1
vote
1answer
71 views

Managing differences in Ubuntu and CentOS features when deploying app

We have a problem that our programmer uses Ubuntu to develop advanced php application (advanced because he installs many extensions/seperate databases/utilities) and the problem is that whenever he ...
2
votes
2answers
165 views

Cant install php-posix on CentOS 6

I'm trying to install php-posix on CentOS 6, with no luck: $ yum install php-posix Getting the following error: Loaded plugins: downloadonly, fastestmirror Loading mirror speeds from cached ...
0
votes
2answers
64 views

How to let user create folder and upload file, lamp permission [closed]

I use mkdir($folder_path, 0755) in localhost(MAMP) it works, but after I move to VPS I use LAMP it failed. Folder the direction path is /var/www/html/assets/images/ the images folder info: Owner: ...
1
vote
1answer
35 views

Apache serving modified static assets incorrectly: serves obsolete file with sizes adjusted to match that of the new file [duplicate]

I've got a CakePHP project running in a CentOS VirtualBox. The website is served with Apache 2.2.15. There are JS files in the document root folder. Apache seemed to serve them file. But after i ...
1
vote
2answers
129 views

php pdo connection cannot be established, but mysql command line client can

situation as follows: php script on server a, run by user 'web' (nginx + php-fpm) should access mysql on server b via pdo library, but gets SQLSTATE[HY000] [2003] Can't connect to MySQL server on ...
0
votes
1answer
355 views

502 Bad Gateway - Nginx, spawn-fcgi, WordPress

I host several sites on a CentOS VPS, and all was working fine until one of the WordPress sites on the server started returning a 502 Bad Gateway error. Other sites work fine. The WordPress site will ...
0
votes
1answer
139 views

Install php 5.5 on centos with puppet

I am trying to get a more recent version of php and mysql on a centos 6.5 x64 box. I added the yum repos epel and remi and have the remi as a dependency for php but it will not install. The error I ...
2
votes
1answer
57 views

centos + php leak memory, but where?

I have a big php cronjob that run every 20minutes. After each execution the RAM memory used by the virtual server increase and not properly free once the script is terminated! But why? The memory ...
0
votes
0answers
271 views

Getting multiple pools working using PHP-FPM and Apache 2.4

I've been running into an issue with PHP-FPM pools not being able to start up if they're not on port 9000. I get the following error when I try to start a second pool on, say, port 9001: Jun 13 ...
1
vote
1answer
238 views

After compiling PHP, I get mod_fcgid: error reading data from FastCGI server

I'm trying to add multiple PHP version in Plesk 12. Switching my domain to the new version PHP 5.4.29 result in this error: (104)Connection reset by peer: mod_fcgid: error reading data from ...
1
vote
1answer
914 views

Downgrading PHP 5.4 to 5.3 on CentOS 6.5?

I am trying to downgrade PHP from 5.5.8 to 5.3.x. I have tried this but it dint work for me. yum downgrade php The error I have got is Loaded plugins: fastestmirror, refresh-packagekit, ...
0
votes
1answer
76 views

NFS default to 777

I have an NFS share. This share is shared between several different applications. Our web server is running PHP and when it creates directories it is not setting the permissions correctly so it cannot ...
0
votes
1answer
72 views

httpd dead but subsys locked with both ioncube and ZendGuardLoader installed

I installed a php extension ioncube, and restart the httpd, then I got this error "httpd dead but subsys locked". I googled for the solution, and found out I need to comment out the line ...
1
vote
1answer
59 views

CentOS I/O blocking flushing dirtypages

I have an Apache webserver on CentOS. It is not doing anything fantastic or complicated at all but it does at intervals experience a high load (120 for 4 CPUs) for some reason. During this time I see ...
-1
votes
1answer
628 views

how to check ffmpeg if install on centos/php [closed]

hi there how can I be sure that ffmpeg is install in my server... I tried this php code to check: <?php $ffmpeg = trim(shell_exec('which ffmpeg')); // or better yet: $ffmpeg = ...
0
votes
2answers
619 views

No PHP-GD package available on Yum… But it is

What I've done so far Installed CentOS 6.5 x64 Installed cPanel Added REMI and EPEL repositories to the system Tried yum --enablerepo=remi,epel install php-gd The response: No package php-gd ...
2
votes
1answer
390 views

PECL APC install — ERROR: 'make' failed

I get the following error when running sudo pecl install apc. /var/tmp/APC/apc_cache.c: In function '_apc_cache_user_update': /var/tmp/APC/apc_cache.c:818: error: 'IS_CONSTANT_INDEX' undeclared ...
-1
votes
1answer
48 views

Can't seem to install PHP-FPM5?

I am reading some advice on the internet for a solution to another issue I have. It requires me to change the listen to /var/run/php5-fpm/php5-fpm.sock. I however don't have that folder.. I have a ...
2
votes
0answers
239 views

PHP Files being downloaded instead of displayed in browser

I created a VPS using Nginx and I tried to display the php info with: <?php phpinfo(); ?>. Instead, the browser asks me to download the php file, and it's not parsed either. This happens only ...
0
votes
1answer
51 views

Connection timing out on webserver?

My server is currently timing out when I try to view the site. I tried restarting nginx. I tried restarting php-fpm. I tried restarting mysql. No dice. I tried rebooting the box. Still no dice. ...
0
votes
0answers
29 views

Why are emails sent from postfix getting bounced from gmail as spam? [duplicate]

I am working on a codeigniter project in php that sends emails. In the email config file its setup to use sendmail but in the logs it shows that its going though postfix. I get a bounce back in the ...
-1
votes
1answer
600 views

Scheduled Task issue - /usr/bin/php/: No such file or directory

Can't get it working, I want to set up a cron job for a domain user in plesk 11.5, but seems that there's a problem to find the php executable. The command is: /usr/bin/php/ -f ...
0
votes
0answers
10 views

how to resolve yum replace php-common --replace-with=php55w-common error? [duplicate]

how to resolve yum replace php-common --replace-with=php55w-common error? on CentOS 6.5 root@server [~]# yum replace php-common --replace-with=php55w-common Loaded plugins: fastestmirror, replace, ...
0
votes
2answers
656 views

Change apache (PHP) $PATH environment variable on CentOS with cPanel

I need to add a path to $PATH environment variable for PHP scripts on CentOS linux server with cPanel Pro 1.0 and Apache 2.2.27. For Ubuntu or SuSE it just means adding the row export ...
1
vote
0answers
122 views

Can't load Mongo extension in php.ini

I'm having some issues while try to load mongo.so extension at php.ini. Below is what I tried: Compile the mongo extension by following the documentation at php.net for MongoDB site. This resumed ...
0
votes
2answers
921 views

Apache fails to start after PHP upgrade on CentOS 6.5 x64

I have a developer server with CentOS 6.5 and PHP 5.5.11 (latest from REMI repos). Today I did: yum --enablerepo=remi,remi-php55 update That updated Apache and some other libraries like Mongo for ...
0
votes
3answers
549 views

PHP exec “unable to fork” intermittent error on CentOS VPS

Using: PHP 5.5.10 nginx 1.5.10 Centos 6.5 a xen-based 4GB VPS My site uses encrypted paypal buttons. This encryption is done by the following code: $openssl_cmd = "($OPENSSL smime -sign -signer ...
-1
votes
1answer
61 views

mails doesn't fire from php script - some issue with vps configuration

I am unable to fire any email from the php scripts on my vps server. I went to check in the logs and found this: Mar 26 05:53:30 corporatepixels sendmail[23772]: STARTTLS=client, ...
1
vote
1answer
250 views

Can't send email via PHPMailer

I'm using the PHPMailer class to send email from an online application, it works fine on development server, and if I disable iptables. However whenever iptables is started, no mail sends - it seems ...
0
votes
1answer
14 views

php is not interpreting inpinfo on new centos install

I just installed latest centos as a desktop version. Then I installed php via yum and turned on httpd. Php code is being interpreted, but phpinfo() is messed up. I see all the html code as well as the ...
0
votes
0answers
194 views

Unable to install Phpmyadmin on Centos 5, missing dependency php-common

I keep getting this error when trying to install Phpmyadmin: Setting up Install Process Resolving Dependencies --> Running transaction check ---> Package phpMyAdmin.noarch 0:2.11.11.3-2.el5 set ...
1
vote
1answer
116 views

What does ā€œuā€ in an rpm filename stand for?

I currently have PHP 5.4 installed. These packages are all prefixed with "php54-" (pecl, pear, pdo, fpm, gd, mysql, etc). I'd like to make the transition to 5.5. The packages are available... ...
0
votes
1answer
460 views

Cannot install PEAR on Centos 6.5 and PHP 5.5

This is driving me nuts already and there's no information about this whatsoever in Google, only 2006 posts, but they don't really help me. I have CentOS 6.5 freshly updated, PHP 5.5, MySQL, Apache, ...
0
votes
0answers
119 views

Webserver high cpu usage and slow responses

I would like to find bottleneck for web server (running on 32GB RAM/24 cores HT enabled, apache/mod_php). Here are my observations, memory does not seem to be a problem (only 10MB of swap) very ...
0
votes
1answer
2k views

Resolving “php54w-common-5.4.24-1.w6.x86_64 conflicts php-common < 5.4.0”

We're running CentOS release 6.5 and PHP 5.4.24, and I'm trying to get mcrypt-php installed. When I follow the instructions at ...
0
votes
1answer
1k views

Trying to install gd, getting conflict error

I am trying to install gd using sudo yum install php-gd but I get the error below. I know I have ran into this problem before but I can't seem to recall how I got around it. Am I in the wrong ...
0
votes
1answer
17 views

apache: add external .conf files dynamically?

I create directories dynamically and for each of them I have to set a custom open_basedir directive. I plan to use the apache's <directory> directive, combined with php_admin_value calls. But ...