The tag has no wiki summary.

learn more… | top users | synonyms

0
votes
0answers
12 views

PHP configure prefix not finding php-config

I am installing phalcon, and while I have my setup working fully I am confused by the configure generated by phpize. Specifically, why do I have to pass --with-php-config - I thought setting ...
1
vote
0answers
9 views

config variable php_suffix does not match

I have a php instance on Webuzo (centos-6-x86_64.openvz) in /usr/local/apps/php54/. It already has pecl and phpize in /usr/local/apps/php54/bin/. When installing igbinary with command ...
1
vote
1answer
192 views

Error after installing mysqlnd_ms

I am working on Amazon EC2 using the Amazon Linux AMI which is based on CentOS. I have installed php54 and php54-mysqlnd. Then I do a sudo pecl install myslqnd_ms. This installs fine. I add the ...
3
votes
2answers
870 views

phpize: m4 error just in one extension

On Linux, I installed php 5.3.8 from source. Using phpize for installing an extension works fine but not on one specific extension (mysqlnd). # cd /opt/php/5.3.8/ext/pdo && ...
3
votes
1answer
2k views

“Unable to initialize module” fileinfo php-pecl-Fileinfo.x86_64

I have a brand new server server that I am trying to get setup up. This is a 64 bit machine that I can not install "fileinfo" or "memcache". I have uninstalled these and reinstalled them using yum ...
1
vote
0answers
27 views

How to enable ffmpeg php extention in Cent OS 6.5 server with php 5.5

I need to create a screen shot from video, I have followed this tutorial to do the intial setup in window 8, php 5.3 I downloaded the ffmpeg from here for 64 bit operating system. I followed the ...
1
vote
0answers
14 views

Configuring openldap/PHP LDAP against “signed” LDAP connections with Active Directory

This may sound like a stupid question, and maybe it's already been answered, but I can't find a definitive answer anywhere, so I thought I'd ask. When someone enables "Domain controller: LDAP server ...
0
votes
1answer
883 views

How to fix Apache from crashing with PHP+Curl on an SSH request?

My Apache process segfaults whenever I call curl_exec() from PHP with an "https://" URL. If I use http instead of https as the URL transport, it works perfectly, so I know curl and the other curl ...
1
vote
1answer
1k views

SUSE 12.1 Apache startup after oci8 installation

I have got a virtual server running opensuse 11.4 with apache, php, oracle instantclient, and oci installed through pecl. The steps it took for me to have it up and running on 11.4 were: # Install ...
-5
votes
1answer
209 views

php5.6.2 installation with httpd24 ( apache version 2.4.10 ) on centos/rhel [closed]

using this repo : http://dl.iuscommunity.org/pub/ius/stable/CentOS/6/x86_64/ius-release-1.0-13.ius.centos6.noarch.rpm for php installation , and for apache i am using amazon linux repo current ...
1
vote
2answers
341 views

Error while installing php extension 'expect'

I got some serious error while installing expect extension in PHP. I ran sudo pecl install channel://pecl.php.net/expect-0.3.1 I got error like this while running make, running: make /bin/bash ...
0
votes
1answer
33 views

Apache “No such file or directory” doesn't give me a file name

I'm using an Apache / Ubuntu config. After installing php-gd library, I am getting error messages in my /chroot/httpd/var/log/apache2/error.log file (/chroot/httpd/ being the "jail" in my chrooted ...
0
votes
1answer
113 views

Yum php-yaml install issues

We had an issue with an ansible playbook using vagrant - where formerly php-yaml was installing fine. Then, we were getting issues with our PHP repo: [vagrant@localhost ~]$ sudo yum install php-yaml ...
1
vote
2answers
22 views

fractions Display Error

I migrated my website to new server. However, i got the error with fractions Display. Here is the error: On the old server: I installed the same extensions for php. What am I missing? Thanks. ...
0
votes
2answers
2k views

How can clear cache in eAccelerator?

I can't clear the cache in eAccelerator. I have deleted all files from the directory /var/cache/php-eaccelerator/* with the following command: rm -rf /var/cache/php-eaccelerator/* But this does not ...
0
votes
0answers
113 views

RedHat Yum Install Errors (PHP Module)

All, I am trying to use yum to install a PHP module which I expected to take all of five minutes... After quite a bit more than that I am stumped. Yum is throwing an error about a dependency missing ...
1
vote
2answers
2k views

Install & Configure PHP to MS SQL Server on Windows 7 (64bit)

I have been striggling to set up the following scenario: Apache 2 (64bit) running on Windows 7 (64bit) PHP (64bit) MS SQL Express 2008 as (local) I have managed to install and configure both ...
0
votes
2answers
626 views

Unable to install Wordpress on Amazon's EC2 instance due to missing php-mbstring

I've created a new instance on Amazon's EC2 and I'm trying in wordpress and it's failing due to php-mbstring: # yum install wordpress Loaded plugins: amazon-id, rhui-lb Resolving Dependencies --> ...
0
votes
1answer
269 views

Can't get pspell to work

I installed aspell\pspell, and if I do > aspell dump dicts ar cs de de_AT de_CH de_DE en en-variant_0 en-variant_1 en-variant_2 en-w_accents en-wo_accents en_CA en_CA-variant_0 en_CA-variant_1 ...
0
votes
0answers
238 views

Configure VestaCP - NGINX to be extension less

Currently, my VestaCP NGINX configuration is like this: location / { proxy_pass http://65.181.118.46:8080; location ~* ...
0
votes
1answer
888 views

How to configure Ajenti V hosted website with extension less URL

I am trying ways to configure my website to be extension less. That is when .php or .html files are visited, it'll be redirected to an URL without the extension. Eg: www.mywebsite.com/products.php ...
0
votes
1answer
125 views

Can't install php-mysql module

First time using php 5.5 and well I'm getting a lot of headaches. I can't install php-mysql, I get the following error: Error: Package: php-mysql-5.4.30-1.el6.remi.x86_64 (remi) Requires: ...
1
vote
2answers
563 views

CentOS6 PHP extension install: Cannot find php-config. Please use --with-php-config=PATH

This may seem trivial to some, but I have been developing on Windows all my life and only moved to Linux this week - all is new to me. I've been following The following guide on how to install php ...
3
votes
1answer
1k views

How can I install phalcon (or any custom PHP module/extension) on my shared cPanel web host? [closed]

Is it possible to install phalcon (a custom PHP PECL extension/module) on a shared web hosting service that uses cPanel, or is it normally something that requires root access? That is, can I still ...
0
votes
1answer
466 views

Installing ext-libevent, ext-libev, ext-event for php

I installed reactphp on my LAMP environment (CentOS 6.4). After the installation was successful, I got this message: react/react suggests installing ext-libevent (Allows for use of a more performant ...
0
votes
0answers
192 views

How to install gearman on Ubuntu12.04 and php54?

I am trying to install gearman on my Ubuntu12.04 machine. I have upgraded php to version 5.4 via the ppa php5-oldstable. I downloaded the source of gearmand-1.1.12 and compiled it and installed it ...
1
vote
2answers
2k views

The requested PHP extension ext-mcrypt * is missing from your system

I have updated my php to version 5.4.13 etc and well in the terminal my version of php states this PHP 5.4.12 (cli) (built: Mar 16 2013 21:46:23) But running a composer install io get the ...
0
votes
0answers
242 views

Issue Running Imagick module (PHP 5.4.13, WAMP server)

I have been trying to solve the issue with my production server for the past few hours now. The issue I am encountering relates to the PHP module Imagick (Image Magick). I am running a WAMP server on ...
1
vote
1answer
172 views

PHP CLI with IMAP, 5 second startup delay

Having installed "php-imap-5.3.3-27.el6_5.x86_64" on a RedHat Enterprise 6.5 server, the CLI version of PHP always takes 5 seconds to run: php -n -d extension=imap.so -v PHP 5.3.3 (cli) (built: Dec ...
1
vote
3answers
4k views

pecl_http extension not loading

For some reason pecl_http extension is not showing up in my test.php file with contains: <?php phpinfo(); ?> I just installed pecl_http using: pecl install pecl_http The install was ...
1
vote
3answers
2k views

Compile pHash on Centos + PHP extension

I'm trying to compile pHash 0.9.5 on Centos 6.3 x86_64 Here is the detail of the steps I've followed: $ yum install unzip $ wget https://downloads.sourceforge.net/project/cimg/CImg-1.5.4.zip $ unzip ...
3
votes
2answers
3k views

cPanel on CentOS: PHP with ZIP?

I've been tasked with a project to install PHP 5.2.x so that it has the ZIP extension onto a CentOS server that is already running PHP via cPanel / Easy Apache. Apparently cPanel's version of PHP ...
0
votes
0answers
318 views

Nginx + php-fpm + Zend Opcache + php 5.3.10 - Dynamic Generated CSS|JS

I have the Zend Opcache pecl extension working almost completely- except for that I have 4 files that technically are content-types of css and js - but are "php" files and get sent through fastcgi and ...
0
votes
0answers
107 views

uploadprogress.so is installed, but does not appear in phpinfo

I'm on RHEL6 (Red Hat Enterprise Linux Server release 6.5 (Santiago)), but I've upgraded PHP to version 5.4.16. I've downloaded and installed the PECL uploadprogress library version 1.0.3.1 that is ...
0
votes
0answers
431 views

How to check if php-apc is running?

I've installed APC using 'pecl install apc'... apc sucessfully installed... I copied this file /local/lib/php/apc.php to my www directory, to see stats: But accessing this url I can see it's not ...
0
votes
1answer
762 views

MongoDB: unable to load driver on PHP [closed]

I'm trying to make mongo-php-driver work with PHP 5.5.7 on OS X 10.9.1 but I came to a dead end, I've tried everything I could possibly find and nothing works... Everything compiles just fine, but ...
1
vote
3answers
4k views

CentOS 6: PHP can not load gdchart.so and oci8.so compiled by me

I have been trying to add 2 PHP extensions to a freshly installed CentOS 6.0 Linux server, but get the error messages in /var/log/httpd/error_log: [notice] SELinux policy enabled; httpd running as ...
0
votes
1answer
421 views

Undefined symbol “php_libxml_disable_entity_loader”

I have php5.4 installed.It runs on freebsd server I also use soap.so extension. But when I start php script (new SoapClient) it stopped. Apache logs: tail -f /var/log/httpd-errors.log : ...
-1
votes
2answers
2k views

How to build & install pgsql PHP extension manually on Ubuntu

I've searched high and low and haven't found anything. Perhaps I don't know what to search for. Environment is Ubuntu Lucid (10.4) with PHP 5.2.4 & PostgreSQL 9.2. PHP is "held" at 5.2.4 with ...
0
votes
0answers
347 views

PHP extension (XHProf) installation problems with PHP 5.5.3

Recently I have upgraded my PHP on Ubuntu 10.04 to the lastest 5.5.3 version, and XHProf profiler stops working. I have compliled last version of xhprof PHP extension (either from official pecl site ...
14
votes
4answers
25k views

how to restart/clear memcache without restarting the whole web server?

/opt/eduserver/eduserver gives me options: Usage: /opt/eduserver/eduserver ...
0
votes
2answers
201 views

PHP extension is not loading when running fcgid

I need to use the libpuzzle extension for PHP, and so far I failed to make it run with fcgid. I have installed it (manually, unfortunately, because of the dependency issues) and added the ...
-1
votes
2answers
149 views

Installing php extension with yum [closed]

I'm very new to Linux and yum. I need to install a php extension (ioncube loader) using yum, but I'm not sure how exactly this is done. I'm going off this article, which tells me I need to run the ...
0
votes
2answers
251 views

Bundling tidy-html5 with PHP?

I want to setup the W3C fork of HTMLTidy (tidy-html5) as a PHP extension. I had installed the normal php/tidy extension using the php5-tidy package. I then downloaded the Git repository, and ran the ...
3
votes
1answer
5k views

How to install/enable GMP (math functions) for PHP on Ubuntu?

When calling a gmp math function like gmp_mod, I get: Fatal error: Call to undefined function gmp_mod() I have installed the php5-gmp package and restarted the web-server, and the function is still ...
-3
votes
2answers
1k views

Can't install PHP PDO [closed]

I have now tried to install PHP PDO in 2 hours without any luck, and i have searched everywhere to get a solution - but without any luck. yum install php-pdo doesn't work and i cannot find ...
0
votes
3answers
3k views

Trying to install php-soap and getting the 'No package php-soap available.'

Tried this: yum install php-soap Says: No package php-soap available. Then tried this: yum --enablerepo=centosplus install php-soap Still same sh!t. Tried this: rpm -Uvh ...
9
votes
4answers
33k views

How to --enable-dom without recompiling PHP?

From the output of phpinfo(), --disable-dom are included the configure command. How do I change it to --enable-dom without recompiling PHP? Edit: I'm using Fedora 10. The PHP i'm using is the one ...
1
vote
2answers
1k views

Trouble installing xhprof

I'm currently trying to install the xhprof (PECL) extension onto my Mediatemple gridserver. I'm having a bit of a time of it since write restrictions won't allow the PECL installer to work. I've done ...
0
votes
1answer
467 views

Installing Gearman with PHP Extension on Debian 6.0.5 leads to error

What I have tried ... # apt-get install php5-dev # apt-get install gearman-job-server libgearman-dev # pecl install gearman Result ... ... configure: error: Please install libgearman ERROR: ...