The tag has no wiki summary.

learn more… | top users | synonyms

12
votes
4answers
17k views

how to restart/clear memcache without restarting the whole web server?

/opt/eduserver/eduserver gives me options: Usage: /opt/eduserver/eduserver ...
9
votes
4answers
31k views

How to --enable-dom without recompiling PHP?

From the output of phpinfo(), --disable-dom are included the configure command. How do I change it to --enable-dom without recompiling PHP? Edit: I'm using Fedora 10. The PHP i'm using is the one ...
5
votes
1answer
3k views

Trying to install pecl Solr extension but it needs curl

When I try to install solr-beta: pecl install solr-beta I get this error: pecl/solr requires PHP extension "curl" No valid packages found install failed The thing is curl is already installed and ...
3
votes
1answer
8k views

Enable php extension within .htaccess

Does anyone know how to enable a PHP extension within the .htacess file? Possibly: (.htaccess file) php_value extension=php_soap.so
3
votes
1answer
385 views

PHP DL Function

Is allowing dynamic extension loading dangerous for some reason? I ask because I need it to include the pecl oauth.so extension to make the Google Adwords PHP SDK work using dl(). I've tried all ...
3
votes
2answers
2k views

V8js PHP module on Linux - can't find libv8.so

Running into a problem with v8js-0.1.2 (beta) - I'm seeing others have success on the net but regardless of what platform/OS I'm running, I always hit the same problem. I'm currently attempting to ...
3
votes
2answers
853 views

Error on installing SVN extension with pecl

I'm trying to install the following PHP extension: http://php.net/manual/en/book.svn.php But when I do pecl install svn-beta I receive an error message that it can't locate the svn_client.h file. I ...
3
votes
2answers
763 views

phpize: m4 error just in one extension

On Linux, I installed php 5.3.8 from source. Using phpize for installing an extension works fine but not on one specific extension (mysqlnd). # cd /opt/php/5.3.8/ext/pdo && ...
3
votes
2answers
2k views

cPanel on CentOS: PHP with ZIP?

I've been tasked with a project to install PHP 5.2.x so that it has the ZIP extension onto a CentOS server that is already running PHP via cPanel / Easy Apache. Apparently cPanel's version of PHP ...
3
votes
1answer
2k views

“Unable to initialize module” fileinfo php-pecl-Fileinfo.x86_64

I have a brand new server server that I am trying to get setup up. This is a 64 bit machine that I can not install "fileinfo" or "memcache". I have uninstalled these and reinstalled them using yum ...
2
votes
2answers
233 views

Do I need all of these Apache modules?

I'm getting 9 second load times on a very powerful server. Query time is .05 and total php time is 9 seconds. Not good! I took a look at my list of apache modules and I'm wondering if there's a ...
2
votes
3answers
3k views

How to force CentOS yum to use a later version of a package dependency already installed (php-common as a dependency of php-xml)

It would appear that the version I have of php-common-5.2.10-1.el5.centos is newer than the one being asked for as a dependency of php-xml when I try to install php-xml using yum install php-xml. The ...
2
votes
3answers
1k views

How can I pass configure options when installing php extensions with pecl?

There is a PHP extension to which I need to pass a configure option when I install it with a pecl command. I can't find a way to do this. Of course I can install it manually, but I need it to be able ...
2
votes
2answers
193 views

“Installing” GD for PHP

I'm new to server admin & Linux and have just got a VPS running CentOS 6. Apache, MySQL and PHP all came installed (along with cPanel and WHM), however I'm now also trying to install the GD ...
2
votes
1answer
3k views

How to install/enable GMP (math functions) for PHP on Ubuntu?

When calling a gmp math function like gmp_mod, I get: Fatal error: Call to undefined function gmp_mod() I have installed the php5-gmp package and restarted the web-server, and the function is still ...
2
votes
1answer
230 views

Why are my php extensions being compiled for PHP4 and not PHP5

I'm trying to compile memcache for Dreamhost PS. The library is created but not shown in phpinfo. Apache logs says the library isn't loaded because "undefined symbol: OnUpdateInt in Unknown on line ...
2
votes
0answers
229 views

MagickWand PHP Module DDL for Windows

I'm struggling with enabling MagickWand as a PHP extension which is ran on Windows (Apache). I am running PHP 5.3.x. (I need namespaces). I have been able to install MagickWand on PHP 5.2.4 but not ...
1
vote
3answers
3k views

pecl_http extension not loading

For some reason pecl_http extension is not showing up in my test.php file with contains: <?php phpinfo(); ?> I just installed pecl_http using: pecl install pecl_http The install was ...
1
vote
1answer
3k views

How can I find installed php extensions on Debian?

Is it possible to get a list of installed php extensions on Debian? Is there any simple way to find which extensions exist in debian php packages and which have to be compiled manually (actually three ...
1
vote
3answers
1k views

Compile pHash on Centos + PHP extension

I'm trying to compile pHash 0.9.5 on Centos 6.3 x86_64 Here is the detail of the steps I've followed: $ yum install unzip $ wget https://downloads.sourceforge.net/project/cimg/CImg-1.5.4.zip $ unzip ...
1
vote
3answers
3k views

CentOS 6: PHP can not load gdchart.so and oci8.so compiled by me

I have been trying to add 2 PHP extensions to a freshly installed CentOS 6.0 Linux server, but get the error messages in /var/log/httpd/error_log: [notice] SELinux policy enabled; httpd running as ...
1
vote
2answers
4k views

php-xml install complains of dependency php-common but this is already installed (CentOS)

How do I force php-xml to see the already installed dependency? sudo yum install php-xml complains about: php-common = 5.1.6-34.el5_8 but running yum install php-common ...
1
vote
2answers
14k views

OpenSSL extension for PHP in Ubuntu?

I'm not sure how to recompile PHP with OpenSSL? I've been looking around the OpenSSL PHP page and the OpenSSL tutorials but I don't see any openssl.so or php-openssl.so around my server? Is there a ...
1
vote
1answer
134 views

missing config files when compiling a php extension

I do the phpize.. When I reach the ./configure It tells me it can fins the php-config (configure: error: Cannot find php-config. Please use --with-php-config=PATH) I assume it means a file named ...
1
vote
1answer
3k views

Can we have 2 'extension_dir' in php.ini?

When I installed pdo-pgsql, the extension was installed into /usr/lib/php/extensions/no-debug-non-zts-20090626/ and thus not automatically loaded. In php.ini, I have extension_dir = ...
1
vote
1answer
144 views

PHP upgrading to 5.3.3 - what should I be aware of?

I have a VPS that's hosting half a dozen PHP-based sites. All is OK on php5.2.10 but I want to upgrade to 5.3.3. I have tested the functionality of the sites on my local dev machine running 5.3.1 and ...
1
vote
2answers
95 views

CentOS6 PHP extension install: Cannot find php-config. Please use --with-php-config=PATH

This may seem trivial to some, but I have been developing on Windows all my life and only moved to Linux this week - all is new to me. I've been following The following guide on how to install php ...
1
vote
1answer
243 views

How can I install phalcon (or any custom PHP module/extension) on my shared cPanel web host? [closed]

Is it possible to install phalcon (a custom PHP PECL extension/module) on a shared web hosting service that uses cPanel, or is it normally something that requires root access? That is, can I still ...
1
vote
2answers
3k views

PHP - Extensions - no-debug-non-zts-xxxxxxxx

I am compiling php extensions (memcached and xdebug), and when I run make install, they keep getting installed into /usr/local/php/lib/php/extensions/no-debug-non-zts-20090626. So a few questions: ...
1
vote
2answers
2k views

Changes made to cli's php.ini not taking effect

I have two php.ini files - /etc/php.ini which loads in case of cli /opt/lampp/etc/php.ini which loads in case of browser. I am able to use PHP's Mailparse extension after adding the line ...
1
vote
2answers
1k views

PHP in snow leopard

Snow leopard comes with PHP already installed and configured I am running a web application on a development server which has MAMP and the system runs fine however when I put the application on a ...
1
vote
2answers
609 views

PHP Fatal error: Call to undefined function enchant_broker_init() - enchant not found?

I have php 5.3.10 (and CentOS 6) and as I understand enchant automatically comes with it. When I try to run an example like $tag = 'en_US'; $r = enchant_broker_init(); $bprovides = ...
1
vote
1answer
321 views

Error while installing phabricator using http://www.phabricator.com/rsrc/install/install_rhel-derivs.sh

The command thats run is yum install httpd git php php-cli php-mysql php-process php-devel php-gd php-pecl-apc php-pecl-json mysql-server I get these errors. How do I fix these? Error: Package: ...
1
vote
1answer
249 views

Add module to custom compiled PHP

In CentOS I have a compiled version of PHP but it is missing IMAP module. Is it possible to add that module without re-compiling php?
1
vote
1answer
380 views

phpMyAdmin doesn't find mbstring eventhough it's installed

I'm running Kloxo at the moment and have updated phpMyAdmin to the latest version as well as php and mysql, however, phpMyAdmin seems to complain about mbstring not being installed, eventhough it is. ...
1
vote
1answer
2k views

Install & Configure PHP to MS SQL Server on Windows 7 (64bit)

I have been striggling to set up the following scenario: Apache 2 (64bit) running on Windows 7 (64bit) PHP (64bit) MS SQL Express 2008 as (local) I have managed to install and configure both ...
1
vote
1answer
366 views

PHP upgraded to 5.3.8 - Can't install/upgrade extensions

I managed to upgrade php from 5.2.10 to 5.3.8 in CentOS 5.4. Some of the extensions were lost in the process (mbstring, mysql). One quick run for: yum list installed | grep php Returns: ...
1
vote
1answer
536 views

Install PECL mailparse on XAMPP?

Similar to Is it possible to install Mailparse extension via PECL installation - without recompiling PHP I'm trying to install mailparse on xampp. XAMPP actually has a guide for this, and I've tried ...
1
vote
2answers
1k views

Trouble installing xhprof

I'm currently trying to install the xhprof (PECL) extension onto my Mediatemple gridserver. I'm having a bit of a time of it since write restrictions won't allow the PECL installer to work. I've done ...
1
vote
1answer
764 views

Is it possible to install Mailparse extension via PECL installation - without recompiling PHP

I am putting this question basically because I want to use PHP: Mailparse extension and stuck in its installation. But, I also want to know some basics of PHP extension installation - Please check ...
1
vote
1answer
4k views

PHP module installed but does not appear in phpinfo()

Im tying to install php5-ffmpeg module on my ubuntu server. I've typed: sudo apt-get install php5-ffmpeg Everything was installed and web server was reloaded. Now, the fallowing line is added to ...
1
vote
1answer
302 views

How to install gChartPhp (Google Charts) at CentOS 5 machine

I've copied gChartPhp into /var/www/html on my CentOS 5 Linux machine and it works ok, but I wonder if there is maybe a better way to install and maintain that code. I'm asking this because gChartPhp ...
1
vote
1answer
246 views

General introduction into handling PHP extensions on Linux

There are a lot of questions about how to get extension X for PHP Version Y on Linux Distro Z running. What I'm missing out there are comprehensive general tutorials about how PHP on Linux works. ...
1
vote
1answer
1k views

Reconfiguring PHP with OpenSSL Extension on CentOS

Long time browser, first time poster! I have a CentOS Dedicated server running just fine. I'm trying to reconfigure PHP to include the OpenSSL extensions so I can use some of the Youtube API's. I ...
1
vote
1answer
249 views

Error while installing php extension 'expect'

I got some serious error while installing expect extension in PHP. I ran sudo pecl install channel://pecl.php.net/expect-0.3.1 I got error like this while running make, running: make /bin/bash ...
1
vote
0answers
430 views

Soap client in Centos6, zval_property_ctor in Unknown on line 0

We're having such a big problem in our Centos server in order to have working the SOAP client of PHP 5.3.3. One of our customers reported us that they were having problems to consume some webservices ...
1
vote
0answers
166 views

Error after installing mysqlnd_ms

I am working on Amazon EC2 using the Amazon Linux AMI which is based on CentOS. I have installed php54 and php54-mysqlnd. I then do a "sudo pecl install myslqnd_ms" This installs fine. I add the ...
1
vote
1answer
313 views

PHP Configuration on IIS 6 Mysql extension is not loaded

I have limited knowledge of PHP. I would really appreciate your help. I have the problem with "PHPMyAdmin is not working because mysql extension is not loaded." I checked phpinfo and all other ...
1
vote
1answer
133 views

How can I figure out which PHP extensions aren't being used?

I manage a server (running Ubuntu) which hosts our client's sites with a few dozen different PHP-based websites, mostly small sites but also some installations of CMSes and forums. I used the ...
1
vote
1answer
1k views

SUSE 12.1 Apache startup after oci8 installation

I have got a virtual server running opensuse 11.4 with apache, php, oracle instantclient, and oci installed through pecl. The steps it took for me to have it up and running on 11.4 were: # Install ...