1
vote
1answer
68 views

ubuntu 12.04 apt-get purge php5 doesn't seem to remove php5

I recently made the mistake of upgrading to php5.5 without reading more up on it. It obviously broke my install of apache2.2. I'm in the process of trying to downgrade back to php5.3 or preferable ...
0
votes
1answer
874 views

“php5-fpm: unrecognized service” and other issues after reverting from PPA

Added a repository so that I could move from PHP 5.3 to 5.5 easily in Ubuntu 12.04.3 LTS. After adding the PPA and following most of the suggestions here http://askubuntu.com/a/109544 it seemed that ...
1
vote
1answer
846 views

Error after trying to install php5-mcrypt on Debian Squeeze

I want to install php5-mcrypt, but I get this error after entering a apt-get install php5-mcrypt Error: php5-mcrypt : Hängt ab von: php5-common (= 5.3.3-7+squeeze15) aber 5.3.9-1~dotdeb.2 soll ...
0
votes
1answer
112 views

Downgrade php5-cgi using APT on Debian

I have lighttpd install with PHP5.4 installed I need to downgrade it to 5.3.2 (possibly older/newer) but I can't install it I tried this apt-get install php5-cgi=5.3.2 but it says "E: Version ...
1
vote
3answers
450 views

Upgrade to the latest php by aptitude

I'm install php5 by aptitude, but php release the new version and recommend we upgrade. But I unwant to compile the new version by myself. How to upgrade the php to the newest version by aptitude?
4
votes
3answers
1k views

php5-gd shows in “php -i | grep -i gd” but not in phpinfo();

I am trying to enable GD in my installation of Apache2, PHP5 and MySQL on my Ubuntu server. I installed php5-gd with: apt-get install php5-gd And when I run php -i I get: gd GD Support => ...
2
votes
2answers
2k views

Installing php5-imagick in Ubuntu 12.04 w/ ondrej packages results in dependency error

I've been trying to setup an Ubuntu 12.04 VM that is running PHP 5.4 with the imagick module. All the results I find on google say to use the ondrej packages, which for the most part works perfectly. ...
0
votes
1answer
1k views

apache 2.4 with php on debian squeeze

I've just compiled and installed apache 2.4 on my debian squeeze machine. It was the first time I've compiled it on my own. My next step should be installing mod_php for the server. Now I was thinking ...
-2
votes
2answers
1k views

Need help updating PHP 5.2 to 5.3 (on Debian Lenny)

I need to update 5.2 to 5.3 in one of our servers urgently. My unix skills are limited so please be as specific as possible. Is there any way to do this easily with apt-get upgrade ?
0
votes
2answers
662 views

php ugrade error on ubuntu: packages have unmet dependencies

if I try to upgrade php on my vps with apt-get install php5-cli i get this error: The following packages have unmet dependencies: php5-cli: Depends: libc6 (>= 2.11) but 2.6.1-1ubuntu10 is to ...
1
vote
2answers
681 views

Can't install PHP after apt-get dist-upgrade

I had a server with perfectly running for months classical LAMP installation on Ubuntu 8.04: Linux localhost 2.6.24-23-generic #1 SMP Wed Apr 1 21:47:28 UTC 2009 i686 GNU/Linux DISTRIB_ID=Ubuntu ...
1
vote
1answer
6k views

How do I install php 5.2.10 on Ubuntu 10.04? [duplicate]

Possible Duplicate: PHP 5.2x on Ubuntu 10.04 Lucid Lynx I'm setting up a new Ubuntu server, but it's going to be running a somewhat old PHP application that seems to have conflicts with PHP ...
0
votes
2answers
3k views

Update php 5.2.0 to 5.2.4 with aptitude

I would like to update my php 5 in my server. At this moment, I use php 5.2.0 so I want to update it to php 5.2.4 (not php 5.3). I tried to do this: aptitude update aptitude upgrade 63 packets were ...
1
vote
3answers
2k views

Downgrading PHP from 5.3 version to 5.2.x on Ubuntu

I'm looking some some way to downgrade php from 5.3 version to 5.2.x on Ubuntu 9.10