The tag has no wiki summary.

learn more… | top users | synonyms

6
votes
4answers
5k views

Nginx + PHP 5.3.3 (with php-fpm) - memory usage?

I recently bought Xen VPS (linode.com) with Debian 5.0 Lenny (i386), 512MB RAM. At the moment I have only three small websites (built with Drupal) with about 600 users per day in total running on this ...
6
votes
3answers
31k views

CentOS 5: How to resolve php53 RPM dependency conflict with php-foo and php-common?

We are running a CentOS 5.6 system, and want to install php53 with php-mcrypt. However, this introduces a dependency conflict between php-common & php53-common. Does anyone have a good workaround ...
4
votes
1answer
3k views

Install php 5.3.6 on ubuntu 10.04 64 bit

I dont want to build from source and was looking to find some repository where I can simply do an apt-get install php5 and get the latest version. Does anyone know of any reliable source I can use to ...
3
votes
4answers
5k views

Can I run PHP 5.3 and PHP 5.2 on the same server with Apache?

I just curious if there's a way I can set up my development box so that I can have some sites running PHP 5.3 and some with PHP 5.2, and that I can switch between them fairly painlessly.
2
votes
1answer
114 views

Having a ball re-selecting PHP make config settings…FreeBSD

I am installing PHP 5.3 and having accidentally hit enter when selecting options failed to enable a module. After the installation make no longer gives me options but continues with saved options. ...
2
votes
1answer
732 views

Can't start Apache after attempt to upgrade to PHP 5.3.8

After attempting to upgrade my PHP version on Windows 7, I cannot start Apache. I get this error message: I used the Windows installer to upgrade to PHP 5.3.8 from 5.2, afterwards I was unable to ...
2
votes
4answers
659 views

How to install a sandboxed version of PHP 5.3 (so I can still use an older version of PHP)?

Our development server is running Ubuntu with PHP 5.2.14. I need PHP 5.3 to try out the Behat library. How can I install PHP 5.3 to satisfy Behat, but keep PHP 5.2.14 as the default PHP version (so ...
2
votes
2answers
393 views

What would be better in my case - apache, nginx or lighttpd?

I'm writing a PHP site that's expected to get about 200-300 concurrent users browsing it. When initializing the application will load about 30 PHP classes, some 10 maybe 15 images and a couple of css ...
2
votes
1answer
302 views

CLI SAPI based daemon, PHP app with cronjobs support

I need to build an CLI SAPI based daemon, PHP app with cronjobs support for iOS platform. We have dedicated server. What kind of PHP environment to run this type of PHP applications?
2
votes
1answer
502 views

open_basedir problems with APC and Symfony2

I'm currently setting up a shared staging environment for one of our applications, written in PHP5.3 and using the Symfony2 framework. If I only host a single instance of the application per server, ...
2
votes
0answers
332 views

linode cloud server, symfony and phar

Okay, So I've recently got a linode cloud server running Ubuntu 12.04. I got it configured with the default symfony2.0 installation, but I've got a project that runs on the Symfony2.1 installation.. ...
2
votes
1answer
969 views

Symfony 1.4.8 not working in PHP 5.3.4? [closed]

I have installed PHP version 5.3.4, and working on Symfony 1.4.8 with Propel as ORM. But while installing Symfony project, it is giving me error. When i use the command to build database it giving me ...
1
vote
1answer
8k views

Can't find Role Services in Windows 7

I'm trying to install PHP on Windows 7 Home Premium using these instructions: Using FastCGI to Host PHP Applications on IIS 7 and a 1/3 of the way down on the page I have to do this: Server ...
1
vote
2answers
380 views

PostgreSQL Left join select VS Normal select

I was wondering which is faster - joining several selects into one join select or actually doing the separate selects is faster ? I'm doing a task which has many tables(currently 4 but it'll increase ...
1
vote
2answers
2k views

php sessions files incompatible? - php5.2 debian lenny vs php5.3 debian squeeze

php is truncating the session files to zero after migrating the session files from server one (debian lenny php 5.2) to the new server (debian squeeze php 5.3). i create a session on server one with ...
1
vote
2answers
2k views

Running mod_php and suPHP same time

I recently went from Debian Lenny with 5.2.x and was able to use mod_php for any php files that were not located in /home/ and suPHP for all the php files that were located in /home/. I did this ...
1
vote
1answer
147 views

PHP-FPM max_requests parameter causes 502

On a setup using nginx with PHP-FPM v5.3.3, I noticed the following errors occurring frequently in the nginx' errors log: Feb 16 15:00:22 mymachine www.example.com 2015/02/16 15:00:20 [error] ...
1
vote
1answer
4k views

Installing PHP 5.5.6: Can't start php-cgi.exe - MSVCR110.dll is missing

I'm trying to update from PHP 5.3 to PHP 5.5 after downloading the last version from here and I'm having this error: Can't start php-cgi.exe - MSVCR110.dll is missing I've read that I need to ...
1
vote
1answer
3k views

I want to install php 5.3.9 in ubuntu 12.04 via apt-get - what repository should I add?

I want to install php 5.3.9 in ubuntu 12.04 via apt-get. apt-cache show php5-fpm only lists 5.3.10-1ubuntu3.1 and 5.3.10-1ubuntu3. There is a critical bug in 5.3.10 ( ...
1
vote
1answer
482 views

PHP upgraded to 5.3.8 - Can't install/upgrade extensions

I managed to upgrade php from 5.2.10 to 5.3.8 in CentOS 5.4. Some of the extensions were lost in the process (mbstring, mysql). One quick run for: yum list installed | grep php Returns: ...
1
vote
1answer
462 views

php53 in CentOS 5.6: which package?

I see (using GNOME Package Manager) that there are two PHP 5.3 packages available for CentOS 5.6. One of them is "php53-5.3.3-1.el5_6.1", and the other is ""php53-5.3.3-1.el5". What's the difference ...
1
vote
1answer
259 views

IIS 6 produces a 404 error whenever I try to access a php file (PHP 5.3.5)

This seems to be a frequent issue of IIS users who are trying to setup php - I guess I'm not an exception here. I followed serveral tutorials online for setting up PHP, and I am pretty sure that I ...
1
vote
2answers
6k views

Windows7 IIS7: zips don't have php5isapi.dll Can I use php.dll instead?

The page: How to Install PHP 5.2 on IIS 7and Windows Vista (and a few others) reference a mysterious php5isapi.dll which is not in the Windows install, or the zip files: php-5.3.2-Win32-VC9-x86.zip - ...
1
vote
1answer
118 views

is it safe for the Apache to be the owner of the session directory (php)

Since I have upgraded to php 5.3 I have issues with the session GC. Seems he can't access the directory which is owned by root, Although I see sessions are being created there. Is it safe to change ...
1
vote
2answers
34 views

Trying to mirror a legacy PHP 5.3.29 app on CentOS 7 (strange I know!)

I'm wondering if any linux/php gurus out there could help. Long story short, i've been tasked with creating a mirror/backup of a website which is made in PHP 5.3.29 to mitigate any risks if the ...
1
vote
0answers
2k views

How to Upgrade PHP 5.2 to 5.3 on Windows Plesk Panel 8.2

I need to upgrade my server PHP version becasue of Wordpress New version not support PHP 5.2. On My server windows 2003 stansard edition x64 with SP1 installed, IIS 6.0, MySQL 4.1, Plesk Panel 8.2. I ...
1
vote
2answers
1k views

php pages in a nginx + php-fpm server doesn't load

I've installed a nginx server and php-fpm in a CentOS 6 system (hosted in Amazon EC2) with the following this instructions: ...
0
votes
2answers
906 views

Apache restart needed after php code change

When I change php code of an application I need to restart apache to make the new code effective. $ sudo apachectl -l Compiled in modules: core.c mod_log_config.c mod_logio.c itk.c ...
0
votes
2answers
482 views

Installed php53 but still displaying php 5.1.6 in phpinfo()

I am running nginx 1.0 on centos 5.6. I had php 5.1.6 installed and running and then decided to uninstall it and switch to php 5.3. I ran the following commands: [user@server]$ /etc/init.d/nginx stop ...
0
votes
3answers
4k views

Installing PHP 5.3 Pear on centos 5.8

I just created a VPS with 32 bit Centos 5.8 and installed php53 and a host of other php 5.3 packages. I would like to install memcached using yum but I get the following error Resolving Dependencies ...
0
votes
1answer
34 views

How to test if a particular version of php executable is available on a server?

An automatic upgrade Bash script requires PHP executable 5.3+, how do I ensure that is the case in the upgrade script? I'd like the script to quit and generate some message into the log when php 5.3+ ...
0
votes
1answer
283 views

PHP 5.3 for recent Debian versions, with security backports (for Legacy apps)

Is there any way, to get a PHP 5.3 package for recent debian versions (i.e. wheezy) which is still getting security support? There are legacy projects which depend on register_globals() - and while ...
0
votes
1answer
454 views

Centos 6.5 — backported upgrades/php.ini directives included in php 5.3.3

PHP 5.3.3 is the latest version of PHP available with the official CentOS 6.5 repos. As most of you know, calling it version '5.3.3' is slightly deceptive because critical bug fixes are actually back ...
0
votes
1answer
56 views

How can I update php using zypper?

I'm currently running 5.3.17 and I'd like to update to the latest stable version. I've looked up a bunch of guides and they all have me doing it manually using wget. I'd like to do it all through ...
0
votes
2answers
984 views

Installing memcached deamon on Centos PHP conflicts

I have Centos 5.10 installed on my server and tried running the following command yum install php53u-pecl-memcached.x86_64 Setting up Install Process Resolving Dependencies --> Running transaction ...
0
votes
1answer
454 views

Trying to configure CentOS 6 and PHP 5.3.15

I'm trying to replicate a production environment so It's very important that I run PHP 5.3.15. The problem is that my dev server is running Centos 6 and the package manager will only install PHP ...
0
votes
2answers
177 views

php 5.3.6 is php-fpm included?

I just did a yum install of php on amazon linux beta. (it's similar to centos, jfyi) php -v reveals its php 5.3.6. awesome so. Now I am trying to figure out if I can package install the php-fpm. ...
0
votes
3answers
2k views

Imagemagick apparently correctly configured, still won't work under IIS 7.5 + PHP 5.3.2

I have managed to get imagemagick working (tested using the command line example on their website) It also appears that the php extension is correctly installed: I can see it listed in my phpinfo(); ...
0
votes
1answer
753 views

Building php-devel package from source (php 5.3)

I am building PHP 5.3 rpm packages for our custom CentOS 5 yum repo. I am fairly new to building rpms to be honest, but I have had moderate success downloading the SRPMS for a given package and ...
0
votes
1answer
886 views

Php 5.3.3. Access log

I'm using php-fpm. In 5.3.2 when I'm opening phpinfo page in access log I get: ip - - [26/Aug/2010:16:35:32 +0400] "GET /phpinfo.php HTTP/1.1" 200 13322 "-" "Mozilla/5.0 (X11; U; Linux i686; en-US; ...
0
votes
1answer
3k views

How to install PHP5.3 and SQLite3 on Ubuntu 8.04

I got a Ubuntu Hardy VPS and I am trying to install PHP5.3 with SQLite. I added the dotdeb PHP5.3 repository and succeeded in installing PHP5.3. But I need to install SQLite as well. When I'm trying ...
0
votes
1answer
205 views

Duplicate PHP installations

Started with 5.2.6 installed, then proceeded to install 5.3.1, but instead of overwriting, SSH php is now running 5.3.1, whereas the web server still servers content with the 5.2.6 installation. Any ...
0
votes
1answer
492 views

Is xdebug compatible with a custom install of php 5.3?

sudo apt-get install php5-xdebug Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have ...
0
votes
1answer
138 views

How to install different extensions when using multiple PHP versions

I have the following setup : Centos 6.4, Apache set up to work with WHM/ cpanel with it's version of PHP (5.4) and nginx running a separate version of PHP to handle everything else. How can I do a ...
0
votes
0answers
37 views

apache server has weird behavior

Okay, this one's weird for me. I have a wordpress mu site under a dedicated server. It runs Apache 2.2.21 and php 5.3.10. When msn and google bots crawls my site the system crashes. The system crashes ...
0
votes
0answers
182 views

PHP5.2 and PHP5.3 Maxing CPU on IIS7.5 Server 2008 R2

I have a shared server running Server 2008 R2 with IIS7.5 - the server has about 200GB ram, Several hundred websites dual Xeon 8 core hyperthreaded processors, so CPU shouldn't be a problem; What is ...
0
votes
1answer
290 views

php.ini - How to recover pdo.so?

I recently installed memcached. Everything worked swimmingly until I restarted the system. I have no idea what went wrong, but after the restart, some files were missing. Main main problem is that I ...
0
votes
1answer
125 views

Downgrade php5-cgi using APT on Debian

I have lighttpd install with PHP5.4 installed I need to downgrade it to 5.3.2 (possibly older/newer) but I can't install it I tried this apt-get install php5-cgi=5.3.2 but it says "E: Version ...
0
votes
3answers
973 views

Sendmail Errors when Sending via PHP

I'm trying to setup a new help desk program (Kayako), but I'm having problems relaying the mail to our mail server. Here's the error I'm getting: sendmail[2371]: NOQUEUE: SYSERR(apache): can not ...
0
votes
1answer
371 views

Proper Linux environment for php5.3?

I use CentOS 5.5 64bits, and I'd strongly prefer running php5.3 there (please focus on this), but if you have a safe recipe to run it on another distribution, I'll take it into consideration. My ...