PHP is a general-purpose scripting language that is especially suited for Web development. The online manual is an excellent resource for the language syntax and has an extensive list of the built-in and extension functions. Most extensions can be found in PECL.

learn more… | top users | synonyms

2
votes
2answers
3k views

Enabling Sqlite3 for php on fedora

I am trying to get php with sqlite working on my fedora server. In the phpinfo is see that ./configure was set with the option --without-sqlite3. From what I have read these means that I might have to ...
2
votes
3answers
6k views

How to Upgrade to PHP 5.5 on Windows Server 2008

What is the proper way to upgrade from PHP Version 5.4.32 to PHP Version 5.5.22 on Windows? All that I can find is how to to install. PHP is already running on Windows Server 2008 R2 64 bit alongside ...
2
votes
1answer
7k views

PECL APC install — ERROR: 'make' failed

I get the following error when running sudo pecl install apc. /var/tmp/APC/apc_cache.c: In function '_apc_cache_user_update': /var/tmp/APC/apc_cache.c:818: error: 'IS_CONSTANT_INDEX' undeclared ...
2
votes
4answers
2k views

solr php extension fails to run on newest Debian Wheezy

I'm trying to use the Solr PHP extension on the recently-upgraded Debian Wheezy. It installs both from PECL and from sources flawlessly but instead of giving me expected functionality it gives me this ...
2
votes
1answer
948 views

Is there an equivalent to Debian's cli/php.ini on Redhat?

How do you configure the command line version of PHP to have different settings on a Redhat system? On Debian based systems, php has a separate command-line version config file: /etc/php5/cli. On ...
2
votes
2answers
15k views

How downgrade PHP 5.5 to 5.4 or 5.3 on centos6

I have server running centos 6, i recently upgraded the php on the server to version 5.5 and noticed that some of the scripts in laravel framework i use are breaking. i get this error Parse error: ...
2
votes
2answers
78 views

What packages do I need to install to serve php pages from apache2 on Fedora 17?

This seems like it should be easy to answer, but as a php newbie, I can't find out what exactly I need to install. Some sites recommend just httpd, php and php-common; other suggestions include ...
2
votes
3answers
2k views

php-fpm version 5.4 with nginx constantly restarting

I just upgraded my php version from 5.3.x to 5.4.x and since doing this - memory has dropped signifincantly! - however, I'm constantly getting these in my php5-fpm.log: [18-Sep-2012 15:11:34] ...
2
votes
1answer
694 views

XCache loses performance gain after a day or so

I'm having some performance problems with XCache and PHP5 running on a Ubuntu 8.04 server. A few Zend Framework applications peak at about 12MB of memory. General response time before Apache 2 can ...
2
votes
2answers
14k views

PHP5 is installed, but Apache is displaying PHP as uninterpreted text. How can I get it to process it as PHP?

In a Drupal installation, it's displaying the root PHP file as plain text below. a2enmod says that php5 is enabled, aptitude says libapache2-mod-php5 is installed, mods-enabled/ has php5.conf and ...
2
votes
3answers
8k views

Update from PHP 5.3 to 5.4 on CentOS 6.3 while keeping Plesk [closed]

I need to update the servers PHP version, but when I try to remove the old php to install the new PHP 5.4 via yum it wants to remove the whole plesk suite which I want to keep. I followed this guide ...
2
votes
1answer
93 views

Secure against c99 and similar shells

I'm trying to secure my server as much as i can without limiting my options, so as a first step i've prevented dangerous functions with php disable_functions = "apache_child_terminate, apache_setenv, ...
2
votes
2answers
2k views

Upgrading PHP from version 5.3 to 5.4.7

Quickly so to speak I have noticed this topic around, I have searched and there are plenty of solutions. However these solutions do not work for me, not only that but I'm intending to learn more about ...
2
votes
2answers
9k views

Apache2: Server reached MaxClients setting, consider raising the MaxClients setting

I'm encountering issues on a dedicated Ubuntu 12.04 LTS (Apache/2.2.22), PHP 5.3 with APC. Every few hours I see this happen: [Fri Aug 17 15:36:51 2012] [error] server reached MaxClients setting, ...
2
votes
2answers
156 views

I have a fresh VirtualServer running Ubuntu 12.04, how do I get a LAMP server running?

Although I have an overview of running commands like apt-get install apache2 what I don't know is what order I should run them in to get a LAMP server running. Also, I assume I should create a ...
2
votes
1answer
889 views

Enable coloured PHP CLI messages on console

How to enable coloured messages for PHP CLI on console (Mac OS X, latest PHP/Apache from MacPorts)? export CLICOLOR=1 export LSCOLORS=gxfxcxdxbxegedabagacad doesn't seem to be enough, all PHP CLI ...
2
votes
1answer
3k views

Disable DNS Caching PHP

I need to get the latest A records of a DNS in a script. The script is doing some monitoring operations. The Default TTL of DNS record is 5 minutes, but the monitoring script is running every minute. ...
2
votes
3answers
766 views

How to Kill a PHP process and delete the Uneraseable File?

I'm trying to delete a file on the server but the PHP is still busy on it and wont let me delete it... FTP says SORRY cant do: > DELE ml.txt < 550 ml.txt: Permission denied > PORT ...
2
votes
1answer
730 views

Is the Debian Lenny PHP5 package secure?

For instance I'm running the php5 package using apt-get install php5. The reported version is: PHP/5.2.6-1+lenny9 However, there's currently listed 53 vulnerabilities for PHP/5.2.6 on CVE: Long link ...
2
votes
3answers
5k views

MAMP - Unable to turn off PHP E_STRICT error reporting [closed]

For some reason, MAMP won't allow me to turn off E_STRICT warnings. I've tried everything from changing the value explicitly in php.ini to error_reporting(E_ALL & ~E_STRICT) in my file... to ...
2
votes
2answers
2k views

Installed php-mcrypt but it doesn't show up in phpinfo()

I'm trying to install php-mcrypt on a CentOS 5.4 but while the extensions appears to be installed, there's nothing about it when I do a phpinfo(). For example, you can see below that php-mcrypt ...
2
votes
1answer
2k views

Running php4 and php5 along side each other

I need to have both installed and running on the same server instance for a dev environment. They both need to handle the .php extension, I have read that this can be done by .htaccess set up but ...
2
votes
2answers
543 views

How do I get Apache to use a different local PHP.ini for different domains?

is there some sort of .htaccess directive. I dont have access to httpd.conf. I have php5 in a fastcgi/cgi module. Multiple domains. But for some reason all the domains are pointing to the first ...
2
votes
2answers
197 views

CentOS 7.2, PHP 5.4 - MySQL extension is missing [closed]

I'm trying to install a Wordpress blog on my Linux server (CentOS 7.2), using PHP 5.4 and MariaDB, but I keep running into this error: Your PHP installation appears to be missing the MySQL extension ...
2
votes
1answer
98 views

Issue installing Ioncube with PHP 5.6.11 with Apache 2.4.16 on centOS 6.7

This is how I am compiling PHP 5.6.11 with apache2 2.4.16 on cenOS 6.7: ./configure --with-apxs2=/usr/local/apache2/bin/apxs --with-config-file-path=/usr/local/lib --with-mysql --with-curl ...
2
votes
1answer
7k views

Installing SSH2 on Windows Server using PHP5.5 VC11NTS

for the past few days i've been aching my brain on installing the SSH2 Connection on PHP. My current setup is VC11 Non thread safe, which I have downloaded the appropriate zip folders on the PECL ...
2
votes
1answer
4k views

Apache 2.4: mod_php vs php-fpm performance

There are plenty of old benchmarks on Apache mod_php vs nginx with php-fpm However, with version 2.4, Apache can use php-fpm. Are there any sensible benchmarks comparing mod_php with php-fpm (both ...
2
votes
3answers
19k views

Connection refused HTTPS on Apache

I'm currently trying out HTTPS on one of my sites, and I got a trial certificate from a trusted CA. I've gone through the following checklist: Copied all the cert files according to the CA's ...
2
votes
1answer
2k views

Can't configure PHP error log

I'm running apache2 with php5 on Linux Mint 13 Maya. I have defined a virtual host and these two entries there: ErrorLog ${APACHE_LOG_DIR}/error.log CustomLog ${APACHE_LOG_DIR}/access.log combined ...
2
votes
4answers
4k views

apache with php fastcgi keeps going down

I have an apache2 server configured with MPM worker and php fast cgi. Lately the apache logs have been telling me that MaxClients is being reached frequently, even though it's already pretty high. ...
2
votes
3answers
8k views

php5-mcrypt install errors

Running Ubuntu 9.10 and I am trying to install the php5-mcrypt module is killing me softly. I am not sure what else to try. Anyone have any idea? Here is the error i get: sudo apt-get install ...
2
votes
1answer
250 views

Why are my php extensions being compiled for PHP4 and not PHP5

I'm trying to compile memcache for Dreamhost PS. The library is created but not shown in phpinfo. Apache logs says the library isn't loaded because "undefined symbol: OnUpdateInt in Unknown on line ...
2
votes
2answers
3k views

edit httpd.conf to run PHP5?

I've installed apache and the server runs fine. I then installed PHP5, and it gave me a warning that it failed to edit the needed apache files. I did some googling and I found an article that said I ...
2
votes
2answers
1k views

206 Partial Content returned with Content-Length: 0

I'm serving large audio files on an Apache server using mod_xsendfile (version >= 0.10). The files are served fine when I use header( 'HTTP/1.1 200 OK' ); However, those files are served in full. ...
2
votes
1answer
992 views

Apache missing php module

I installed httpd v2.2.15 and php v5.5.13 via yum. I first noticed the problem when I tried to access my site and it displayed the PHP code. Then I discovered that there is no php module in ...
2
votes
1answer
3k views

Unable to install php5.5 apcu module on Debian 6.0 server

Since APC is not supported by PHP 5.5 as an OP code cache I read that I can still use APC for user data which sounds good for me. It's called APCu and it should be compatible with the old APC. ...
2
votes
2answers
4k views

How to have multiple PHP on Webmin/Virtualmin

I've scoured the internet for 4 hours now trying to find how to get newer PHP Versions on Webmin. No luck! Ideally, how do you get PHP 5.5 on Webmin/Virtualmin? If this is not available yet the ...
2
votes
2answers
4k views

How do I disable functions on servers for particular directories?

I want to disable some functions on server to improve security of server. I followed these steps: STEP: 1 Open php.ini file: vi /etc/php.ini STEP: 2 Find disable_functions and set new list as ...
2
votes
2answers
2k views

How to install latest version of imagick on centos 5.8 64bit using bash

How can I download and install latest version of imagick on centos 5.8 64bit using bash for php 5.4. >yum info php Loaded plugins: fastestmirror Loading mirror speeds from cached hostfile * ...
2
votes
2answers
870 views

How can I override mod-php5's .php mapping to php4-cgi per VirtualHost or Directory?

I am running Debian Linux with apache2 and libapache2-mod-php5 5.3.3-7. I have one VirtualHost which requires php4. So I researched and compiled php4-cgi. However, I cannot seem to: Override ...
2
votes
3answers
1k views

Unknown Apache2 + PHP5 FastCGI 500 error .. caused by search engine bots?

My Ubuntu server is configured with Apache 2.2.8 and PHP 5.2.4-2ubuntu5.18 in FastCGI mode. Everything works well, except I am seeing 500 errors that only seem to come from bots accessing the server.. ...
2
votes
3answers
4k views

Linux SUSE - How to install PHP 5.3.x on SUSE?

I'm trying to install php 5.3.x on Suse/linux platform, but whenever I install and check it with phpinfo(); it shows php 5.2. Any idea how to deal with it? please provide the detailed instructions. ...
2
votes
1answer
239 views

PHP APC MAJOR Fragmentation Issues?

So I have been using memcached to cache lots of data that was the result of queries to the database. Everything left at default, and on average I stored < 40MB in memcache. I used memcache.php to ...
2
votes
1answer
662 views

php4 and php5 together, same extension, restrict 4 to a folder

Is there any way I could have php 4 and 5 installed in the same server, while keeping the same ".php" extension for both, and making it so only a specific folder (+subfolders) in the server run under ...
2
votes
2answers
502 views

Why do I get a PHP 5.2.6 segmentation fault when using PDO_SQlite?

This is an installation on ModWest's shared hosting. I have enabled both PDO and PDO_sqlite on the server and phpinfo() verifies both are running. When I access PDO itself, I'm fine, and getting a ...
2
votes
2answers
839 views

date.timezone PHP error

I'm getting the infamous PHP timezone error: PHP Warning: PHP Startup: It is not safe to rely on the system's timezone settings. You are required to use the date.timezone setting or the ...
2
votes
1answer
934 views

How many fast-cgi processes to use with PHP-FPM and NginX

Does anyone know of a good source out there - or possibly can answer this in here - that can guide me as to how many Fast-cgi processes and Nginx processes I need to have running to serve a moderatly ...
2
votes
1answer
121 views

Inconsistent download size with PHP + NGINX configuration

I'm building a Joomla website using docman for document management/downloading. The site is built on a Ubuntu 14.04 server running Nginx 1.4.2 and PHP5 (FPM). The issue i'm having is that files are ...
2
votes
1answer
30 views

Why is my connection to php-fpm.sock being refused?

I've seen a bunch of questions about this problem on here but none of those had answers that helped me out. I kept getting a 502 error from nginx so I took a look at the access.log and saw I kept ...
2
votes
0answers
433 views

php5 not working with nginx 1.9.3

I am new to nginx, and having some trouble with php5. (I had it sorta working, but cant seem to get it working again.) There are 2 files I am woring with, that seem to control nginx, and php5-fpm. ...