PHP is a general-purpose scripting language that is especially suited for Web development. The online manual is an excellent resource for the language syntax and has an extensive list of the built-in and extension functions. Most extensions can be found in PECL.

learn more… | top users | synonyms

1
vote
0answers
177 views

PHP scripts on live Apache servers consume more memory?

Lately, I've been spending time trying to optimise PHP code. I develop on localhost inside a VM and have been putting the memory_get_usage() at the end of scripts to help do this. The localhost uses ...
0
votes
0answers
36 views

Is it safe to upgrade a current mysql CentOS 6.0 server to CentOS 6.5?

This server has specific configuration of php, it is also acting as a node in a DRBD cluster which holds a critical MYSQL database. I wanted to know if this procedure is safe and if there are any ...
-1
votes
1answer
825 views

High CPU Load, Crashes frequently [closed]

I have been struggling the past few days to keep my server up and running. The load averages hover around 2 and peak in the double digits until it crashes. Currently I am on a cloud VPS with WHM and ...
0
votes
1answer
4k views

How to install new PDO driver to existing LAMP install

How do I install a new PDO driver to an existing LAMP installation? I am using Amazon Linux (on AWS EC2), and have installed PHP 5.5 and MySql from the Amazon repositories. When I look at phpinfo I ...
0
votes
2answers
800 views

Unable to install PHP5-APC

When trying to install php5-apc, getting this error : root@x-fr-1:/etc/apt# apt-get install php5-apc Reading package lists... Done Building dependency tree Reading state information... Done The ...
1
vote
0answers
211 views

(111 connection refused) while connecting to upstream

I have a ubuntu 13.10 server with nginx and php5-fpm installed, the server has just been started and as such i am sure it is not a buffer or connection overload issue. I have set the site config in ...
0
votes
2answers
4k views

nginx does not seem to load memcached module for php

I have an Ubuntu machine with nginx and memcache running, and I'm trying to use PHP with Memcached. I'm getting Fatal error: Class 'Memcached' not found. The ini file is loaded from ...
1
vote
1answer
280 views

Rewrite file extensions in NGiNX

I'm looking to show a file like domain.com/login instead of domain.com/login.php My NGiNX site config is: #02API server { # listen 80 deferred; # for Linux # listen 80 accept_filter=httpready; ...
1
vote
2answers
145 views

Unable to upgrade to PHP 5.4 on my VPS

I'm able to see in phpinfo.php that I've PHP5.4 installed for use. Now, I'm trying to install symfony2 via composer. When I begin installing composer, it gives me an error stating that php5.3 is ...
0
votes
1answer
4k views

“php5-fpm: unrecognized service” and other issues after reverting from PPA

Added a repository so that I could move from PHP 5.3 to 5.5 easily in Ubuntu 12.04.3 LTS. After adding the PPA and following most of the suggestions here http://askubuntu.com/a/109544 it seemed that ...
0
votes
2answers
112 views

Nginx not passing uri to php5-fpm, instead serving as text file

as stated above the uri isn't being passed to nginx. I've included the entire "try" block to show this. location / { # First attempt to serve request as file, then # as directory, then fall ...
0
votes
1answer
4k views

Location directive is not allowed nginx

Hello I am setting up php with nginix and I need to add some code to the /etc/nginx/nginx.conf file. My nginx.conf file currently looks like this user nginx; worker_processes 1; error_log ...
-2
votes
1answer
65 views

how to make already compiled php5 shared module to static in apache 2.2

I have compiled apache 2.2 with php5 and after uncommenting loadmodule line for php in apache conf file the php started but as a shared module so is there any way to compile it as static ?
0
votes
2answers
1k views

how can I install PHP5 manually on Ubuntu

I have a new VPN with Ubuntu server 10.04 LTS which came with Mysql 5.1 installed, that was not supporting Barracuda file formats, so I manually installed and configured Mysql 5.6. Which works ...
0
votes
1answer
376 views

curl lot loaded after adding SFTP support

I installed Tartarus, and since my current curl didn't have SFTP support I've done this . Tartarus worked fine but I started to receive mails: PHP Warning: PHP Startup: Unable to load dynamic ...
0
votes
1answer
108 views

Verify PHP 5.3.27 has been patched for CVE-2013-4248

Server setup: CentOS release 5.10 (Final) WHM 11.40.0 (26) EasyApache 3.22.24 rev9999 compiled apache 2.2.26 and PHP 5.3.27 w/ SuHosin 0.9.33 I already had PHP 5.3.27 installed (since before most ...
5
votes
1answer
7k views

error: Cannot find OpenSSL's <evp.h> centos 6.3 (install php) [closed]

I have a problem during the intallation of php 5.3.27. When I launch the. / Configure I get this error and does not complete the installation. Configuring extensions checking size of long... ...
1
vote
1answer
141 views

PHP MAIL() dsn status

Is there a way to get the dsn status of an email set with postfix, with php mail function or any other library ? . I could parse the log for the id and dsn status, but that won't be quite good for the ...
-3
votes
4answers
512 views

How to configure Tomcat6 to run Php5 [closed]

I am using Tomcat6 as a server and i want to run php5 application on tomcat . Is there anyway to configure tomcat6 to run php on it .? I am using Ubntu 13.10 to run tomcat6
0
votes
2answers
352 views

how to install php5-memcached in linux?

I've installed memcached server using yum. My server os info - Linux version 3.8.4-x86_64-linode31 (maker@build) (gcc version 4.4.5 (Debian 4.4.5-8) ) #1 SMP Mon Mar 25 16:00:34 EDT 2013 But when ...
1
vote
0answers
2k views

“Cannot allocate memory” Using composer to install composer using fork from laravel git

Whenever I try to install a new laravel project, I receive the following error: PHP Fatal error: Uncaught exception 'ErrorException' with message 'proc_open(): fork failed - Cannot allocate memory' ...
0
votes
1answer
367 views

php_ibm_db2.dll on IIS 7.5 using PHP 5.3 error message

I'm trying to use ibm_db2 extension to access iSeries DB2 database. This is the testcode (taken from here) <?php $database = 'ALI452BFAL'; //library $user = 'STN452'; $password = '**********'; ...
1
vote
4answers
778 views

.php file blank - .php5 files works

I have a problem with a server of mine. I've installed virtualmin/webin on it for administration and I have 1 domain on it. DNS management is external. On this domain I only have an html "Under ...
0
votes
1answer
2k views

dll in php “the specified module could not be found”

I am having trouble with PHP extensions. I am trying to run a script and nothing happens then I checked my error log and here is what I got: PHP Startup: Unable to load dynamic library 'C:\Program ...
-1
votes
1answer
42 views

Updating PHP+Apache

I'm using Debian Wheezy x64. I've installed PHP and Apache via "apt-get install php5 apache2" with all dependencies. But as Debian packages are so slow in updating, I want to reinstall PHP and Apache ...
0
votes
1answer
895 views

php-fpm unable to restart because of another FPM instance

/etc/init.d/php-fpm restart Stopping php-fpm: [FAILED] Starting php-fpm: [10-Oct-2013 21:24:37] ERROR: An another FPM instance seems to already listen on ...
0
votes
1answer
542 views

Unable to adjust php.ini max upload size directive on Centos 6.3

Currently i'm setting up Centos 6.3 (64 bit) on vm and installing Wordpress: Already adjust /etc/php.ini but seems like overwritten by other settings. Suspect this is due to selinux feature. My goal ...
-1
votes
2answers
575 views

Red Hat Software Collections 1 Beta channel has 0 packages?

I want to install PHP 5.4 on a RHEL 6.x box as described in this Red Hat blog post. I have a valid subscription and have added the channel, but a yum repolist shows a status of 0 for the channel. ...
0
votes
1answer
176 views

How to install different extensions when using multiple PHP versions

I have the following setup : Centos 6.4, Apache set up to work with WHM/ cpanel with it's version of PHP (5.4) and nginx running a separate version of PHP to handle everything else. How can I do a ...
1
vote
1answer
17k views

Apache consuming too much CPU and memory

I am having some troubles with CPU loading an memory with Apache Web Server. We are running a Ubuntu Server 12.04 LTS on a Virtual Machine. Our server have the following specs: 8GB RAM; 4 vCPUs ...
0
votes
1answer
489 views

php5-cgi gives 502 with varnish but is ok without

problem summary: php5-fastcgi works with nginx but doesn't work with nginx+varnish (502 Bad Gateway) does anyone have a suggestion of what I could change to get varnish working ? problem details: ...
0
votes
1answer
715 views

PHP thinks date.timezone isn't set

For some reason, even though I've uncommented the line in php.ini and properly set the value to date.timezone = America/New_York, php refuses to acknowledge it. When I open up phpinfo.php it says ...
0
votes
1answer
40 views

Under What Conditions May PHP Server Variables Be Disabled

As per the question: "Under What Conditions May PHP Server Variables Be Disabled". Basically on Shared Hosting I am using I can choose to run my website in 'Apache' or 'CGI' mode. When running in ...
2
votes
1answer
892 views

Is there an equivalent to Debian's cli/php.ini on Redhat?

How do you configure the command line version of PHP to have different settings on a Redhat system? On Debian based systems, php has a separate command-line version config file: /etc/php5/cli. On ...
0
votes
2answers
8k views

How to build & install pgsql PHP extension manually on Ubuntu

I've searched high and low and haven't found anything. Perhaps I don't know what to search for. Environment is Ubuntu Lucid (10.4) with PHP 5.2.4 & PostgreSQL 9.2. PHP is "held" at 5.2.4 with ...
1
vote
2answers
2k views

How to downgrade php 5.5 to 5.4 on Ubuntu 13?

I'm using kubuntu 13.04 I've used a downgrade script to downgrade php 5.4 to 5.3 earlier, and now I deleted the repo and that script, removed php 5.3 and now when installing again, it's installing php ...
1
vote
0answers
49 views

Installation of nagios failed due to ucf and file acls

While installing Nagios give me this error and hence the packages left unconfigured on my server. I looked for some help but they don’t tell me the exact solution. Does any one have a fix. cp: ...
2
votes
1answer
4k views

Apache 2.4: mod_php vs php-fpm performance

There are plenty of old benchmarks on Apache mod_php vs nginx with php-fpm However, with version 2.4, Apache can use php-fpm. Are there any sensible benchmarks comparing mod_php with php-fpm (both ...
-1
votes
2answers
78 views

Database based Mail Server [closed]

I have a single case problem, it relates to selecting the correct mail server. A group wants to create their own business PHP website, where the public can read articles, news etc. and the staff can ...
1
vote
2answers
620 views

Nginx and PHP working with <?php but not <?

I'm trying to configure nginx with shorthand open and close tags. Currently the following code works for example: <?php include('this.php'); ?> But this doesn't: <? include('this.php'); ...
2
votes
1answer
4k views

How to have multiple PHP on Webmin/Virtualmin

I've scoured the internet for 4 hours now trying to find how to get newer PHP Versions on Webmin. No luck! Ideally, how do you get PHP 5.5 on Webmin/Virtualmin? If this is not available yet the ...
0
votes
2answers
2k views

Apache restart needed after php code change

When I change php code of an application I need to restart apache to make the new code effective. $ sudo apachectl -l Compiled in modules: core.c mod_log_config.c mod_logio.c itk.c ...
-1
votes
1answer
487 views

www-data runs in terminal but in php it does not execute, apache2, debian squeeze [closed]

I have external program.exe inside my website that gets data from text file, process it and then output to another textfile. Since apache uses www-data as user account, i manage to log in to terminal ...
6
votes
2answers
9k views

Error installing APC in apache2 VPS with php-5.5.1

When I install APC: pecl install apc I'm getting this error: Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. ...
-5
votes
1answer
97 views

How much memory will this PHP Script need? [duplicate]

I'm trying to use a WordPress Plugin to backup my database and files but it keeps running out of memory. How much memory will this script need to finish and how much should I ask for from my hosting ...
2
votes
1answer
15k views

How do you completely purge Apache, MySQL, PHP, and phpMyAdmin on Ubuntu? [closed]

I really need to completely purge my web server on Ubuntu 12.04. I have tried sudo apt-get purge apache2 php5 libapache2-mod-php5 mysql-server libapache2-mod-auth-mysql php5-mysql phpmyadmin (which ...
0
votes
1answer
108 views

Mysqli is installed on my system and the extension is enabled in php.ini but I can't find the actual extension

Centos 6.4 X86_64 with Apache 2.2.4 and PHP 5.4.17. I've rebuilt PHP to include mysqli. Phpinfo shows mysqli installed. Php.ini has the extension un-commented. How do I get the mysqli.so into the ...
1
vote
1answer
657 views

PHP Files being cached by unknown entity

I'm hitting a weird cache issue on my server, the project I am working on doesn't have any caching enabled at this time, but the server it self has APC installed (which was set to cache everything by ...
2
votes
0answers
448 views

nginx/php + zurmo, rewrite or internal redirection cycle

I am trying to get Zurmo CRM running on my Debian Jessie system on localhost. I couldn't find an example nginx config and the application needs to rewrite URLS, which I have done wrong. I also use ...
1
vote
3answers
7k views

libapache2-mod-php5 uninstalled after update impossible to put back

I use Webmin to administrate my Ubuntu 12.04 x86_64 machine. Yesterday, as often, I got notified of updates and installed them. During the installation process, libapache2-mod-php5 has been ...