PHP is a general-purpose scripting language that is especially suited for Web development. The online manual is an excellent resource for the language syntax and has an extensive list of the built-in and extension functions. Most extensions can be found in PECL.

learn more… | top users | synonyms

1
vote
3answers
997 views

APC minimal shm size

What is the minimal amount of shm Space APC needs to operate properly? I'm currently running a Wordpress blog on a VPS based on virtuozzo and I can't set kernel shm to anything above 32 mb. Is there ...
1
vote
1answer
215 views

PHP 5.3.8 doesn't load module xapian.so

I have web server on fedora 16 nginx + php-fpm (PHP 5.3.8),all installed with yum from standard repo. I'm trying to use xapian.so module so I istalled php-xapian and added extension=xapian.so to my ...
1
vote
1answer
1k views

Unable to load dynamic libraries (pcre,spl,gettaxt,mhash,snmp,sockets,tokenizer)

I'm a bit new to freeBSD and trying to set up a webserver. I've managed to get phpmyadmin installed and phpinfo(); works fine. But when i typ in 'php -v' i get some warnings: PHP Warning: PHP ...
1
vote
1answer
140 views

Running PHP 4 and PHP 5 at the same time on the same site using Apache on Windows

Most results I get on google is how to get both versions running simultaneously on the same server but at different URLS but that's not what I want. I'd like, for example, to get http://localhost to ...
1
vote
1answer
382 views

php session_start() permisson denied

PHP Notice: session_start(): ps_files_cleanup_dir: opendir(/var/lib/php5) failed: Permission denied I am getting it in my apache error log /var/lib/php5 owner and group is root, so is it fine ...
1
vote
1answer
2k views

Zend Optimizer not compatible with PHP+APC+Drupal. Can I disable it for Drupal-run domains?

I use the following set up: PHP Version 5.2.17 Apache/2 Zend Optimizer v3.3.3 Drupal 7.8 As far as I read other articles and questions, Zend Optimizer doesn't do any good neither for PHP5 ...
1
vote
1answer
152 views

centos 5.6 switching/migration from apache to lighttpd

i currently run apache 2 with php5.1.6 running as mod_php on a centos 5.6 box, I use .htaccess for mostly redirection I already have latest APC running apc.so I also have mysql etc Until recently ...
1
vote
1answer
2k views

PHP files not getting parsed? [duplicate]

Possible Duplicate: Problem with php and apache I have php 5.1.6 running on my CentOS 5 server running Apache 2.2.3 when i use command php -v it says PHP 5.1.6 (cli) (built: Nov 29 2010 ...
1
vote
1answer
53 views

Apache/PHP Configuration question - Where else can info.php be disabled besides php.ini?

Sorry for the bone head Q. but I rarely need to reinstall my server :) I wish to enable phpinfo() function. My php.ini config file has the disable_functions directive blank--which I understand is the ...
1
vote
1answer
816 views

NGINX + PHP5-FPM segfaults under high load!

I have been dealing with this problem all day and it is driving me insane. All Google results and searches here lead to dead ends. I hope someone can work with me to provide a solution for myself ...
1
vote
2answers
598 views

Can't install PHP after apt-get dist-upgrade

I had a server with perfectly running for months classical LAMP installation on Ubuntu 8.04: Linux localhost 2.6.24-23-generic #1 SMP Wed Apr 1 21:47:28 UTC 2009 i686 GNU/Linux DISTRIB_ID=Ubuntu ...
1
vote
1answer
1k views

PHP file gets download instead of getting executed when browsed in any browser

I have a phpinfo.php file which I am trying to run by browsing to it using browser but the browser downloads the file instead of executing it. phpinfo.php <?php phpinfo(); ?> I followed ...
1
vote
1answer
300 views

unable to fsockopen

I have 2 ethernet eth0 and eth1 on my server. The default gateway is set to be eth0. I need to connect ip 10.10.6.2 using fsockopen in php. The ip 10.10.6.2 is routed through eth1 (I have a rule set ...
1
vote
1answer
2k views

php.ini use multiple include paths - openbasedir restriction

I need to allow an include path for a vhost subdomain on Plesk 10. I've edited the PHP PEAR path into /etc/php.ini as I'm happy for it to be globally available: include_path = ".:/usr/share/pear/" ...
1
vote
1answer
142 views

Ideal technology stack for Drupal 6 in Windows Server 2008R2

My background is predominantly Linux-based servers, with which I can configure anything however I want. However, I'm building a Drupal6 site for a client, who (despite my warnings) wishes to self-host ...
1
vote
1answer
432 views

Apache2/mod_fcgid/PHP Process Limits Not Respected

I've recently moved to Apache2 / mod_fcgid / PHP from nginx / php_fpm. This is the second server on which I've made this migration, but it's used much less frequently than the first, which is working ...
1
vote
3answers
3k views

MAMP - Unable to turn off PHP E_STRICT error reporting [closed]

For some reason, MAMP won't allow me to turn off E_STRICT warnings. I've tried everything from changing the value explicitly in php.ini to error_reporting(E_ALL & ~E_STRICT) in my file... to ...
1
vote
2answers
320 views

Ubuntu server with Apache supporting php4,5 and 6

I have websites hosted on 1and1 and the servers default to PHP 4 and if you want PHP 5 or 6 you add "AddType x-mapp-php5(or 6) .php" and it'll run the scripts as PHP 5 or 6. There isn't a lot of ...
1
vote
4answers
732 views

how optimize small linux server?

I have a small Ubuntu server with 512MB of ram and several php/mysql websites (~20) running on it.It's been running for 2 years now without a single issue. But I think the moment for some optimization ...
1
vote
1answer
2k views

Limit APC opcode caching to specific sites? Nginx + PHP-FPM + APC

Is there any way to enable/disable APC on a per virtual host basis? I'd rather not use precious apc shared memory on caching my PHPmyAdmin subdomain or lesser used sites. Setup is Nginx, php-fpm, and ...
1
vote
1answer
1k views

Upgrading PHP, MySQL old-passwords issue

I've inherited a Windows 2k3 server running an XAMPP-installation from the stone age. I needed to upgrade PHP to facilitate an upgrade to MediaWiki to facilitate a new MediaWiki extension (to ...
1
vote
2answers
112 views

Simple to follow guidance on update PHP from 4.3.10 to at least 5.1.1

I need to update my version of PHP to at least 5.1.1, via SSH and need simple to follow advice on how to do it. We have a VPS (with Plesk) with webfusion, who won't update it for us and we need to get ...
1
vote
1answer
4k views

PHP module installed but does not appear in phpinfo()

Im tying to install php5-ffmpeg module on my ubuntu server. I've typed: sudo apt-get install php5-ffmpeg Everything was installed and web server was reloaded. Now, the fallowing line is added to ...
1
vote
1answer
351 views

How do I connect Apache2 and PHP5?

I'm trying to install the LAMP stack on a server running Ubuntu 10.10. Whenever I browser to a PHP file on the server, my browser will download it as a file named "download" (with no extension). I ...
1
vote
1answer
721 views

why won't php 5.3.3 compile libphp5.so on redhat ent

I'm trying to upgrade to php 5.3.3 from php 5.2.13. However, the apache module, libphp5.so will not be compiled. Below is a output I got along with the configure options I used. The configure ...
1
vote
2answers
2k views

where can I find php_mssql.dll?

I'm trying to get PHP set up to connect to a SQL Server database. I'm looking for the php_mssql.dll file to put in my extensions directory but for the life of me can't locate it online. Can anyone ...
1
vote
1answer
83 views

File Permissions: Who are the user, group, and others on my web server? What perms should i use for uploaded files, php files, etc.?

I am using cPanel with apache 2 and php 5.2. I have a file upload script, which currently puts the uploaded files in a directory with 0777 perms and the file itself also has 0777 perms. this is ...
1
vote
1answer
1k views

PHP Safe Mode/open_basedir - lstat performance problem

PHP lstat the full path many times before read the file is looking for. And this happens when in apache httpd configuration is specified PHP_ADMIN_VALUE open_basedir setting or if safe_mode is ON. If ...
1
vote
1answer
285 views

Anti-bot techniques

I want to do some research on anti-bot techniques for my web application. I am aware of Captcha, but want to explore some other techniques. Especially, I want users to visit all the pages before they ...
1
vote
1answer
317 views

PHP not loading php.ini in directory or following error_reporting() on Windows 7

Normally I develop under E_ALL error level, but for sanity on this project I want notices and strict off. So initially tried: error_reporting(E_ALL & ~(E_STRICT|E_NOTICE)); And several other ...
1
vote
2answers
6k views

Windows7 IIS7: zips don't have php5isapi.dll Can I use php.dll instead?

The page: How to Install PHP 5.2 on IIS 7and Windows Vista (and a few others) reference a mysterious php5isapi.dll which is not in the Windows install, or the zip files: php-5.3.2-Win32-VC9-x86.zip - ...
1
vote
2answers
2k views

PHP cannot connect to MySQL

I recently installed Apache 2 + PHP 5.3.1 + MySQL 5.1.44 on my Windows 7 64bit machine following this guide: http://sleeplessgeek.blogspot.com/2010/01/setting-up-apache-php-mysql-phpmyadmin.html ...
1
vote
3answers
2k views

Downgrading PHP from 5.3 version to 5.2.x on Ubuntu

I'm looking some some way to downgrade php from 5.3 version to 5.2.x on Ubuntu 9.10
1
vote
1answer
656 views

Lighttpd wont restart due to an fastcgi.server error

Here is what comes up when I try to restart lighttpd user:/# /etc/init.d/lighttpd restart Stopping web server: lighttpd. Starting web server: lighttpdDuplicate config variable in conditional 0 ...
1
vote
3answers
1k views

64bit UnixODBC and FreeTDS: a bug in libtdsodbc.so?

We have a legacy Windows web application which uses Microsoft SQL Server 2005. Two years ago we rewrote a part of this application using PHP and ODBC on a 32 bit virtualized Debian system. This ...
1
vote
1answer
325 views

How do you get syck to compile with php5.2.x

What are the steps needed to compile in support for syck into php 5.2.x on a 64 bit centos 5.3 system? I haven't seen this another good FAQ on this, so I figured I would drop both the question and ...
1
vote
1answer
584 views

How do you setup 64-bit PHP5 with APC?

I followed this # script on my webhost's wiki to setup a custom install of PHP5, but now theyre telling me they need to move my account to a 64-bit server, and I have no idea how to set this up. APC ...
1
vote
3answers
3k views

Howto make MCrypt and PHP work together on CentOS

I've installed mcrypt on CentOS ( via yum ), but when I try to do a dl() call in A), I get the message in B). A) dl( mcrypt.so ) or die('The Mcrypt module could not be loaded ['. $prefix . ...
1
vote
1answer
1k views

Apache2/fastcgi/php fastcgi/haproxy - graceful restart problems changing configuration settings

I have an Apache2 with php fastcgi setup; I want to do config changes without a client noticing it (so no dropped/failing requests), so I put haproxy in front of it; so I have 2 Apache2 servers ...
1
vote
1answer
669 views

Apache 2 Fails to start after upgrade to PHP 5.3

I just upgraded to PHP 5.3 (Thread Safe VC6) on my windows server 2003 machine running Apache 2.2.4, and now Apache fails to start. I tested the pre-packed development ini file, and Apache will ...
1
vote
0answers
14 views

Can't seem to install pdo-mysql extension on RHEL6 server

I'll try to be clear, I don't have a lot of server experience, but I'll tell you what I know: I'm trying to install Magento on a site, but I kept getting an error, after looking at the error logs, ...
1
vote
0answers
38 views

How can I get openSSL to run on my web server with a PHP5-FPM chroot?

On my web server, I changed the chroot to only have access to the root of my website's home directory as opposed to the rest of the file system, for security purposes. However, I've noticed that since ...
1
vote
1answer
230 views

Unable to install php5.5 apcu module on Debian 6.0 server

Since APC is not supported by PHP 5.5 as an OP code cache I read that I can still use APC for user data which sounds good for me. It's called APCu and it should be compatible with the old APC. ...
1
vote
0answers
60 views

Can't seem to set AcceptPathInfo in Apache

I'm trying to migrate an ExpressionEngine site onto a new server and seem to have run into a roadblock. For the desired functionality, EE requires the AcceptPathInfo directive to be turned on, and for ...
1
vote
2answers
449 views

php5-fpm optimization for long polling

I'm designing a chat application in PHP. I use nginx with php-fpm environment. The problem is, that after several clients connected, PHP scripts are getting very slow. I have just several (5-10) ...
1
vote
0answers
87 views

Why is memcache not functioning with elgg in debian 7?

I am moving a php website (built using elgg - www.elgg.org) from a CentOS server to a different Debian 7 server and have installed memcached + php5-memcache on both. I have recreated all the ...
1
vote
0answers
48 views

PHP scripts on live Apache servers consume more memory?

Lately, I've been spending time trying to optimise PHP code. I develop on localhost inside a VM and have been putting the memory_get_usage() at the end of scripts to help do this. The localhost uses ...
1
vote
0answers
94 views

(111 connection refused) while connecting to upstream

I have a ubuntu 13.10 server with nginx and php5-fpm installed, the server has just been started and as such i am sure it is not a buffer or connection overload issue. I have set the site config in ...
1
vote
2answers
76 views

Unable to upgrade to PHP 5.4 on my VPS

I'm able to see in phpinfo.php that I've PHP5.4 installed for use. Now, I'm trying to install symfony2 via composer. When I begin installing composer, it gives me an error stating that php5.3 is ...
1
vote
0answers
864 views

“Cannot allocate memory” Using composer to install composer using fork from laravel git

Whenever I try to install a new laravel project, I receive the following error: PHP Fatal error: Uncaught exception 'ErrorException' with message 'proc_open(): fork failed - Cannot allocate memory' ...