PHP is a general-purpose scripting language that is especially suited for Web development. The online manual is an excellent resource for the language syntax and has an extensive list of the built-in and extension functions. Most extensions can be found in PECL.

learn more… | top users | synonyms

-1
votes
0answers
5 views

How would I go about setting php handler mapping and fastcgi parameters without using GUI

I like to be able to set php handler mapping and fastcgi parameters without GUI - would I be correct in saying, this can be done using Poweshell or if not, what would be best approach to do this. ...
0
votes
0answers
20 views

APCu Fragmented sectors unrecoverable

I currently have APCu (v4.0.6) running with nginx + php-fpm (v5.5.16) and it's creating a scenario where the fragmented area keeps on growing and is not naturally recovered by APCu. Eventually, the ...
-1
votes
1answer
35 views

Strange php redirections with nginx (Works fine in apache)

Finally I decide to ask here after hours trying, searching and researching. Months ago I migrated my site to a newer version and everything works fine with my old hosting in apache. Recently I ...
0
votes
0answers
46 views

Analyzing PHP Scripts to Identify Source of Intermittent Website Performance Issue

My site has been getting some hits on performance as of recently. About half the time, my site will run smoothly, while at other times it loads ridiculously slow. My server is running on CentOS 5. I ...
0
votes
1answer
25 views

SuPhp 500 internal server error

Hi i upgraded php to PHP Version 5.4.32 Now SuPhp generate a 500 internal server error If i switch to DSO it runs but that cause other php read write permission error I have tried with permission ...
0
votes
1answer
21 views

Under what conditions in Apache installations is AddHandler application/x-httpd-php .php required?

I am a security researcher who has been running into multiple cases where file upload forms can be exploited, allowing attacker-controlled PHP code to be interpreted by the server, leading to remote ...
0
votes
0answers
20 views

Huge request duration value for a particular php script

We are facing issues with a php-fpm server that spawns too many children. This morning, I set up php-fpm's status page, and got an interesting piece of information : among all the scripts that are ...
0
votes
1answer
72 views

umask for www-data user running PHP on Ubuntu

Setting up a new webserver in Ubuntu 14.04 and trying to wrangle file permissions for PHP generated files. By default, all the directories and files in /var/www are owned/grouped to www-admin. ...
0
votes
0answers
33 views

Override PHP Cache-Control Header from Apache config?

PHP is setting the Cache-Control header in multiple places. I don't want to break my code upgrade path, but I'd like to change the Cache-Control header in Apache config instead. However, it looks like ...
0
votes
0answers
68 views

How do one run PHP-FPM on subdomain?

I run Apache 2.4 and PHP-FPM via ProxyPassmatch in httpd.conf, not vhost (for what it's worth): ProxyPassMatch ^/(.*\.php)$ unix:/var/run/php-fpm.sock|fcgi://127.0.0.1/home/user/www I wanted to ...
0
votes
2answers
52 views

Php runs on server, but not command line: “libssl.so.10: no version information available”

php is running on my server, though I'm unable to get it to run command line. I'm running this file: <?php echo "done"; ?> using this command: php test.php When I do, I get this error: ...
0
votes
0answers
26 views

cacti fails on new install with 'failed to open stream: Permission denied'

/usr/share/cacti is set to apache:apache 0755 for directories and 0644 for files (httpd recommended) [Wed Aug 27 11:31:56.505530 2014] [:error] [pid 19799] [client 67.83.132.41:52100] PHP Warning: ...
0
votes
0answers
27 views

RHEL 5 with PHP 5.1.6 VS RHEL 6 with PHP 5.3.3: Security implications

Using only the RHEL Repositories, RHEL 5 considers PHP 5.1.6 to be up to date, and RHEL 6 considers PHP 5.3.3 to be up to date. My question is: Are security updates/patches backported so that 5.1.6 ...
1
vote
3answers
40 views

PHP Sessions directory is filling up and overflowing

Running PHP, Apache2... Our login stopped working and anything trying to grab session data. It all stopped working randomly at 7pm last night. I found out the sessions directory is being filled with ...
0
votes
1answer
27 views

Apache2 internal server error not being logged

I'm doing some web development with the Laravel framework, and I have my jQuery set up so that it sends a request on click of a button to a PHP file, which then returns the result back to my jQuery. ...
0
votes
1answer
85 views

Upgrade PHP-mysql Lib Centos 6 [duplicate]

I just delete all php and mysql and installed it again. but in PHPMyadmin i still get: Your PHP MySQL library version 5.1.69 differs from your MySQL server version 5.5.39. This may cause ...
0
votes
1answer
43 views

Apache 2.2(mod_event) + php-fpm + apc + fastcgi Max Clients Reached

I'm currently running apache2.2 with mod_event, php-fpm and apc on Debian Wheezy. I've hosting 3 normal websites and 1 really shitty website, which has really bad code and needs sometimes 2 minutes ...
0
votes
1answer
28 views

Install a pecl package (gmagick) without PHPize

I am running Debian Wheezy with PHP5.5 (not the default PHP version of Wheezy). I want to install gmagick (already installed graphicsmagick from aptitude). So I did this command line : pecl install ...
0
votes
2answers
63 views

Centos Your PHP MySQL library version 1.5.73 differs from your MySQL server version 5.5.39 [duplicate]

I have recently updated my PHP version to 5.4 and my mysql version to 5.5 [root@**** ~]# php -v PHP 5.4.31 (cli) (built: Jul 25 2014 07:41:53) Copyright (c) 1997-2014 The PHP Group Zend Engine ...
1
vote
0answers
50 views

Zabbix PDF Report Generation

if any of you have an idea how to implement zabbix generate PDF reports? in forum I found some like this: https://www.zabbix.com/forum/showthread.php?t=24998 . I try implement this to my zabbix ...
-1
votes
1answer
20 views

How to get terminal access to a php/AngularJS app deployed using opsWorks

Background: I have a php backend application (cakephp with dependencies resolved with composer), and javascript front end (AngularJS, using bower for dependency management), with the repository on ...
0
votes
2answers
59 views

Webhost similar to Dropbox with PHP Support? [closed]

I have a website that uses PHP. I need to host it online on a webserver that is similar to dropbox. I'm trying to look for features that include: PHP Support Version Control Sync Client (windows) ...
-1
votes
0answers
13 views

mysqli::mysqli(): [2002] Connection refused. Php stops talking to MySQL once migrate to a new server [duplicate]

So I have a php/mysql application running on my AWS Ubuntu LTS server. I am trying to migrate it to another old Ubuntu server in my company. While it worked fine on the AWS server, it keeps returning ...
-1
votes
0answers
25 views

When to look for Apache alternatives [duplicate]

How many pageviews, UU/day will require to move on faster webserver than Apache? Let's say it's Wordpress with few plugins webpage with 20-30 articles and few some average complex php scripts. 2GB ...
1
vote
1answer
48 views

PHP - Memcached - Libmemcached - Handle cache server outage

I am working on ensuring our app degrades gracefully in case of a complete cache outage, which is highly unlikely, as we have minimum of at least 3 cache nodes to add to the cache pool, by way of ...
2
votes
1answer
33 views

NginX/Varnish and Auto Caching

Let's say we have a wordpress site example.com On our site, there are multiple products. Urls look like this: example.com/products/product-1/ example.com/products/product-2/ ...
-4
votes
3answers
51 views

cronjob or similar to open a local php file including query [closed]

How do I open the following file with cronjob correctly every 5 minutes: /var/www/mysite/folder/foo.php?query=1 I tried myself but i just did not get it working... i tried with /usr/share/php5 , ...
0
votes
2answers
111 views

PHP stopped working after upgrading from 5.3 to 5.5 using PPA

I had PHP 5.3 working on an old server that my company uses. I have PHP 5.5 working on my AWS server. Both of the servers are Ubuntu. My application is working fine on my AWS server. But when I ...
0
votes
0answers
34 views

LIVE Video Streaming with Nginx + PHP-FPM / Process Timeout

I have a live video streaming in my server using nginx + php. the php file reas a live streaming and it directly sends it to the client. I have only one problem. The problem is that i want each ...
1
vote
1answer
68 views

CentOS 5 : error in installing php-imap

can someone please help me with this CentOS 5 question? I am trying to install php-imap, i tried yum install php-imap but I am getting the following output: Loaded plugins: fastestmirror, ...
-2
votes
1answer
33 views

installing php gd on ubuntu on a vps server [closed]

I was working on localhost with resizing images and everything was great. Then I uploaded to my server and things got interesting. After searching around, looks like I have to enable php-gd on my ...
1
vote
0answers
49 views

Requests are never queued after pm.max_children with Nginx and PHP-FPM

As soon as a pool reached pm.max_children, Nginx starts timing out when trying to send new requests to PHP-FPM. "max listen queue" is always 0 in the php-status page. PHP-FPM 5.5.16 Nginx 1.6.1 ...
1
vote
2answers
76 views

PHP Startup: Unable to load dynamic library '/usr/lib/php5/20100525/apc.so'

I have updated my php from 5.3.3 to 5.4.31. I have a Debian 6 Squeeze. PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php5/20100525/apc.so' - /usr/lib/php5/20100525/apc.so: ...
0
votes
1answer
22 views

Override PHP options with .htaccess, DSO works (suPHP doesn't)

I am using .htaccess in a sub directory as below: php_value apc.cache_by_default 0 But this throws an error, if i use DSO, then it works. I understand with suPHP I have to ovveride with a php.ini ...
-1
votes
0answers
13 views

PHP only processing 1 request/execution at a time [duplicate]

I recently installed nginx and PHP to a windows server I want to use as webhosting. My problem is that I have a script that takes a very long time to run when a user executes it (1-2 mins), and it ...
0
votes
0answers
68 views

Enable Soap for PHP 5.5.x on CentOS 6.5

Unfortunately I have to support soap on my server for the Fedex webservice. I recompiled PHP enabling support and it works via CLI but not PHP-fpm. They both point to the same ini file and both show ...
0
votes
1answer
93 views

Installing PHP 5.2.17 from WHM/Cpanel server by replacing 5.4.31

Recently we purchased a dedicated server with WHM/Cpanel. The PHP version installed on the server is 5.4.31. But i want to downgrade the pHP version from 5.4.31 to PHP 5.2.17 as to run some old ...
0
votes
1answer
30 views

Having CORS Issues with Apache/Wordpress

I have enabled CORS in Apache, here are the headings I am seeing when loading the site: HTTP/1.1 200 OK Access-Control-Allow-Methods: GET, POST, OPTIONS Access-Control-Allow-Origin: * Cache-Control: ...
0
votes
1answer
57 views

PHP - Centos OpenSSL error

i'm currently having a problem with OpenSSL on my Centos 6.5 Server. it ran perfectly fine until sunday. and i checked the error_log and i saw this error in the log PHP Warning: PHP Startup: ...
-2
votes
1answer
52 views

High load of RAM but low CPU

I've a dedicated problem.. When I make a load test with ~500 connections, CPU stay low (about 30%) but memory grow up fast ! And I have a 100% used RAM and 50% used SWAP.. An other dedicated with 2x ...
0
votes
2answers
37 views

updating php from 5.3 to 5.5

I'm thinking of updating my php from version 5.3 to version 5.5. I was wondering if 5.5 is backwards compatible with 5.3 as it is 'just' a minor update (eg not 5.3 to 6.4). Am I running into ...
0
votes
0answers
17 views

Cannot get libcurl-devl on OpenSUSE 11.3

I have a server running OpenSUSE 11.3 that I can't really upgrade to a newer version of OpenSUSE (it's a managed appliance). I have some PHP shell scripts that need to run on the server that have a ...
0
votes
3answers
59 views

Securely executing system commands as sudo from PHP

Is it possible? I have written a command line tool in PHP for creating new environments for our company. It creates system users, directories, databases, VHosts and restarts apache, amongst other ...
-1
votes
1answer
87 views

Memory Ram too high in HTTPD processes

I management two dedicated servers. I use Centos 6 with Plesk Panel. Update: I use Apache with mod_php. On the first server I have a site in Wordpress. I have noticed that my httpd processes take ...
0
votes
1answer
50 views

Deploying Zend Opcache Using Chef PHP Cookbook

I'm new on Chef. I tried writing a recipe that installs Zend OpCache (for PHP 5.4, since its not built-in yet) using Chef PHP cookbook. I tried using the php_pear php_pear "opcache" do ...
1
vote
2answers
45 views

Where should I put my web app so it is private by default but accessible through subdomains?

I have a web application written in PHP that I want to host on an Apache 2.2 server. The tricky part though is that the same web application should be accessible through different subdomains (the web ...
0
votes
1answer
162 views

Install mcrypt for php54 on centos 6.5

I'm completely new to VPS and am trying to install php54 on a centos6.5 server. I've updgraded the php version to 5.4 which appears to work. Currently using php5.4.31 However I now need to install ...
0
votes
1answer
144 views

php-mbstring no package available on RHEL6?

[root@ltfs1968 yum.repos.d]# yum install php-mbstring Loaded plugins: dellsysid, downloadonly, replace, rhnplugin This system is receiving updates from RHN Classic or RHN Satellite. Setting up Install ...
1
vote
1answer
43 views

disabling webtatic repo spitting back errors on centos

I installed the "webtatic" repo for PHP and it's caused nothing but trouble. When I try to run yum --disablerepo=webtatic distro-sync it returns this: Transaction Check Error: file ...
-1
votes
1answer
23 views

Is it possible to upgrade version of php on my remote hosting server? [closed]

I have a hosting server which provides me php version 5.2 but the application made by me require php version 5.4.So is there possible any way how can i upgrade that version of php on my remote server ...