0
votes
2answers
35 views

How do I update YUM repositories to get Postgres9.x version?

I need to install some Postgres9.1 libs, but "yum list" only shows 8.4 version. How to "update" yum repo list to get 9.1 version? My Linux version: # cat /etc/redhat-release Red Hat Enterprise ...
0
votes
1answer
48 views

Unaccent for postgresql 9.0.8 (over RHEL6)

I need to install the unaccent extension in a postgresql server 9.0.8 running over a RHEL6 box which doesn't have the contrib package. So I need to install postgresql-crontrib first. Facts: Server ...
0
votes
1answer
46 views

Which package to upgrade psql client?

I have updated my Postgres install from 8.4 to 9.3. Now when I log onto the server with the initial command sudo -u postgres psql template1 I get the following error psql (8.4.18, server ...
1
vote
1answer
341 views

RHEL SELinux blocking Apache access to PostgreSQL

I'm running a Django app that uses PostgreSQL. The server is running RHEL 6.5 with SELinux. I'm having an issue where the Django app can't connect to the DB, and I think it's because SELinux is ...
2
votes
1answer
88 views

High shmmax value in Redhat 6.3

We are using Redhat 6.3 with 30G RAM to host our Postgres server. The (default) shmmax value is 68,719,476,736 In some forums I have read that having an shmmax value larger than the RAM causes ...
1
vote
1answer
476 views

postgres updated from 9.1 to 9.2, required database update fails

On going from postgres 9.1 to 9.2, it says that the data bases need to be upgraded so on giving the upgrade command I give and get the following $ sudo service postgresql upgrade Stopping postgresql ...
1
vote
1answer
2k views

Postgresql unrecognized, even though it's installed

Postgresql 8.4 seems to be installed properly, according to this: sudo yum install postgresql Loaded plugins: product-id, refresh-packagekit, rhnplugin, security, subscription-manager This system ...
0
votes
1answer
126 views

PostgreSQL 9.1 won't restore because “a user is connected”

I'm transferring a database as part of transferring a website. I've not used PostgreSQL before, so assume that I don't know much about it (I primarily use MySQL). We cannot directly connect the ...
-2
votes
1answer
171 views

Installing PGAdmin 3 [closed]

How can I install pgAdmin3 on RHEL 4? I've install it but I can't access it. After ./configure, I don't know what I should do. I want access to the postgresql with a GUI, because from i don't ...
0
votes
3answers
457 views

How to install or upgrade to PostgreSQL 8.1 in RHEL 4?

I'm using RHEL 4 with the default database installed in there (PostgreSQL 7.4), but I want to have PostgreSQL 8.1 installed. What is best, upgrade it or install a new one?
3
votes
2answers
5k views

How can I install PostgreSQL 9 on RHEL 6?

I am new to RHEL 6 but have a project where I need a postgres 9 database and I only have RHEL 6 available to me. How can I safely do this? Should I install from source or is there a package around ...
3
votes
4answers
1k views

Install postgresql on RHEL 5.6

When I try to run yum install postgresql I get the following error message: Transaction Check Error: file /usr/lib64/libecpg.so.6.1 from install of postgresql-libs-8.4.4-2PGDG.el5.x86_64 ...
0
votes
1answer
739 views

Postgres 8.4 server not starting on Redhat after crash

I am not a Database Admin but have to take care of this request. The PostgreSQL Server crashed during an update. Now I am unable to start it again. The process id dead. When I am trying to stop the ...
0
votes
2answers
252 views

Problem in creating UDP sockets

Our production server is running PostgreSQL v8.2.3 on Red Hat Enterprise Linux Server release 5 (Tikanga). For some reason, statistics collector in PostgreSQL is not working. Even posted this ...
0
votes
1answer
122 views

Disk space consumed

I have a very serious problem here in one of my client server. The remote server is installed with REDHAT ES 5.2 and we have a postgresql as database. I was trying to clone the database. The hard ...