0
votes
1answer
648 views

How to use a different version of python duing NPM install?

Salam (means Hello) :) I have terminal access to a VPS running centos 5.9 and default python 2.4.3 installed. I also installed python 2.7.3 via these commands: (I used make altinstall instead of make ...
1
vote
2answers
200 views

Install gettext-0.17-1.el5.i386.rpm on CentOS 5.8 i386 gives “/usr/bin/python is needed” error

I've removed yum by mistake. So, now I'm installing all the dependencies needed by yum manually. One of those is gettext-0.17-1.el5.i386.rpm and when I try to install it gives the following error, ...
0
votes
1answer
557 views

Installing Ajenti fails because of python dependencies which aren't found

I'm trying to install Ajenti http://ajenti.org I've followed the instructions on their website but when I do: yum install ajenti I get this: python26-greenlet-0.3.4-trunk.i386 from ajenti has ...
0
votes
1answer
1k views

How do I install psycopg2 for multiple python interpreters on a CentOS box?

I have a CentOS 5.5 box, which comes preloaded with Python 2.4. I wanted 2.6, so used yumto get it from the EPEL repository. I also used yum to install the psycopg2 package, but it installed it for ...
0
votes
2answers
2k views

How should I upgrade Python on CentOS 5.5 (64-bit)

I believe I am running CentOS 5.5 (64-bit) on CA AppLogic 3.0. uname -a says Linux LINUX64 2.6.18-194.32.1.el5xen #1 SMP Wed Jan 5 18:44:24 EST 2011 x86_64 x86_64 x86_64 GNU/Linux I have upgrade ...
0
votes
1answer
102 views

How do I adjust this python script to backup to Amazon S3

The following script is nearly perfect for my backup needs: http://pastie.org/3368661 However, it only allows you to backup to the server or a remote FTP. I would like to add an option to backup to ...
8
votes
2answers
365 views

FreeRADIUS 2 should use a different Python than default

We've got a FreeRADIUS 2 deamon installed on a CentOS 5.7 server. We'd like to use a pre-written Python module to do authorization but there's a problem: The Python module we've got requires Python ...
1
vote
0answers
1k views

Fixing problems with yum, urllib2, and missing dependencies?

I've been trying to resolve the following problem with yum / python's urllib2: [root@...]# yum Traceback (most recent call last): File "/usr/bin/yum", line 4, in ? import yum File ...
1
vote
1answer
6k views

How to completely remove and re-install python (without yum)?

I have a corrupted / missing installation of Python on a CentOS 5 server, and yum won't help me reinstall because python is a dependency. When I try installing python-2.4.3-44.el5.x86_64 from the rpm, ...
1
vote
1answer
732 views

Apache showing “Python version mismatch” with mod_wsgi

I am trying to get web.py working. I have compiled mod_wsgi to use python2.6, and configured my virtualhost correctly (at least I am pretty sure it is!). The hello, world application keeps showing up ...
1
vote
2answers
358 views

Python on CentOS 5.x

CentOS 5.x comes with python 2.4 preinstalled. I'd like to use a newer version, but I don't want to break anything. How should I install a newer version without causing problems? How can I force ...
1
vote
1answer
580 views

Install Twisted on CentOS 5.5

CentOS 5.5 is using the old python 2.4 ! But I want to install Twisted on it ! Does anyone maintain a RPM of this library ?
2
votes
1answer
725 views

problem while installing some python packages

There is an issue while installing some of the packages for python. They show 'No package available' message while trying to do yum install . They are these: python-psycopg, python-reportlab, ...