RAID, an acronym for Redundant Array of Independent Disks (sometimes incorrectly referred to as Redundant Array of Inexpensive Disks), is a technology that provides increased storage functions and reliability through redundancy. -Wikipedia

learn more… | top users | synonyms

4
votes
1answer
291 views

How to recreate a RAID 10 array with mdadm

So our virtual machine has broken (it's actually a Linux machine in Azure) on which we were running a RAID10 array of 4 disks. It's an ubuntu box. From what I can tell the four data disks are fine, ...
3
votes
1answer
69 views

RAID-5 array being split on reboot (ubuntu)

I've set up a RAID-5 array on Ubuntu 13.04 (kernel 3.8.0-27-generic) using mdadm - v3.2.5 - 18th May 2012. It appears to work fine and be in high spirits: $ cat /proc/mdstat Personalities : ...
3
votes
1answer
344 views

flashcache with mdadm and LVM

I am having trouble setting up flashcache on a system with LVM and mdadm, I suspect I am either just missing an obvious step or getting some mapping wrong and hoped someone could point me in the right ...
3
votes
1answer
420 views

Resize openSUSE 12.3 GPT ext4 partitions in a RAID1 disk array

I have a software raid configured (/dev/md2) which has assigned the partitions sda3 and sdb3 from two 3TB disks (sda and sdb). The partition types are GPT not LVM and file system is ext4. Now, the ...
3
votes
1answer
206 views

Cannot get at data in my NAS

I've got a bit of an issue that I'm hoping you can help me with. I have an Iomega ix4 as my NAS. This runs Linux and each drive in the box has 2 partitions: one for the OS and RAID info, and the ...
3
votes
1answer
573 views

Configure Windows RAID-5 “drive failed” timeout?

When a hard-drive controller detects an error, and needs to remap a sector, the drive normally becomes unresponsive for the seconds (or possibly minutes) it takes to try to complete the re-mapping. ...
2
votes
1answer
145 views

Boot failed, continue to look for media

I have a new server that runs a RAID 1. I've had it off for about a month and I turn it back on and I am getting "boot failed, continue to look for Boot Media" and it just loops. Did my RAID die or ...
2
votes
1answer
162 views

How to get email alert if one of raid 1 disks fails?

I need to know how can I get email alert if one of raid 1 disks fail to work/crashes. I have CentOS 6.4 64bits, software raid. I did some mistake folowing this tutorial, because it was a bottom note ...
2
votes
1answer
341 views

Should I enable “Patrol Read” on SSD drives?

LSI, Intel and Dell RAID controllers (perhaps others) have a "Patrol Read" feature to try to spot when a drive is failing before it completely fails. LSI seems to disable patrol read on SSD by ...
2
votes
1answer
276 views

Recover mdadm RAID 10 array: listing all as spares

I'm a bad person and haven't backed up my RAID elsewhere. I now have a RAID10 array that won't assemble, and I'm hopeful I can save it. Here's the details: I have five hard drives set up as RAID10 ...
2
votes
1answer
755 views

How to create Raid 10 with megacli

I have OpenFiler storage server. Without installing Windows and MSM, I want to create raid10 array from disks 2 to 21. I have already successfully installed MegaCli to OpenFiler but I'm stuck in ...
2
votes
1answer
112 views

Using old RAID configured disk after new disk has been used in the controller

I have Dell Poweredge T100 server with Dell SAS 6 and two hard disk on RAID 1. Last week the server died including one RAID 1 hard disk. We sent the server for repair and the problem with PSU was ...
2
votes
1answer
56 views

mount hardware raid disk 1 with one disk and no hardware raid controler

I have one of two raid disk (from LSI raid card) There is a way to mount it in a PC and access to the disk without the raid card? Maybe mounting or skipping the first bytes!? Thanks in advance. ...
2
votes
1answer
400 views

Error 5 partition table invalid or corrupt

I'm trying to add a second SSD to a Centos 6 system. But I get the Error 5 partition table invalid or corrupt at boot. The system already has a single SSD (sdb) and a pair of HDDs (sd{a,c}) in a ...
2
votes
1answer
272 views

RAID iostat showing 0.00 for wait's and %util

I have a EC2 server running ubuntu 11.10 with 6 raid devices, 5 with 8 EBS drives each as part of a RAID 10 setup, the other one with 4 EBS drives as part of a RAID 0 setup. I am finding that even ...
1
vote
1answer
23 views

MegaRaid SAS 8708EM2 Capacity Expansion

I have a ThinkServer RD230-4011 in hosting which initially had 4x 300Gb drives divided into 2 RAID 1 arrays using the built-in SAS 8708EM2 card, such as this: DISK 0 (300 Gb) | VD 0 (RAID 1, 300 Gb) ...
1
vote
1answer
45 views

Replacing a failed and degraded virtual disk on Dell T110 II RAID 1 PERC S300

We have a Dell T110 II server, factory installed with Microsoft Windows Server 2012, Standard x64 Edition, running PERC S300 RAID Controller (1068E HBA). It came installed with RAID 1 on the 500GB ...
1
vote
1answer
49 views

Raid 5 verifying

Good day every one, i all ready read this RAID 5 detects write errors? I have raid 5 on "3 ware" controller i want to ask: - do i need run from time to time verify schedule or i can use only ...
1
vote
1answer
115 views

Btrfs vs ext4 — Where's the safety break-even point?

Btrfs is still in heavy development and still considered "unstable" by Chris Mason, and many important features are still being added, but the dire warnings of data loss are calamity are long since ...
1
vote
1answer
54 views

RAID 5 Array A00-01 is “optimal” but not showing when I boot from my RAID 1 Array A00-00 OS

This server was originally setup with RAID 1 mirrored drives for the C:\ primary partition where the Operating System was installed. And a RAID 5 array with 3 drives for the data partitions. The C: ...
1
vote
1answer
201 views

IBM ServerRaid lost Raid-5 configuration

I have an IBM server x3400 with 8 drives divided into two arrays. After reboot, ServerRaid lost the configuration of the Raid-5 array. The 6 drives that used to be part of this array are there, but it ...
1
vote
1answer
113 views

RAID controller won't rebuild RAID-1 array

I have a RAID-1 array on a desktop computer. The RAID controller is a 3ware 7006-2. Recently the controller has been reporting ECC errors from one of the drives. It was able to correct all of those ...
1
vote
1answer
520 views

How to get notified of mdadm RAID problems?

I am running Ubuntu 12.04 LTS. Yesterday I found a message in my mailbox saying that my server was shut down. I proceeded to reboot the system, but it didn't come up after many minutes, and I didn't ...
1
vote
1answer
78 views

IBM serveraid problems

When I start my server serveraid gives me this error: not responding properly Error 00D0 any help would be appreciated. I can't find any information on this. Where can I go to get more information on ...
1
vote
1answer
141 views

100% SSD usage Linux

Every 20-30 seconds my HDD usage goes to 100% (iostat). iotop is showing that [flush-8:0] is using 99% HDD during these times. In between HDD usage is 1-10%. iostat output: 04/22/2013 08:58:44 AM ...
1
vote
1answer
246 views

mdadm did not notice a failed disk in raid0

I have a server with mdadm raid0: # mdadm --version mdadm - v3.1.4 - 31st August 2010 # uname -a Linux orkan 2.6.32-5-amd64 #1 SMP Sun Sep 23 10:07:46 UTC 2012 x86_64 GNU/Linux One of the disk has ...
1
vote
1answer
128 views

Linux RAID: Replacing Failed Drive…permanantly

Okay, odd question here. I have a server with RAID 5. A drive failed, in a really physically in a really odd way. On the machine it boots and is seen by the BIOS but...no partition can be seen on the ...
1
vote
1answer
140 views

Storage setup on Ubuntu Server used for running virtual machines with software redundancy

I have a server I would like to use explicitly for running virtual machines under Ubuntu Server 12.04. It has plenty of RAM, 64GB and three large identical HDD´s. I would like redundancy through ...
1
vote
1answer
78 views

DegradedArray event on /dev/md0 without actually having a RAID

Since I upgraded from Ubuntu LTS 10 to LTS 12, I have been getting error messages like: N 60 mdadm monitoring Mon Sep 3 06:38 31/1022 DegradedArray event on ...
1
vote
1answer
141 views

ML350 Using both p800 and e200i

I have an ML350 G5 with a P800 and the integrated e200i. I'm using the P800 to service the main drive cage with 6 SAS drives in RAID 5. However, I would love to also convert some of the unused 5.25" ...
1
vote
1answer
356 views

RAID 5 has no READ speed advantage over single drive?

I have recently acquired an Intel SASMF8I raid card for my office. I have 5 x 1TB disks and have created two arrays, 3 x 1TB RAID-5 and 2 x 1TB RAID-1. The second drive is for sensitive/vital data and ...
1
vote
1answer
660 views

MDADM not able to connect to EBS drives on Ubuntu 11.10

I have been using a raid.sh script [1] for over a year now and has never gave me trouble. I recently started moving from Ubuntu 10.04 machines on AWS to Ubuntu 11.10. I updated the raid.sh script from ...
1
vote
1answer
980 views

prevent filesystem from entering read-only mode

I have found that my server's filesystem is continuously entering read-only mode. There have been some issues with the raid1 array, but I have removed the bad disk from the array. However, it is ...
1
vote
1answer
393 views

mdadm: hot remove failed for…

My RAID1 is degraded and I need to replace /dev/sdb. However, I could mark /dev/sdb5 (in /dev/md1) as failed and removed it, but I can't do the same with /dev/sdb1 (/dev/md0 which is mounted on /): ...
1
vote
1answer
288 views

Disk/EBS volume that is part of an Raid0 drive suddenly becoming unreadable/unavailable

We have a 4 x 100gig EBS volumes used as dynamic disks in a raid 0 (striped) drive attached to a Windows2008 R2 Datacentre 64bit Amazon EC2 instance. This all works fine, except we have had 3 ...
1
vote
1answer
438 views

XServe Raid with Ubuntu 10.04 problems

I have an Apple XServe RAID connected via fibre channel to a Dell Poweredge R610. This server is mainly for hosting subversion repositories, and storing disk images. In the past 6 months or so we ...
1
vote
1answer
160 views

Erratic write patterns with linux md RAID1

I'm experiencing strange write performance patterns on a RAID1 array of SATA disks. My kernel is vanilla 2.6.37 and my server has 32G RAM. I'm copying a 32G file from an XFS filesystem on a SAS drive ...
1
vote
1answer
121 views

Hyper-V R2: Need help with disk structure

I'm going to use the free (non gui) version of Hyper-V R2. In my new server I have 8 disks in total (for Hyper-V R2 installation and virtual machine). Atm I'm going to run a single virtual machine, ...
1
vote
1answer
181 views

“Verifying DMI Pool” hang caused by raid array

I have a problem, I obtained a new server with 4 hard drives (2 500 gig, 2 two TB), and an adeptec RAID card. I arranged them in two arrays with RAID 1 (500 gigs together as primary and the 2 TB ...
0
votes
0answers
42 views

Server 2003 RAID 5 new adaptec controller card

I believe I lost an Adaptec 2410 controller card over the holiday weekend. I purchased a new card and installed the same card. The card sees the drives, but when I go to manage arrays it says no ...
0
votes
0answers
101 views

Strange Raid 1 error

cryptsetup: WARNING: failed to detect canonical device of /dev/md1 cryptsetup: WARNING: could not determine root device from /etc/fstab I constantly get this error, although everything seems to be ...
0
votes
0answers
395 views

HP ML110 G7 with Huge Raid5

I try to Install a Hyper-V 2012 Core on a HP Proliant ML110 G7 with a Raid 5 (4x3TB=~8TB for use). It seems, that this Server has no UEFI Support (can't figure it out). So I ended up with 350MB ...
0
votes
0answers
856 views

Can't mount logical volume, RAID/MD/LVM problems

I have a file server with 48 2TB HDDs split across 2x 3ware 9650SE-24M8 RAID cards. Both cards have 24 drives in RAID 1+0. MD softraid is setup in raid 0 with the two RAID 1+0s making RAID 100. LVM2 ...
0
votes
0answers
220 views

Dell systems build and update utility fails to see logical drives and raid config

I have a Dell Poweredge 2850 with a RAID 5 array and a RAID 1 array. A disk has an amber light on for a while. I forced the disk out and replaced it. I Rebuilt the disk and now the system will not ...
0
votes
0answers
653 views

How to install Squeeze on a Dell R210 with H200 Raid Card

I am having trouble installing Debian squeeze on a Dell R210 with H200 Card. After Installation, I am not able to boot it. Has someone installed Debian Squeeze on a Dell R210 with S100 or H200, and ...
0
votes
0answers
164 views

mdadm Build legacy array with 512-byte chunk

I'm attempting to build an array using mdadm. The array has 512-byte (not kibibyte) sized stripes. Because mdadm accepts arguments to chunk in kibibytes, not in bytes, I have been unable to build ...
0
votes
0answers
278 views

Is Adaptec Storage Manager Agent (RaidMan) Necessary?

I recently started renting a server with a hardware RAID controller. It came with software called Adaptec Storage Manager Agent (RaidMan, a java process). This agent is always running and using ~1% ...
0
votes
0answers
119 views

Dell PERC5 raid; firmware

I have been having problems with disks on my Dell PERC5/i Raid controller, and was instructed to update the controller's Bios (by Dell and by OpenManage). One of these problems is disks getting a ...
-1
votes
0answers
17 views

RAID 1 without cache protection - ZCMP/backup battery

I'm running RAID 1 on an Adaptec 6405. I'm trying to decide if I need to install the ZCMP on the card to provide Cache protection. Adaptec's ZCMP is the equivalent of a BBU - battery backup for the ...
-1
votes
0answers
15 views

RAID moved to new server, Clients sporadically get error message

I have a really strange problem and I can't figure out what it is. Our company server runs on OS X 10.8 and has a RAID connected to it. The RAID was moved from an old server, all permissions were ...