2
votes
2answers
220 views

RHEL 5 list missing critical patches/packages

Im trying to figure out if there is an easy way to identify the missing critical patches/packages on my RHEL5 boxes. This is for audit purposes and was trying to figure out if there was an RPM command ...
1
vote
3answers
609 views

RPM ignore conflicts

is there a way to ignore rpm version conflicts by keeping the latest version installed? For example. I want to install gawk in AIX. I have all the required rpms in a folder ...
12
votes
1answer
351 views

Can you help me with my software dependency issue?

This is a Canonical Question about Compile Dependencies and Package Management. I have a question regarding compiling ports/software or installing RPMs on my *nix server. When I try to do this ...
0
votes
1answer
261 views

Cannot get exclusive lock on rpm database in Unix

I was trying to install a python rpm on AIX 6.1 and it was taking too long and so I had to close ther terminal. Later when I tried to install the same rpm as root I am getting the problem as : ...
4
votes
3answers
494 views

%post section of rpmbuild not working

Situation: I'm trying to build a custom rpm to place a config file in a particular location. The installation completes fine by placing config files in proper directories but the %post section is not ...
2
votes
1answer
426 views

How to add new path to $PATH variable in a post-installation script of RPM?

I want to automatically add a new path to the $PATH variable each time when my RPM package is installed. I tried to use a post-installation script in the my RPM. Here is the part of RPM spec file ...
2
votes
1answer
1k views

Rpm removal does not remove delivered dirs and leaves garbage

I deliver an application via an RPM. This application delivers various directories and files. E.g. under /opt/internal/com a file structure is being copied. I was expecting that on rpm -e all ...
1
vote
1answer
3k views

Failed depencies: libmysqlclient.so.16 is needed

I'm trying to install something on my server that requires mysqlclient, but looking at my RPM package list I have it ("MySQL-client-5.0.91-0.glibc23"). Doing a locate on libmysqlclient gives me this: ...