RPM Package Manager is a package management system used primarily for GNU/Linux operating systems. It used the .rpm file format.

learn more… | top users | synonyms

1
vote
3answers
3k views

Install xdebug for php 5.3.17 on centos 6.3 (final)

I'm really having difficulty finding out how to install xdebug for php 5.3.17 on centos 6.3. I've tried this link (for centos 5.6 admittedly) but had no luck. Can anyone point to the right RPM ...
-1
votes
2answers
3k views

What is the correct dependency rpm for libcurl.so.3

So I have a failed dependency and I am having trouble downloading the correct rpm. The error is libcurl.so.3()(64bit) is needed. I have Centos 6 and I have looking in this site for the correct rpm. ...
1
vote
2answers
190 views

Install gettext-0.17-1.el5.i386.rpm on CentOS 5.8 i386 gives “/usr/bin/python is needed” error

I've removed yum by mistake. So, now I'm installing all the dependencies needed by yum manually. One of those is gettext-0.17-1.el5.i386.rpm and when I try to install it gives the following error, ...
4
votes
3answers
532 views

yum update, how to make rpm package updateable

need a link or tutorial on how to make an rpm package work with yum UPDATE. i have it and already works with yum INSTALL and yum ERASE, but is there somewhere info on how to make rpm package work when ...
1
vote
2answers
389 views

yum update kernel without removing old?

When I yum update it wants to remove the oldest of the 3 kernel I have and upgrade to a new. Is it possible to get yum not to remove old kernels?
1
vote
1answer
79 views

Alien: .rpm -> .deb | Compability / Built per system?

At the moment I'm playing a bit with alien (for OpenVZ packages on Debian) and was wondering myself about one question for which I was not able to find an answer anywhere. Therefor I thought it might ...
0
votes
1answer
35 views

Installing multiple mysql as rpm vs tarball

Which is the suitable way to install multiple mysql servers without affecting the current installation in fedora( rpm or tarball)?
0
votes
1answer
71 views

Creating YUM/RPM repositories [closed]

I'd like to create a standard yum/rpm repository with package signing and whatever other best practices exist. What is the procedure to add RPM, sign it and update the repo xmls?
4
votes
3answers
476 views

%post section of rpmbuild not working

Situation: I'm trying to build a custom rpm to place a config file in a particular location. The installation completes fine by placing config files in proper directories but the %post section is not ...
2
votes
3answers
3k views

Howto get yum to install only dependencies for a given pakage?

I am looking for a way to have yum install only dependencies for a given package, something like an --prepare-for-install option so I can take a snapshot of the prepared system and test the rpm setup ...
3
votes
1answer
66 views

Re-packaging commercial software into RPM packages

The situation is this - I have a small CentOS 5 "cluster" (currently 7 machines, but potential for more) which run a commercially available software package that's distributed essentially in tarball ...
0
votes
1answer
428 views

rpm -Uvh & yum install

I am new to linux and wants to understand the reason for using some commands. I am trying to install PostgreSQL on CentOs by following the instructions here. First we do rpm -ivh ...
1
vote
2answers
128 views

download all RPMs from a metapackage

example of what im trying to do # yumdownloader net-snmp.x86_64 --source Enabling epel-source repository epel-source ...
1
vote
1answer
52 views

Overriding RPM public key database

Can rpm be persuaded to import and fetch public keys from an arbitrary pubkey database? On the same build machine I've got two automated users who each need to verify package signatures from ...
2
votes
3answers
106 views

Trying to install a freshly built RPM but it says it is dependent on a lib it should not be dependent on

The package in question is samba-3.6.7. I've built the package successfully, but when trying to install it, it returns, error: failed dependencies: libtalloc.so.1 is needed by samba-3.6.7 I have ...
3
votes
2answers
408 views

setting up rhel 5.x RPM build server for mortal users

My task is to setup a RHEL 5.x build host, that can build RPMs for mortal users. On RHEL 6.x with rpm version 4.8, I have in /usr/lib/macros: # Path to top of build area. %_topdir ...
0
votes
4answers
3k views

How to uninstall mysql on redhat linux version 5

I have identified the rpm to uninstall which is the following: mysql-5.0.77-4.el5_6.6 I run the following rpm command to uninstall it: rpm -e mysql-5.0.77-4.el5_6.6 Then I receive a dependency ...
1
vote
2answers
337 views

Remove installed packages from one repo and reinstall from CentOS?

I have 62 packages from RPMfusion that have overridden the CentOS upstream packages, and now I would like to return to the original CentOS packages. The only idea I can think of is ...
0
votes
1answer
806 views

Client is not able to use Yum Server configured on Server under /home/RPMS file path

I have configured Yum Server on Server 10.0.0.1(Redhat 5.3) All RPMS are here /home/RPMS/Server. Now on another machine i have Centos 5.3 (10.0.0.30).I want to use yum Server of 10.0.0.1 on 10.0.0.3 ...
0
votes
2answers
2k views

~/.rpmmacros and how to view/add to it

I am currently following a guide to install Java 1.4 on the CentOS site and was wondering if anyone could help me understand some of the terminology. It states: For this example, it will be ...
1
vote
1answer
267 views

rpm rollback ignoring rpms - no error output

Issue rpm rollback is not working with a set of repackaged rpms created in the last couple days, but does work with more recent ones. [root@host1 repackage]# ls -l zsh-4.2.6-* -rw-r--r-- 1 root ...
3
votes
2answers
1k views

Install software on CentOS: binaries or rpm?

I am pretty new to linux systems. I have the option of installing a software (ImageMagick) using either its .rpm or compiling the source from .tar.gz (which I have already done). Which one should I ...
2
votes
1answer
403 views

How to add new path to $PATH variable in a post-installation script of RPM?

I want to automatically add a new path to the $PATH variable each time when my RPM package is installed. I tried to use a post-installation script in the my RPM. Here is the part of RPM spec file ...
1
vote
3answers
4k views

Install MySQL 5.6 on CentOS 6.3 gone WRONG

I am trying to install MySQL 5.6 on CentOS 6.3 64bit using the .rpms provided by MySQL. I downloaded all the 64bit linux rpms into /usr/local/src/mysql and performed rpm -Uvh *. The installation gave ...
0
votes
1answer
122 views

Building RPM containing passwords

I need to be able to send an RPM to customers that will install the complete server, including Apache and MySQL. The customers will install it on a clean machine. After installation, the server ...
6
votes
2answers
990 views

Do .rpm files have metadata

I have a .rpm file on my windows machine. Is there a way to inspect this file (either on windows or centos) without installing it, to find out where it was compiled from? something like metadata?
0
votes
2answers
485 views

Postgres 9.2 beta for Suse SLES

I am searching the internets high and low, but can't find any Postgres 9.2 beta versions for any SLES versions. Can I take some Fedora RPM or similiar, or can someone tell me how to find the RPMs on ...
0
votes
1answer
32 views

What is the RPMRepository

In several CentOS tutorials, they advise enabling the RPMRepository. I have some questions about this repository. It seems like it's a RedHat repository that CentOS uses as well, since it's based on ...
1
vote
1answer
1k views

How to update crontab for a non-root user on Solaris non-interactively?

I would like to update crontab entries for a non-root user for an application which gets installed as OpenPKG RPM package. Currently I have this in the %post section of my .spec file: # # Set up the ...
2
votes
2answers
1k views

Upgrade mysql version

I am trying to upgrade mysql package to 5.5 on centos. (amazon image - ami-cc5af9a5) There is 5.1 version of mysql-libs that can not be uninstalled because postfix is dependent upon it. But I can not ...
6
votes
2answers
152 views

RPM: Set Required: somepackage >= 0.5.0 AND somepackage < 0.6.0

Is it possible to set dependecy version requirements like this: Required: somepackage >= 0.5.0 AND somepackage < 0.6.0 So only somepackage 0.5.x will be automaticly installed.
0
votes
1answer
143 views

Getting Segmentation fault when installing my RPM trough another RPM requirement

I have a RPM to install SWFtools as written here. I have a another RPM that I created containing basic applications, shared to all of our servers. the first RPM (SWFtools) should be installed after ...
-1
votes
1answer
650 views

How to install puppet devel version from yum?

In /etc/yum.repos.d/puppet.repo have I put [puppetlabs] name=Puppet Labs Packages baseurl=http://yum.puppetlabs.com/el/$releasever/devel/$basearch/ enabled=1 gpgcheck=1 ...
3
votes
2answers
77 views

RPM package naming for alternative configurations

I currently install PHP from source in several different configurations around my environment, each providing the minimum feature set required for its particular deployment: one deployment requires ...
3
votes
3answers
433 views

Decompiling an RPM?

This is hopefully a simple question. Are there any tools out there to find out an enhanced description (beyond the normal rpm command) of the contents of an rpm, and possibly decompile it? We ...
1
vote
1answer
378 views

Roll back RPM package

Is there any way to roll back a single package from yum update. I've noticed that the rpm --rollback switch is depreciated in SL linux 6.2. There is also yum history however I would like to rollback ...
1
vote
1answer
376 views

yum - find packages in version minimum 'x' in specific repository?

I have configured several repositories on my CentOS 5 box. As an effect, command: yum search nagios outputs just mess - thousands of duplicated packages. To make my life easier I would like for ...
2
votes
0answers
167 views

Unable to upgrade proftpd on plesk 9.5.4 with atomic rocket turtle repos

I've been trying to crack this one for a while now. I'm running Plesk 9.5.4, and have tried to upgrade and reinstall proftpd from ART packages. Here's what I'm getting from the following commands: # ...
-1
votes
1answer
840 views

NRPE installation issues “Starting nrpe in daemon mode … /usr/sbin/nrpe: error while loading”

I'm trying to install the nrpe package for OP5 on Centos. I think something is corrupt since I get following when trying to start the nrpe service: service nrpe start Starting nrpe in daemon mode ...
3
votes
1answer
381 views

How to cutomise a CentOS iso to include my own rpm packages

Say I have downloaded a CentOS live desktop CD. How would I include my own rpm packages, so that they get installed automatically as soon as I boot with the live CD or have it permanently install in ...
1
vote
1answer
333 views

Obtain newer version of NetSNMP for CentOS 5

I'm using CentOS 5. I have a need to use net-snmp version "net-snmp-utils-5.5-37.el6_2.1.x86_64" which is currently available in CentOS 6 but not in CentOS 5. The reason I need this version (or ...
0
votes
1answer
216 views

Handling yum upgrade from pkg-x.y.rpm which requires mod_python to pkg-x.(y+z).rpm with conflicts mod_python

With yum/rpm on RHEL 5 can a yum upgrade be made to remove another, conflicting package - similar to the behaviour of apt-get dist-upgrade on Debian? I am updating the .spec for our product's rpm. ...
3
votes
1answer
2k views

RPM Spec How to specify in package so that previous RPM is removed

Question: What do I put in the foo.spec file so that the rpm's will remove the previous rpm before installing? Description: I have created a spec file that creates rpm's for a few packages that use ...
1
vote
3answers
127 views

Running rpm command in particular directory breaks

I have an unrelated issue to this RPM issue. I'm not sure if the two relates but I'll just talk about the one that's related to running the rpm command since it's easier to explain. The other issue ...
2
votes
2answers
2k views

yum trying to install el5 when I am on el6

When I run the following yum command I get this error: Package: git-1.7.10.1-1.el5.rf.x86_64 (rpmforge) Requires: libcurl.so.3()(64bit)" I read that this error is due to running an el5 ...
3
votes
4answers
156 views

rpm -ql package_name equivalent for Windows MSI?

Is there such a utility or capability an MSI? Perhaps msiexec? rpm -ql provides the list of all the files installed by a given package. I'd like to get the same info from a Windows system.
-1
votes
1answer
101 views

%files section in building rpm from source using Red Hat package Manager

I am creating customized rpm through source. I want to know what is the use of %files section. These are the files that rpm will include in the package or it needs these files for rpm creation ...
0
votes
2answers
428 views

getting permission denied while creating rpm through rpm package manager on RHEL 5.3

I am trying to create rpm through rpm package manager. Following is my spec file: **# This is a spec file for openldappkg** %define _topdir /osp/rpmBuildOpenLdap %define name openldap %define ...
3
votes
3answers
425 views

Is there a way to build rpm's and deb's on the same system

I have a large Java enterprise application that is required to output rpm and deb packages. Currently this means that we build the application on two different boxes, one with CentOS and the other ...
1
vote
0answers
249 views

Mock build system error: sh: ruby: command not found

I am trying to build a RPM using the mock build system. However, the shell in the mock environment cannot seem to find the ruby command. I run in to a build error: sh: ruby: command not found I can ...