RPM Package Manager is a package management system used primarily for GNU/Linux operating systems. It used the .rpm file format.

learn more… | top users | synonyms

2
votes
0answers
27 views

Automatically remove a %preun broken RPM?

We have an error in the %preun script of an RPM we distributed in the past. This has been corrected, but, now, upgrading to the newer version is failing because the previous version is not ...
0
votes
0answers
13 views

Yum dependency issue with newer release version

I'm having an issue installing some software with yum, it shows a dependency issue even though all the packages are installed. I'm trying to install the redhead-lsb package. I get the following ...
0
votes
2answers
175 views

Automate NetBackup agent installation via RPM

We have an automated process of deploying new RHEL VMs. However, there's still an annoying manual step to install a NetBackup agent on the machine. This requires coyping a large archive (~ 1 GB) to ...
22
votes
5answers
93k views

How do I install an rpm that complains about rpmlib(FileDigests) <= 4.6.0-1?

Im trying to install an rpm file on CentOS 5 and Im not sure how to resolve this issues it brings up: $ rpm --install epel-release-6-5.noarch.rpm warning: epel-release-6-5.noarch.rpm: Header V3 ...
1
vote
0answers
25 views

CentOS 5.11: yum installs, but packages remain missing

I'm trying to figure out a very strange problem with yum on a fairly old CentOS 5.11 VPS using DirectAdmin. Executing the following command suggests the telnet package is installed: # yum install ...
0
votes
5answers
676 views

Error: Nothing to do trying to install local RPM

I'm trying to install this RPM locally via yum and am greeted with just a "Error: Nothing to do" message. Full stdout Loaded plugins: fastestmirror, priorities Setting up Install Process Examining ...
0
votes
0answers
1k views

Install PHP-SOAP for PHP-FPM 5.5.4 CentOS 6

I have the following version of PHP installed (My server is 64-bit CentOS 6): php-common.x86_64 5.5.4-1.el6.remi This is running via PHP-FPM, if that makes a difference. I've discovered several ...
2
votes
1answer
27 views

What are the consequences of installing some el6 packages on Centos 7?

I'm responsible for administration of a Centos 7 box at my contract job. I'm really more of a developer and not much of a Linux admin, so please bear with me and maybe try to explain this to me like ...
0
votes
1answer
996 views

can not install glibc-devel 'Requires: libnss_files.so.2' error

I'm using Linux 6.1 I need to install glibc-devel but it fails with this error. [root@server1 Packages]# yum install glibc-devel-2.12-1.25.el6.i686.rpm Loaded plugins: refresh-packagekit Setting up ...
1
vote
1answer
66 views

yum repo responding with [Errno 14] HTTP Error 403 - Forbidden

I am trying to set up a YUM repository containing some RPM packages from our nightly Jenkins build. The YUM repo resides on the Jenkins server in a repository folder [path to ...
0
votes
0answers
20 views

Is the lmdb-devel package necessary for installing the cfengine on RHEL v.7 via an RPM .spec file?

I have a problem when I try to build from my spec file. I run this: rpmbuild -ba newpackage.spec I see a great deal of output. It ends with these lines: configure: error: Cannot find ...
1
vote
1answer
25 views

How do I get a basic spec file to work with rpmbuild?

I installed rpmlint and rpmdevtools. I used rpmdevtools to create a template of a .spec file. I modified the spec file so it will install cfengine. I ran rpmlint on the spec file, and I saw no ...
0
votes
2answers
3k views

How to install MariaDB rpms in CentOS 6.4 using rpm (not yum cmd) + handling mysql-libs conflicts

I need to script the install of MariaDB using the rpm command in CentOS 6.4. I can't use yum since it's going to be an offline install so there's no access to the repository. The only MySQL package ...
0
votes
1answer
1k views

Unable to install awstats on redhat 7 due to missing perl(LWP::UserAgent)

I'm unable to install awstats on my rhel7 aws ec2 instance: [root@ip-10-146-180-60 ~]# cat /etc/redhat-release Red Hat Enterprise Linux Server release 7.0 (Maipo) [root@ip-10-146-180-60 ~]# rpm -ivh ...
1
vote
0answers
44 views

RHEL yum broken

I have RHEL which is deployed from Amazon AMI, and yum is somehow broken. I must use that AMI because of corporate software installed on it. There is no way to rollback to previous state. This is the ...
1
vote
1answer
33 views

install libxml2 without internet connection so that nokigiri can be installed

I am trying to install libxml2 on a redhat box which cannot connect to the internet. So i downloaded and scped the following rpms: libxml2-2.7.6-1.x86_64.rpm libxml2-devel-2.7.6-1.x86_64.rpm ...
1
vote
1answer
348 views

RPM: How to force required version to be greater than the specified in .spec file?

I have the following entry in my package .spec file: Requires: jdk >= 1.7 Even though, jdk-1.6.0_45-fcs.x86_64 is installed my package installs without problems (even without warnings). How to ...
10
votes
5answers
52k views

How to install mcrypt for PHP 5.3.3 on CentOS 5.7 64 bit?

I installed php 5.3 and some modules using yum install php53-{module-name} But mcrypt did not work. I searched like this: yum list php* | grep mcry The only package that came up was ...
0
votes
3answers
88 views

MySQL Upgrade RPM

I have a centos5.5 system and have MySQL 5.0.27 install. Now I want to upgrade this to MySQL 5.5.28(Latest). I have two questions, What is the difference between RPM(Redhat) which is recommended and ...
0
votes
0answers
51 views

Building a stack of SRPMs in build-dependency order

If I have a stack of SRPMs that I'd like to build, leading to a final product binary RPM. Many of the SRPMs require the built RPMs of other SRPMs to build. These requirements are expressed in the ...
1
vote
0answers
65 views

rpmbuild spec file: how to have files only used during install

How do I specify in a .spec files that are only used during install of the rpm (such as .sql scripts that I feed into the database), but I specifically don't want to persist post-install? I can't omit ...
6
votes
2answers
3k views

Make kernel modules available that have been deactivated on Fedora

Edit: I turned Cristians answer into a script which does everything automatically: https://github.com/frans-fuerst/magic/blob/master/fedora-activate-can.sh I need some kernel modules which are ...
1
vote
4answers
3k views

rpmbuild on Cent OS 6: “cpio: bad magic”

When I try to run this command : rpmbuild -bb SPECS/software.spec I get an error when the WAR file (as in tomcat java web archive file) is being added to the rpm: error: create archive failed on ...
0
votes
0answers
34 views

RPM Dist Tag not behaving as documented

According to the Fedora documentation the %{?dist} tag when building an RPM on CentOS 7 I should get .el7. but currently I get .el7.centos. The line from my .spec: Release: 1%{?_buildid}%{?dist} I ...
5
votes
3answers
12k views

Upgrade cURL to latest on CentOS

I need to upgrade cURL to the latest version on Centos 2.6.18-164.15.1.el5.centos.plusxen #1 SMP Wed Mar 17 20:32:20 EDT 2010 x86_64 x86_64 x86_64 GNU/Linux I'm unable to find any suitable ...
1
vote
0answers
41 views

Library Dependency is different when checked via yum vs. rpm

I'm new here and am debugging something I've never seen before, so I'm hoping someone can show me where I'm going wrong. I've created a local yum repo for all my servers. The idea is to distribute ...
0
votes
0answers
201 views

rpm dependency failed to install, package installed anyway

I have this issue and I would like to understand why it is like this. I have build 3 really simple rpm packages called a, b and c, and I made a independant, b depending on a and c depending on a and ...
1
vote
0answers
10 views

libexecdir in systemd .service file?

I'm deploying something to machines (internally, not for public consumption) using RPMs. Now, in RPM .spec files there's the %_libexecdir variable. The package deploys a service binary in that ...
0
votes
1answer
128 views

Yum Cache Service

I have a LAN where I currently use an instance of Sonatype Nexus to proxy several yum repositories. All the clients on the LAN are configured to install packages only from this service. The only ...
2
votes
1answer
35 views

rpm - how to execute a php file in %post rpm

I'm creating an rpm installer for a php web application. One of the requirement is to run a php script, an entry script that will update the source, database and execute fix scripts. To accomplish ...
0
votes
0answers
34 views

rpm spec file is not executed on rpm install

I am creating an rpm installer for my web applications. On the spec file, i got this on %prep and %install %prep #will create and cd to the named directory before doing the untar. %setup -c -n ...
0
votes
0answers
47 views

Solved but Confused: Fedora 19 to 20 - “Protected multilib versions: chkconfig”

Initial Problem When upgrading from Fedora 19 to 20 using this command: yum --releasever=20 --setopt=deltarpm=0 distro-sync I get the following error Error: Multilib version problems found. This ...
12
votes
2answers
16k views

tell yum to ignore a single dependency

I'm trying to install winswitch on CentOs 6. It requires 'nxagent'. But in centos, the package name is 'nx'. Is there a way to tell yum to skip checking the 'nxagent' dependency (i installed 'nx' ...
0
votes
0answers
46 views

yum list available - not showing all packages

I have a strange problem with yum, working on one server and not working on another server that should be identical. The symptom is that after running createrepo on a directory containing RPMs (and ...
0
votes
0answers
46 views

When debuginfo rpm is generated?

I have a series of RPM spec files and no debuginfo directive set in them. When I run rpmbuild, some packages generate a debuginfo rpm, some do not. What is the criteria used by rpm to decide if a ...
1
vote
0answers
63 views

Cannot install mysql server - Error in PREIN scriptlet in rpm package mysql55-mysql-server-5.5.32-3.el5.x86_64

I am trying to install mysql server 5.5 (or any 5.x versions) on Redhat 5.5 and am having some trouble. I can install the other mysql components but when I try to install mysql-server (or ...
0
votes
0answers
36 views

Can FPM make one RPM package that acts differently if systemd is being used?

I build an RPM using fpm for EL6 hosts. It installs a /etc/init.d script. However if that package is installed on an EL7 host, I want it to install a file in /usr/lib/systemd/system instead. Is ...
0
votes
1answer
115 views

RPM or YUM equivalent of apt-get install libgraphicsmagick1-dev

I was using Ubuntu for development and one of the dependencies needs apt-get libgraphicsmagick1-dev now I need to deploy to a AWS EC2 which runs AMI and only support YUM or RPM, what the the ...
0
votes
0answers
142 views

RPM build errors File listed twice

I'm trying to build an rpm of the latest stable php (5.6.7) under CentOS 7. And when I try to build it, I'm getting the following errors: [bluethundr@repo SPECS]$ rpmbuild -ba php.spec Processing ...
0
votes
1answer
153 views

How to build from source on CentOS 5.9?

I'm building iptraf-ng on CentOS 5.9 and running into the following errors: src/packet.c: In function ‘packet_process’: src/packet.c:322: error: ‘ETH_P_QINQ1’ undeclared (first use in this function) ...
0
votes
1answer
21 views

Yum installs dependency after main package

I have 3 packages A, B and C. C depends on B, B depends on A. I've created a repo of these 3 packages. When I run yum install C, it installs B first, then A, and then C. How do I make sure it installs ...
1
vote
1answer
90 views

Getting diffs for file changes detected by rpm -V

I have an installation that has been tampered with, and I want to find out what exactly has been changed. I can run rpm -V MY_PACKAGES which gives me a list of modified files. Now I am looking for ...
4
votes
3answers
1k views

yum update, how to make rpm package updateable

need a link or tutorial on how to make an rpm package work with yum UPDATE. i have it and already works with yum INSTALL and yum ERASE, but is there somewhere info on how to make rpm package work when ...
3
votes
4answers
7k views

Install msttcorefonts on CentOS 6.3

I have installed Mantis Bug Tracker on a CentOS 6.3 server and enabled the JP Graph plug in. However, to get this plug in to display the required TTF fonts I have to install something called ...
0
votes
2answers
628 views

Yum problems with easy apache - The server’s system package manager, ‘YUM’, failed.? [closed]

I keep getting the following error on easy appache !! The server’s system package manager, ‘YUM’, failed. ! !! This is the command that failed: yum -y install gettext automake19 libstdc++.x86_64 ...
2
votes
2answers
2k views

CentOS yum *.rpm package changelog (not installation changelog)

I just logged into my new rented server and updated openssl because of the heartbleed-bug (http://heartbleed.com). I updated using yum list openssl ... Installed Packages openssl.x86_64 ...
5
votes
6answers
2k views

Parse an RPM name into its components

Is there a name-parsing tool that is part of the official RPM tool package? I have a list of filenames. Each is the filename of an RPM package. I don't have the actual packages, just the filenames. ...
2
votes
1answer
115 views

replace or remove GPG signature on RPM

Is there a way to remove or replace an existing GPG signature on an RPM? I am placing a few obscure RPMs on an internal repo we use for supplementary rhel/centos packages. A few of those RPMs are ...
1
vote
1answer
45 views

fedora packages for enterprise linux

There are a number of packages available on fedora that I would like to install on RHEL v6.x. These packages do not appear to be available from RHEL (release, release-optional, or supplementary ...
2
votes
1answer
84 views

.rpmnew file not created on package upgrade?

I'm currently testing installing a RPM with a config file using the config(noreplace) directive. As per using config(noreplace) my spec file marks a single file as a config file: %config(noreplace) ...