RPM Package Manager is a package management system used primarily for GNU/Linux operating systems. It used the .rpm file format.

learn more… | top users | synonyms

3
votes
1answer
381 views

Is there a way to see if an rpm was installed manually or installed from a repo?

Title pretty much sums it up, but I'm looking for an rpm or yum command to see if an installed package was installed from the repos (if repo, which repo?), or manually.
2
votes
1answer
168 views

RPM packaging conflicting libraries

What is best practice for RPM packaging something that provides a library which in name shadows a system library? Background: For an RPM-backed Linux system, I am packaging a "self-contained" app foo ...
1
vote
1answer
40 views

rpmbuild fails with parenthesis in name

I am building RPMs with maven, triggered by Jenkins. Someone decided it was a good idea to have ( and ) in jenkins job names. This breaks my rpm generation, and it's immediately evident what's wrong ...
1
vote
1answer
130 views

Ordering RPM virtual packages

I have following packages, built by my RPM spec: libevent backend %package -n libfoo-libevent Summary: libevent backend for FOO Provides: libfoo-backend Requires: libevent >= 1.4 libev backend ...
1
vote
1answer
168 views

Running rpm does nothing

I'm not sure what happened with rpm on my system. This is a CentOS 6.3 VM hosted on Amazon EC2 if that makes a difference. When I run any rpm commands, it returns to the command prompt doing nothing. ...
1
vote
1answer
206 views

RPM packages with dependencies based on a major version of software (i.e php 5.3 with it's addons and then php 5.4)

Scenario: PHP5.3 php-5.3.21-1_x86_64.rpm (base) php-pecl-memcache-3.0.6-1_x86_64.rpm (dependant on above because of the internal PHP ABI version change) PHP5.4 php-5.4.13-1_x86_64.rpm (base) ...
1
vote
1answer
51 views

Multiple identical GPG Keys. What can cause that?

I'm using OpsCode Chef to manage all my VMs, but since the last week, I'm having issues with one VM. When running chef, it hangs right at the beginning. After a bit of investigation, I found out that ...
1
vote
1answer
375 views

rpm rollback ignoring rpms - no error output

Issue rpm rollback is not working with a set of repackaged rpms created in the last couple days, but does work with more recent ones. [root@host1 repackage]# ls -l zsh-4.2.6-* -rw-r--r-- 1 root ...
1
vote
1answer
167 views

RPM postinstall script missing?

I executed the following on xyz-3.0.rpm: $ rpm -qi --scripts ~/xyz-3.0.rpm > list Now here's what list showed: $ cat list postinstall scriptlet (/bin/sh): rm /opt/xyz/config/appkey.cfg ...
1
vote
1answer
513 views

Add RPM package to mrepo?

I'm learning mrepo. I've got it generating repos based on ISOs. But is there a way I can add an RPM (package I built) quickly/easily to one of these repos? Do I just add the RPM to the srcdir? My ...
1
vote
1answer
123 views

Query IBM domino server linux package

I have used rpm -qa to export the list of package installed on the linux machine. After which, I didn't see any IBM domino server related packages in the exported file. May I know what is the ...
1
vote
1answer
491 views

How To Clone part of a RPM repository?

I have mechanisms for cloning RPM repos from the 'net. But what I really want is a way to clone PART of a repo. So far I haven't found any such existing mechanism. Here's the requirements: We ...
1
vote
1answer
193 views

How best to automatically deal with multiple site_ruby locations?

Is there a way to automatically append to $: variable in ruby to account for additional site_ruby locations? Ruby is installed in /usr/local/ and using gem_install will properly install the new ruby ...
0
votes
1answer
44 views

Automate NetBackup agent installation via RPM

We have an automated process of deploying new RHEL VMs. However, there's still an annoying manual step to install a NetBackup agent on the machine. This requires coyping a large archive (~ 1 GB) to ...
0
votes
1answer
48 views

rpm package conflicts with itself in yum

I prepared custom package platform-6-1.2.3-1.x86_64. I want it to be conflicting with every OTHER plat-6 package installed in the system. Files of the package are not conflicting with the others ...
0
votes
1answer
613 views

Unable to install awstats on redhat 7 due to missing perl(LWP::UserAgent)

I'm unable to install awstats on my rhel7 aws ec2 instance: [root@ip-10-146-180-60 ~]# cat /etc/redhat-release Red Hat Enterprise Linux Server release 7.0 (Maipo) [root@ip-10-146-180-60 ~]# rpm -ivh ...
0
votes
1answer
86 views

yum update rpm packages installed manually

I needed to install the libxml 2.7 package and for this i uninstalled yum (yum have dependencies on libxml), is there any way I can make the pass to work with yum rpm packages installed previously? I ...
0
votes
1answer
168 views

Upgrading PHP 5.2 to PHP 5.3 on EC2

I am a HUGE novice with this, and I have spend a whole day and a night trying to fix this. I know this has been asked before, but I have tried everything in those answers as well as from all over the ...
0
votes
1answer
119 views

Building 64 bit rpm on 32 bit rpmbuild system

Are there any way for building x86_64 arch target rpm on a 32 bit rpmbuild build system? $ rpmbuild -ba --target=x86_64 kernel64.spec Building target platforms: x86_64 Building for target x86_64 ...
0
votes
1answer
68 views

rpmbuild not taking $LD_LIBRARY_CONFIG

I'm trying to build Agent++ into an RPM that installs into an alternative location. It's complaining that it can't find libsnmp++. I have libsnmp++ installed, also in an alternative location. ...
0
votes
1answer
332 views

Yum broken in Amazon instance

This is an instance launched using Amazon AMI. when I run yum with anything (search,install, etc), this is what I am getting: yum search yum error: bad option 'archcolor' at (null):93 Loaded ...
0
votes
1answer
139 views

Where to download MySQL server 5.0.77-log

I have MySQL Server version: 5.0.77-log Source distribution on a RHEL6 server. I need to reinstall it on a second RHEL6 server to set up a testing environment but I cannot find where to download this ...
0
votes
1answer
392 views

Centos 6.4. building rpm for cups 1.7

I try to build rpm from source by running rpmbuild -ta cups-1.7.0-source.tar.gz --without dbus but get Processing files: cups-1.7.0-1.x86_64 error: File not found: ...
0
votes
1answer
88 views

Warning messages while building Apache server

I am building Apache server 2.4.6 from source and am not sure about a few warning messages I received during the rpm build process. The build completes OK and everything seems fine..BTW, this is on ...
0
votes
1answer
315 views

Some files from RPM have bogus permissions

I'm building RPMs with fpm. One of the goals is to set the user and group of the installed files, so I'm using the --rpmuser and --rpmgroup flags. It's working for the most part, however one of the ...
0
votes
1answer
273 views

Failed to build rpm from source

I want to build a package from source, basically all I did was downloading Percona-Server-56-5.6.12-rc60.4.393.rhel6.src.rpm and adding -DWITH_INNODB_MEMCACHED=ON to spec file. ...
0
votes
1answer
111 views

Building apache 2.4 RPM

I'm trying to build up-to-date packages for httpd... I would like to build Apache 2.4.4 (latest) as an RPM. so that i can install on multiple servers and not compile each time... When i try to do ...
2
votes
0answers
148 views

how to keep a rpm package during system upgrade?

I have a custom built rpm package which I installed manually (via rpm -Uvh / or yum localinstall). If I do an upgradee from CentOS5 to CentOS6 this package is removed and, because it missing in the ...
1
vote
0answers
45 views

How to stop meta-rpm transaction if a precondition fails?

I currently have a meta-package rpm which contains a list of dependencies on other rpm packages. I want to stop the update/install transaction of the meta-package (and all subsequent packages) if the ...
1
vote
0answers
273 views

Oracle's JDK RPM doesn't provide “java”

I have the Oracle RPM for the Java 7 JDK installed on an Amazon EC2 instance. The Oracle RPMs for Java 7 JDK don't "provide" java nor jre. RPM reports that it provides the following: # rpm -q jdk ...
1
vote
0answers
172 views

Can't make Koji Work on A Centos6 server

I setup the koji build environment in a Centos6 Machine server as suggested by the documentation (http://fedoraproject.org/wiki/Koji/ServerHowTo). I could properly access the Koji Web using http. Yet ...
1
vote
0answers
27 views

Keeping a local mirror lean and mean for what our application needs

We have a local mirror RPM repositorythat lives where our virtual servers live on Amazon Web Services. This setup could conserve some network bandwidth, but my predecessor probably set it up as place ...
1
vote
0answers
310 views

Mock build system error: sh: ruby: command not found

I am trying to build a RPM using the mock build system. However, the shell in the mock environment cannot seem to find the ruby command. I run in to a build error: sh: ruby: command not found I can ...
1
vote
0answers
709 views

BUILDROOT files during RPM generation

Currently i have the following spec file to create a RPM. The spec file is generated by maven plugin to produce a RPM out of it. The question is: will i find files which are mentioned in the spec file ...
1
vote
0answers
96 views

Error when installing lighttpd

I have a server using lighttpd with the kloxo control panel, and some of the lighttpd files were missing the PHP configuration so I decided to reinstall lighttpd using Kloxo (this should regenerate ...
1
vote
0answers
123 views

Installing handlersocket

I am trying to install handlersocket plugin as explained here... http://www.percona.com/doc/percona-server/5.5/performance/handlersocket.html#enabling-the-plugin I have downloaded and installed ...
0
votes
0answers
19 views

RPM build errors File listed twice

I'm trying to build an rpm of the latest stable php (5.6.7) under CentOS 7. And when I try to build it, I'm getting the following errors: [bluethundr@repo SPECS]$ rpmbuild -ba php.spec Processing ...
0
votes
0answers
25 views

How to install php5.5 in centos 6.5 just via rpm?

I can't use the yum at all! Is there any php5.5 rpm file can be download to fit the the centos 6.5? I can't use yum, so the php extension such as php55w-xml php55w-mcrypt php55w-gd php55w-devel ...
0
votes
0answers
79 views

Yum Cache Service

I have a LAN where I currently use an instance of Sonatype Nexus to proxy several yum repositories. All the clients on the LAN are configured to install packages only from this service. The only ...
0
votes
0answers
49 views

Producing RPMs that conflict with all versions released by someone else?

I find myself needing to create a variant of the PostgreSQL packages that are mostly compatible with the official http://yum.postgresql.org/ packages. My packages are compatible with client apps that ...
0
votes
0answers
72 views

Logstash from RPM fails to run under nice command

I downloaded the Logstash RPM logtsash-1.4.2-1_2c0f5a1.noarch from the official site, but have been having problems getting it to run from the init script. I get no log data passed to ...
0
votes
0answers
507 views

Yum does not install specific RPM version with custom repo

We use RPMS for our packaging and yum to update our environments. We have an rpm package-5.1.1-3 installed in our production server and in our yum repository we have 2 newer versions such as ...
0
votes
0answers
28 views

How can I specify multiple result files created by one source file in Apache Ant

I'm attempting to build some RPMs via the rpmbuild system command using Apache Ant's exec tag. The SRPM creates multiple RPM results. I've previously used the uptodate tag to set a property when I've ...
0
votes
0answers
119 views

How to build the rpm package with SHA-256 checksum for files?

In standard alone RHEL 6.4 rpm build environment, the rpm packages is generated with SHA-256 check sum, which is gotten by command rpm -qp --dump xxx.rpm [user@redhat64 abc]$ rpm -qp --dump ...
0
votes
0answers
474 views

include(SoapClient.php): failed to open stream: No such file or directory

I have problems with yum, 1st one is when i run yum "commmand" 2nd time, example, yum search php or sudo yum install php-gd i get the error msg, rpmdb: Thread/process ...
0
votes
0answers
174 views

rpm dependency failed to install, package installed anyway

I have this issue and I would like to understand why it is like this. I have build 3 really simple rpm packages called a, b and c, and I made a independant, b depending on a and c depending on a and ...
0
votes
0answers
526 views

Install libxml2.8 on RHEL 6

I want to install the software TinyOWS on a RHEL 6 server. I followed the instructions: $ wget http://download.osgeo.org/mapserver/tinyows-1.1.0.tar.bz2 $ tar xvjf tinyows-1.1.0.tar.bz2 $ cd ...
0
votes
0answers
1k views

Install PHP-SOAP for PHP-FPM 5.5.4 CentOS 6

I have the following version of PHP installed (My server is 64-bit CentOS 6): php-common.x86_64 5.5.4-1.el6.remi This is running via PHP-FPM, if that makes a difference. I've discovered several ...
0
votes
0answers
361 views

RPM Version Issue and won't install

Get this error when trying to install an RPM: rpm -Uvh rpmforge-release-0.5.3-1.el6.rf.x86_64.rpm warning: rpmforge-release-0.5.3-1.el6.rf.x86_64.rpm: Header V3 DSA signature: NOKEY, key ID 6b8d79e6 ...
0
votes
0answers
81 views

Optimal way to register existing local files as a package in the local RPM database

My final goal is a way to register a bunch of local files as a package in the local RPM database. This is what I've done so far: I build an RPM package from existing files using rpmbuild, then use ...