3
votes
1answer
433 views

SSH 'connection reset' when attempting multiple simultaneous outbound connections to the same host

I have a script that executes a Rake remote task which executes once for each of two roles. Both roles are users on the same Vagrant instance. So essentially the task is opening two SSH connections ...
2
votes
2answers
506 views

Puppet and Vim fighting over Ruby version

I have installed puppet 3.0.1 from the .dmg from puppetlabs. If I remove ruby 1.9.3, puppet works, but other things like my vim install (dependant plugins) do not. According to ...
2
votes
1answer
459 views

How can I set up redis to run automatically on my Ubuntu machine the way it does on mac

On my (new) mac I can use spork and redis seems to be already running. However on my Ubuntu system (11.10) I get Connection refused - Unable to connect to Redis on localhost:6379 ...
1
vote
0answers
241 views

Why does my long-running nohup process quietly stop processing on Mac OSX?

I have a Ruby rake process that does a whole lot of intensive data loading and manipulation. When run a against a particularly large file, the process will run for several hours (which is fine), but ...
0
votes
1answer
237 views

Mac terminal unix questions. Trying to install showoff.io

I installed the gem according to the instructions at showoff.io, but when I try to run show 8888 it doesn't work and I get -bash: show: command not found In their faq, they mention running gem ...
1
vote
2answers
427 views

New to Ruby on Rails, having socket trouble with MySQL (on Mac OS X)

This is my first question on serverfault, although I have used stackoverflow before. I am in a Ruby on Rails class over this summer and need to get RoR running ASAP. I used MacPorts to install Ruby, ...
1
vote
3answers
634 views

Insecure world writable dir

I can't figure out how to fix this, apparently ruby doesn't like anything in my home directory. /Users/Connor/.rvm/rubies/ree-1.8.7-2010.01/bin/gem:4: warning: Insecure world writable dir ...
1
vote
3answers
617 views

I upgraded to leopard and everything works fine except for ruby and rails

I just upgraded my Mac OS X to 10.5. Everything works great after a little Apache love, except for ruby and rails. This is what I am seeing Macintosh:~ TAmoyal$ ruby test.rb -bash: ...