0
votes
2answers
83 views

Foreman installation on amazon ec2 instance

Hi there and thank you for reading, I am currently in the process of setting up a puppet service for our ec2 instances and decided to give foreman a try (node certificate management and automatic ...
1
vote
1answer
84 views

Reload Puppet gem provider source

So I've got Puppet Enterprise 2.7 on a "master" node, puppetentmaster. While working to craft new recipes for installing Ruby 2.0 on a "client" node, I noticed if I forced the client to begin using ...
1
vote
3answers
546 views

Can you install puppet without ruby 1.8?

I need to install puppet 3.2.0 or greater along with ruby 2.0.0-p247 on an ubuntu 12.04 server. Is there no way to install puppet without ruby 1.8? Most my experience comes from CentOS so I may ...
2
votes
1answer
103 views

Most appropriate place for custom Puppet facts - RHEL

I'm not much of a Ruby guy, but found how to list the Ruby load path. Here's what it looks like for me $ ruby -e 'puts $:' /usr/lib/ruby/site_ruby/1.8 /usr/lib64/ruby/site_ruby/1.8 ...
0
votes
1answer
132 views

When should Passenger, Unicorn, and Rack be used? [closed]

Reading about Puppet often Passenger, Unicorn, and Rack are mentioned, but I can't figure out what the purpose of these are. The website for Passenger says: Phusion Passenger is a web server and ...
1
vote
1answer
141 views

Puppet: build DNS file from node config (or: how do I iterate over node variables globally)

I also use puppet for my nodes. I am also running a (BIND) dns server. Would it be possible to use the $aliases variable I have for each node in a template for the DNS module? My nodes look like ...
1
vote
1answer
286 views

Puppet - Call custom function (which contains case/when) from manifest

I am working on puppetizing my httpd and nginx vhost confs. Right now I have 5 servers which each have their own port and are run on server1, while nginx is running on server2. Obviously I need to ...
2
votes
2answers
504 views

Puppet and Vim fighting over Ruby version

I have installed puppet 3.0.1 from the .dmg from puppetlabs. If I remove ruby 1.9.3, puppet works, but other things like my vim install (dependant plugins) do not. According to ...
2
votes
1answer
853 views

Why does my namespace and class name conflict?

I have a puppet module installed that is called ntp. A node do I define by node testip { include myconfig::ntpp } and in /etc/puppet/modules/myconfig/manifests/init.pp have I class myconfig::ntpp ...
2
votes
1answer
383 views

Why isn't the variable available?

Background I would like to apply this idea of having a common class that includes all the specific info about my setup. So I have created /etc/puppet/modules/common/manifests/init.pp with class ...
0
votes
2answers
1k views

MCollective cannot load the Stomp library?

CentOS 5.5 I'm facing with this problem when restarting mcollective: # service mcollective restart Shutting down mcollective: Starting mcollective: ...
1
vote
1answer
1k views

Puppet templates and undefined/nil variables

I often want to include default values in Puppet templates. I was hoping that given a class like this: class myclass ($a_variable=undef) { file { '/tmp/myfile': content => ...
1
vote
1answer
367 views

Loading dependencies for custom puppet functions

I have written a custom puppet function, which is working fine, that depends on the cloudservers gem (a Rackspace client library). This is fine if I have pre-installed the gem on a server before ...
1
vote
1answer
588 views

How do I require a resource in a Puppet definition based on an array parameter?

I have a define that looks like this: define user::sys_user($fullname, $uid, $groups, $shell='/bin/bash', $authkey, $authkey_type=rsa) { $username = "sys_${name}" group { $username: ...
2
votes
1answer
443 views

How do I add a provider for the package type in Puppet?

The puppet-rvm FAQ mentions that they didn't extend the package type because "it becomes harder to manage multiple Ruby versions and nearly impossible to install gems for a specific Ruby version". I ...
0
votes
1answer
1k views

puppet dashboard fails to start

So here's the situation. I'm running Puppet on CentOS 5.7 64-bit, and on the puppet master I also have puppet-dashboard, however when I try to start it, I see the following: [root@puptest-master ...
1
vote
1answer
193 views

Installed ruby from source on debian, apt-get no longer works due to failed dependencies, how do I fix it?

I installed ruby from source, and everything ruby related seems to work just fine. I can't install anything that depends on ruby using apt because I don't want 2 versions of ruby installed. After I ...
3
votes
1answer
1k views

Is there a Ruby/ERB cheat sheet for puppet users not familiar with Ruby in general?

I'm still getting to grips with puppet and starting to mess around with templating, which is based on Ruby's ERB system. I am not familiar with Ruby in general, does anyone know of a cheat sheet for ...
1
vote
2answers
2k views

How can I edit puppet .pp files with Eclipse & DLTK

The puppet editor tips page seems to suggest that using eclipse & dltk (presumably the ruby tools) will assist with editing .pp files. http://projects.puppetlabs.com/projects/1/wiki/Editor_Tips ...
1
vote
1answer
109 views

Puppet keeps trying to install mongrel

I'm using Puppet to administrate my servers and one of the things I'm doing is installing Mongrel from the Gem: package { mongrel: provider => gem, ensure => latest, require => ...
2
votes
2answers
2k views

Puppet- ERB template- Question about defined classes

Puppet template files are erb rails files. I want the line: Include modsecurity.d/*.conf To be included in the final file if the class mod_security is included. From the puppet docs: ...