2
votes
1answer
207 views

Redmine won't start after move

I met trouble with redmine(or ruby configuration) when move from one server to another redmine@dirty:~/www$ ruby script/rails server webrick -e production ...
1
vote
0answers
344 views

How to install libv8 using a specific version of g++? [closed]

I'm trying to install therubyracer gem for a rails project - http://stackoverflow.com/questions/13793533/unable-to-install-therubyracer-on-centos-errors-with-v8-and-gcc and i'm thinking that now that ...
1
vote
3answers
3k views

Upgrading Redmine, activerecord-mysql2-adapter not working

For upgrading Redmine from 1.0.1 to 2.1.2, I need to execute the command: rake db:migrate RAILS_ENV=production However, doing so produces the following error: rake aborted! Please install the ...
0
votes
1answer
97 views

rails-boilerplate (0.1.9) gem mirror

Using paperclip (3.2.0) Using polyamorous (0.5.0) Using pr_geohash (1.0.0) Using slop (3.3.3) Using pry (0.9.10) Using pry-rails (0.2.2) Gem::RemoteFetcher::FetchError: too many ...
0
votes
1answer
807 views

Error installing new rails version. Failed to build gem native extension

I am trying to build my first ruby on rails app using the following guide (http://ruby.railstutorial.org/chapters/a-demo-app#code-demo_gemfile_sqlite_version_redux) and have run into a few obstacles. ...
1
vote
2answers
241 views

Monit and Thin and Unfound Gems

I've been using Monit to monitor my Thin server and everything was working until I upgraded my Rails version from 2.3.4 to 2.3.14. Now when I try and start Thin using monit it gives me an unfound gem ...
2
votes
0answers
524 views

Problems installing Gitorious on Debian 6.0.4

i am trying to install Gitorious on latest Debian 6.0.4 but i am running into some problems and hope there is somebody out here who might be able to help. I followed this article: ...
0
votes
1answer
125 views

issue with installing rails using rubygem

I tried doing the following: sudo gem install rails and I always get the error message: Successfully installed rails-3.0.9 1 gem installed Installing ri documentation for rails-3.0.9... file 'lib' ...
0
votes
2answers
192 views

Can't remove RubyGem in Ubuntu

I ran this command: gem --version 1.3.5 I found it to be kind of strange since I didn't specify which gem I was asking about. I am trying to install the rails gem like this: gem install rails ...
1
vote
1answer
40 views

How is a Ruby Gem usually updated (from developers to my applications)?

We are using the tiny_mce plugin in our applications, utilized through the Ruby Gem. First question: The plugin is hosted here https://github.com/kete/tiny_mce/, and there the latest version is ...
0
votes
2answers
121 views

Rails: missing gem roxml

I'm trying to setup a Rails app on an Ubuntu machine, but the app always fails with the error: Missing these required gems: roxml the gem is installed, and appears in gem list. The app requires a ...
0
votes
1answer
981 views

Getting “Insecure world writable dir /home/chance ” in PATH, mode 040777 for Rails and Gem on Ubuntu 10.10

I've tried this but it didn't work and seemed to be for osx. I have a fresh Ubuntu 10.10 (x64) install with rvm, rails 3 and ruby 1.9.2. I have a new rails app but using either gem or rails results in ...
1
vote
1answer
363 views

Error 302 when installing rake gem

i try to install rake on my clean lenny server, i get the following error: Updating installed gems ERROR: While executing gem ... (Gem::RemoteFetcher::FetchError) bad response Found 302 ...
1
vote
1answer
249 views

Rails won't install on Ubuntu because of builder

Can someone explain why gem thinks I don't have builder >= 2.1.2 even though I clearly have 3.0.0? jason@ve:~$ gem install rails --pre ERROR: Error installing rails: activemodel requires ...
2
votes
1answer
492 views

Memcache on ubuntu server lucid and ruby 1.9.1

I'm trying to set up a memcache server on the above setup. I'm getting the following error: /var/lib/gems/1.9.1/gems/activesupport-2.3.8/lib/active_support/dependencies.rb:443:in ...