Ruby is a general-purpose object-oriented open-source scripting language. It sees a high degree of use in the configuration management space, and is popular for web development due to the high adoption of Ruby On Rails

learn more… | top users | synonyms

1
vote
1answer
12 views

Puppet does not work with augeas in a multiple ruby versions environment

I am trying to make puppet work with augeas but it complains there is no augeas provider. Some googling suggested to sudo yum install augeas augtool ls /files/etc/php.ini # test it works as expected ...
0
votes
1answer
1k views

Starting command on boot with correct user env vars

I am attempting to create a start-up script that will run this command on boot for my ubuntu 12.04 server: bundle exec thin -R config.ru start -p 3030 When I run it as a regular user it works just ...
-1
votes
1answer
29 views

How to open rails on port 80 in ubuntu [on hold]

I have rails installed on a user on my server but not on the root user. I have full access to the root user however when I attempt to run my rails server on port 80 on the user it specifies I need ...
-1
votes
0answers
22 views

Error deployment of project via deploy.sh script [on hold]

I need help. I have script for deployment my project on Ruby. #!/bin/sh if [ $# -eq 0 ]; then echo "Usage:" echo " ./deploy.sh some_stage_name" else rvm use `cat .ruby-version`@`if [ ...
1
vote
1answer
23 views

Which way is the correct way to pass variables to chef templates?

Looking at this official documentation: https://docs.chef.io/resource_template.html I see examples of passing variables to the Template resource that use either "{", "({" or "(" to scope the ...
2
votes
2answers
29 views

Setting a MAC address from file for a VM

I'm not sure if this is entirely possible so thought it was worth asking. I would like to use Vagrant to allow users to spin up a VM when needed. However, on our network devices must be registered via ...
-1
votes
0answers
68 views

Install Ruby 2.1.x or 2.0.x using rbenv "make[2]: Leaaving directory error

I'm trying to install ruby 2.1.x, or 2.0.x on my ubuntu 14.04 server using this guide. The commands I run are, sudo apt-get update sudo apt-get install git-core curl zlib1g-dev build-essential ...
1
vote
1answer
38 views

Compilie ruby 1.8.6 with openssl 0.9.8

I'm trying to install ruby 1.8.6 on CentOS7 and successfully finished, but ruby cannot load openssl. My install steps are below. Install openssl 0.9.8 from source. wget ...
2
votes
1answer
36 views

Apache passenger setup - Multiple projects under same domain

I want to setup different projects under same domain with different ruby version for each app. Eg: example1.com is a main app which runs on Ruby 1.8.7 example1.com/tasks is another app which runs ...
1
vote
1answer
197 views

Install gems of ruby 1.9 bins without suffix in openSuSE

I got issue on my openSuSE instances. By default in openSuSE after installation by gem utility (gem install some_app) you will got something like that: # some_app1.9 # chef-solo1.9 etc. That a ...
0
votes
0answers
33 views

mailjet with brimir (open source Ruby project) on debian doesn't send mail

I tired of searching a tip to be able to send mails with mailjet on my debian. I configured a dashboard for tickets (Brimir, Ruby open source plateform) Here is the link : ...
5
votes
5answers
2k views

Is it possible to install precompiled Ruby versions with RVM?

I'm using EC2 and sometimes launch servers that I want to use only for a short time. Usually I want to install some version or versions of Ruby on them, and for this RVM is very convenient -- if it ...
0
votes
2answers
1k views

Connection refused while setting up Chef Server 11 on Ubuntu 14

I just spun up an Ubuntu 14.04 VM on HPCloud.com to practice Chef. Following this turial I setup a DNS on HPCloud, as well as set the hostname in /etc/hosts to chef-server.mydomain.com When ...
1
vote
0answers
22 views

Create chef recipe by passing values dynamically, from properties file

I created a chef recipe which has the installation of a specific rpm mentioned in it. This rpm has a version number which needs to be loaded dynamically from a properties file (which is itself created ...
0
votes
1answer
1k views

Production redis server has 100% cpu usage

My production redis server has gone mad and has been hogging up 100% of CPU usage. I have done everything that I can from upgrading redis server to restarting the machine. I can't figure out what's ...
0
votes
2answers
306 views

Trouble Starting Snorby / Ruby dependency issue

I am trying to install Snorby on a CentOS 6.6 machine and keep getting an issue with ruby and my Gemfile. I believe I either have to edit my Gemfile or it has something to do with an installation ...
0
votes
1answer
44 views

How can I determine why a process is dying? [closed]

On a CentOS 6.5 server I am running a very simple HTTP listener with Sinatra that exists simply to accept POST requests and pass the payload content of the POST request to another service. I often ...
1
vote
2answers
139 views

No Space left on device after Jenkins installation

Is there any reason i would get a 'No space left on device" error on mkdir. I have confirmed that i have enough space left. around 68% is free. and also i have 1% iNodes consumed. This is CentOS 7 ...
0
votes
0answers
31 views

Using serverspec to test an application running on rails on a remote machine

In the environment we login as user1 which has sudo access, we then sudo to user2 which does not have sudo access. All installation on the machine is done via user1. When I write test to verify ruby ...
0
votes
1answer
43 views

ChefSpec - Coverage when testing for include_reciepe

I' am trying to write ChefSpec tests for some of our Cookbooks. One of those is including a lot of other cookbooks, to setup an Jenkins CI Enviroment. Iam wondering how other people are testing the ...
0
votes
1answer
323 views

Gem installation on vanilla ubuntu fails - EACCESS

I'm trying to install the Middleman gem on a completely generic installation of Ubuntu Trusty (i386). Here's my console input/output: vagrant@vagrant-ubuntu-trusty-32:~/rj$ which ruby /usr/bin/ruby ...
0
votes
1answer
117 views

Can I use serverspec on a remote system without requiring root or sudo access on that system? [closed]

Main thing I am trying to do is to run the tests from an unprivileged user (a gui runs these tests) without giving away the keys to the castle if this user gets compromised. Most of the tests ...
2
votes
1answer
1k views

Best practice for setting up RVM, Passenger/Apache with multiple Rubies and running as specific users?

My goal is to run ruby applications under different server users with potentially different versions of ruby. So i would have users that serve as the "hosting account" essentially. Document ...
2
votes
2answers
89 views

error: no space left on device when saving file (but there is space)

I am implementing in ruby however when I want to save my work I get "Opening output file: no space left on device, /afs/edu/usr7/ael/p\ rivate/RUBY/inc.rb" When I checked if I got any space using ...
1
vote
0answers
101 views

Getting 403 Forbidden w. Referer on Nginx+Passenger

We're using Nginx 1.6.2 + Passenger 5.0.6 and have a vhost defined with PHP-FPM which serves a MODx installation. Only one location /sinatraapp serves a Sinatra App using Ruby 2.1.1. The setup is ...
1
vote
1answer
65 views

How do I get puppet master to listen on IPv6?

So I have a RHEL 7 server on an internal network with IPv6, and I am able to SSH into it via IPv6 and it is also serving DNS to other hosts over IPv6. I have noticed that puppet master bind to IPv4 ...
7
votes
4answers
4k views

How do I setup Apache with FastCGI and Ruby?

I've been reading alot of forum posts, tutorials, etc., about setting up apache under linux with fastcgi. I'm trying to run fcgi for some of my ruby development (not rails), but I figure it should ...
1
vote
1answer
330 views

EC2 Public DNS not working with HTTPS - Elastic Beanstalk URL is working

I have completely ran out of ideas to fix this issue. I've gone through just about every given solution to similar issues and nothing has worked successfully. I've successfully set up my Ruby on ...
1
vote
0answers
63 views

How to configure Monit for use with Puma Ruby Web Server?

I am getting started with Monit and don't have a lot of systems knowledge. I have a Ruby app running on Puma. I want to use Monit to automatically restart Puma if it ever dies. I'm currently using the ...
2
votes
1answer
719 views

How do I get supervisord to use a user's rbenv environment?

I've daemon owned that I'd like to have system supervisor manage. The daemon has its own user and, being done up in ruby, it's own rbenv environment. The supervisord conf for the daemon: ...
1
vote
1answer
524 views

Ruby Enter Your Password to Create App

I have just installed ruby on rails on a Centos server with directadmin following http://blog.ilwilliams.net/installing-rails-3-with-apache-on-centos/ I'm now in a non privileged user account ...
0
votes
1answer
141 views

Unicorn displaying Rack errors uninitialized constant Rack::Lint::REQUEST_METHOD

I've attempted to install Unicorn + Nginx on Ubuntu 14.04. Whenever the site gets accessed (via localhost:8080 or via Nginx) it just returns a blank 500 error. The error log gives me the following: ...
0
votes
1answer
126 views

gem install does not rebuild all instances of a gem

user@sv1 [/home/user/]# env|grep GEM GEM_HOME=/home/user/.gems/2.1 GEM_PATH=/home/user/.gems/2.1 user@sv1 [/home/user/]# gem install mysql2 Building native extensions. This could take a while... ...
1
vote
0answers
24 views

ubuntu 12.04 ruby1.8 depends on libreadline5 which does not exist any more?

I just built a new 12.04 ubuntu box and tried to install puppet package. This failed because it could not load ruby1.8. After some fiddling around I tracked the issue down to the fact that the ...
0
votes
1answer
159 views

ruby complains about a package being not installed which actually is installed

This question might be very unprofessional but I'm very not into Ruby and I have no clue where to start.. I used to run Jekyll which runs asciidoctor to render html pages. After a Fedora update ...
0
votes
0answers
35 views

Can I get Vsphere cluster networks (and thier details) using Ruby?

(On linux) I am looking for a way to get my VMware Vsphere networks details using a Ruby script. I tried to find a way using rlane/rbvmomi on [1]: https://github.com/rlane/rbvmomi but I could nt ...
0
votes
0answers
38 views

What could cause Ruby's free heap slots to rapidly increase?

I'm diagnosing why our Rails servers seem to leak memory. In looking at New Relic today, I noticed that "Free heap slots" of our Ruby VMs seems to jump from almost nothing up to the baseline level of ...
1
vote
1answer
142 views

Puppet and windowsfeature - Boolean Error

I'm new to Puppet Enterprise, but trying to learn how to deploy custom class files to Windows servers. I am attempting to use the opentable/windowsfeature module, but I'm getting an error when my ...
0
votes
0answers
90 views

Slow insert speed to Mongodb utilizing Mongoid ORM

I have a production platform utilizing Sidekiq, Mongoid and a replica set (3 nodes). This has been operational for about 6 months and running very smoothly. All jobs were processing in usually less ...
0
votes
0answers
413 views

Apache 2.4 & Phusion Passenger generating 403 Error

I'm trying to setup a Rails application (Project Fedena) on the following Server configuration. I am using the virtual host configuration below. I get a 403 when I visit the IP/Domain. There's only ...
4
votes
6answers
3k views

Scripts That Need (some) Root Access

I have a general question about system administration scripts that require "some" commands to be executed with root access, and other as a normal non-root user (ie myusername, etc.). I should mention ...
0
votes
1answer
498 views

Starting Rails App with Phusion Passenger Standalone?

I am deploying a Rails application ( Project Fedena ) to a VPS at Digital Ocean. I can use either of mongrel_rails start and ruby script/server to launch my app with no problem. It binds to port :3000 ...
0
votes
1answer
82 views

Why is cron using a different Ruby than my user and how to fix it?

I have a cron job that is a Ruby script. The problem is that the ruby executable is different than expected. Ruby was installed from source so it should be the new global default. $ ssh ...
1
vote
0answers
28 views

Which dependencies are removable after building ruby?

I've successfully built ruby 2.1.1 on Ubuntu/Debian by installing the following dependencies: apt-get install \ autoconf \ bison \ build-essential \ libssl-dev \ libyaml-dev \ ...
0
votes
1answer
228 views

puppet defined type and creating multiple templates from 1 .erb file

I need to find a solution to this problem that I've come across. I have a hash (it's supposed to be overriden as a smart class parameter later on) that I am iterating trough in my template.erb to ...
0
votes
1answer
90 views

Puppet: How to write a proper “condition and condition” statement?

I wrote a "Message of the day" Puppet module which affects all proxy servers in my company. Within the template file, I have the following "if statement": <% if @hostname !~ /^haproxy\d+/ and ...
0
votes
0answers
218 views

mongodb authentication not working in puppet

I used the same connectionstring in the terminal and it's working ok. But from Ruby I get error output when vagrant provision runs mongo admin -u 'vaga' -p 'vaga' --authenticationDatabase admin ...
0
votes
1answer
872 views

Ruby/Chef include_recipe and know variables from parent file?

I am trying to use a local variable in an included file. I get the error that's it's not defined. I am not sure a way to do this, do you? I have a recipe folder with: recipes/ development.rb ...
2
votes
2answers
549 views

Cannot find amitools

I have newly created an Amazon EC2 instance. It came with Ruby 1.8.7 which I uninstalled (with YUM) in favor of RVM and Ruby 1.9.3. However, every time I connect to the instance via SSH I get the ...
1
vote
1answer
1k views

Installing rubygems after manually installing ruby 1.8

I have successfully installed Ruby 1.8.7 on Ubuntu 14.04 by downloading the package, building locally and installing. The command ruby -v, outputs Ruby 1.8.7 (2012-02-08 patchlevel 358) [i686-Linux] ...