SSL and its successor, TLS, are encryption and authentication protocols that encrypt the full contents of a TCP connection, as well as potentially verifying the identities of the devices making the connection.

learn more… | top users | synonyms

7
votes
0answers
95 views

How can you gracefully restart Apache without disconnecting SSL connections?

We are trying to reload Apache gracefully using a command such as: apache2ctl -k graceful This works as expected for HTTP users and the Apache config is reloaded without affecting users of the ...
6
votes
0answers
2k views

The OCSP server has no status for the certificate. (Error code: sec_error_ocsp_unknown_cert)

Just set up a website (Apache/Centos) with SSL where the free cert came from startssl. I've used startssl before, and never had any problems. I have no problems accessing the site from IE and ...
6
votes
0answers
606 views

IIS 6.0 SSL handshake error

Hi all I installed a trusted certificate in an IIS 6.0 server. I have the port 443 opened in the firewall and I verified the server is listening on that port. However when verifying using openssl I ...
4
votes
0answers
49 views

Is it possible to change the SSL binding order in IIS?

I have Site A in IIS 8.0 configured to an SSL certificate with the binding ###.###.###.###:443. I also have Site B configured to a different certificate with the binding ###.###.###.###:443 (same IP ...
4
votes
0answers
117 views

What would be involved in moving a site like stackoverflow to https?

I've seen a lot of requests in the SO Meta asking for StackOverflow to be moved over completely to https. I've never run a site as large as Stack Overflow, so enabling SSL/TLS has always just meant ...
4
votes
0answers
2k views

Disable SSLv3 on Windows Server 2012

I have disabled the SSLv3 on Windows 2012 sever using the following method: http://blog.brankovucinec.com/2014/11/13/disable-the-sslv3-protocol-on-microsoft-windows-servers/ Around the same thing is ...
4
votes
0answers
3k views

SSL verification error with git (on github) on Ubuntu 14.04

I'm trying to clone the atom repository that just went fully open-source and I've run into some trouble. Attempting to git clone the repository is producing an SSL error: wug@wugputer:/src/test$ git ...
4
votes
0answers
351 views

How do I clear cached SSL state data from schannel?

I'm trying to clear SSL state data for a normal TLS session (no client certs are involved) for Outlook when connecting to a SSL based CAS server. How do I clear the SSL state of SChannel? Does the ...
4
votes
0answers
1k views

Redirect user on SSL authentication failure

I configured a VirtualHost with SSL enabled and SSL client authentication, all of that on apache2 2.2.8 (ubuntu server 8.04). All SSL certificates (CA, Server certificate, Client certificate, CRL) ...
4
votes
0answers
2k views

OpenSSL SHA256 testing

I'm having an issue testing a hardened SSL configuration for pound. One of the requirements is for the inclusion of AES[128|256]-SHA256 ciphers, along with strict ordering of preference. I've ...
4
votes
0answers
5k views

Tomcat fails to find a key entry in keystore

I am installing a SSL cert in my Tomcat server, but it fails to find the key entry in my keystore file. If I don't specify keyAlias="mykey" it shows me the following error message: ...
4
votes
0answers
2k views

Apache/SSL: (70014)End of file found: SSL input filter read failed

Figured upgrading on a long weekend was a smart move... Now I'm stuck. The server is spitting out this error (loglevel info): "(70014)End of file found: SSL input filter read failed" when using the ...
3
votes
0answers
30 views

What process on a SonicWall Security Appliance Checks the DPI-SSL Client Inspection?

I'm interested in determining if there is high CPU usage on a SonicWall Security Appliance, but I don't know which process to check for high CPU usage. There are various options for this in the UI ...
3
votes
0answers
68 views

Schannel Error - Random

I'm currently experiencing an issue on a Windows Server 2012 R2. In the event log is an Error for the Source "Schannel". The error description is: "A fatal alert was generated and sent to the ...
3
votes
0answers
51 views

Improve SSL Performance with Nginx

We have Nginx in the front of our system and we Proxy to Apache at the back. We use SSL/TLS for our connection. Question: Is Nginx the best option to terminate SSL/TLS connections in terms of ...
3
votes
0answers
60 views

Nginx - SSL forward secrecy and iOS9 support

I'm trying to bring a couple of Linux web servers into line with the current recommendations for SSL - in particular for allowing iOS9 to connect. One server is CentOS 7, the other CentOS 6.4. I have ...
3
votes
0answers
153 views

Multiple Client Certificates in SSLProxyMachineCertificateFile

Here is my use case. I want to learn how to setup Apache, so this is just for learning. Feel free to suggest better alternatives. I'm using Apache 2.4 in RHEL5. I want to use a ProxyPassMatch to ...
3
votes
0answers
316 views

rabbitmq-shovel amqps connection handshake failure

I fail to setup a rabbitmq shovel over amqps. The same shovel works fine over amqp. my (edited) uri: ...
3
votes
0answers
88 views

Apache - Virtual Hosting Mass Client Configurable SSL, Reverse Proxy

My scenario is that we host multiple websites for clients and all of the clients sites run on SSL only. Currently we have a seperate virtual host file for each client for Apache. Each file is ...
3
votes
0answers
1k views

PuppetDB: unable to get local issuer certificate

I'm attempting to use puppetdb on but I'm running into some issues. I have a node called puppet. It is the master as well as where I've installed puppetdb. It's also a node that puppet manages. ...
3
votes
0answers
402 views

Strict-Transport-Security on CloudFront with S3 origin?

My company's site has a static homepage for speed and cost reasons. We use S3 as the origin for CloudFront. Now, we would like to declare Strict-Transport-Security for the entire domain, but S3 seems ...
3
votes
0answers
3k views

ProFTPd/FTPS issue: unable to accept TLS connection: received EOF that violates protocol

It took some time while I tried to find solution over the net. Nothing helped. The story: I have Ubuntu 10.10 (Amazon EC2 instance). ProFTPD Version 1.3.2e (latest via apt-get). I changed nothing on ...
2
votes
0answers
48 views

Installing apache2 ssl - ubuntu

I need to install a ssl in my apache2 ubuntu, and do not know what I'm wrong, but the fact is that I do not get ... I have the relevant files: one .key file and two .crt files. At first, when editing ...
2
votes
0answers
31 views

Upgrade openssl in apache from source and set as default

I have upgraded the openssl from source to version OpenSSL 1.0.1s for Apache, which installed under /usr/local/ssl/bin/openssl, and change the symlink to point it into this new installation directory ...
2
votes
0answers
92 views

Which permissions should I set to dhparam.pem?

I am generating Diffie-Hellman parameters for the ssl_dhparam directive in the SSL configuration of nginx. The file dhparam.pem is created with the command openssl dhparam 2048 -check -out ...
2
votes
0answers
530 views

RabbitMQ TLS clustering - “insufficient security”

I am currently setting up a RabbitMQ cluster where a requirement is that all communication within the cluster be encrypted. I followed the guide at https://www.rabbitmq.com/clustering-ssl.html - ...
2
votes
0answers
51 views

Apache2:Unable to read server certificate from file

Cannot start apache2 server. error info is below. Looking into similar questions (SSL Error - unable to read server certificate from file, Apache cannot read certificate file, and so on), still ...
2
votes
0answers
26 views

SSL for Lighttpd on different port Error 451 -

I'm not quite sure how to explain my problem but I'm going to try. I have lighttpd 1.4.35 on Centos 6.4 64bit behind a firewall. One of the virtual host is running using different port (8800) with ...
2
votes
0answers
65 views

SVN Edge not authenticating correctly with domain controller

SVN Edge (version 4.0.10-3880.131) not authenticating correctly with domain controller. I have SVN Edge setup and working perfectly when I use LDAP Security Level of NONE.. However when set to SSL, ...
2
votes
0answers
381 views

How do I configure in IBM WebSphere 8.5.5 a data source using Oracle Wallet?

I have a server with a fresh installation of WebSphere Application Server 8.5.5 and I'm trying to configure a data source over a connection using JDBC and Oracle Wallet for SSL. The error message in ...
2
votes
0answers
196 views

SSL - Apache and Node.js on the same Amazon EC2 instance

I hosted my website on an EC2 instance, using Apache. SSL was also set up properly, running on HTTPS, port 443. Currently, I just added a chat application to the website using Node.js + socket.io. ...
2
votes
0answers
1k views

chrome requests get stuck pending

Description of issue We have a web server that is serving static assets. We are experiencing a problem where after you browse around some of the http requests get stuck in the "pending" state. In the ...
2
votes
0answers
256 views

Problems installing Homebrew on a new OS X installation (SSL error)

Have a fresh OS X installation here (new VM), and when trying to install Homebrew I just get an SSL error. fatal: unable to access 'https://github.com/Homebrew/homebrew/': Unknown SSL protocol error ...
2
votes
0answers
4k views

Chrome & IE not accepting client certificate

I have two websites on different hosts protected by the same SSL certificate, one Apache2, one JBOSS. My process: Created a private CA. Created a new certificate and signed it with the CA. ...
2
votes
0answers
35 views

Can IE be considered a reasonable website access test for the .Net framework

We are currently updating our SSL cipher settings in order to improve our SSL rating. The changes included the removal of SSL3 and RC4 ciphers. However this appears to have caused problems with some ...
2
votes
0answers
49 views

Certificate can only be used by network service account

Issues : Our service is using one certification for partner service call. It worked well in IIS site which is running as network service account. But when we run test the code as administrator ...
2
votes
0answers
1k views

How to replace Zentyal CA certificates and key with an already existing CA

The context: we're using a CA which is deployed on all our client machines, and a lot of hosts and web servers. It seems that Zentyal CA module only allows to issue a new CA using the GUI, but not to ...
2
votes
0answers
246 views

“invalid security certificate” (ssl_error_bad_cert_domain) after PFX uploaded to Azure

My SSL certificate (purchased on godaddy) on Azure stopped working all of a sudden. I am running a standard Azure website and I previously uploaded a .pfx file and bound my custom domain to it. ...
2
votes
0answers
199 views

replay decrypted ssl traffic with tcpreplay

I have an pcap format from some https traffic from one of my web-servers. So I can use the key from my webserver to decrypt the traffic in wireshark. The problem I'm now facing is that I can't get an ...
2
votes
0answers
719 views

Maven - resolving “java.security.cert.CertPathValidatorException: Path does not chain with any of the trust anchors”

I am attempting to build/install this project on an Ubuntu 12.04 box: https://bitbucket.org/petermr/pdf2svg However: mvn clean install Fails to build due to getting errors like this: ...
2
votes
0answers
494 views

Internet Explorer SSL use causes segfault - Apache httpd SIGSEGV in apr_uri_parse

Recently I've had quite a large influx of the error below in the error_log. I've found out that it happens when someone browses my site using SSL https: and Internet Explorer, all other browsers are ...
2
votes
0answers
259 views

Accessing ActiveMQ's JMX via SSL

I'm trying to get SSL-enabled JMX access to ActiveMQ (5.8.0 or 5.9.0 running under java 1.6.0) but I'm not having any luck. I've dealt with SSL-enabled JMX access in the past, so I'm quite familiar ...
2
votes
0answers
200 views

How do I obtain the ssh public key from my VSphere ESXi 5.1 host hypervisor residing in vcenter with puppet-enterprise cloudprovisioner

I am using the learn puppet 3.1 vm and trying to connect to a host hypervisor. I followed the instructions to create a .fog file under root which includes a yaml hash, and I read that the yaml hash ...
2
votes
0answers
254 views

Forefront UAG with SSL/X509 auth for REST API

I'm not a network engeneer, but a software engeneer, so this theme is quite unfamiliar for me. We develop a solution, that consists of a server-side web application (with a rest api), working on java ...
2
votes
0answers
210 views

SSLv2 required on TLS-only site?

This problem has been driving me crazy for a very long time. We have three web servers, serving East, West and Central offices. We built the Central server first, imaged it, and copied the image to ...
2
votes
0answers
560 views

large javascript file not being served properly by nginx

I'm having trouble serving a large (376kb) javascript file via nginx over ssl with gzip enabled. The file is served without issue over plain old http. The file in question is ckeditor.js and is ...
2
votes
0answers
653 views

SSL connection alert hanshake failure

I'm having problem establishing the connection between the client and the Server .I'm using my own signed certificate on client and on server. I'm using the SSL ciphers SSLCipherSuite ...
2
votes
0answers
524 views

(35) Unknown SSL protocol error in connection to localhost:8443

I've followed some instructions at: http://docs.codehaus.org/display/JETTY/How+to+configure+SSL I can serve requests over http (http://localhost:8080/ping), but I can't hit (https://locahost:8443). I ...
2
votes
0answers
425 views

Debugging incorrect certificate with SNI for some clients

I have a number of domains with SSL certificates served by Haproxy (using Haproxy 1.5's support for SSL). For the most part the correct certificates are being served, but a particular user is ...
2
votes
0answers
2k views

The timeout specified has expired: SSL input filter read failed. - is this an error?

We have apache log level on debug as we are hunting a bug on our magento site ...