Transport Layer Security is a cryptographic protocol for encrypting and authenticating network communications, and replaces SSL. It is commonly used to secure Internet protocols such as HTTP.

learn more… | top users | synonyms

3
votes
0answers
46 views

How can I explicitly disable TLS when sending to one specific recipient?

I have a SendMail 8.14 server deployed in the middle of an SMTP workflow (Outbound mail looks like Exchange -> SendMail -> Appliance -> Internet) I have TLS configured for the first three hosts. ...
2
votes
0answers
54 views

rabbitmq-shovel amqps connection handshake failure

I fail to setup a rabbitmq shovel over amqps. The same shovel works fine over amqp. my (edited) uri: ...
2
votes
0answers
98 views

OpenLDAP TLS - test results in Bad file descriptor

I have set up an openldap server including tls on ubuntu 14.04 following this guide. While testing the connection, I get results that I can not find an explanation for. ldapsearch -xLLL -Z -W -D ...
2
votes
0answers
56 views

Can TLS-enabled rsyslog use a certificate revocation list?

When using the gtls driver, is it possible to configure rsyslog to use a certificate revocation list? We are running rsyslogd 5.8.10 (standard in CentOS 6.5).
2
votes
0answers
134 views

SSLv2 required on TLS-only site?

This problem has been driving me crazy for a very long time. We have three web servers, serving East, West and Central offices. We built the Central server first, imaged it, and copied the image to ...
2
votes
0answers
287 views

Forcing IIS virtual smtp server to verify outgoing TLS certificate

I am in a situation where a web application is using the IIS virtual SMTP server to send out email. The IIS virtual SMTP server is then configured to send all mail out through a smarthost, over TLS ...
2
votes
0answers
364 views

Dovecot TLS Handshake not working

I have set up my mailserver using http://workaround.org/ispmail and it worked until today, where I can not access the server using IMAP. The error I see in dovecot.log is 2012-02-09 16:37:40 ...
2
votes
0answers
2k views

TLS (STARTTLS) Failure After 10.6 Upgrade to Open Directory Master

Environment: Mac OS X 10.6.3 install/import of a MacOS X 10.5.8 Open Directory Master server. After that upgrade, LDAP+TLS fails on our MacOS X 10.5, 10.6, CentOS, Debian, and FreeBSD clients ...
1
vote
0answers
54 views

How to fix the Logjam vulnerability in OpenVPN server config?

As of this writing (Day-2), there are quite few accurate guidelines as to how to mitigate Logjam for Apache and other web servers, such as this page: https://weakdh.org/sysadmin.html What are the ...
1
vote
0answers
13 views

How to make Postfix SMTP TLS Optional?

Just did an [emergency] conversion from qmail to postfix last night - but now I'm getting people complaining that mail client errors are showing up stating "no available encryption methods available" ...
1
vote
0answers
16 views

Key management for HAProxy instances in OpsWorks

I'm trying to use client certificate verification in an OpsWorks HAProxy instance. The question I'm running into, and it's probably a noob issue, is how am I supposed to deploy my ssl private key to ...
1
vote
0answers
74 views

WARNING: None of the ciphers specified are supported by the SSL engine

I have a working web service running through Apache Tomcat 7 with the following connector element in server.xml: <Connector port="443" protocol="org.apache.coyote.http11.Http11Protocol" ...
1
vote
0answers
14 views

How to correctly secure Reverse Proxy communication with actual server in LAN

I have Nginx acting as gateway and reverse proxy for requests based on host name. However, the communication with the actual server in lan isn't secured. Does the connection remain encrypted with ...
1
vote
0answers
71 views

Outlook/Exchange certificate errors after setting clientaccessserver, etc… properties

After updating exchange 2010 using the commands for Set-ActiveSyncVirtualDirectory, Set-ClientAccessServer, Set-ECPVirtualDirectory, Set-OABVirtualDirectory, Set-OWAVirtualDirectory, & ...
1
vote
0answers
92 views

openvpn TLS handshake fails on client because firewall drops packets (but why?)

I seem to have problem with my openvpn server - client connection. now, the important information is in the log (verb3) of my client: Mon Mar 30 17:09:59 2015 OpenVPN 2.2.2 ...
1
vote
0answers
45 views

TLS server extension

We have an Ubuntu 12.04 server with Tomcat and Nginx webservers on it to serve two different portals. Tomcat is serving on 443 port and Nginx is serving on 8443 port. And this server got latest ...
1
vote
0answers
118 views

Ubuntu OpenLDAP TLS negotiation failure

I've been following the Ubuntu Server Guide for OpenLDAP, and have run into an issue with what I suspect is replication. If I run the following command on the client with access to the server: ...
1
vote
0answers
652 views

Enable TLS 1.2 in Windows Server 2012 running Exchange 2013 via IIS 8.0

I got some issues getting the TLS 1.2 protocol running on one of our Windows Server 2012 machines. I checked this using ssllabs.com by Qualys and also tested with a powershell script and the linux ...
1
vote
0answers
22 views

Nss-pam-ldapd host based login with TLS

I have an openldap server configured and set up for linux client logins with host based authentications. All is fine except I wanted to have TLS and have found that it is not working de to a bug ...
1
vote
0answers
68 views

Remmina TLS, NLA works, but high encryption fails

Remmina works fine with TLS and NLA. But if encryption is set to high instead of client compatible, then it stops working. Questions: 1. Why setting high encryption prevents connectivity? 2. What's ...
1
vote
0answers
601 views

IIS Site breaks after disabling SSLv3

I am trying to disable SSLv3 on a 2008 R2 web server that runs IIS 7.5 but as soon as I disable SSLv3 and reboot, the website is no longer reachable. I ran a packet capture with SSLv3 still enabled ...
1
vote
0answers
153 views

Disable SSL3 on tomcat4

I have a very old web application that uses tomcat4. B/c of the poodle vulnerability I need to disable SSL3 and disable a bunch of weak ciphers. My connector looks like this, but apparently ...
1
vote
0answers
80 views

Get and set the certificate used by Exchange with port 587 (submission)

Sometimes users want to use POP3/SMTP with Exchange. They report that there is certificate issue with sending mail as the server uses the domain certificate for encryption. Of course I could install ...
1
vote
0answers
64 views

How can I test connectivity to a TLS-enabled OpenVPN server?

Unfortunately we don't have access to the management interface, so I'm after a way to tell that tls-enabled OpenVPN us up and responsive. I'm familiar with this trick, but it doesn't work for ...
1
vote
0answers
51 views

here filtering terminate TLS in openvpn but not ssl

I have configured an openvpn sever appliance on vmware and windows 2008 R2 and set it to use port 80 for openvpn, iphone and ipad could connect to it but windows and mac could't and generated error in ...
1
vote
0answers
215 views

openSuse and openldap:ldap only login

I 've managed to setup ldap server and i can search it succefully from the server machine. i ve added to the database all info except from the fstab file and automount info. I migrated succefully the ...
1
vote
0answers
211 views

Exchange 2010 TLS Cert questions

I'm trying to wrap my head around with enabling TLS for a specific domain on Exchange 2010 server but I have a few questions that I'm sure you guys have an answer to. I've gone through this guide ...
1
vote
0answers
558 views

(apache `mod_proxy`) reverse proxy - how to reuse TLS sessions to origin server

I have set up a reverse proxy which can be accessed by http only, client requests are translated to http or https communication towards the origin server. Configuration is as follows: ...
0
votes
0answers
6 views

How can the HSTS header be added to WebLogic?

Is there an implementation for using the Strict-Transport-Security header to WebLogic? I figure it would be using something in web.xml under <security-constraint> I know how to do this for an ...
0
votes
0answers
26 views

IIS 7.5 FTPS stops working when disabling TLS 1.0

Trying to get a windows 2008 R2 server to the latest PCI standards, which require disabling of TLS 1.0 FTPS stops working once TLS 1.0 is disabled. TLS 1.1 and 1.2 are enabled and all other SSL ...
0
votes
0answers
27 views

Apache server chooses TLS1.2 for all request even when TLS1.2 is disabled in IE9 / Windows7

Following is my apache ssl protocol and cipher configuration SSLEngine on SSLProtocol all -SSLv2 SSLCipherSuite HIGH:MEDIUM:-SSLv2:!ADH When tested on IE9 with TLS1.2 checkbox checked in ...
0
votes
0answers
34 views

Send data over DTLS with socat

I'm trying to exchange files over DTLS with socat with one-liner client/server. I'm able to do it with UDP: server:socat -d -d -lh -lu UDP-LISTEN:5000,reuseaddr,fork OPEN:out.dat,create client:socat ...
0
votes
0answers
60 views

Nginx TLS renegotiation

Our webserver has recently failed a PCI compliance test due to existence of "TLS Session Renegotiation Vulnerability" (CVE-2009-3555) However I'm not sure whether those results are right. We're using ...
0
votes
0answers
21 views

vsftpd service with tls enabled exit code 2

I am trying to set up TLS for VSFTPD on CentOS7. Whenever I try to start the service it fails with exit code 2 and no other information. anonymous_enable=NO local_enable=YES write_enable=YES ...
0
votes
0answers
19 views

JPG file and other of higher size not downloading

We have a SAP application for official use wherein all the documents are uploaded and saved in a server and from where it can be downloaded by anyone after logging in the server with his/her user ID. ...
0
votes
0answers
65 views

How to configure HAProxy to use SNI for SSL enabled backends?

I have several backend web servers that have multiple vhosts and I want to use HAProxy in front of them. It doesn't appear that HAProxy is sending the hostname in the TLS connection to the backend ...
0
votes
0answers
53 views

gandi sendmail tls slow

I set up a Debian with Sendmail && SSMTP to be able to send mail through my Gandi Mail Account. It works fine, except that the authentication took like 5 seconds to be established which can ...
0
votes
0answers
42 views

HTTP DoS prevetion with UFW firewall

I am trying to creator an HTTP DoS attack on my servers using UFW firewall using this Resource. I edited /etc/ufw/before.rules to get the following rules. # # rules.before # # Rules that should be ...
0
votes
0answers
183 views

HTTPS request works to Linux, not to Mac, sometimes

I have two sites, say mac.example.com and linux.example.com. I'm using the same wildcard SSL cert, obtained from RapidSSL. If hit up either of the sites in a browser, hosted either in Linux (on ...
0
votes
0answers
45 views

Certificate stops working after computer reboot

Got a strange issue that I just can't find any clues. We have a program (Qlikview) which talks to a remote admin service via SSL (Qlikview Server) but it uses the certificate to validate the client. ...
0
votes
0answers
143 views

LDAP with TLS: connect error(-11)

I configured OpenLDAP and today I've configured the TLS for more security following these guide lines: Configure OpenLDAP with TLS=required Modifying the cn=config.ldif with config file: dn: ...
0
votes
0answers
116 views

In nginx logs: SSL3_GET_CLIENT_HELLO:required cipher missing

We disabled SSLv3 several months ago, and on Sunday I noticed this filling our nginx logs. It's been continuing ever since and users are emailing us saying they cannot connect to our site. 2015/01/13 ...
0
votes
0answers
283 views

How to disable TLS v1 in Apache v2.2 (Openssl 1.0.1)

I’ve been asked to disable SSL v3 and TLS v1 on our web servers. But Apache reports: [error] No SSL protocols available [hint: SSLProtocol] when I include –TLSv1 in the SSLProtocol stanza below. ...
0
votes
0answers
217 views

How to configure Coldfusion 10 CFLDAP to use TLS instead of SSL2

We are using CFLDAP to authenticate users from a remote system. The remote system has now shut down SSL 2 and 3 due to the POODLE issue. Is there a way to configure either Coldfusion or Tomcat to use ...
0
votes
0answers
934 views

GnuTLS error -15: An unexpected TLS packet was received

I have been trying to set up VSFTPd on my CentOS 7 machine, and I have been running into an issue when connecting through FileZilla. I keep receiving error -15 regarding the TLS packet. The following ...
0
votes
0answers
28 views

Is there a way using the shell to install certificates and enable encryption in 389 directory server?

My client has a 389 directory server installation that I discovered does not have SSL enabled on it. I would like to do this but I've always had to do it using the Admin console. At some point they ...
0
votes
0answers
83 views

SSL with rsyslog on CentOS - protocol family not supported?

For the life of me, I can't seem to get rsyslog to have imrelp use TLS(SSL). I've engaged the good people on http://kb.monitorware.com/post25017.html#p25017 to try and chase the rsyslog angle, but I'm ...
0
votes
0answers
108 views

SPDY error on all JS files

I've setup nginx with BoringSSL but I seem to have run into an odd problem: Chrome throws a net::ERR_SPDY_PROTOCOL_ERROR for every JavaScript file. I've disabled SPDY to no avail, the error persists ...
0
votes
0answers
2k views

Encrypted Alert Error 21 Wireshark SSL 3.0 error

I continue to receive schannel errors in the event log on an exchange server using outlook web access (OWA). From the capture I took during one of these schannel errors I see IP address 65.55.53.190 ...
0
votes
0answers
859 views

Fixing TLS renegotiation vulnerability on Apache 2.2.3

On a RHEL 5.3 server, I have Apache version: Server version: Apache/2.2.3 Server built: Nov 12 2008 07:09:03 Server's Module Magic Number: 20051115:3 Server loaded: APR 1.2.7, APR-Util 1.2.7 ...