Ubuntu Linux is a Debian derivative that aims to bring Linux mainstream. Questions on this site should generally refer to Ubuntu Server. Note that http://askubuntu.com is specifically dedicated to Ubuntu questions.

learn more… | top users | synonyms (2)

4
votes
1answer
513 views

EC2 disk goes to 100% util, but fine after reboot

We've been running some production services on Amazon EC2 for a while, using mainly t1.large and t1.xlarge instances (non-EBS). Every so often one of the attached (ephemeral disks) will get into a ...
3
votes
1answer
233 views

UFW: Disable logging of blocks due to optional FIN/ACK message being received

I've recently built a server and decided to use UFW for the first time. I was investigating a possible connection issue (turns out it was their end) but I noticed that the logs are full of entries ...
3
votes
1answer
711 views

Writing an upstart config file for Unicorn

I've had a good hunt and can't find a good example of an upstart script for Unicorn. From what I've read however I think that upstart and unicorn might step on each others toes if I just try to set ...
3
votes
1answer
2k views

HAProxy: Display a “BADREQ” | BADREQ's by the thousands

My HAProxy Configuration. #HA-Proxy version 1.3.22 2009/10/14 Copyright 2000-2009 Willy Tarreau <w@1wt.eu> global maxconn 10000 spread-checks 50 user haproxy group haproxy ...
2
votes
1answer
327 views

Server responds to pings but no SSH or HTTP access

I do not know what has caused this but my websites have been down for 2+ days now and I cannot connect via SSH or FTP either. The only way to get signs of life from my server is to reboot it via the ...
2
votes
1answer
148 views

Cannot directly reject traffic on port 25

My server is running Ubuntu 10.04.4 LTS and I want to reject traffic to port 25. The goal is this: $ telnet {ip} 25 Trying {ip}... telnet: connect to address {ip}: Connection refused telnet: Unable ...
2
votes
1answer
716 views

virt-install kept on adding --no-reboot - even though I don't want it to

I have a bit of a problem getting my guests to reboot after the OS installation using virt-install. For whatever reason, virt-install insists on inserting "--no-reboot" when you create a VM: ...
2
votes
1answer
354 views

qmail smtpd uptime less then 1 sec

not sure what is going on here but my qmail install isnt working corretly everything is running except smtpd output from qmailctl stat /service/qmail-send: up (pid 2874) 608 seconds ...
2
votes
1answer
174 views

Not enough resources available

I have setup a private cloud to get service from VM instances, but I can't run the instances: cloud@node:~$ cd /home/cloud/.euca cloud@node:~/.euca$ . eucarc cloud@node:~/.euca$ ...
2
votes
1answer
869 views

Ubuntu wired network disconnected

I am not able to establish a wired network connection between two computers on which I just installed Ubuntu 10.04. I am new to this environment. Unlike in the Windows environment, where it happens ...
2
votes
1answer
305 views

Securing an Apache Setup with a Fresh Ubuntu Web Server with users and permissions

I have a virtual Server with Ubunto 10.04 on. My host Mediatemple have a few guides on trying to secure the apache config, but I think they are missing some details, or at least it makes no sense to ...
1
vote
1answer
634 views

Apache Server Hello in SSL Slow

I'm trying to debug a problem with SSL in Apache. I've used Wireshark to capture the packets, and I see the client hello message go out, and then about 10 seconds or so later, I get back a server ...
1
vote
1answer
164 views

Is ffmpeg incorrectly interpreting .aif files?

Being on an Ubuntu 10.04 server i installed the ffmpeg packages with apt. ffmpeg is working afterwards, and doing as it should. Almost. For testing purposes i uploaded a few audiofiles. One of them, ...
3
votes
0answers
430 views

Exim 4.71 does not add DKIM signature to outgoing emails

I am trying to add DKIM to my domain, I have created a key, added the following to /etc/exim4/conf.d/transport/30_exim4_config_remote_smtp: dkim_domain = mydomain.com dkim_selector = mail1 ...
2
votes
0answers
515 views

Folder shares over NFSv4 private to user groups

I want to share a folder over NFSv4, available to some users, and I'm having permission issues. I set up the folder permissions with setGID so new files are created with the folder group owner. But ...
2
votes
0answers
234 views

How to add SSL for localhost in RAILS

I want to test my application which needs to work both with and without SSL. If it is possible to set up SSL for a local application (http://localhost:3000), please let me know some suggestions, my OS ...
2
votes
0answers
954 views

HT Link Sync Error after Ubuntu 10.04 LTS Installation

Update 1 I just assembled an exact replica of this server, and successfully installed Ubuntu 10.04 LTS in a RAID10 configuration. The success was confirmed by a login to the initial account. There ...
2
votes
0answers
577 views

Could not connect to FreeNX server using Desktop--->Shadow

I have installed FreeNX server on ubuntu 10.04 Desktop and I could connect to the system remotely with NXClient selecting "UNIX" and "GNOME". I want to use the 'shadow' feature of NX and I could not ...
2
votes
0answers
258 views

Passenger/Rails not releasing memory

I have an Ubuntu server running three separate Rails (2.3.8) applications with Passenger, REE and Apache. Recently we started experiencing problems with ruby processes eating up memory and consuming ...
2
votes
0answers
328 views

Getting regular PHP updates in Ubuntu Lucid

So we have a few servers that are running Lucid and will be running apache/php. We would like to be able to run PHP scripts as different systems users as well as have customized php.ini files for ...
1
vote
0answers
73 views

__ticket_spinlock high cpu

We are having a strange problem on our Ubuntu 10.04 KVM infrastructure, where periodically, one of two vm webservers freaks out, with persistently high load, even if we restart the applications. (the ...
1
vote
0answers
165 views

How to solve UNIQUE_ID variable issue in modsecurity_crs_16_session_hijacking.conf ubuntu 10.04

I have been trying to harden ubuntu 10.04 using modsecurity and its core rules from owasp version 2.2.5. I have used the package from their github . After the symbolic link of the files in the ...
1
vote
0answers
429 views

Can't connect to proftpd from outside the virtual machine

This is related to a previous question. I have a machine with Windows 7 acting as a server and it hosts several virtual machines. One of them, a Debian Squeezy is acting as a PostgreSQL server and I ...
1
vote
0answers
80 views

Linux server crashing (drm:drm_fb_helper_panic)

We have a server (IBM x3850 8864) running Ubuntu 10.04 LTS. It's acting as a KVM host with several virtual machines on it (also running Ubuntu 10.04). The (physical) server sometimes crashes with ...
1
vote
0answers
136 views

Windows XP cannot join (samba) domain

I've a setup with Samba 3.4.7 on Ubuntu 10.04 running as Primary Domain Controller for the network. [Almost] everything works fine, except for a single Windows XP computer which cannot join the ...
1
vote
0answers
301 views

racoon pure IPSEC VPN, best way to give vpn server an IP address on the VPN?

We are testing a VPN server for DR. We have a rackspace cloud instance, with a pure IPSEC VPN server running in racoon, serving "road warrior" clients. We have some NAT going on on the server to route ...
1
vote
0answers
439 views

Ubuntu, ruby 2, rails 4

I'm trying to setup a server, which has Ubuntu 10.04 LTS, Ruby 2.0.0-p0 and Rails 4 beta1. I can get everything installed but rails 4 has a slight error and I'd like to get someones opinion. When I do ...
1
vote
0answers
26 views

Ubuntu 10.04 server delay when POST to mySQL

I have a Ubuntu 10.04 Server and for some reason it always seems to exhibit an intermittent delay whenever performing CRUD operations on the mySQL database. Most Post commands are executed within a ...
1
vote
0answers
85 views

Preventing NFS Denial of Service

I have a NFS4 server running Ubuntu 10.04 Server, on an enterprise environment with 50+ clients. Overall, everything works fine, but from time to time, some client starts making +1000 NFS operations ...
1
vote
0answers
312 views

r1soft agent is failing with the error: “write error while sending code: Broken pipe”

I have an Ubuntu 10.04.4 LTS server with r1soft agent installed in it. Recently, the backups are failing with the following error. -------- write error while sending code: Broken pipe -------- I ...
1
vote
0answers
197 views

apache2 vhost error

the error says: Virtualhost mysite.com has no server environment set, request will not be honoured my vhost file is: <VirtualHost *:80> ServerName mysite.com ServerAdmin ...
1
vote
0answers
100 views

Ubuntu 10.04 Server - Apache2 | url come in high rate - caused cpu overload

I got an issue with one of our webserver. Yesterday, I noticed that the website is very slow, and so, I login to the webserver to check. issuing, 'top' command showing me 100% utilization on CPU, but ...
1
vote
0answers
140 views

Amanda: selfcheck fail, client times out

I'm testing an Amanda install on an ubuntu 10.04 server as a backup server for primarily OS X 10.6 clients. The server has been setup and has successfully run backups on specific local directories ...
1
vote
0answers
246 views

libvirt timing out. parted blocked messages in kern.log

I'm using Ubuntu 10.04.4 LTS to host KVM virtual machines. I'm using eucalyptus to manage them and having a lot of issues with libvirt not being able to interface with the KVM components and timing ...
1
vote
0answers
344 views

Vsftpd virtual users hidden quota?

I have a problem with vsftpd on Ubuntu 10.04 LTS. I have configured vsftpd enabling virtual users, everything works fine until the size of the specific virtual users home dir reaches 40GB then I get ...
1
vote
0answers
254 views

Redmine “Internal Error” While adding quotes, Updating and other settings

I've installed redmine 0.8.7 on a ubuntu 10.04 LTS without any errors. I can add issues to it but, when it comes to update or even create a quote i get this error from the server on the browser: ...
1
vote
0answers
540 views

qmail installation on ubuntu 10.04

I just tried to install qmail on my server running Ubuntu 10.04 I followed all the instructions but it seems that svscan /service is not running on my machine. How do I fix it? AFAIK, it should be ...
1
vote
0answers
154 views

External Command Error on VHCS Installation

I have Ubuntu 10.04 LTS (Lucid Lynx) server and i'm trying to install VHCS . I'm following this steps but on last steps of the Configuration Script title i'm executing vhcs2-setup . After last ...
1
vote
0answers
256 views

Ubuntu Server install on SCSI array

I installed Ubuntu Server 10.04 LTS on an Infortrend storage array connected over SCSI to an IBM Server. The installation goes well and the SCSI controller recognizes the Disk. When I boot the ...
1
vote
0answers
246 views

Heavily loaded ubuntu machine connection timeout

I've got a webserver running Ubuntu 10.04 Server edition (on rackspace cloud), running nginx and jetty. It's under quite a bit of load (60-70 requests/sec or so successful). Nginx is proxying requests ...
1
vote
0answers
133 views

Reset Active Directory Passwords Using RHEL6

Does anyone know of a way to reset Active Directory Passwords through RHEL6 or Ubuntu 10.04LTS so that the Active Directory user can still access network resources with their AD account. Also, is ...
1
vote
0answers
294 views

store image installation error in UEC

to my college final year project we planned to setup the private cloud on the two machines. I recently installed Ubuntu Enterprise Cloud (UEC) on two of my machines . I was trying to install the ...
1
vote
0answers
593 views

VMWare Workstation 6.5.5 (64-bit) on Ubuntu 10.04 (64-bit) Odd Problem

I managed to successfully install VMWare Workstation 6.5.5 (64-bit) on Ubuntu 10.04 (64-bit). It works well and somehow feels faster and snappier than the same exact version on Ubuntu 8.04. However, ...
0
votes
0answers
49 views

Building OFED 3.12 Ubuntu

I am trying to build OFED 3.12 (I have tried many versions they all have unique problems) on Ubuntu 14.04 TLS. When I run sudo ./install.pl and choose option 1, I get this error: CC [M] ...
0
votes
0answers
24 views

HowTo: Let ufw block single IPs when default policy is ALLOW

I want to be able to block certain IPs from accessing my server. As I don't really know what services are running on what port on the machine, I decided to quick&dirty let ufw's default policy be ...
0
votes
0answers
71 views

Low disk I/O causing high disk busy and CPU wait

I have an Ubuntu 10.04 server on VMware that is experiencing 99% disk busy with only 1 MB of disk I/O according to nmon. 300 KB of disk I/O causes 25% to 30% disk busy. iostat reports the same: ...
0
votes
0answers
539 views

Diagnose SASL LOGIN authentication failure with postfix and sasldb

I am trying to configure a Postfix SMTP server on my personal machine (ubuntu server) using sasldb2. So far what I have set up works well with the test command: testsaslauthd (however it may be ...
0
votes
0answers
64 views

Which Log file to check for strange Ubuntu server behaviour (offline for 5minutes at random times)

I am having problems with my Ubuntu 10.04.4 LTS server. My monitor application claims it goes off every morning at about 4 AM for 5 to 10 minutes. I am not sure where to start the troubleshooting ...
0
votes
0answers
267 views

configuring ldap client in ubuntu ( Bad file descriptor error )

I am configuring ldap client in ubuntu. I am following this tutorial link to configure the ldap client. But, When I try to update nss to use ldap, I am getting an error. That is, root@sat:/# ...
0
votes
0answers
716 views

Multiple Duplicate Lines when running iptables -L?

Specifically talking about an Ubuntu 10.04 LTS server (Lucid Lynx), although its probably applicable to other Linux versions. I was trawling through the logs for a few websites, doing some spring ...