Ubuntu Linux is a Debian derivative that aims to bring Linux mainstream. Questions on this site should generally refer to Ubuntu Server. Note that http://askubuntu.com is specifically dedicated to Ubuntu questions.

learn more… | top users | synonyms (2)

0
votes
0answers
58 views

Gitlab update from 7.2.0 centos(mysql) to 7.7.2 ubuntu(postgres), can't create ssh key, or new project

I had a CentOS server running gitlab 7.2.0, which uses mysql server. I updated to the omnibus version of 7.7.2 successfully porting the database from mysql to postgres using instructions found here ...
0
votes
0answers
5 views

How to configure iptables to set public IP for outgoing traffic from private IP [migrated]

I have multiple public IPs at home: 1.1.1.1 (main IP) 2.2.2.2 (additional IP) In my local network, I have two computers, let's say 192.168.1.1 (PC1) 192.168.1.2 (PC2) Infront of the computers I ...
0
votes
1answer
72 views

Apache SSL error: Private key not found

I'm running apache on Ubuntu 14.04 and trying to implement SSL. Any help would be greatly appreciated. default-ssl.conf has: SSLCertificateFile /etc/apache2/ssl/domain.crt ...
0
votes
0answers
7 views

Share a hard drive for backing up using Mac TimeMachine and Ubuntu System Backups [migrated]

I have a Macbook Pro using Time Machine for whole system backup and a Ubuntu installed on another Macbook Pro (not dual boot) using default system backup. I have a 4TB SATA hard drive partitioned ...
-3
votes
1answer
60 views

Are these Advanced Features possible with a Bash Script on an Ubuntu Server? [closed]

I am trying to build a really flexible and useful Server Backup Bash Script. I have pretty much no experience working or building Bash scripts. I know that thousands of them exist in the wild but I ...
-1
votes
1answer
39 views

autostart rc.local 2>&1 redirect, 'open /dev/tty: No such device or address'

I'm trying to execute this command with rc.local: wget http://address/file -P /root/ 2>&1 | stdbuf -o0 awk '/[.] +[0-9][0-9]?[0-9]?%/ { print substr($0,63,3) }' | whiptail --gauge "Progress" 6 ...
0
votes
2answers
60 views

Crontab: Authentication token expired; new one is required

I have a crontab job running daily as a non-root user job. Unfortunately it did stop working with the following message (in /var/log/syslog): CRON[29256]: Authentication token is no longer valid; new ...
1
vote
0answers
25 views

Domain randomly becomes unresolved

Recently, I've been having some issues with a domain name. I set up my domain to point to my server, but every now and then, when attempting to ssh in, I get the error: ssh: Could not resolve ...
1
vote
2answers
52 views

In an OpenVPN network, Windows clients cannot access the host and other clients

I have set up an OpenVPN network and I'd like to let every client in the network be able to connect to each other, ie. servers 10.8.0.1, 10.8.0.2 and 1.8.0.3 should be able to communicate over VPN and ...
0
votes
0answers
5 views

Start a process remotely on the window manager [migrated]

How do I start a process and attach it to the terminal corresponding to the local graphical shell? I'm running Lubuntu 13.04 using lightdm as my login environment. If I'm logged into the graphical ...
3
votes
1answer
53 views

Ubuntu 14.04 - tc not working

I have used tc before on another servers to restrict the total bandwidth available on port 80, in order to make sure that there is enough throughput for port 22 during peak hours of the day. I need ...
0
votes
2answers
83 views

3ware array limited to 6TB in linux

I have a server with a 9650SE-24M8 in it. which has a 7x2TB drive RAID5 array. tw-cli shows the following: Unit UnitType Status %RCmpl %V/I/M Stripe Size(GB) Cache AVrfy ...
1
vote
0answers
31 views

How to restore redmine on an ubuntu server after a dist-upgrade?

I just became a new admin on a server (ubuntu-server virtual machine) that host redmine on apache2 and subversion in my company. I discovered that the OS is Ubuntu Raring 13.04 that is out of date ...
2
votes
0answers
22 views

/etc/cron.daily/locate has blank line. File is readonly can't edit

I get this output every day. /etc/cron.daily/locate: run-parts: failed to exec /etc/cron.daily/locate: Exec format error run-parts: /etc/cron.daily/locate exited with return code 1 File contents ...
1
vote
0answers
41 views

IPTables on two interfaces - cannot see where I'm going wrong

Ubuntu 14.4 I have used iptables before without issue but am having a real struggle with them today. I have two cards eth0 and eth1. eth0 does have more than one ip so has eth0:0 and eth0:1 etc. If ...
0
votes
0answers
48 views

ZFS on Linux denied access when accessing child dataset on NFS

This is on 12.04 LTS with the latest ZFS on Linux from the ppa. I have two a storage pool named data, and a dataset data/Other with different settings (e.g. compression). I set data to sharenfs and ...
0
votes
2answers
48 views

How to set exim to use outside SMTP?

I want my scripts on the server to be able to send emails, but via outside, 3rd party mail service for which I'm paying anyway. I have exim and even dovecot installed anyway, but I suppose i will need ...
0
votes
0answers
29 views

Migration of LDAP and GOsa-config to new server

I have a running LDAP-server (using Ubuntu 12.04) with GOsa installed on it. Is there a way to migrate the whole database including the GOsa-config to a new server (Ubuntu 14.04)? I tried exporting ...
0
votes
0answers
3 views

NFS4 & VirtualBox: Ubuntu 14.04 host Windows 10 Techpreview client [migrated]

I have a host OS Ubuntu 14.04 (my main OS). I run a Windows 10 client inside VirtualBox. I wish for NFS4 to work between them, I cannot see the share in my Windows 10 client. I followed the following ...
0
votes
1answer
18 views

Error while running juju deploy jenkins-slave

Note: I'm running this on 3 Ubuntu trusty VM's on my OS X laptop over VMWare Fusion. I am a juju newbie and having some trouble with setting up jenkins-slave. I have a bootstrap machine, and 2 other ...
0
votes
1answer
53 views

OpenVPN client cannot connect to the server

I'm trying to configure VPN between two PCs both running Ubuntu 14.04 x64. I have created and configured OpenVPN server on one of them, OpenVPN daemon is online and I can see tun0 interface in ...
0
votes
1answer
74 views

How to start rpcbind automatically at boot on Ubuntu 14.04 server?

I have been unsuccessfully trying to configure my Ubuntu 14.04 server to start rpcbind on boot. RPCbind is installed and works fine if I start it manually with service rpcbind start I have added the ...
0
votes
0answers
21 views

Supersede the default Apache config on a different config file

I'm using Ubuntu with Apache 2.4. The config file for Apache is found at /etc/apache2/apache2.conf at the end of this config file it's written # Current File: /etc/apache2/apache2.conf <Directory ...
0
votes
1answer
92 views

Postfix / Dovecot not receiving e-mails in Ubuntu 14.04

I've just setup a VPS with Ubuntu 14.04 at Linode. I have installed Postfix, Dovecot & SquirrelMail to handle E-mail. I am able to send e-mails to other accounts (GMail & Yahoo!) but when I ...
1
vote
1answer
55 views

Ubuntu 14.04 LTS - SSH and VNC cannot be connected infrequently / connection loss

sometimes it seems to be impossible to establish a connection to this server. Later when a connection could then be established I am not able to see any hints what was causing this behaviour. When I ...
0
votes
0answers
40 views

Destination host is unreachable

Points to Note I am installing cloudera 4.6.0 using docker in pseudo distributed mode. I have created two docker containers. One is for hadoop and another is for flume. I linked two containers as ...
-2
votes
0answers
18 views

Ubuntu server won't boot, stops at initramfs

14.04.1-server-amd64 into dell server poweredge t619. But when booting it stops at initamfs. then i enter 'exit' command. then it boot and goes to login page. Why this happen ? thanks Gayan
0
votes
0answers
25 views

EC2 Ubuntu 12.04 refuses do-release-upgrade

I'm running Ubuntu 12.04 on EC2 and I want to upgrade to 14.04. do-release-upgrade returns that there are no upgrades. do-release-upgrade -d begins to work and then halts stating: Calculating the ...
0
votes
0answers
69 views

OpenVPN start at boot not working on Ubuntu 14.04

I am trying do configure my Ubuntu 14.04 server, so OpenVPN will start at boot. So far, I am able to start OpenVPN server with the command: service openvpn start After I execute this command, I ...
-1
votes
1answer
29 views

Website hosting moved from internal to external, issues

First I would like to let you know that I've researched this problem and I have seen similar questions on other sites, but I am VERY inexperienced when it comes to things like this so I really don't ...
0
votes
0answers
28 views

Client denied by server configuration, after upgrade

Yesterday, after upgrade my development machine, received this messages on intermittent mode. Client denied by server configuration. I working for years with the same configuration without problems. ...
0
votes
0answers
46 views

Install latest mysql 5.6 update (update 19 to update 22) on Ubuntu 14.04

A while ago I installed Mysql 5.6.19 via "apt-get install mysql-server-5.6" on a Ubuntu 14.04 amd64 server, now I want to upgrade this Mysql 5.6.19 to the latest stable update (5.6.22). I can't do it ...
0
votes
2answers
38 views

Clean /boot on Ubuntu

When I boot my Ubuntu server, I have this warning message: => /boot is using 100.0% of 235MB And when I look into /boot, I have a lot of files which are dependent of the version of the kernel. ...
2
votes
1answer
61 views

Postfix Rejects incoming bounce notifications ( Recipient address rejected: User unknown in local recipient table )

So I've set up a postfix email server, I can send, I can receive. But I noticed some interesting activity in my logs. I was testing an accidentally sent to a non-existent email address, now the ...
3
votes
1answer
67 views

NginX + WordPress + SSL + non-www + W3TC vhost config file questions

I have the following questions about my server block(s) for a WordPress site running solely on https, with nginx and W3TC browser caching. Environment: Ubuntu - 14.04LTS nginx - 1.4.6 ...
0
votes
1answer
46 views

Cannot connect on port 80 to Azure Ubuntu machine

I have recently set up a Linux Ubuntu VM on Azure. I can SSH into the machine just fine, but HTTP requests are answered with "Connection refused". I have: Set up an Endpoint for port 80 in the ...
1
vote
2answers
31 views

apache listening to 7080 after installing ubuntu desktop (gui) on 10.04 vps

Before ubuntu desktop was installed sites were normal and everything (virtuals hosts/ sites) was working normally but suddenly it stopped listening to 80 and went on 7080 and 7081 any idea why this ...
1
vote
1answer
114 views

OpenVPN connected but no Internet or LAN

Good evening, I'm facing an issue with my OpenVPN installation. Been at it for 3 days now but still cant figure out what is wrong for the life of me... Basically the issue is that i'm able to ...
0
votes
1answer
76 views

How to point Ubuntu 14.10 Apache2 (mod-wsgi) server to a specific virtual environment (Python 3.4 / Flask)?

I am running apache2 (mod-wsgi) on Ubuntu 14.10. I am getting 500 Internal Server Error when serving my web-site. I am also using Flask and Python 3.4, and virtual environment. It appears that Ubuntu ...
0
votes
0answers
38 views

Members of my PPTP VPN can't see each others

In relation to the answer of this post: pptp on Ubuntu server can't ping other machines on the LAN Is it possible to have the members connected to the VPN see each others if they don't use the ...
0
votes
1answer
55 views

TCP: out of memory - Nginx

I'm running a high traffic site on a nginx server. Last fews days I'm having problems with my VPS locking up (unable to SSH, and nginx seems to be down). When I look in the logs I can see the ...
0
votes
0answers
34 views

“Packet Dropped” in OpenVPN on Ubuntu Server

I configured OpenVPN Server in Ubuntu 14.04 Server. It's okay but in /var/log/syslog I got the error. Mon Jan 26 02:46:02 2015 us=389908 user/20.10.10.1:57237 MULTI: bad source address from client ...
0
votes
1answer
68 views

ubuntu 14.04 server wordpress file permission

I have an webserver running Ubuntu 14.04. I host 3 wordpress 4.1 sites using apache virtual hosts. The website are working well but I can't upload any picture using wordpress>media>library>add new. ...
1
vote
1answer
48 views

NGINX and Chrome [duplicate]

Going a bit mad here, pulling my hair out. The site on http://alpha.draser.co.uk works on IE and Firefox (only tested those) and doesn't work on Chrome. I've tested this on my computer and a remote ...
1
vote
1answer
252 views

(111: Connection refused) while connecting to upstream - Opsworks Rails 4

I deployed a rails 4 application in OpsWorks (Ubuntu 14.04, nginx and unicorn), when I open the homepage I'm getting a 502 Bad Gateway error. In nginx/error.log I can see this error: 2015/01/25 ...
0
votes
0answers
41 views

CSF does not open port

I'm having a Ubuntu 14.04 server which has a TomCat installation listening on port 8080. I installed CSF today. Following is netstat -tulpn tcp6 0 0 :::8080 :::* ...
0
votes
1answer
62 views

BackupPC schedule advanced settings

I've just installed this great tool for network backups called BackupPC but I'm having some difficulties setting the Schedule parameters as I want. As I see it, BackupPC has some basic schedule ...
0
votes
1answer
48 views

opsworks/chef databag where to put the json file?

Hello I'm reading this howto: https://github.com/imoglobe/opsworks-cookbooks/blob/master/user/README.md but it does not mention where to put the data bag in the cookbook with the list of users in json ...
2
votes
1answer
51 views

Linux: Rebuilding software Raid 1 fails when adding partition

I had an issue yesterday with a software Raid, where one disk had to be replaced. I removed the partitions from the array using mdadm /dev/mdx -r /dev/sdbx After the failed drive has been replaced ...
0
votes
1answer
18 views

Exim4 panicking, missing /etc/vmail/<domain>/passwd file

I keep getting this error. /var/log/mail.err Jan 22 05:00:03 home exim4: ALERT: exim paniclog /var/log/exim4/paniclog has non-zero size, mail system possibly broken Checking ...