Xen is a hypervisor based virtualization. It supports x86, AMD64, IA64, ARM and other CPU types, and Linux, Windows, Solaris and *BSD guest operating systems.

learn more… | top users | synonyms

3
votes
0answers
923 views

xen:balloon: reserve_additional_memory: add_memory() failed: -17

We're running Ubuntu 14.04 on an EC2 virtual machine. I've been seeing a lot of these errors in our kernel log: [ 704.032085] xen:balloon: reserve_additional_memory: add_memory() failed: -17 [ ...
3
votes
0answers
149 views

Network filtering with libvirt + xen + bridge + nat?

How can I properly add basic network filters (clean-traffic or, at least, ip-spoofing prevention) to XEN (xend) guests managed by libvirt? Or, in particular, can I manually execute libvirt's ...
2
votes
0answers
195 views

Xen and Turbo Boost

Running the Debian Squeeze default Xen, I am unable to get any of the CPU frequency scaling stuff going. As soon as I revert to the standard kernel I get it. Digging through the internet it seems ...
2
votes
0answers
107 views

Upgrading kernel on Debian server hosting Xen 3.2.1

I have a physical server running Debian 6 and Xen Hypervisor 3.2.1, and kernal -a says "2.6.26-1-xen-amd64". I have not updated for a long time, because when I run apt-get upgrade, one of the updates ...
2
votes
0answers
807 views

Citrix XenApp Fundamentals

I have a problem with a new install of a XenApp Citrix server. Everything was working fine, but I was setting up Citrix Access Gateway and single sign in. Now, on the main server I am getting an ...
2
votes
0answers
219 views

Why I get different network traffic values from dom0 and from domU?

I'm using Xen 4.0.1 with Linux 2.6.32-5-xen-amd64 (standard packages on a Debian Squeeze system). From Xen Networking: For each new domU, Xen creates a new pair of "connected virtual ethernet ...
2
votes
0answers
414 views

Xen and dhcp. Not connecting

I'm sorry if this sounds like a really stupid question but I started today for the first time using Xen. I'm using it on a fresh installation of Debian Lenny. I followed this tutorial ...
1
vote
0answers
31 views

Xen VM could not be installed

I have rented a server from Hetzner. I have installed Xen on Dom 0 - Centos 6.5. I couldn't create a Dom1 Centos 6.5 VM. The Error I see is 'Unable to retrieve 'the link for centos image' while ...
1
vote
0answers
195 views

Weird Phusion+nginx spawning delay error

We are trying to migrate an application written on REE from cloud provider A to cloud provider B. The application code, VM specs and operating systems are the same. The basic difference is that cloud ...
1
vote
0answers
16 views

Xen: resizing underlying iSCSI SAN volume

I have a SAN volume that provides the storage for 3 machines running Xen 6.2. The volume is down to about 10% free but there is more available unallocated. The SAN (Equallogic) supports volume ...
1
vote
0answers
154 views

reclaim space from xen server

i found xencenter stotage => general tah display 1096.6 GB used of 1107.7 GB total (708.5 GB allocated) seen some space have been eaten and not release. the SMLog show that [13816] 2014-03-28 ...
1
vote
0answers
114 views

Virtual Allocation Unreasonably High

Just upgraded our pool to Xenserver 6.2 and installed a brand new host, also with Xenserver 6.2. Was excited about the new features since Xenserver was fully open-sources (over-allocate ram, ha live ...
1
vote
0answers
548 views

CentOS 6.5 Xen Virtual Machine Issue 'this function is not supported by the connection driver'

I am trying to segment my system into a number of virtual machines but just cant seem to get this to work. I think I am close but not quite there. I have install xen, virsh, xl etc and I am using ...
1
vote
0answers
78 views

How can I export a XenServer virtual machine with all its snapshots?

Is there a way to export a virtual machine running on XenServer with all its past snapshots? I have tried to export a VM through XenCenter (right click on the machine and "Export..."). After importing ...
1
vote
0answers
344 views

xen hotplug can't add vif to eth0: operation not supported

I am new to xen and I am trying to get a domU running but I am having problems with it. I think my network card might not support bridging which is bizarre. This is the error I get when trying to ...
1
vote
0answers
211 views

FreeBSD XEN kernel not booting in XenServer 6.2

I have a XenServer 6.2 host, and I am trying to get a FreeBSD-9.1-i386 guest to run in PV mode. The installation of the guest is fine, but after a reboot with the new kernel the system does not boot. ...
1
vote
0answers
52 views

Obtain the free_memory value in xen

I would like to know if there's an alternative to the command I am currently using to get the real free memory for the system (meaning memory that can be assigned to new domU) xm info | grep ...
1
vote
0answers
69 views

How to move a template from one xen nfs storage repository to another?

I have a bunch of templates on an NFS XCP 1.6 storage repository using thin provisioning for some of my VMs. I want to move the template's disks to a different NFS storage repository. There doesn't ...
1
vote
0answers
306 views

Xen hangs on boot when scrubbing RAM

I have a CentOS 5 server I can boot into the stock kernel just fine, but when I try kernel-xen, it gets stuck here: http://i.stack.imgur.com/wAI20.png When I try adding no-bootscrub to the kernel ...
1
vote
0answers
1k views

Nagios: check services being orphaned?

Recently I noticed that there are some warnings in the nagios.log: [1366060611] Warning: The check of service 'pt-deadlock-logger' on host 'xx' looks like it was orphaned (results never came back). ...
1
vote
0answers
68 views

Domus Memory Used Issue With Xen On CentOS

Anyone know why I'm receiving this error? I compiled latest libvirt from source, I also tried with various rpm. I would like to get memory used by domus and it looks like it's not working with Xen 3 ...
1
vote
0answers
67 views

OSPF on XEN host running several VMs

Is it possible to set OSPFs areas in a XEN environment to setup a virtual cluster? Main intention is to avoid a external router since all VMs will run inside the same machine.
1
vote
0answers
86 views

how to setup VM with debootstrap

I'm having problems to configure a virtual machine with xen server. following tutorial I made this steps: make the lvm partitions (root, swap) on my host and format mount root partition on /mnt ...
1
vote
0answers
1k views

Import Xen Server VHD

I am trialing using a distributed file system as the backend storage for my Xen Servers. I have set up the DFS (distributed file system) (using CentOS and GlusterFS) and everything is working ...
1
vote
0answers
477 views

Access All VLANS over XenServer Interface

For my current setup, I have a physical NIC on a XenServer machine that receives traffic tagged with various VLAN IDs. I have a virtual machine that is running Vyatta that needs to be able to access ...
1
vote
0answers
190 views

xen 4.1 host priodically dropping network packets of domU

I have xen 4.1 Host running on a ubuntu 12.04 LTS Server with ip 153.x.x.54. I have setup 2 VMs on it, namely, "dev.mydomain.com" and "web.mydomain.com" with ips 195.X.X.2 and 195.x.x.3 respectively. ...
1
vote
0answers
135 views

How to make all of my IPs works in HyperVM XEN?

I've installed HyperVM on CentOS 5.8 final to make XEN VPS. I have 5 IPs, and added them to an IPPool. They are from *.123 to *.126. But when I add Virtual machines, just the first one (which indicate ...
1
vote
0answers
368 views

XenServer Offsite Replication

I am trying to find the best way to migrate my VHD's to my DataCenter offsite for DR purposes. Currently I have a number of Xen Stacks setup as the following: Dual RAID ISCSI SAN multipathed to at ...
1
vote
0answers
192 views

XCP vm created via xl create doesn't show up in Xencenter neither in xe vm-list

i am running XCP 1.4.90.530.170661 and i have many PV guests running and created via XenCenter. I have created now an openwrt PV guest via the xl create command but it doesn't show up in Xencenter ...
1
vote
0answers
102 views

Ubuntu 10.04 Xen guest - why would time drift be proportionate with the system load?

We are trying to troubleshoot an issue with random system lockups during medium - heavy loads on an Ubuntu MySQL 5.1 server. There is nothing logging into the system during these lockups. The only ...
1
vote
0answers
112 views

XEN - (magic) networking issue

I have a very strange situation and do not know where to look. I have a XEN installed on Ubuntu 12.04 LTS. My hosting-provider does require, that every new IP my server uses has an own MAC-address. ...
1
vote
0answers
179 views

Mounting shared memory in XCP/ XEN Server,for storing VM

Requirement vm with 2HDD each 1gb OS will be installed on hdd 1 and required data on HDD 2 I want all my VM running on Xen Cloud Platform XCP 1.1 to use /dev/shm of host machine for HDD1. Is ...
1
vote
0answers
513 views

Ubuntu Xen DomU Boot Error

I am attempting to boot an Ubuntu 12.04 Precise DomU (Dom0 is Ubuntu 12.04 with xen-hypervisor-4.1-amd64) and it is failing to boot, dropping me back into a shell (see below). I am using ...
1
vote
0answers
117 views

How to pass two USB-devices to XEN domU guest?

how do i pass more then one USB device to Xen domU guest? Either usbdevice = 'host:1d6b:0002' OR usbdevice = 'host:04f3:0232' works fine, but with only one device at the time. Obvious thing: ...
1
vote
0answers
55 views

Linux webserver reboot issue

I've webserver, it works fine when there is no load into it. when I've load onto it and try to restart httpd server gets reboot itself or sometimes it automatically get reboot It is Xen HVM with OS ...
1
vote
0answers
124 views

how to deal with backup & restore of private cloud environment?

using Cloudstack OSS - with NFS as storage backend.... How to deal with VM image backup and restore? snapshot backup is preferred softwares like PHD Virtual are built for specific Hypervisor: ...
1
vote
0answers
380 views

Xen domU mem-set issue

I'm running into a problem on my xen 4.0.1 server (debian squeeze) My host has 32G of memory, Domain-0 has 2048 M assigned to it. (scaled down with xm mem-set Domain-0 2048) top in Domain-0 confirms ...
1
vote
0answers
280 views

CentOS 5.7 Xen Host

Here is the situation: I am running CentOS 5.7 x86_64 with Xen 3.0.3 (xen-3.0.3-132.el5_7.2.x86_64) and the Xen kernel (2.6.18-274.12.1.el5xen). The server has 8GB RAM, and an i7-950 @ 3.07Ghz. I am ...
1
vote
0answers
665 views

64 bit HVM guest freezes while booting on Debian Lenny 64 bit Xen hypervisor

I'm trying to create an x86 64 bit guest machine on an old Debian Lenny x86 64 bit hypervisor using HVM. The physical CPU is a first generation Intel i7 with VT-x support. Xen recognizes the VT-x ...
1
vote
0answers
139 views

Xen Hosting - What Could Be Causing My Kernel to Not Boot - At All?

I have a VPS at Linode, and I'm trying to boot Gentoo's hardened kernel - which is patched with Grsecurity and PaX. On Linode, you can boot a kernel of your choice by utilizing their "PV-Grub" ...
1
vote
0answers
79 views

CentOS/Xen Hypervisor Completely Locked-Up, Where To Look For Answers

Our hypervisor server running CentOS and Xen completely locked-up just right now. The screen was completely blank. I had to hard reboot, and everything came back up normally. No indication of a ...
1
vote
0answers
798 views

Target filesystem doesn't have /sbin/init — Ubuntu server 8.04LTS

I recently copied the logical volume containing an Ubuntu Server install from one Xen server to another. I have done this many times in the past and have not had issues before. However, when I ...
0
votes
0answers
20 views

What is causing `skb rides the rocket` errors?

On one of our busy (virtual) Debian 6 servers we are seeing a lot of messages in the syslog like this: kernel: xen_netfront: xennet: skb rides the rocket: 19 slots We are seeing some connectivity ...
0
votes
0answers
23 views

Difficulty sharing physical ethernet device with Xen 4.4

I have a virtualized PowerEdge T320, with a Ubuntu Server 14.04 running Xen 4.4 as host, that I use at my lab to do scientific computations (I'm the admin of the machine). This server has two physical ...
0
votes
0answers
49 views

External USB drive on xen windows guest

I have an external USB 2Tb drive I'm trying to use with a xen guest. Xen Center 6.1 sees the drive in the removable storage repository and I can assign it to a guest. But the guest (tested ...
0
votes
0answers
7 views

xen routed setup, no internet connectivity in domU

My server has 4 public ips, but I have 5 vms running, the vm which doesn't have an own public ip should be able to reach the internet and all other vms over private interfaces. I configured a private ...
0
votes
0answers
20 views

Using Xenlight with libvirt in debian, Unable to configure listen with remote libvirt

I am using libvirt 1.2.0 with xen hypervisor 4.4 in debian server. I am facing error when I try to connect remotely with other libvirt using TCP or TLS. I couldnt make libvirt to listen to the port. I ...
0
votes
0answers
21 views

fdisk -l do not detect device accessed using iscsi o XEN virtual machine

I am experiancing an issue in accessing the iscsi target in VMs created on XEN hypervisor. I have used Suse 11 SP3 to configure this. After discovering the iscsi targets from VM , I am able to view ...
0
votes
0answers
37 views

How to boot xen dom0 with UEFI support?

I boot my system with EFI+grub2. If I boot into a normal system, I can modprobe efivars and view all the efi variables. But if I boot into xen, I cannot see the efi variables from my dom0. I build my ...
0
votes
0answers
114 views

Cannot create windows HVM with SDL in xen 4.4.1

I want to create a win HVM, and set sdl=1. I was able to do so. But after I upgraded to xen-4.4.1, I got this error libxl: error: libxl_dm.c:1371:device_model_spawn_outcome: domain 4 device model: ...