Xen is a hypervisor based virtualization. It supports x86, AMD64, IA64, ARM and other CPU types, and Linux, Windows, Solaris and *BSD guest operating systems.

learn more… | top users | synonyms

0
votes
1answer
295 views

Xen.org Master/Slave in a pool with HA-Lizard

I have a pool of 3 servers with XCP only, each with 1 VM running on them, and managing them through XenCenter. Since the opensource version of xen does not have support for HA, I am using HA-lizard, ...
0
votes
0answers
57 views

Xen Debian VM and NFS

I have 2 servers in a pool running a single VM on each server. I just got xencenter running so I am managing through that. I want to have a shared storage (NFS) between the two of them, so that if one ...
1
vote
1answer
264 views

RAID1 LVM, XEN and flashcache

I am regarding to question: Improving IO with FlashCache I have setup a RAID1 (/dev/md0) LVM (*/dev/vg_xen*) and executed following command: flashcache_create -p thru flashcache0 /dev/sdc /dev/md0 ...
4
votes
2answers
868 views

virtualized windows 2003 domain with CentOS 5.3 and poor connectivity

I have a test lab set up running a virtualized windows 2003 domain on a CentOS 5.3(xen) host and am experiencing connectivity problems with guests running on other hosts that are part of the same ...
2
votes
1answer
257 views

Busy Debian server (Xen guest) seems to go to sleep (energy saving mode)

I have a Debian 6 Xen guest that seems to go to sleep from time to time. Randomly, it just stops to answer to any network requests (HTTP, ssh, ping) and only resumes activity when we log on the ...
2
votes
3answers
2k views

How can I run Rackspace images locally?

As the title says, I regularly download my Rackspace images for backup of my VPS, however I'm wondering if it's possible to run them locally on KVM (for example) so I can run tests on my application ...
0
votes
1answer
353 views

Can I set noatime for my XEN guest OS partition? Will it work?

I have a VPS in cloud environment based on XEN Virtualization platform. /etc/fstab looks like that: LABEL=PRGMRDISK1 / ext3 errors=remount-ro 0 0 As far as I know IO can pretty ...
0
votes
0answers
132 views

Why does Xen fail to create domUs/start the virtual network interface?

I have received two errors while trying to create a new domU on Xen. First, I received this error: Unable to complete install: 'POST operation failed: xend_post: error from xen daemon: (xend.err ...
1
vote
0answers
59 views

How to move a template from one xen nfs storage repository to another?

I have a bunch of templates on an NFS XCP 1.6 storage repository using thin provisioning for some of my VMs. I want to move the template's disks to a different NFS storage repository. There doesn't ...
1
vote
2answers
621 views

Xen: synchronizing time with Dom0

I have Xen virtual machines running on Debian 6 (both Dom0 and DomU). I would like to synchronize clock on DomU with Dom0. On http://wiki.xen.org/wiki/Xen_FAQ_DomU I have read that I need to set ...
0
votes
1answer
74 views

Add OpenStack Compute to existing Xen based server

I have an existing server running Cenos 6.x with Xen 4.x and a dozen or so virtual machines. I'm building out an OpenStack environment and was wondering if is possible to install OpenStack compute on ...
1
vote
1answer
559 views

Creation of Xen VM fails with Error: Creating domain failed: name=buildbox03

Since a few hours, my xen VM does not want to be created. The VM is quite unstable so I need to destroy and create is quite often. This morning I was able to do such a destroy-create cycle. A few ...
0
votes
1answer
176 views

Trying to make pvgrub: xen-setup-stubdom not found

I wish to use pvgrub. I'm using debian wheezy x86_64. I did an apt-get soruce xen and apt-get build-dep xen, cd-ed into the xen source dir and issued "make world". The package doesn't compile, it ...
1
vote
2answers
303 views

fix kernel on Xen Server hypervisor vps

I have a cloud server hosted at Rackspace, and they use Xen Server hypervisor. I was running Ubuntu 12.04, and really messed up by attempting to do a release upgrade manually. The hypervisor ...
0
votes
1answer
384 views

Grub can't find Xen multiboot file

I am running Debian Wheezy on a software RAID 0 with LVM. I'm trying to get Xen to work but grub refuses to boot in it. I installed Xen by following the instructions here: http://wiki.debian.org/Xen ...
2
votes
2answers
2k views

Problem with Xen, xvda and sda

I am creating a cloud for my university using Eucalyptus with Xen (PCs have Debian Squeeze 64 bit installed). I have a problem with the following guest configuration: # # Configuration file for the ...
0
votes
0answers
37 views

Optimize monothreaded application under XEN

I have an single threaded application who uses 100% cpu on virtual machine under XEN. Adding more VCPU will not help. Is it possible to configure XEN VCPU in order to have better performance with ...
1
vote
1answer
66 views

Centos install in Xen problems

I'm running ubuntu 12.04.1, and I want to install CentOS 5 or 6 using network installation via http. Using xen images from http://mirror.centos.org/centos/5.7/os/x86_64/images/xen/ my config: ...
0
votes
1answer
165 views

XenServer xe CLI on OSX [closed]

Is there a port of the XenServer/XCP xe command-line tool to Mac OS X? Or, alternately, if this tool is open-source, what's the easiest way to get access to the source?
0
votes
1answer
284 views

How do I change a xen vm storage from hda to sda?

I am trying to import an ovf appliance created for VMWare into our Xen infrastructure. The imported image uses hda rather than sda, and the appliance has some hard references that appear to be ...
1
vote
1answer
294 views

Booting Ubuntu 12.10 guest on Debian 6.0.4 Xen with pygrub

I'm trying to run a Ubuntu 12.10 off a Debian 6.0.4 and Xen-4.0. I realised that pygrub might not be able to parse the menu.lst (I symlinked menu.lst to grub.cfg in /boot) and ended up with this ...
0
votes
5answers
1k views

VMWare->Xen migrated image does not boot

I've a Windows Server 2003 installation on VMWare Server 1. Using the instructions at http://ian.blenke.com/vmware/vmdk/xen/hvm/qemu I converted this virtual machine to a Xen image (Xen 3.3). However, ...
0
votes
2answers
522 views

Strange Ubuntu boot up warning

I have a VM (Xen based), I can boot up the machine but there are some warning during the boot up. Are they normal? If not, how to solved? md: Scanned 0 and added 0 devices. ...
0
votes
1answer
98 views

Split management network from data in Xen Server

I'm working on configuring our existing pool of four hypervisors running XenServer 6.1 to use a separate management network. Currently the setup is a single link with a public address over which all ...
-1
votes
1answer
102 views

Error: Cannot find ramdisk “hd(0)/boot/grub/menu.lst”

I have a dom0 and try to run domU with config like this: kernel = '/root/xen/dist/install/usr/local/lib/xen/boot/pv-grub-x86_32.gz' ramdisk = 'hd(0)/boot/grub/menu.lst' vcpus = '2' ...
2
votes
3answers
569 views

Xen memory management on small server

I am currently running VMware vSphere 5 on a server I use for various projects. Mainly I use it for honing my skills with administration and running a few game servers. Recently I was considering a ...
3
votes
3answers
3k views

compile kernel 2.6.34 for Ubuntu Lucid for xen dom0 / pvops

I'd like to compile a recent Linux kernel (2.6.34) for my Ubuntu 10.04 Lucid Lynx AMD64 box, mainly because I'd like to use it as a dom0 kernel with the recent xen4. There's plenty documentation on ...
1
vote
2answers
70 views

mount a partition on an lvm partition

I have a xen dom0 server (named virtserver), which contains a guest machine, let's call it "virtguest". The virtguest used to be a physical machine earlier, and the whole old disk (with several ...
1
vote
0answers
179 views

Xen hangs on boot when scrubbing RAM

I have a CentOS 5 server I can boot into the stock kernel just fine, but when I try kernel-xen, it gets stuck here: http://i.stack.imgur.com/wAI20.png When I try adding no-bootscrub to the kernel ...
1
vote
0answers
878 views

Nagios: check services being orphaned?

Recently I noticed that there are some warnings in the nagios.log: [1366060611] Warning: The check of service 'pt-deadlock-logger' on host 'xx' looks like it was orphaned (results never came back). ...
0
votes
3answers
1k views

NTP time sync not working in a DOMU Centos 5.5 server

I have a Xen Centos 5.5 server with ntpd working in virtual server. NTP time sync seems not working. I have disabled any firewall. my grep -i ntpd /var/log/messages output: Apr 1 16:15:47 ...
2
votes
2answers
2k views

Weird fluctuating time on a XEN linux guest

I have a weird problem with some servers here at work. We have a few XEN guests who's current time fluctuates. # date;date;date;date;date;date;date Thu Feb 25 16:00:40 PHT 2010 Thu Feb 25 16:00:48 ...
1
vote
3answers
2k views

Can't connect to remote Xen libvirt with ssh, using virsh or virt-manager

I'm running Xen 4 on a Debian server running Squeeze (stable). I want to connect remotely over ssh using virt-manager or virsh, because I can do that on a Lenny server (oldstable). Xen is installed ...
1
vote
2answers
129 views

Does Xen need an XServer for graphical display?

I'm trying to create a very small ISO, which is bootable and brings up a DomU such as Windows 7 using Xen. I want to setup the minimal number of packages in the small ISO, therefore I'm wondering if ...
1
vote
1answer
196 views

ntpdate setting incorrect date after boot

I have a few Debian XEN virtual machines and upgraded them to wheezy(I need the 3.2 kernel for a project). Everything was okay until I rebooted on of the machines. My current problem is, that ntpdate ...
0
votes
2answers
883 views

What causes the error “Error: Device 0 (vif) could not be connected. Hotplug scripts not working.” on CentOS5.6 x86_64 with Xen kernel?

I have 10 domU's on my CentOS 5.6 server running Xen kernel. All 10 are set to start on system boot; however, for just 1 of the machines, I get this error: Error: Device 0 (vif) could not be ...
0
votes
2answers
555 views

How to reset root password CentOS (domU) hosted in Xen?

Need help on resetting root password of a CentOS which is a guess OS (domU) in XEN. I already tried to get to grub but it doesn't display or maybe using a different grub (pygrub). Thanks in advance.
0
votes
1answer
82 views

Setting up VPN on a VPS

I want set up a VPN in my Xen VPS with one static IP. What I should set in /etc/pptpd.conf as localip and remoteip. I followed this tutorial: ...
0
votes
0answers
265 views

Xen 4.2.1 dom0 boot hang

I'm having some issues with booting xen dom0. Initially I started out with Ubuntu 12.04 LTS server and compiled and installed xen 4.2.1. Unfortunately, the machine wouldn't boot but would show a ...
0
votes
1answer
227 views

Xen guest - cannot get network connection beyond the host

I've just installed a XenServer 6.1. It came with a standard configuration: network 0 connected to NIC 0. I created a VM but I can't reach any network beyond the host. From the VM (172.18.32.20), I ...
0
votes
1answer
167 views

Issues with Xen Kernel and Debian

My Xen installation has gone weird on me and I am trying to get back to normal. I overflowed the base partition and in my haste to delete unused files I think I deleted something important, so now ...
0
votes
0answers
304 views

Xen 4.1 forces hard reboot in IBM x-series 346 server

we've installed Debian "Wheezy" on a machine previously running "Squeeze". We were running Xen (4.0.1, Squeeze's version) without problems, but after we upgraded to Wheezy (Xen 4.1) the machine ...
4
votes
2answers
3k views

How can I obtain a new XenServer license using only the command line?

Many sites explain how to renew the license using XenCenter. Is there a way to do this directly from the console?
0
votes
1answer
55 views

Xen domU sees 35MB less than assigned

I am using ubuntu precise 12.04 and I am booting a paravirtualized ubuntu 12.04 domU, all being 64 bits. The VM has memory=1024 assigned and xentop at the host correctly shows 1024MB, but htop in the ...
0
votes
1answer
208 views

Migrate Windows XP to Xen HVM

I want to migrate a Windows XP machine to a Xen 4.1 HVM virtual machine with Windows XP installed (the custom software will only work with XP). The software is custom made, and needs to be migrated ...
3
votes
1answer
332 views

Use SSHFS on XenServer 6.1

On Xen Server 6.1, to backup my VMs, I use a script based on the following tools: xe vm-list to build a list of the VMs to backup xe vm-snapshot to take a snapshot of the VMs xe template-param-set ...
2
votes
1answer
437 views

I can't mount a LVM snapshot on a XEN host

I'd like to backup my XEN VMs by copying-rsyncing a LVM snapshot. I'm trying to mount a snapshot that contains a XEN guest's virtual disk (ext4). Below are all the steps I follow. I can't mount the ...
1
vote
1answer
249 views

Xen XCP: Route failover IP to Guest

I have two hosts, which I installed XCP 1.6 on. The machines are hosted at Hetzner. Each host currently has a public IP and an additional IP assigned. There is a guest on each of the hosts which ...
1
vote
1answer
62 views

Always use Xen? [closed]

I'm installing the usual bunch of servers for general office stuff, a mixture of Windows/Sharepoint and Linux Since none of these need direct access to the hardware, fancy graphics or are really ...
0
votes
1answer
330 views

Unable to run libvirt with xen on Centos 6. Fails with ioctl 3166208

As per subject. Xen 4.2.1 libvirt 0.10.2-18.el6 Linux gatto.example.com 3.8.3-1.el6xen.x86_64 #1 SMP Sat Mar 16 15:16:57 EST 2013 x86_64 x86_64 x86_64 GNU/Linux I followed the instructions given ...