Xen is a hypervisor based virtualization. It supports x86, AMD64, IA64, ARM and other CPU types, and Linux, Windows, Solaris and *BSD guest operating systems.

learn more… | top users | synonyms

0
votes
1answer
1k views

Xen dom0 bridge interface drops a lot of RX packets?

I'm running Gentoo Hardened as Dom0. It also acts as a router/NAT. There's a bridge interface called br0 which contains a pci-e wlan card, ethernet nic & domU. bridge name bridge id ...
0
votes
1answer
2k views

Xen Vif creation xl vs xm

Hi everyone, I switch my server from a xend/xm Xen install to a 4.1 xl Xen install. Therefore Xen does not create vif network interface when I launch xl create /etc/xen/my_server.cfg but does create ...
1
vote
1answer
1k views

Where is my new hard disk Citrix Xen Center

I'm trying to create a new storage repository on a server that already has 2 old hard disks, set up with hardware RAID 1. It's my first time doing this in Xen Server environment so I wanna be extra ...
2
votes
1answer
1k views

Install xenserver on iscsi target

Is is know that Xen Server is based on CentOS, and it is fact that CentOS can be installed on an ISCSI target flawlessly, but I wanted to install Xen server on an ISCSI target I couldn't find a way. ...
1
vote
2answers
7k views

Citrix Xen VM's lose networking

My client has a XenServer 6.0.2 installation with 2 Window Server 2008 R2 virtual machines. Whenever the virtual machines are rebooted they lose their IP settings (IP address, subnet, gateway). Each ...
4
votes
1answer
8k views

Can I safely uninstall “Citrix Tools for Virtual Machines”?

Having several virtual servers with Windows 2008 R2 at our web hoster (Germany's "1&1", they seem to use Citrix Xen), I have every now and then some servers that hang (RDP login screen hangs ...
2
votes
5answers
4k views

SSL connection hangs as client hello (curl, openssl client, apt-get, wget, everything)

I've run into a problem on my Debian VPS (a xen domU) regarding SSL. Namely almost all SSL connections hangs at client hello. For example: # curl -vI https://graph.facebook.com About to connect() ...
1
vote
1answer
3k views

Bringing the xenbr0 interface up on XEN under Ubuntu 8.04

I installed XEN on Ubuntu 8.04 using this tutorial but after I reboot with the XEN kernel, I don't have xenbr0 device. I see that network-bridge script runs and it creates peth0 device, but not xenbr0....
0
votes
1answer
2k views

Error while creating VM using virt-manager on Xen

After a great struggle I got my XEN installed now I am using virt-manager and trying to create a VM. Since my H/W doesnt support full Virtualization using the Para Virtualization installation over ...
0
votes
1answer
10 views

Bridging host-only subnet on multiple Dom0s

I currently have two XEN-Hosts running a set of virtual machines. These machines can communicate with each other via a host-only network. I want to be able to move virtual machines between both ...
1
vote
1answer
4k views

Can I use XenServer GPU Pass-Through without XenDesktop?

XenServer documentation only covers using GPU Pass-Through ("vGPU") to run XenDesktop's "HDX 3D Pro Graphics." XenServer GPU Pass-Through cannot be used with the XenCenter VNC console and it does not ...
0
votes
2answers
1k views

Blocking STP Traffic

I am using Xen virtualization with a bridged mode netwrk. I noticed that there is a lot of spanning tree (as understand) traffic coming from a network. Such as: STP 802.1d, Config, Flags [none], ...
5
votes
2answers
7k views

LVM is reporting I/O errors, but the disk reports no problems. Argh

I've started seeing errors reported by LVM on certain Logical Volumes (and by Xen when attempting to create virtual machines on these LVs). But I've run tests on the disk, and can't see any hardware ...
3
votes
1answer
1k views

Ubuntu upstart hangs on interactive start & stop

How do I get Ubuntu upstart to not hang on interactive start & stop? I have created many upstart scripts that work fine during init, but often hang when I enter them at the console. If I CTRL+C ...
3
votes
2answers
3k views

Xen / libvirt - “End of file while reading data: Input/output error” when attempting to start a domain

I'm getting the following string of errors when I attempt to start a domain using virsh: virsh # start vimes error: Failed to start domain vimes error: End of file while reading data: Input/output ...
2
votes
2answers
1k views

Xen Remus setup

Currently, I'm running the IT for a small organization, and we just purchased a new server to replace our aging Dell poweredge. As the Dell isn't so bad as to be junk, I was hoping to set up Xen on ...
0
votes
1answer
144 views

XenCenter displays sometimes that the XenServer Tools has not been installed

When I restart a Windows VM then it happens quite often that the XenCenter displays this message even the XenServer Tools are installed: When I restart the VM then the message is gone. I tried it ...
2
votes
2answers
3k views

CentOS 6 Xen guest fails to boot after 'yum update'. Kernel?

I Seem to be having an issue with a Xen guest not booting after a yum update. DomU Configuration: #kernel = '/boot/solus-vmlinuz' #ramdisk = '/boot/solus-initrd.img' bootloader = '/usr/bin/...
2
votes
1answer
2k views

Xenserver 5.6 SR_BACKEND_FAILURE_47 no such volume group, but it is there

I've looked everywhere (Google, here, a bunch of other sites), and while I have found people with similar problems, I couldn't find a single one with a solution to this. Last night our xenserver 5.6 ...
2
votes
1answer
1k views

Cannot connect to Xen domU via VNC if X isn't installed on domU

I'm trying to build a Xen domU that can be connected through the Xen's VNC server. Below is the template (actually it's generated by OpenNebula): name = 'one-153' #O CPU_CREDITS = 256 memory = '128' ...
0
votes
1answer
12 views

Xen Dom0's networking lost, guests OK

So I had to unplug the Xen server's NIC. When I was done, I plugged it back in, and attempted to SSH into it. Fails. But my connections to the guests work perfectly fine. They're still up and running ...
4
votes
1answer
2k views

How to get virtualized SR-IOV Infiniband interface UP?

I've spent several days on this now and I've managed to get SR-IOV working with the Mellanox Infiniband card using the latest firmware. The Virtual Functions appear in Dom0 as 06:00.1 Network ...
0
votes
0answers
22 views

Does guests see if the host network interface is down in Xen?

I am seeing that the DomU guests are not being able to see that the Dom0 network interface is actually down. Is this a normal behavior in xen? How can the guests track that the Dom0 interface is a ...
1
vote
2answers
3k views

Convert libvirt Xen configuration to native

I've configured some virtual machine under Xen on Debian Squeeze using libvirt with virsh. Now I want to get rid of the libvirt layer, because I need to configure some specific parameters on the DomUs ...
0
votes
0answers
18 views

No network on XenServer VMs

I'm trying to set up a CloudStack private cloud with advanced networking and I seem to have navigated most of the hard part. The problem now is my system VMs are not able to access the public gateway ...
1
vote
0answers
34 views

What's the impact of a high cpu steal time on XenServer's dom0?

From what I understand, cpu steal time is the CPU time that the VM kernel requested, but was denied by the hypervisor because it was serving another VM. From my experience, on a XenServer that has ...
1
vote
3answers
2k views

centos xen http kickstart installation fails with : 'Unknown command: <!DOCTYPE'

I am trying to install a Centos 5.5 xen domU using this method: http://wiki.centos.org/HowTos/Xen/InstallingCentOSDomU It suggests a kickstart config file served by the local apache. I managed to ...
0
votes
0answers
16 views

Having different two different public IPs or Xen guests

I'm using XenServer and CentOS. I have successfully configured two Windows Server guests and they both work properly. On the host machine, I have xenbr0, xenbr0:0 and xenbr0:1 (for two different IP ...
3
votes
6answers
552 views

Xen Versions

Does anyone know the difference between version of xen produced by xen.org and Citrix XenServer? I can't seem to find any mention of the differences between the two? Thanks
0
votes
0answers
22 views

CentOS network bridging and Xen

I'm using CentOS 6 and Xen 4.6 on a bare metal machine. I'm trying to install ubuntu as a guest but I fail in the networking section. (I use netboot image). I have two eths named eth0 and eth1. ...
0
votes
0answers
32 views

Virsh cannot connect to Xen server

I have installed the latest version of Xen server 6.5. Now I want to connect to it with virsh (libvirt-bin). When I do this I get the error error:end of file while reading data: sh:nc:command not ...
0
votes
1answer
47 views

Xen Server interference on ARP requests

I have a strange behaviour on my network as my unix-like hosts seem to have problems to reach the gateway. Digging into the network traffic via tcpdump, I've seen that two different hosts answer to ...
0
votes
1answer
49 views

XEN kernel, CPU missing flags?

I'm using Opteron 6386SE processor, 16 cores. It's capabilites (flags) are here: CPU World But when I run cat /proc/cpuinfo (dom0 or guest), flags are missing, for example SSE3 and SSE4. flags :...
0
votes
1answer
64 views

unrecognized usb passthrough to windows server 2012 r2 on ubuntu 16.04

I have a ubuntu 16.04 lts on a intel NUC machine. I want to use a TV usb tuner, in Japan, which only works for Windows. So, I'm trying to install a windows server 2012 r2 guest VM on the ubuntu host....
2
votes
0answers
351 views

How to Reclaim Space from XenServer?

I found that the XenCenter storage tab claims there is 1096.6 GB used of 1107.7 GB total (708.5 GB allocated). It appears that some space has been eaten and not released. The SMLog shows: [13816] ...
0
votes
0answers
14 views

Auto Power On Xenserver 6.5

After applying updates to my xenservers I noticed VM's that were turned off turned themselves on after the server I applied updates to rebooted. I do not have any vApps configured and I did not ...
3
votes
1answer
1k views

Xen VM won't come up: could not find bridge device xenbr0 (configured to use routed)

I am using xen 4.4.1 on an Ubuntu 14.04 server, my DomU is running Ubuntu 14.04 Server as well. I've run this DomU in bridge-mode previously no problems. However I want to switch to a routed setup. I ...
0
votes
1answer
27 views

Can't find logical volume when booting imported disk images in Xen guest

I've got a couple of drives I copied over using ddrescue to image files for booting under Xen. They contain an LVM volume group with a couple of volumes in it, which was originally split across two ...
1
vote
3answers
2k views

How to reset root password CentOS (domU) hosted in Xen?

Need help on resetting root password of a CentOS which is a guess OS (domU) in XEN. I already tried to get to grub but it doesn't display or maybe using a different grub (pygrub). Thanks in advance.
2
votes
1answer
54 views

Active/Active MultiPathIO to two HP d2700s?

Our XenServer 6.5 hosts connect over ethernet to shared SAS storage via a single Linux based HP DL360 G6 "bridge". This single StorageServer bridges ethernet to SAS and shares out via an iSCSI daemon....
1
vote
0answers
30 views

virsh (xen) not listing dom0 nor domU

I have Xen 4.4.2 installed on Ubuntu. xl list shows Dom0 and all DomU but virsh -c xen:/// list --all doesn't return anything. virsh version returns Compiled against library: libvirt 1.2.2 Using ...
0
votes
0answers
23 views

Xen migration - Error [backed has not unmapped grant]

I am trying to migrate between two servers running Xen version: 4.1.6.1 and Ubuntu 12.04.5 LTS. The problem I am currently having is when I migrate from: Server1 -> Server2 (with VNC I see this) ...
2
votes
3answers
14k views

How to get more I/O performance from Citrix XenServer?

I have a Citrix XenServer 6.1 installed on a HP Server (1x Intel Xeon E5630 @ 2.53GHz (4 cores, 8 threads, RAM: 752MB for dom0 and 55286MB for the guests). The server has 2 scsi mirrored disks and is ...
1
vote
1answer
100 views

Libvirt with Xen fails to start correctly Ubuntu 14.04

At the moment i'M really feeling a little helpless: I tried to setup Ubuntu 14.04 with Xen and libvirt for management. I created a VM but I did not auto-start (altough autostart is checked). If I do ...
4
votes
2answers
774 views

Use SSHFS on XenServer 6.1

On Xen Server 6.1, to backup my VMs, I use a script based on the following tools: xe vm-list to build a list of the VMs to backup xe vm-snapshot to take a snapshot of the VMs xe template-param-set ...
4
votes
5answers
7k views

Can I virtualize multiple hosts into one virtual system?

I have 5 computer systems in our small office. From my basic understanding of Virtualization technology, I think I can virtualize the 5 systems into one big virtual system. I wish to confirm this. So,...
2
votes
2answers
78 views

Ping only works twice

I have created a vm inside a xen host. By following this guide, I have managed to ping www.google.com, but it only ping-pongs twice before getting Destination Host Unreachable. If I restart the vm, I ...
0
votes
0answers
17 views

Xen - VM not reflecting memory

I am using Xen to hot-add memory to virtual machines, but it seems that I am not getting the correct vales in /proc/meminfo on the guest. As displayed below the guest has 2 GB of allocated memory. ...
1
vote
0answers
599 views

Xen hangs on boot when scrubbing RAM

I have a CentOS 5 server I can boot into the stock kernel just fine, but when I try kernel-xen, it gets stuck here: When I try adding no-bootscrub to the kernel command line, I get this and a ...
0
votes
0answers
71 views

How to recover XenServer vm's from a mdadm raid 1 HDD

I have an older server, namely, Fujitsu Siemens Primergy TX 150 S6 on witch i have installed XenServer 6.5.0-90233c. On it i have multiple virtual machines of different sizes of witch i need to ...