1
vote
1answer
41 views

Perl compatability issues when installing Git on EC2

Can anyone help me install git on one of my EC2 boxes? When I run: sudo yum install git I get: Resolving Dependencies --> Running transaction check ---> Package git.x86_64 0:1.8.2.1-1.el6 ...
0
votes
1answer
49 views

How does one get a recent version of git installed on an ec2 instance?

I can't for the life of me figure out how to get yum to install a recent version of git on an ec2 instance. yum install git installs 1.7.4.5, which is not recent enough. Surely there's some 1.8.x ...
1
vote
0answers
184 views

How to install latest Tomcat7 using yum on AWS EC2?

I'd like to install the latest (7.0.53) Tomcat on an AWS EC2 instance running Amazon Linux. If I were to do "sudo yum install tomcat7 -y", I would only get version 7.0.47, as shown by " yum list ...
0
votes
1answer
194 views

“yum update” error. How to handle this?

I have an ec2 instance and I'm trying to update all packages. But the problem is when I execute "yum update" it shows the message: Transaction Check Error: file /usr/lib64/perl5/vendor_perl/Cwd.pm ...
-1
votes
3answers
175 views

yum won't update my glibc packages

Is there any way to fix corrupted "yum"? This is what I got myself into by accidentally pressing ctrl+c while doing sudo yum update on an amazon linux EC2 instance $ sudo yum update Loaded plugins: ...
4
votes
1answer
143 views

What can I do to safely repair my yum packages after a bad update?

I'm running amazon linux on an EC2 micro box. Recently I ran sudo yum update --security in the hope that it would patch Heartbleed. Unfortunately I ran out of memory during the update process and some ...
0
votes
3answers
131 views

Yum update problems on AWS with missing requirements and duplicate sendmail

I am running an AWS VM and tried: sudo yum update Result: Error: Protected multilib versions: sendmail-8.14.4-8.12.amzn1.x86_64 != sendmail-8.14.4-7.9.amzn1.i386 You could try using ...
0
votes
1answer
170 views

Downgrade Perl 5.16 to 5.14

I carelessly did yum update on my Amazon Linux AMI and updated Perl. Now my Movable Type install doesn't work. I did some google but could not find any solution except downgrading Perl to 5.14. ...
0
votes
1answer
194 views

Yum broken in Amazon instance

This is an instance launched using Amazon AMI. when I run yum with anything (search,install, etc), this is what I am getting: yum search yum error: bad option 'archcolor' at (null):93 Loaded ...
1
vote
0answers
103 views

How to downgrade OpenSSL on Amazon EC2

I'm using a version of the Amazon Linux AMI (v 2013.03) that comes with OpenSSL 1.0.1 installed as described here: http://aws.amazon.com/amazon-linux-ami/2013.03-release-notes/. I have an application ...
3
votes
1answer
151 views

Yum won't reinstall PHP on Amazon Linux

Ultimately, this question is about Yum and the Amazon Linux AMI (see the end for that part), but first I'll give some background to how I got into my situation. I installed PHP from source I am ...
0
votes
2answers
117 views

Yum repository configuration on Amazon EC2 instance

I'm trying to install postgis on an Amazon EC2 instance, the instance is running Red Hat, and by following this tutorial: http://wiki.postgresql.org/wiki/YUM_Installation#Configure_your_YUM_repository ...
-1
votes
1answer
553 views

Amazon linux package conflict [closed]

I was trying install php55-fpm on amazon linux, but there is a package conflict with php-common. How solve this issue ? [ec2-user@ip-10-0-12-54 ~]$ sudo yum install php55-fpm Loaded plugins: ...
0
votes
1answer
90 views

Missing Package Dependency - CentOS - Amazon EC2

After running yum update --skip-broken I get the following: Packages skipped because of dependency problems: aws-cli-1.1.0-1.3.amzn1.noarch from amzn-main ...
5
votes
3answers
927 views

AWS Linux EC2: yum won't run with plugins

Short Version: yum commands on my Amazon Linux EC2 AMI only work with --noplugins. Long Version: A couple of days ago, I ran yum update at the behest of the SSH Login MoTD telling me I had updates to ...
1
vote
1answer
346 views

postgres updated from 9.1 to 9.2, required database update fails

On going from postgres 9.1 to 9.2, it says that the data bases need to be upgraded so on giving the upgrade command I give and get the following $ sudo service postgresql upgrade Stopping postgresql ...
1
vote
1answer
319 views

yum update php libjpeg dependency

I'm having a problem doing a yum update with php and it's having a dependency problem with libjpeg.so here is the yum update output: yum update Resolving Dependencies --> Running transaction ...
0
votes
3answers
302 views

Trouble Installing php-mysql from webtatic

I have a fresh instance on EC2 of "Linux/Unix, CentOS 6 | 64-bit Amazon Machine Image (AMI)" This is what I did to get it running. yum install wget wget http://repo.webtatic.com/yum/el6/latest.rpm ...
2
votes
1answer
1k views

Linux EC2 Broken Yum

I am having a very very frustrating problem with the yum command. Here's how I think it started: I am running an EC2 server. A micro EC2 server. Today, I SSH'ed into the server and found '144 ...
0
votes
1answer
231 views

Amazon EC2 Linux AMI: What is the third column of yum list installed?

Output of yum list installed, rightmost column: Most of them say installed, some say @amzn-main, and some say @amzn-updates. What is the meaning of this? It says tmux is @amzn-main, but I have ...
1
vote
2answers
925 views

SUDO YUM not found

I am running a Amazon ec2 instance on amazon's linux. Whenever I run anything sudo yum it give me this: sudo: yum: command not found ec2-user$ rpm -qf /usr/bin/yum yum-3.2.29-30.24.amzn1.noarch ...
0
votes
1answer
109 views

zlib/libxml2 duplicate package?

I've been updating my amazon ec2 micro instance every month till now. when i try to "yum update" i receive this error : zlib-1.2.5-7.11.amzn1.x86_64 has installed conflicts libxml2 < ('0', ...
1
vote
0answers
413 views

gcc46 and no c compiler found on Amazon EC2

I've been trying to install Gearman on my EC2 instance, but when I try to ./configure gearmand, I get this: checking build system type... x86_64-unknown-linux-gnu checking host system type... ...
0
votes
1answer
940 views

install openssl-devel on ec2

I am trying to install openssl-devel on a 64bit linux instance on ec2. However, when I try to install it sudo yum install openssl-devel I get this error: Error: Package: ...
0
votes
0answers
236 views

Reconfigure a yum package

I'm running an Amazon linux AMI and using sendmail as the mail server. By default, STARTTLS is disabled on this build and I'd like to enable it for SMTP and POP3. I seem to have it configured ...
1
vote
2answers
3k views

yum not working on EC2 Red Hat instance: Cannot retrieve repository metadata

For some reason yum has stopped working in my Amazon EC2 instance, located in the EU West sector. There seems to be something wrong with the path of the repo metadata, is this correct? I would be very ...
1
vote
2answers
257 views

upgrade to nginx 1.0 on Amazon Linux EC2 Instance

I've noticed that the official Amazon repos only host nginx 0.8 which is now considered a legacy release. Short of manually compiling from source what must I do to upgrade to the stable 1.0 version of ...
0
votes
2answers
9k views

How to install gedit using yum

I'm trying to install gedit on an Amazon EC2 instance running Redhat 4.4.4-13. I thought it would be as easy as sudo yum install gedit But that just gives me: Loaded plugins: fastestmirror, ...
1
vote
2answers
909 views

Building nginx 1.0.4 on Amazon EC2 micro - perl and python problems

I'd like to run nginx as a reverse proxy with apache2 on my EC2 micro instance. yum install nginx gives me nginx-0.8.53-1.2.amzn1.x86_64.rpm The current nginx is 1.0.4 I found and followed this ...
0
votes
1answer
308 views

how do I install scripts like pg_lsclusters on a Amazon AWS Linux AMI

I am used to debian/ubuntu distros and now trying to experiment with the official Amazon AWS Linux AMI. I have installed postgresql-server, postgresql-devel, postgresql-contrib yum packages. The ...
1
vote
1answer
1k views

Can't install mongodb via 10gen.repo on Amazon 64bit AMI

Following the instructions here: http://www.mongodb.org/display/DOCS/CentOS+and+Fedora+Packages Can't really decipher what I should be doing...broke down and just got the linux binary but I want yum ...
1
vote
2answers
983 views

Broken yum package tree

I tried to update OS on my EC2 instance using yum update but I get the following error: Loaded plugins: fastestmirror, security Loading mirror speeds from cached hostfile * epel: ...