1
vote
2answers
87 views

error installing mysql client after installing remi php-mysql

after installing nginx with php-fpm thanks to remi repository, I get an error when I simply install mysql client : yum install mysql give me the following result (see bellow). Loaded plugins: ...
4
votes
1answer
313 views

Why do I get different openssl versions?

I'm trying to check if I running the latest OpenSSL version, my main concern is the heartbleed bug. I tried 2 commands: openssl version yum info openssl openssl version output OpenSSL ...
0
votes
1answer
149 views

postfix failed to start CentOS 6.5

DISCLAIMER: I am new to CentOS, so please forgive me if I overlooked something simple. Here is my issue: I recently just reformatted my server to CentOS 6.5 x64 and I have been having issues getting ...
0
votes
0answers
12 views

CentOS 6.3 can't find libssl.so.1.0.0 after update OpenSSL to 1.0.1e [duplicate]

I've upgraded OpenSSL from 1.0.0 to 1.0.1e in CentOS 6.3 as a dependency to PHP-FPM package. Now php and yum don't work anymore, displaying: PHP: php: error while loading shared libraries: ...
0
votes
1answer
189 views

Yum repo priorities and conflicts

On my CentOS 6.4 server, I am running MySQL 5.5.33 that I installed from the remi repository. I decided to upgrade MySQL to 5.6.x via MySQL's own yum repositories: ...
2
votes
1answer
974 views

CentOS yum *.rpm package changelog (not installation changelog)

I just logged into my new rented server and updated openssl because of the heartbleed-bug (http://heartbleed.com). I updated using yum list openssl ... Installed Packages openssl.x86_64 ...
0
votes
0answers
10 views

centos 6.4 PHP 5.5 installation dependency errors [duplicate]

I'm trying to install php 5.5 via the remi repositiory but i'm getting dependency errors such as: Error: Package: mysql-5.5.36-1.el6.remi.x86_64 (remi) Requires: libssl.so.10(libssl.so.10)(64bit) ...
1
vote
1answer
128 views

how to install python-elementtree on CentOS 6.5?

How to install python-elementtree on CentOS 6.5 using yum? I need it for s3cmd, but their documentation page doesn't explain it.
-1
votes
1answer
81 views

How to install pip and other specific python modules onto a CentOS server that is air-gapped from the internet?

Ultimately, I'm trying to install SaltStack on a super computer that has no internet connection. And I'm not allowed to hook it to the internet. So far, I have installed an entire yum repo on the ...
1
vote
2answers
592 views

Yum Update Issue

Not sure if I should asking this here but am quite stuck at the moment. I wouldn't be the best on Linux but can get around. My issue is with Yum update on my CentOS 6.3 x64 system. Basically for ...
0
votes
1answer
91 views

openvz / centos 6 vps yum failing with error

Installed new openvz container with centos 6.4 64bit Resolving Dependencies --> Running transaction check ---> Package kernel.x86_64 0:2.6.32-431.el6 will be installed --> Processing ...
0
votes
1answer
37 views

What does proxy in yum repo do?

Referring to http://www.centos.org/docs/5/html/yum/sn-yum-proxy-server.html, What does the option do? Can it substitute the base URL by providing a local URL instead? That way I can access a local ...
1
vote
4answers
209 views

How do I uninstall `php` that's not found in `yum list` or `rpm -qa`?

I have a rogue php install somewhere on my server that I'd like to remove and stick with pure yum installs. How can I find and uninstall this rogue php install? yum and rpm searches both come up ...
0
votes
1answer
257 views

why does yum update fail in cent os 6.4 when wget and curl succeeds

I am using Cent OS 6.4 in a corporate lab and the yum update fails with the below error: I am able to access the same repositories through browser. [root@LAB1 ~]# yum update Loaded plugins: ...
0
votes
1answer
690 views

CentOS 6 LEMP update - dependency error issue

I have setup a LEMP server following the guide Install Nginx/PHP-FPM on Fedora 20/19, CentOS/RHEL 6.5/5.10. It's been a while since I did the setup, so I wanted to grab the latest updates from REMI ...
1
vote
2answers
515 views

CentOS 6 missing dependencies for default PHP

I have a brand new Dedi install of CentOS 6 x86_64, nothing has been done to it but install rpmforge and htop. Other than that we are default, well as default as GoDaddy gives which is garbage ha ha. ...
2
votes
3answers
177 views

Centos: How to install all packages of one server on another?

I've done rpm -qa > file and now I want to copy the file to another server and run through it and install all these packages on the new server. I did something like this: for pkg incat file; do yum ...
1
vote
1answer
185 views

yum update fails to unpack archives for nodejs dependencies on centos 6.4

I run "yum update" on my CentOS 6.4, but the Node.js package and dependencies fail with multiple errors like this: Error unpacking rpm package nodejs-fstream-0.1.23-1.el6.noarch error: unpacking of ...
1
vote
1answer
93 views

Self compiled Perl package Centos [duplicate]

I have a Centos 6 server.. I have compiled Perl 5.16 in it (in a non-standard location). Now when I try to install Some package which is dependent on Perl using yum.. Yum tries to install Perl ...
0
votes
1answer
138 views

yum and rpm nothing happens

I am experiencing an odd problem in CentOS 6. when I try to use yum or rpm nothing happens. For example if I type yum update it simply returns to the command prompt. I have checked that yum and ...
1
vote
4answers
125 views

Good pratices to update servers? [closed]

I have many servers running CentOS 5.* and CentOS 6.*, I would like to update them, but there's some applications running and I might crash these applications, which led me to write this post with ...
-2
votes
4answers
731 views

cannot use any yum command: no space left on device

if i use any yum command, i get Loaded plugins: fastestmirror Traceback (most recent call last): File "/usr/bin/yum", line 29, in <module> yummain.user_main(sys.argv[1:], exit_code=True) ...
1
vote
1answer
467 views

yum not showing any updated package

I have a CentOS 6.3 machine. I'm running yum update but it doesn't show any updated package. I have already tried yum clean all and yum clean expire-cache. Any help will be really appreciated. ...
0
votes
0answers
582 views

Unable to update/download packages from yum

I've installed a fresh new installation of CentOS 6.3 . The only things I've configured are: NICs: /etc/sysconfig/network-scripts/ifcfg-eth0 and 1 and DNS: /etc/resolve.conf (nameserver 8.8.8.8) When ...
3
votes
2answers
156 views

Yum update notification when logging on to CentOS server remotely

I have 3 CentOS 6.3 Virtual Servers that I manage. I have them all set-up and configured, but am notoriously bad with remembering to run yum update on them from time to time. Is there anyway that I ...
0
votes
1answer
154 views

php-soap 5.3.17-2 el6 x86_64

I just transferred a website to a server where I appear to lack the PHP-SOAP extension. Unfortunately I cannot upgrade to the 5.4.10 that is available on remi at the moment as I am not 100% sure if ...
2
votes
2answers
1k views

rpmbuild on CentOS 6.3 64-bit - broken dependencies

I'm trying to build a package using rpmbuild on 64-bit CentOS 6.3 server. Here is the spec file: Name: test-fms Version: 1.0 Release: 1%{?dist} Summary: my FMS Package ...
15
votes
3answers
27k views

How do I upgrade to the latest PHP version in CentOS with yum?

I found some blog posts about this, but it's rather lack of descriptions on possible side effects. I could really use some detailed on these steps: How to add a repo that provides PHP 5.4 into yum ...
2
votes
1answer
695 views

Centos 6, local yum repo, and multiple versions of the same rpm

I'm trying to set up a really simple local repo. I want to have a basic repo with two versions of only one rpm, so I did: mkdir /packages/x64 copy two rpms to /packages/x64 [root@repo x64]# ...
0
votes
1answer
367 views

Is this an OK way to install Apache with SSL on CentOS 6?

I'm setting up a CentOS 6 server on a VPS. I've worked with Apache before, but I've never dealt with CentOS 6. I guess it would just be this right? sudo yum install httpd -y sudo yum install mod_ssl ...
0
votes
2answers
601 views

howto remove udev from centos(lxc-guest) without dependencies

i downloaded a openvz template for my lxc server to create a new centos 6.3 guest. Now the guest is not starting because udev is hanging in the boot process. Last time i didn't had this problem but ...
2
votes
2answers
1k views

Installing lighttpd on CentOS 6.3 yum 404 errors

I have a CentOS 6.3 x86_64 server and I am trying to install lighttpd. I have installed the EPEL repo on the server using the following: rpm -Uvh ...
0
votes
1answer
461 views

Centos/RHEL 6: 32bit PHP package on 64bit architecture

How can I install the i686 php package on an x86_64 architecture?
0
votes
2answers
594 views

yum command not loading packages from custom .repo file on CentOS 6

I added a this .repo file in /etc/yum.repos.d/ on CentOS 6. Then when I try to install package from this repo I do not see the mirrors loaded from this repo. Output of yum repolist is Loaded ...
5
votes
4answers
10k views

Munin on Centos 6 - missing perl MODULE_COMPAT_5.8.8

I'm trying to install Munin on a new VPS through yum install munin but I keep getting an error about a missing perl module: Requires: perl(:MODULE_COMPAT_5.8.8). This is the perl version currently ...
4
votes
2answers
5k views

CentOS install proftpd with yum

Server: CentOS 6.2 64bit How can I install Proftpd using yum? A search for the package doesn't find it: yum list proftpd Error: No matching Packages to list Although my CentOS 6 VPS does find it, ...
1
vote
3answers
5k views

Apache 2.4 Package

Does anyone know where I can get a apache 2.4 package for centos 5/6? When i run yum upgrade httpd it returns with version: 2.2.3-53.el5.centos I have these repo lists installed: base ...
1
vote
1answer
470 views

installing dkms fails to work

I would like to install dkms to install the VBGuessAdditions but yum install dkms always results in an error loaded pluggins: fastestmirror, refresh-packagekit, security Loading mirror ...
0
votes
2answers
2k views

On CentOS how do I get boost header files installed?

What CentOS 6 package name do I need to install boost header files: yum install boost doesn't seem to work. Is there a special compiler directive I need to use to point to the include files? Or is ...
12
votes
2answers
11k views

What does that mean: packages excluded due to repository priority protections

When updating with yum i recieve the following message: yum update Loaded plugins: fastestmirror, priorities Loading mirror speeds from cached hostfile * atomic: www7.atomicorp.com * base: ...
5
votes
3answers
9k views

Howto install php 5.2.17 on centos 6 x86_64

Does anyone know how to install php 5.2.17 on a 64bit centos 6 install? I've got a old legacy system that requires php 5.2.17, but centos 6 only supports php 5.3. I've installed repo's such as ...
0
votes
1answer
3k views

CentOS6 and PostgreSQL-YUM, (Error: Cannot retrieve repository metadata (repomd.xml) for repository: pgdg90. Please verify its path and try again)

I'm using CentOS 6. I need to configure my YUM to have access to the PostgreSQL repository, but I'm getting an error. I've followed this guide: ...