1
vote
2answers
151 views

error installing mysql client after installing remi php-mysql

after installing nginx with php-fpm thanks to remi repository, I get an error when I simply install mysql client : yum install mysql give me the following result (see bellow). Loaded plugins: ...
0
votes
1answer
50 views

yum update MemoryError 1G memory free

I am trying to do yum update and getting "MemoryError". The server (OpenVZ box) has 2G RAM and Percona MySQL server running with 1G InnoDB buffer configured. The OS is CentOS 6.5, kernel ...
0
votes
1answer
145 views

Plesk error when adding a subscription: ODBC error #08S01 can't connect to local MySQL

I'm getting this error after updating MySQL to 5.6 (Plesk 11.5, fresh installation) using the official MySQL repository right after adding a new subscription. Internal error: ODBC error #08S01: ...
6
votes
2answers
3k views

Installing a third party application package on CentOS 6.4 fails due to missing dependencies libcrypto.so.10 and libssl.so.10

This is a Canonical Question about OpenSSL binary compatibility issues between Red Hat Enterprise Linux (and its derivatives) 6.4 and 6.5. This issue applies to a wide variety of third party ...
0
votes
2answers
1k views

How to install MariaDB rpms in CentOS 6.4 using rpm (not yum cmd) + handling mysql-libs conflicts

I need to script the install of MariaDB using the rpm command in CentOS 6.4. I can't use yum since it's going to be an offline install so there's no access to the repository. The only MySQL package ...
1
vote
3answers
2k views

Not able to install mysql/mysql-server with yum in Centos 6.4 64bit

It worked initially (yum install mysql mysql-server), and now it won't. I removed the working mysql from the repo with yum remove mysql mysql-server and tried to install from rpm source from the ...
1
vote
1answer
174 views

AWS Amazon Linux MySQL Yum Update Failure

I SSH'd into my AWS EC2 instance using an Amazon Linux AMI, and it told me to run the sudo yum update command for security updates. When I did, it ultimately failed to update MySQL. *I don't know if ...
0
votes
3answers
916 views

newer libmysqlclient.so creates a conflicts with a php-mysql install

I have a working MySQL 5.6 server on a CentOS 6.4 I'm trying tp get PHP working as well, and to create a connection to the MySQL. As I understand I need the following components : php and php-mysql ...
0
votes
1answer
762 views

Installing mysql-devel to match MySQL version

I'm running MySQL 5.1.52 on CentOS 4.6 and I'm trying to install mysql-devel to match my MySQL version. If I do yum install mysql-devel it wants to upgrade MySQL to 5.1.58, yet if I do yum search ...
-1
votes
1answer
122 views

Solving mysql 2003 error

Hi I've just created my new linux server and have yum installed various modules which all seem to be working ok now. My trouble comes from mysql. It's installed and running but when I and connect from ...
1
vote
2answers
3k views

Upgrading MySQL 5.5 to 5.6

I've decided to do the update of MySQL from 5.5 to 5.6 on my CentOS server. How can I backup MySQL5.5 in case I want to downgrade, and how can I install MySQL 5.6? Is there a way to use yum for ...
0
votes
1answer
766 views

RHEL 6.3 Mysql Install

I am attempting to install mysql on a server. It's a fresh install of RHEL 6.3. Yet, when I run 'yum install mysql mysql-server, I get the following messages. Loaded plugins: product-id, security, ...
2
votes
2answers
1k views

Upgrade mysql version

I am trying to upgrade mysql package to 5.5 on centos. (amazon image - ami-cc5af9a5) There is 5.1 version of mysql-libs that can not be uninstalled because postfix is dependent upon it. But I can not ...
4
votes
1answer
361 views

/var/lib/mysql folder is missing

I've created a virtual machine and am installing things from scratch. Definitely not a sys admin so I'm running into some trouble. I've installed these packages and then restarted httpd yum -y ...
1
vote
1answer
269 views

mysql libs conflict with with mysql client

I am trying to get redmine up and running and its not been going well. Currently I am trying to install the required package mysql-devel and getting the error: Transaction Check Error: file ...
1
vote
1answer
835 views

Yum issues after upgrading MySQL from 5.0 to 5.5 on RHEL

I'm running RHEL 5.6 and trying to upgrade MySQL from 5.0 to 5.5. I ran sudo yum remove mysql* to remove all the existing MySQL-related packages. Then I installed MySQL 5.5 packages: $ sudo yum ...
1
vote
1answer
3k views

How to install mysqlnd for php 5.3.3 on Centos 6.2

I have just down graded my PHP-installation from 5.3.9 to 5.3.3. This in order to be able to use yum/EPEL instead of compiling everything myself. Appearently, mysqlnd-support isn't available in ...
1
vote
2answers
4k views

yum install mysql-server.x86_64 - Transaction Check Errors

I think yum is having problems installing MySQL 5.1 because there is already a pre-existing MySQL 5.5 installation. I wanted to cleanly remove MySQL 5.5 (I had problems with 5.5 with PHP and Python). ...
0
votes
1answer
87 views

Error in Fedora 9 while installing MySQL 5.5.20 using “YUM” Command

I am trying to install the latest version of MySQL server on a Fedora 9 machine. When I run the command yum --enablerepo=remi list mysql mysql-server, I get the error: Loaded plugins: ...
6
votes
3answers
7k views

Why are outdated packages installed by yum on CentOS? (specifically PHP 5.1) How to fix?

I'm working on a fresh CentOS server and am extremely annoyed to find out that yum does not work as smoothly and brilliantly as "apt-get install" does on Ubuntu. Installing a LAMP stack, I ran the ...
0
votes
3answers
2k views

Installing MySQL on CentOS

I have set up a nginx server running php-fpm and everything is working great. PHP is compiled with the mysql and mysqli extensions, but I'm having trouble installing MySQL. I did this command: yum ...
0
votes
2answers
359 views

Failed Dependency: libmysqlclient.so.15 as part of Sphinx Install

I'm running CentOS 5.7 and trying to install Sphinx Search but keep receiving missing dependency errors. $ yum install sphinx ... Error: Missing Dependency: libmysqlclient.so.15 is needed by package ...
1
vote
1answer
1k views

How to install Mysql 5.1 on Fedora 16

I can't seem to install MySQL 5.1 on Fedora 16. When I try to install an RPM downloaded from the MySQL website I get conflict errors with the existing 5.5 packages which I have already 'removed' via ...
2
votes
2answers
2k views

Can't install PHP and MySQL on CentOS 5 64 Bits

I'm getting the following error when trying to install PHP and MySQL form the atomicorp.com repository: [root@x171 ~]# yum -y install mysql-libs php php-gd gd mysql mysql-server mysql-devel ...
1
vote
1answer
136 views

Cent OS. Removed yum packages with apt-get. Server at work is down

I ran: sudo apt-get --fix-broken install and ended up removing: MySQL-client (5.0.92-0.glibc23) MySQL-server (5.0.92-0.glibc23) bandmin (1.6.1-1_newinit) exim (4.69-30_cpanel_maildir) mdadm ...
0
votes
2answers
404 views

CentOS/yum - Upgrading php 5.1 -> 5.3 without upgrading mysql 5.0 -> 5.1

I'm attempting to upgrade php from the centos default of 5.1.6 to 5.3.8 out of the Atomic repo, but when doing so, yum wants mysql to upgrade from 5.0 to 5.1, saying that php-mysql-5.3.8-1.el5 is ...
1
vote
3answers
1k views

Can I update MySQL through YUM repository without data loss/corruption? Should I be nervous?

I do not have much experience with upgrading software on a Linux system but am of course familiar with 'yum update' commands. I am currently running a Media Temple DV 3.5 CentOS 5 server with MySQL ...
1
vote
2answers
10k views

How to clean up mysql installation on centos

mysql does not exist anymore but when i run yum remove mysql it says that the package is available but not marked for installation, i cannot install new mysql because of that, I need to completely ...
0
votes
1answer
378 views

upgrading php extension

Since I upgraded from 5.0 version to 5.5 I am getting the following error on my PHP page. None of the supported PHP extensions (MySQLi, MySQL, PDO_MySQL) are available. When I tried to install ...
0
votes
2answers
2k views

How to install specific version of MySQL?

I installed from the repo, 5.0.77... including setup of PowerDNS (and the backend for MySQL). I tried setting up replication from my Master (which is MySQL 5.1.53) but it didn't work even though there ...
0
votes
1answer
169 views

Error after running yum update mysql

I have a redhat linux server. I ran yum update mysql and it worked fine. The problem is that when I went to phpMyAdmin all of the databases were deleted. So I used "import" to import the database ...
0
votes
3answers
803 views

Remi Repo Mysql Server Not Starting

Executing the command to start the mysql service fails to start the mysql server. [root@localhost]# service mysqld restart Stopping mysqld: [ OK ] MySQL ...
0
votes
1answer
777 views

Yum failing “Transaction Check” when updating

I'm trying to update my Cent OS 5.2 system using yum. But I've been getting this error: Transaction Check Error: file /usr/share/man/man1/pcregrep.1.gz from install of pcre-8.02-1.jason.1.x86_64 ...
-1
votes
2answers
1k views

update mysql latest version from yum

I want to update mysql in my VPS from yum. However I only got 5.0.9 mysql version Which repository should I add to get mysql latest version. at least 5.1? (CentOS) Thank you
0
votes
2answers
3k views

MySQL Daemon failed to start

There were no updates when I ran yum update. I was trying to install php-soap (which was failing), and online I found I should run this: wget -q -O - http://www.atomicorp.com/installers/atomic.sh |sh ...
1
vote
1answer
2k views

Problems installing MySQL-python via yum / missing dependency / incompatibility problem?

I have come up against problems installing MySQL-python via yum. Our server is running Centos 5.5 and MySQL Version 5.1.45, Python-dev is installed. Yum complains about the missing dependency ...
2
votes
2answers
124 views

How can the applications get upgraded if they were not installed using yum?

On the VPS (CentOS), after running the following commands, [root@yukiko local]# pwd /usr/local [root@yukiko local]# ls Zend apache bin etc games include lib lib64 libexec man mysql php ...