4
votes
2answers
210 views

Using puppet and ensure latest for RPM package management

Using ensure => latest, I have systems which do not need all of the same packages. Will ensure => latest install the packages or only update if they already are present? If they are not ...
1
vote
1answer
75 views

puppet: how to submit command “yum update” to all agents?

I'm new to puppet and trying to create manifest which will request all agents to update all currently installed yum packages. What should be the best way to describe this in manifest?
6
votes
1answer
379 views

Puppet package “ensure => latest” doesn't always work

I have a unique situation where the Puppet package ensure => latest directive only worked on some of my systems. Out of 30 servers, the packages updated properly on all but 4. I'm trying to get ...
12
votes
3answers
383 views

Notified when a file controlled by puppet is going to be changed by yum

Is it possible to receive a notification on the console when a package containing a file that is controlled by puppet is about to change that file? Meaning, in yum when doing yum update, is it ...
1
vote
2answers
443 views

Pass --nogpgcheck to yum via puppet

How would one get a --nogpgcheck option to yum via puppet? I've tried package { 'unsigned-package': ensure => latest, install_options => ['--nogpgcheck'], } and package { ...
0
votes
1answer
169 views

Automating Unbreakable Linux Network (ULN) registration

To register a RHEL 6.4 machine to the Unbreakable Linux Network (ULN), it is required to launch the uln_register command. This command opens a textual interface, where the user has to input the ULN ...
1
vote
1answer
82 views

Remove old puppet repo configuration

I want to consolidate my repository into a new repository structure and I have this working in Puppet. However, the old yum repository information still remains on the nodes. Can puppet force the ...
1
vote
1answer
683 views

Puppet error on already installed package on centos

I am using puppet on CentOS for the first time. I have the following in one of my .pp files: package {"openjdk-6-jdk": ensure => installed, } Which generates the following error when ...
2
votes
1answer
306 views

Puppet package installation on Linux/CentOS

I am new to Puppet - I have been playing around learning the basics. Most of the examples ( except the very basic ones ) that are on the puppet page do not work for me - either some dependency is ...
7
votes
3answers
627 views

Specifying a source in puppet doesn't seem to work

I have been attempting to create a manifest for installing postgres 9.1 using puppet on a Centos 5 server. I have been trying to adapt the instructions at ...
0
votes
1answer
925 views

Puppet yum repo - Pull down 2.7.x vs 3.0.x

So a few weeks ago I started on the path to using puppet to automate all the configs/services. At the time I was using the EPEL repo, which installed version 2.6.x. After some reading I was trying to ...
4
votes
2answers
440 views

How can I tell Puppet “If I declare class X, apply its resources before class Y”?

In my Puppet configuration I want to say "If I declare class X, apply its resources before class Y." In other words, I want to declare an ordering, but remain silent about whether or not to apply ...
-1
votes
1answer
650 views

How to install puppet devel version from yum?

In /etc/yum.repos.d/puppet.repo have I put [puppetlabs] name=Puppet Labs Packages baseurl=http://yum.puppetlabs.com/el/$releasever/devel/$basearch/ enabled=1 gpgcheck=1 ...
0
votes
1answer
200 views

createrepo fails with os.getcwd

i'm starting to use puppet. i wanted to have my own yum repository to serve puppet server so i issued yum install createrepo no errors reported (cenotos 5.5) after that i issued createrepo ...
9
votes
4answers
2k views

Best practice for automated Linux updates

We are working on a way to perform automatic updates for our RHEL/RHEL-based servers. Initial idea: Using Puppet, we disable the default repositories and point to our own. Then, we use ensure => ...
1
vote
2answers
2k views

Adding a yum repo with puppet - Error 400 on SERVER: Invalid parameter enable at curly bracket?

I'm trying to automate some tasks when receiving a new server. The first thing is adding some yum repos. My /etc/puppet/modules/repo/manifests/init.pp: 1 class repo { 2 file { ...
0
votes
2answers
655 views

Puppet - Update packages on repo installation

I am attempting to have puppet (0.25.5-1.el5) update an already installed package when a new yum repo gets installed. The basic image we have has package X installed at version 1.1 by default. In ...
8
votes
5answers
5k views

How do I install a yum package group with puppet?

Does puppet have a way to install a yum package group (e.g. 'Development Tools'), besides exec?