1
vote
1answer
24 views

Create yum variable, that is the result of a command?

To clarify, I am looking on how to store a yum variable as the RESULT of a command. The command I use to get the OS version is irrelevant to me, I'm sure there are better ways of getting it than what ...
0
votes
1answer
27 views

Spacewalk (satellite) activation refresh child channels on client

We have a (spacewalk) rhn satellite server running and several hundred machines registered with it with a few activation keys. Each of these keys have one or more child channels. We need to know how ...
0
votes
1answer
44 views

“yum groupinstall” i686 packages on x64?

I'm working on enabling x64 host build workers to build i686 RPMs, now that AWS EC2 (which we use to run build workers) is deprecating i386 nodes like m1.medium in favour of x64-only instance types ...
0
votes
1answer
70 views

RESOLVED: yum says mod_cluster is installed, but the files are not there

RHEL 6.5 + JBoss EAP 6. I installed JBoss EAP 6 from the RHEL repos using grouinstall: # yum groupinstall "JBoss EAP 6" This seems to have worked fine except that the files for mod_cluster are not ...
1
vote
1answer
35 views

YUM installs outdated software

I recently acquired a red hat server that runs RHEL 5.5. I get a feeling that my YUM repositories are totally out of date because of the following reasons: I tried updating GCC using YUM. The ...
0
votes
0answers
99 views

Yum does not install specific RPM version with custom repo

We use RPMS for our packaging and yum to update our environments. We have an rpm package-5.1.1-3 installed in our production server and in our yum repository we have 2 newer versions such as ...
4
votes
2answers
200 views

Switching yum from RHEL to .. something else? [duplicate]

My various managers have decided that it's too expensive to keep paying for a subscription to the RedHat network for OS updates. Is it possible to switch to Fedora/CentOS or do I need to reinstall the ...
2
votes
1answer
107 views

yum client doesn't see new packages though server is updated

We have an internal yum server containing several repos (copies of the RHEL repo, programs created in-house, and so on). Our internal systems are firewalled off from the internet, so they can only use ...
2
votes
2answers
38 views

YUM, “patchlevel” and the DTAP street on redhat/centos

Is there a way to make yum update to a certain patchlevel? I always promise my devs the servers between Dev, Test, Acc and Prod are the same with versions of software. But when u use yum via the ...
7
votes
2answers
376 views

How can I mirror a yum repository but download only the newest versions of each package?

I would like to mirror the following Yum/RPM repositories at http://yum.puppetlabs.com/ : http://yum.puppetlabs.com/el/6/products/ http://yum.puppetlabs.com/el/6/dependencies/ ...
0
votes
3answers
186 views

Yum update problems on AWS with missing requirements and duplicate sendmail

I am running an AWS VM and tried: sudo yum update Result: Error: Protected multilib versions: sendmail-8.14.4-8.12.amzn1.x86_64 != sendmail-8.14.4-7.9.amzn1.i386 You could try using ...
2
votes
1answer
1k views

CentOS yum *.rpm package changelog (not installation changelog)

I just logged into my new rented server and updated openssl because of the heartbleed-bug (http://heartbleed.com). I updated using yum list openssl ... Installed Packages openssl.x86_64 ...
0
votes
2answers
211 views

Using `repomirror` to mirror a yum repository for a different OS version?

I have an EL5 machine. On this host I would like to mirror a Puppet repository for EL6 rpms. How can I mirror an EL6 or Fedora repository on an EL5 host? I am using reposync because I only need the ...
1
vote
2answers
36 views

Will redhat yum see packages installed with rpm? [closed]

Or if not, is there a way to make yum be aware of them? Does 'rpm -qa' and 'yum list installed' query the same source?
1
vote
1answer
293 views

yum install throwing error 403 when trying to install from rhel-x86_64-server-6

To preface this, I don't have much Red Hat experience. Most of my experience is with Ubuntu. The server I'm working on right now is running Red Hat Enterprise 6.5. I'm trying to do a simple yum ...
1
vote
2answers
229 views

Installing perl-Time-HiRes on RHEL6.2 gives perl dependency error

I get the following when trying to install perl-Time-HiRes: host1:user1 > sudo yum install perl-Time-HiRes Loaded plugins: product-id, security, subscription-manager This system is not registered ...
0
votes
1answer
119 views

Prevent reboot after yum update

I would like to know how to stop the system from rebooting after running a yum update. I use a script on each system which runs daily yum updates through cron and if an uodate is critical enough (for ...
1
vote
1answer
226 views

How to register RH 6.5 in order to use yum (behind http proxy)

I registered my RH 6.5 machines using subscription-manager. Yum is not working. I'm behind http proxy so I added proxy=http://x.x.x.x:3128 into /etc/yum.conf. But still yum installations fail: yum ...
2
votes
1answer
65 views

Upgrading packages over a large amount of servers

I have a large amount of CentOS servers that I need to periodically upgrade packages on. How can I combine automated upgrades but still retain control? Some of my issues with fully automated ...
0
votes
0answers
105 views

How can I view CentOS update RPM security metadata?

I'm interested in getting useful output from the commands on this page while using CentOS: http://www.cyberciti.biz/faq/redhat-fedora-centos-linux-yum-installs-security-updates/ By default, it seems ...
0
votes
2answers
1k views

Install Tomcat7 on EC2

I'm trying to install Tomcat7 on an Amazon EC2 instance, but it doesn't work. Below is the console output: [ec2-user@ip-XXX ~]$ sudo yum install tomcat7 Loaded plugins: amazon-id, rhui-lb, security ...
3
votes
2answers
153 views

Why does `rpm` show 3 httpd packages, and which one provides the real httpd?

I ran yum update on my CentOS5 webserver a few days ago. Today I just noticed that I have 3 httpd-* rpms! How can I end up with three RPMs for httpd (My other servers only have one httpd rpm). I want ...
-2
votes
1answer
670 views

installing tor on redhat/centos server

i want to install tor package on my centOS server here is the output of cat /proc/version : Linux version 2.6.32-358.18.1.el6.x86_64 (mockbuild@c6b10.bsys.dev.centos.org) (gcc version 4.4.7 20120313 ...
-1
votes
2answers
312 views

Red Hat Software Collections 1 Beta channel has 0 packages?

I want to install PHP 5.4 on a RHEL 6.x box as described in this Red Hat blog post. I have a valid subscription and have added the channel, but a yum repolist shows a status of 0 for the channel. ...
1
vote
1answer
548 views

I'm getting “yum error no such table packages”, how do I fix corrupted db?

I'm trying to use following guide: Scientific Linux - How To Upgrade To The Latest S.L. 6.x Release to update my Scientific Linux release 6.3 to Scientific Linux release 6.4. # yum update ...
2
votes
2answers
159 views

Why must yum update its repos on each command?

Doing anything with yum is frustratingly slow for me. For example, when searching for a package, finding it, and then trying to install it, both yum commands appear to run the exact same updates, just ...
0
votes
1answer
209 views

Automating Unbreakable Linux Network (ULN) registration

To register a RHEL 6.4 machine to the Unbreakable Linux Network (ULN), it is required to launch the uln_register command. This command opens a textual interface, where the user has to input the ULN ...
2
votes
1answer
105 views

yum and command line field

I'm reading the official documentation of Red Hat 6 (Deployment Guide) where in chapter 6 about yum they use the following command to show transactions: yum history info (id) this command should ...
2
votes
2answers
92 views

Fresh Red Hat 6.4 kickstarts out-of-date

I am using an updated rhel-x86_64-server-6.4 channel to kickstart RHEL 6.4. What can explain servers being kickstarted with an out-of-date RHEL? I would like to kickstart the server with the latest ...
1
vote
3answers
661 views

EPEL broken package : How do I reach to EPEL maintainer?

.. it looks like at least two of packages that comes from EPEL is broken: [alexus@wcmisdlin02 ~]$ sudo yum update --skip-broken Loaded plugins: refresh-packagekit, security Setting up Update Process ...
0
votes
1answer
123 views

Having trouble installing php_mbstring on CentOS system

So the new CentOS VPS didn't come with mbstring enabled. Easy enough, right? I typed 'yum install php-mbstring' It then says "Error: Nothing to do." The only thing I can figure is that I'm missing ...
1
vote
1answer
46 views

Long term security risks of rarely updated nginx

We've deployed a system at a university using a stack of Postgres, Nginx and Django on (mandated) RHEL. The ITS department is now pressuring us to switch to Apache on order to benefit from regular ...
2
votes
2answers
303 views

Checking yum connectivity from a script?

When there is a problem with access to yum repos (for example if a needed proxy isn't configured), running a command like 'yum update' will wait for a very long time trying lots of different mirrors. ...
0
votes
1answer
42 views

yum update if installed, otherwise install

Is there a command to do just that: if a package is already installed, update it, otherwise install the latest version For now I'm doing two commands: yum install mypackage yum update mypackage ...
0
votes
2answers
171 views

red hat enterprise 6.3 repository for yum via internet

I have installed a red hat enterprise 6.3 from scratch. The machine is surely connected to internet. When I do yum repolist I got 0. As far as I understood this happens because I didn't activated my ...
1
vote
0answers
160 views

Cobbler import of RHEL6 DVD doesn't seem to create yum repo

I setup cobbler (2.4.0) and imported the RHEL6.4 DVD. It copies all of the packages over to /var/www/cobbler/ks_mirror/RHEL6.4-x86_64. It even runs createrepo and loads the metadata, etc. So you ...
1
vote
1answer
391 views

postgres updated from 9.1 to 9.2, required database update fails

On going from postgres 9.1 to 9.2, it says that the data bases need to be upgraded so on giving the upgrade command I give and get the following $ sudo service postgresql upgrade Stopping postgresql ...
0
votes
2answers
117 views

Any good yum repository management dashboards?

I'm currently managing hundreds of CentOS/Amazon Linux servers, and our homegrown tools for managing the myriad package versions seems inadequate and unnecessary. What I'm looking for is a tool that ...
1
vote
1answer
378 views

Repo via reposync creates Packages dir

I am using /usr/bin/reposync --arch=x86_64 --repoid=rhel-6-server-rpms --download_path=/data/repos --plugins --downloadcomps It creates /data/repos/rhel-6-server-rpms and downloads the packages in ...
1
vote
3answers
375 views

RHEL/CentOS version numbering (before and after the dot)

How does the CentOS numbering work? Major releases are 'before the dot', eg 5.x and 6.x as far as I see, and minor changes after that. Questions: If I do a yum update on a 6.1 system, will it ...
1
vote
1answer
169 views

RPM packages with dependencies based on a major version of software (i.e php 5.3 with it's addons and then php 5.4)

Scenario: PHP5.3 php-5.3.21-1_x86_64.rpm (base) php-pecl-memcache-3.0.6-1_x86_64.rpm (dependant on above because of the internal PHP ABI version change) PHP5.4 php-5.4.13-1_x86_64.rpm (base) ...
1
vote
3answers
7k views

Setting RHEL default yum repositories

I've been tasked with setting up PHP on a RHEL 6 server. running yum install php gives me the following output: Loaded plugins: product-id, refresh-packagekit, security, subscription-manager ...
4
votes
3answers
1k views

Update Red Hat Enterprise Linux's Packages Only To Specific Point Release

Let's say that I have one RHEL6.2 64bit server running. Current latest version available is 6.4. Running "yum update" will update my server up to 6.4 straight away. What if I want to update only to ...
18
votes
2answers
664 views

Best Practices for updating a previously unmaintained server RHEL5.7

A new RedHat EL5.6 server has been recently put under my care. It is immediately obvious that, for the previous 12 months, little to no attention has been given to any sort of package updates. ...
1
vote
1answer
2k views

Postgresql unrecognized, even though it's installed

Postgresql 8.4 seems to be installed properly, according to this: sudo yum install postgresql Loaded plugins: product-id, refresh-packagekit, rhnplugin, security, subscription-manager This system ...
6
votes
1answer
271 views

How to make a RHEL repo static for a specific release

I have been working with CentOS for quite a while now and i got used to the way the repos are managed. Recently a new proprietary app required the company to get RHEL licences and the repo management ...
-1
votes
3answers
721 views

RPM installed but not installed RHEL6

I'm trying to resolve one dependency. Because RHEL6 doesn't contain python-2.4.3, I downloaded the package from RHEL5 and put it into our own repository. Then upon installing it: ... ---> Package ...
2
votes
2answers
888 views

yum-plugin-priorities: Which packages are excluded due to repository priority protections?

I am using multiple third party RPM repositories. Since these repos contain packages with conflicting names, I am experimenting with yum-plugin-priorities to sort out the confusion. When I run yum ...
3
votes
3answers
1k views

RHEL 6.3 Upgrading OpenSSH & Apache

We just ran an external security scan from 403Labs against one of our servers (RHEL 6.3 x86_64) for PCI compliance and the results appeared to mainly dictate that we had a hand full of applications ...
1
vote
3answers
232 views

Keep installed RPMs in sync

What is the best way to keep several CentoS/RH 5 servers keep the same set of RPM's? I.e., when I install or update an RPM on one of them using a common YUM repository, make the other servers ...