1
vote
1answer
34 views

YUM installs outdated software

I recently acquired a red hat server that runs RHEL 5.5. I get a feeling that my YUM repositories are totally out of date because of the following reasons: I tried updating GCC using YUM. The ...
2
votes
2answers
33 views

YUM, “patchlevel” and the DTAP street on redhat/centos

Is there a way to make yum update to a certain patchlevel? I always promise my devs the servers between Dev, Test, Acc and Prod are the same with versions of software. But when u use yum via the ...
0
votes
0answers
100 views

yum update leads kernel error

When I do 'yum update', the following error is shown. Before running the suggested command, I shall better understand, what the cause is. Any advice? --> Finished Dependency Resolution Error: ...
0
votes
1answer
765 views

How to fix “Cannot retrieve repository metadata (repomd.xml)” in CentOS?

I've tried yum update yum and yum clean all, but neither help to resolve the following problem: # yum install httpd --installroot=/opt/httpd2 Loaded plugins: fastestmirror Loading mirror speeds from ...
0
votes
1answer
149 views

kernel-firmware is a duplicate with kernel-firmware Cent OS YUM

I am having isssues getting my server to run after yum update was interrupted. When trying to complete the yum update I am getting the following response. [root@RESCUE-web yum.repos.d]# sudo yum ...
6
votes
2answers
3k views

Installing a third party application package on CentOS 6.4 fails due to missing dependencies libcrypto.so.10 and libssl.so.10

This is a Canonical Question about OpenSSL binary compatibility issues between Red Hat Enterprise Linux (and its derivatives) 6.4 and 6.5. This issue applies to a wide variety of third party ...
1
vote
1answer
26 views

Changelogs for rudimentary Redhat packages such as chkconfig

Frequently when running yum update I will see packages such as chkconfig requiring an update and I'd like to find out exactly what has changed, I mean such packages have been around for such a long ...
1
vote
1answer
44 views

Long term security risks of rarely updated nginx

We've deployed a system at a university using a stack of Postgres, Nginx and Django on (mandated) RHEL. The ITS department is now pressuring us to switch to Apache on order to benefit from regular ...
0
votes
1answer
40 views

yum update if installed, otherwise install

Is there a command to do just that: if a package is already installed, update it, otherwise install the latest version For now I'm doing two commands: yum install mypackage yum update mypackage ...
0
votes
1answer
52 views

How to update/maintain a patched kernel?

If I patch my linux kernel with grsecurity, will I still be able to update my system with yum (or apt-get)? Won't the updates available via yum be incompatible with my patched "non standard" version ...
1
vote
3answers
339 views

RHEL/CentOS version numbering (before and after the dot)

How does the CentOS numbering work? Major releases are 'before the dot', eg 5.x and 6.x as far as I see, and minor changes after that. Questions: If I do a yum update on a 6.1 system, will it ...
1
vote
2answers
435 views

Unresolved dependency after yum update crash (broken ssh connection)

Today I was updating one of production server (one of many to test updates and then update the rest of computers). Soon after run yum update ssh connection was broken :/ . After login once again ...
4
votes
3answers
565 views

yum update, how to make rpm package updateable

need a link or tutorial on how to make an rpm package work with yum UPDATE. i have it and already works with yum INSTALL and yum ERASE, but is there somewhere info on how to make rpm package work when ...
0
votes
2answers
614 views

yum update failed

I have problem doing a yum update on my OpenVZ VPS. I get this error message: (56/69): glibc-devel-2.5-81.el5_8.7.x86_64.rpm | 2.4 MB 00:00 (57/69): ...
2
votes
4answers
11k views

how do I update php on centOS?

I have php 5.1.6 installed on a centOS server, and I need at least 5.3.2 (but would rather install the latest available 5.* version). If I run yum update php it says it will update to ...
1
vote
1answer
264 views

Difference between yum update and using rpm to install updates

I am trying to figure out why exactly this isn't working correctly. Currently there is no way supported by yum to set a milestone in time (install all packages up to point in time T). To get around ...
2
votes
3answers
2k views

How to check when yum update was last run

Is there a canonical way to find out the last time that yum update was run on a system? Our set up is that we have staging servers that run automatic updates, and provided they don't fall over, we ...
0
votes
1answer
1k views

dbus dependency with yum

Whenever, I try and run yum update I get the following error: [root@server ~]# yum update Loaded plugins: dellsysid, fastestmirror Loading mirror speeds from cached hostfile * base: ...
1
vote
0answers
150 views

Performing yum update on an OpenVZ host

My company runs a handful of OpenVZ servers (HN) and hosts all the server as containers on these HNs. We have done some pentest and found out we have to do update the kernel on the HNs to resolve a ...
0
votes
3answers
699 views

Error when trying to update postgresql-libs

When I do a yum update I get the following errors: Transaction Check Error: file /usr/lib64/libecpg.so.6.1 from install of postgresql-libs-8.4.10-1PGDG.rhel5.x86_64 conflicts with file from package ...
2
votes
2answers
2k views

yum update dependency error (already installed)

i'm facing the following error: Transaction Check Error: package apr-1.3.12-1.jason.1.x86_64 (which is newer than apr-1.2.7-11.el5_6.5.cloudlinux.2.i386) is already installed This is on cloudlinux. ...
13
votes
2answers
12k views

What does that mean: packages excluded due to repository priority protections

When updating with yum i recieve the following message: yum update Loaded plugins: fastestmirror, priorities Loading mirror speeds from cached hostfile * atomic: www7.atomicorp.com * base: ...
1
vote
3answers
1k views

Can I update MySQL through YUM repository without data loss/corruption? Should I be nervous?

I do not have much experience with upgrading software on a Linux system but am of course familiar with 'yum update' commands. I am currently running a Media Temple DV 3.5 CentOS 5 server with MySQL ...
5
votes
3answers
1k views

RHN/Yum update from Red Hat Enterprise Linux 5.0 to 5.1

I need to update a server from RHEL 5.0 to 5.1 When I use RHN/Yum and do a yum update the 5.0 server gets updated to 5.6 Is there a way to configure RHN/yum to update the server only to RHEL 5.1 ? ...
1
vote
2answers
5k views

RHEL 5.5 Yum Update Fails Dependency Error

I have 30 different RHEL 5.5 machines that will not update some 33 packages via Yum. Does anyone know why these packages will not install and how to correct this? Yum clean all does not fix the ...
3
votes
4answers
532 views

YUM RHEL Update Server

I need to create a local RHEL5 Update Server to help eliminate the number of servers exposed to the web. All the local rhel5 servers need to be able to use this server as a repository for patches. I ...
1
vote
3answers
183 views

will yum update delete all my databases? settings? etc

I just hosed my Centos install and I'm wondering whether to do a yum update? I have loads of mysql and solr databases that I am working on. Will it delete those? Should I do a backup before doing a ...
0
votes
1answer
149 views

Updating packages on a CentOS 5.5 VPS

I have been running a VPS for several weeks now and yum has informed me that 67 package updates are available. I'm very new to Linux and server administration in general. I have taken time to ...
1
vote
2answers
102 views

Updating PHP on Linux - “No Packages marked for Update”?

Note: I have an application that requires 5.2, yet my server presently runs 5.1.6. I'm very new to server-administration, but I was thinking the task of updating PHP to 5.2+ should be relatively ...
0
votes
1answer
43 views

Problem with kde-filesystem when updating

Since 2-3 weeks, each time I update my fedora 11 box with yum, I get these messages. Error unpacking rpm package kde-filesystem-4-33.fc11.noarch warning: /etc/rpm/macros.kde4 saved as ...
0
votes
1answer
1k views

omreport missing after CentOS 5.4 yum update

I just ran yum -y update and now I get omreport: command not found uname -a Linux smtp.alexx.net 2.6.18-164.6.1.el5 #1 SMP Tue Nov 3 16:18:27 EST 2009 i686 i686 i386 GNU/Linux
0
votes
5answers
3k views

In CentOS, how do I update Python 2.4.3 to 2.5?

I want Python 2.5, not 3.0. Can I use yum update for this?
2
votes
4answers
6k views

How can I keep the RHEL version static (e.g. RHEL 5.1)?

For compatibility with a program : I need to keep one of our servers in a specific version, for example rhel 5.1 I would like to keep it as updated as possible, but not to change versions. What ...
0
votes
2answers
126 views

Why my php is not up to date

I use Yum on Fedora 11 to update my computer. On my box, I have [luc@zappa locale]$ php --version PHP 5.2.9 (cli) (built: Apr 15 2009 09:30:33) Copyright (c) 1997-2009 The PHP Group Zend Engine ...
4
votes
2answers
3k views

Rollback YUM package

What's the best (ie foolproof and easy) mechanism for rolling back an rpm update using YUM? I've not come across the problem where I upgrade something and later find I want to downgrade it, but I'd ...