YUM is an open-source command-line package-management utility for RPM-compatible Linux operating systems.

learn more… | top users | synonyms

1
vote
2answers
369 views

Conflicts with file from package mysql-5.0.77

I'm trying to install APC (Alternative PHP Cache) on a CentOs dedicated server. I've everything done apart from configuring phpize. Running :yum -y install php-devel gives me the following error: ...
1
vote
2answers
195 views

Problem with YUM

I've recently registered a VPS and am trying to update the version of PHP installed on it. I'm used to Ubuntu rather than Redhat so I need a bit of advice on how to solve this problem. Yum seems to ...
1
vote
2answers
3k views

How to install specific version of MySQL?

I installed from the repo, 5.0.77... including setup of PowerDNS (and the backend for MySQL). I tried setting up replication from my Master (which is MySQL 5.1.53) but it didn't work even though there ...
0
votes
1answer
756 views

yum proxy error HTTP redirect

I've a VM running Centos 5.5 and I'm trying to get yum to update via a company proxy. I can browse the web within the VM using the proxy setting , but I cannot get yum to use the proxy. I'm getting ...
2
votes
3answers
3k views

Where is the yum repository for emacs 23 for CentOS 5.5?

I want to update my emacs on CentOS 5.5 to 23 but I can't find any rpms or yum repos that have it?
1
vote
3answers
1k views

Upgrading PHP from 5.1 to 5.2 on CentOS 5.4

i'm trying to upgrade php 5.1 to 5.2 on a CentOS 5.4 I use: yum upgrade php The result is this (check out the last part): [root@mail httpd]# yum update php Loaded plugins: fastestmirror Loading ...
1
vote
2answers
1k views

Building nginx 1.0.4 on Amazon EC2 micro - perl and python problems

I'd like to run nginx as a reverse proxy with apache2 on my EC2 micro instance. yum install nginx gives me nginx-0.8.53-1.2.amzn1.x86_64.rpm The current nginx is 1.0.4 I found and followed this ...
23
votes
5answers
107k views

How do I install an rpm that complains about rpmlib(FileDigests) <= 4.6.0-1?

Im trying to install an rpm file on CentOS 5 and Im not sure how to resolve this issues it brings up: $ rpm --install epel-release-6-5.noarch.rpm warning: epel-release-6-5.noarch.rpm: Header V3 ...
2
votes
1answer
397 views

Is “yum groupinstall” compatible with Red Hat Network?

On CentOS 5, I run yum groupinstall "Development Libraries" to install the commonly used development libraries. Can I use the same command on a RHEL5 server with RHN? Is the "Development Libraries" ...
0
votes
3answers
3k views

Cannot get CentOS 5 to update - Yum Errors

I'm used to Yum on CentOS 5 being a total pig and breaking every other week, but until now I've always been able to fix the problem by simply running: yum clean all And then updating normally. Not ...
0
votes
1answer
921 views

Linux yum install Traceback error

I was trying to install some packages, and now I'm getting tired of this error message: [user@domain~]# yum install mod_ssl Loaded plugins: fastestmirror Determining fastest mirrors Traceback (most ...
0
votes
2answers
1k views

Puppet - Update packages on repo installation

I am attempting to have puppet (0.25.5-1.el5) update an already installed package when a new yum repo gets installed. The basic image we have has package X installed at version 1.1 by default. In ...
0
votes
1answer
1k views

How to unblock sites in squid proxy server

I have installed Squid as proxy server,By default it block the yum install and mails(gmail,yahoomail,etc).How to unblock this functions.i'm using fedora13 as OS
2
votes
1answer
2k views

Whats the difference between `yum groupinstall` vs regular `yum install`?

Whats the difference between yum groupinstall vs. regular yum install?
3
votes
1answer
219 views

How to create a yum repository

Wondering how to create our own CentOS 5 based yum repository? Basically, we want to make rpm packages and then be able to do things like: yum install our-custom-package yum remove our-custom-package ...
0
votes
2answers
2k views

CentOS Repo on RHEL 5.6?

Does anyone know how to setup the CentOS repositories to work under RHEL 5.6? Please be specific if possible.
2
votes
1answer
603 views

Reinstall file from RPM?

So I need to install the original /etc/pam.d/system-auth-ac file from the authconfig RPM. I attempted to do so by "reinstalling" the authconfig package/rpm like so: mv /etc/pam.d/system-auth-ac ~/ ...
2
votes
1answer
3k views

VPS yum update filesystem … killed

I've got a HostGator level 1 VPS - basically, a CentOS 5. I've got full root access to run whatever I want. Anyhow, during a recent maintenance check, I run yum -y update, but after the usual kinds ...
2
votes
2answers
3k views

How to install section 3 manpages for CentOS

I'm trying to read the manpage for read(3) on my CentOS system: $ man read 3 No manual entry for 3 What/Which package do I have to install to get these manpages? (glibc* packages are installed on ...
0
votes
2answers
182 views

Error after running yum update mysql

I have a redhat linux server. I ran yum update mysql and it worked fine. The problem is that when I went to phpMyAdmin all of the databases were deleted. So I used "import" to import the database ...
0
votes
1answer
348 views

Custom configure parameters for yum install php

I use yum as my package manager on CentOS, running as a testing web server. I want to re-configure PHP with --with-mysqli=mysqlnd, but do it through yum. Is this possible, and if so, how? At the ...
3
votes
4answers
2k views

Install postgresql on RHEL 5.6

When I try to run yum install postgresql I get the following error message: Transaction Check Error: file /usr/lib64/libecpg.so.6.1 from install of postgresql-libs-8.4.4-2PGDG.el5.x86_64 ...
4
votes
2answers
10k views

Where did yum put boost?

I installed boost.x86_64 on my Linux system: $ sudo yum install boost.x86_64 Loaded plugins: fastestmirror, langpacks, presto, refresh-packagekit Adding en_US to language list Loading mirror speeds ...
8
votes
2answers
22k views

Install libxml2 2.7.X on CentOS 5.X

CentOS ships with libxml2-2.6.26. I have to install at least 2.7.X version. I downloaded RPMs for libxml2, libxml2-devel and libxml2-python (2.7.8) from XMLSOFT (http://xmlsoft.org/sources/). I am ...
0
votes
1answer
144 views

pidgin install conflicts with libpurple old and new?

package libpurple-2.7.11-0.el5.x86_64 file /usr/share/locale/sr/LC_MESSAGES/pidgin.mo from install of libpurple-2.6.6-5.el5_5.i386 conflicts with file from package libpurple-2.7.11-0.el5.x86_64 ...
3
votes
2answers
2k views

CentOS yum thinks removed packages are still installed

I have 2 packages in my yum that I would like to get rid of. When I list the installed packages they appear in the output, and when I try to erase them, yum seems to think it's ok and proceeds with ...
0
votes
3answers
371 views

restoring usr/share/php with yum on centOS

my httpd service wont start/restart possibly because i have nothing in my usr/share/php/ directory how do i restore this paerticular directory using yum in ssh on centOS? if i have virtual host paths ...
3
votes
2answers
2k views

RHEL5.5 yum can't see a package (xen) on repo?

hi i'm trying to install xen via yum on RHEL 5.5. When i browse the repo here: http://ftp.redhat.com/pub/redhat/linux/enterprise/5Server/en/os/SRPMS/ I can see the package i want. specifically ...
1
vote
1answer
200 views

Why doesn't openSUSE Linux upgrade itself through its software repositories?

openSUSE - fast becoming my favourite Linux distro on the client - doesn't seem to upgrade itself through its own configured software repositories. Do we know why this is the case? Is it a ...
0
votes
1answer
54 views

Updating CentOS

I have a CentOS 5.5 installation with ruby, dovecot (and some other soft) installed from source, and soft like postfix, samba, bind etc. installed from yum repositories. This box is online for more ...
2
votes
1answer
2k views

error from 'yum list <package>' - up2date client abuse?

I recently added a server to our network. After a normal RHEL5 installation I added a number of packages via yum. This was about 2 weeks ago. This morning Im looking for something in yum and tried ...
0
votes
1answer
557 views

php 5.2 repository

I'm quite a noob at configuring servers. Anyway, I'm running CentOS 5 and I've been meaning to install the php-xml package for my PHP 5.2.17. This server runs proprietary software which requires PHP ...
2
votes
2answers
650 views

OCFS2 updating procedures

We plan to use OCFS2 in a project running Red Hat Enterprise Linux (RHEL) 5.6 because we found OCFS2 to be much simpler to set up than GFS. I am, however, worried about the upgrade process since I ...
0
votes
1answer
259 views

install mono rpm like yum?

I want to install the mono RPM like it would be if I installed it through yum. What I mean is that when you install the rpm it puts everything in /opt/novell/. I want it to put in /usr/bin/, etc like ...
0
votes
3answers
226 views

yum suddenly shows 131 updates available

I am running CentOS and have yum-updatesd running everyday and notifying me of any updates. A few days ago, yum started telling me that there are 131 updates available. What would cause it to do ...
1
vote
1answer
499 views

How to install hd on centos?

$ hd test.bin 00000000 e8 06 00 00 00 74 65 73 74 0a 00 b8 04 00 00 00 |.....test.......| 00000010 bb 01 00 00 00 59 ba 05 00 00 00 cd 80 c3 |.....Y........| hd is supposed to be able to ...
2
votes
3answers
5k views

yum does not pick the latest package

I have a local yum repo with some rpms in it. I want to upgrade one of the packages on all my servers. Let's say the existing one is foo-1.0.x86_64.rpm. I dropped in to the local yum repo a new one ...
5
votes
5answers
13k views

yum “ Segmentation fault” in centos

While using yum commands in a centos server(2.6.18-194.el5PAE #1), it throws 'Segmentation fault'. [root@server2 ~]# yum check-update Loaded plugins: fastestmirror Loading mirror speeds ...
1
vote
2answers
429 views

How to make yum also install the manuals?

yum install libevent-dev Now I have installed libevent,but its manuals are not installed: [root@xx test]# man event_base_loop Cannot open the message catalog "man" for locale "zh_CN.UTF-8" ...
0
votes
4answers
439 views

Git not found by yum..installed from source but git still not recognized

I have a Centos server that I tried to yum install git and git-core and all that and I just consistently got the error message that the git package wasn't found. So I installed it from source ...
0
votes
1answer
868 views

how do I install scripts like pg_lsclusters on a Amazon AWS Linux AMI

I am used to debian/ubuntu distros and now trying to experiment with the official Amazon AWS Linux AMI. I have installed postgresql-server, postgresql-devel, postgresql-contrib yum packages. The ...
6
votes
2answers
759 views
2
votes
1answer
1k views

What does $releasever and $basearch mean here?

[dag] name=Dag RPM Repository for Red Hat Enterprise Linux baseurl=http://apt.sw.be/redhat/el$releasever/en/$basearch/dag gpgcheck=1 enabled=1 And when will enabled=0 be useful? Why is there such an ...
0
votes
2answers
90 views

Removing packages from a CentOS installation

I've installed CentOS, along with some applications such as Apache and PHP. How do I remove the currently installed versions so that I can install the correct versions using yum?
2
votes
1answer
5k views

Yum error when updating / install

Yum error are the RHN servers down or is there a problem on my server. yum update Loaded plugins: rhnplugin, security There was an error communicating with RHN. RHN support will be disabled. Error ...
3
votes
2answers
1k views

“Insufficient space in download directory” error on VirtualBox when using yum in Fedora virtual machine

I just did a fresh installation of Fedora on VirtualBox - gave it 8GB of hard drive space. After installing a handful of packages via yum (and nothing more) I am getting the error: Insufficient ...
0
votes
1answer
135 views

CentOS and package version numbers worry

I have heard about a vulnerability in BIND. See here: http://www.isc.org/software/bind/advisories/cve-2011-0414 The issue appears to be with certain versions and my version (9.3.6) is earlier than ...
1
vote
1answer
2k views

Can't install mongodb via 10gen.repo on Amazon 64bit AMI

Following the instructions here: http://www.mongodb.org/display/DOCS/CentOS+and+Fedora+Packages Can't really decipher what I should be doing...broke down and just got the linux binary but I want yum ...
0
votes
1answer
774 views

Yum Transaction Check Error on install

# yum install subversion subversion-devel neon neon-devel While trying to install some packages with yum – as shown above – I get the following error Transaction Check Error: file ...
21
votes
3answers
26k views

Is there a way to install Apache Bench (ab) without installing apache

Can you provide instuctions on how to install ab on a fedora distro with or without installing the apache web server? With yum or compiling from source.