YUM is an open-source command-line package-management utility for RPM-compatible Linux operating systems.

learn more… | top users | synonyms

5
votes
3answers
1k views

RHN/Yum update from Red Hat Enterprise Linux 5.0 to 5.1

I need to update a server from RHEL 5.0 to 5.1 When I use RHN/Yum and do a yum update the 5.0 server gets updated to 5.6 Is there a way to configure RHN/yum to update the server only to RHEL 5.1 ? ...
5
votes
3answers
2k views

Removed YUM? CentOS 5.5

After doing yum remove crontabs this appears after running yum: -bash: /usr/bin/yum: No such file or directory This was the output of yum remove crontabs: [root@vs270 opt]# yum remove crontabs ...
5
votes
1answer
2k views

How do I migrate from RHEL 5 to CentOS 5?

I've found myself in charge of installing some software on an old server running RHEL 5. Unfortunately, since it's just a development server now, it no longer rates a license. I'd like to continue ...
5
votes
1answer
384 views

When should one use EPEL 5 or EPEL 6?

I am not familiar with repos, and I don't get why there are several versions of EPEL (this is a bit philosophical I know, but I am afraid I am missing something in all that). Should I just look ...
5
votes
7answers
19k views

Yum update not working on CentOS 6.2 minimal install

Note: This is my first question on the stack exchange network so please give mercy and provide guidance where needed. I have installed a CentOS 6.2 KVM guest and I am having problem getting yum to ...
5
votes
2answers
4k views

how to add(and install) java openjdk repository to your yum fedora?

executing this command - yum install java-1.7.0-openjdk yields - No package java-1.7.0-openjdk available. That's because i don't have the repo - but im a little clueless as to where, and how to add ...
5
votes
4answers
2k views

Best way to clean up Yum repository?

We have a custom Yum repo that our developers upload builds to. The problem is that after some time it becomes cluttered with old versions. Removing the old versions manually is quite annoying, so ...
5
votes
1answer
2k views

Why are some CentOS 5 boxes still vulnerable to ShellShock after upgrading Bash?

I have two CentOS 5.10 boxen where I have upgraded bash to the latest version. However, in one of the boxes, bash is still vulnerable to CVE-2014-7169 (I am using the test from this ServerFault ...
5
votes
3answers
199 views

rkhunter warns of inode change by no file modification date changes

I have several systems running Centos 6 with rkhunter installed. I have a daily cron running rkhunter and reporting back via email. I very often get reports like: ---------------------- Start ...
5
votes
1answer
1k views

Creating a local rpmforge/repoforge mirror?

I make good use of RPMforge for my production CentOS systems. I have local repositories for the main CentOS distribution and updates, however, recent automated kickstart installs are starting to hang ...
5
votes
3answers
45k views

How do I update YUM repositories?

I am very, very new to all this so baby steps please if helping is appreciated. I am trying to connect to the following repository so I can update my YUM packages: ...
5
votes
2answers
2k views

Caching proxy for yum and debian repositories

Does a caching proxy for yum exist, similar to approx for Debian repositories? Is there a way to have reprepro behave the same as approx? I have heard that approx was not as stable; besides, I would ...
5
votes
1answer
232 views

Why does installing the same package twice with yum not give me the same files?

The situation I am facing: I set up a CentOS 5.9 machine that is supposed to be as close as possible a copy of another CentOS 5.9 machine, but not a clone. Using yum, I installed (as far as possible) ...
5
votes
3answers
10k views

Howto install php 5.2.17 on centos 6 x86_64

Does anyone know how to install php 5.2.17 on a 64bit centos 6 install? I've got a old legacy system that requires php 5.2.17, but centos 6 only supports php 5.3. I've installed repo's such as ...
5
votes
3answers
1k views

AWS Linux EC2: yum won't run with plugins

Short Version: yum commands on my Amazon Linux EC2 AMI only work with --noplugins. Long Version: A couple of days ago, I ran yum update at the behest of the SSH Login MoTD telling me I had updates to ...
4
votes
4answers
1k views

yum claims python isn't installed

Trying to install collectd, but for some reason it claims python isn't installed: yum install collectd Loaded plugins: fastestmirror Loading mirror speeds from cached hostfile Setting up Install ...
4
votes
2answers
571 views

Using puppet and ensure latest for RPM package management

Using ensure => latest, I have systems which do not need all of the same packages. Will ensure => latest install the packages or only update if they already are present? If they are not ...
4
votes
3answers
1k views

What can I do to speed up createrepo?

We are using a yum repository to distribute our software to our production instances. Unfortunately, createrepo is becoming a bottleneck, and we only have 469 packages in the repository. $ time ...
4
votes
3answers
812 views

yum update, how to make rpm package updateable

need a link or tutorial on how to make an rpm package work with yum UPDATE. i have it and already works with yum INSTALL and yum ERASE, but is there somewhere info on how to make rpm package work when ...
4
votes
2answers
6k views

yum equivalent to apt-get upgrade vs apt-get dist-upgrade?

I'm a *.deb guy and I feel quite uncomfortable while managing rpms. I'm used to run apt-get upgrade in my debian based servers for "normal" upgrades and apt-get dist-upgrade for allowing kernel ...
4
votes
2answers
12k views

How do you upgrade PHP 5.1 to PHP 5.3 using yum on CentOS

Using Yum/CentOS. The problem is that php 5.1 is already installed and running so yum update php dont work! I looked around the net for a solution but they say to do the above =/
4
votes
2answers
203 views

Switching yum from RHEL to .. something else? [duplicate]

My various managers have decided that it's too expensive to keep paying for a subscription to the RedHat network for OS updates. Is it possible to switch to Fedora/CentOS or do I need to reinstall the ...
4
votes
1answer
573 views

Why do I get different openssl versions?

I'm trying to check if I running the latest OpenSSL version, my main concern is the heartbleed bug. I tried 2 commands: openssl version yum info openssl openssl version output OpenSSL ...
4
votes
1answer
414 views

/var/lib/mysql folder is missing

I've created a virtual machine and am installing things from scratch. Definitely not a sys admin so I'm running into some trouble. I've installed these packages and then restarted httpd yum -y ...
4
votes
3answers
7k views

Enabling apt-get on a default Amazon EC2 instance which has yum installed

I'd like to call something like: sudo yum install apt to enable me to use apt-get as well as yum for installation. However this doesn't work. I get the following back: Loaded plugins: ...
4
votes
1answer
1k views

How do I prevent yum from updating a particular RPM?

For certain reasons I have to keep a slightly older version of a particular RPM installed on my box (Fedora 11). The problem is that every time I do a package update yum (or one of its GUI ...
4
votes
3answers
2k views

Update Red Hat Enterprise Linux's Packages Only To Specific Point Release

Let's say that I have one RHEL6.2 64bit server running. Current latest version available is 6.4. Running "yum update" will update my server up to 6.4 straight away. What if I want to update only to ...
4
votes
2answers
6k views

CentOS install proftpd with yum

Server: CentOS 6.2 64bit How can I install Proftpd using yum? A search for the package doesn't find it: yum list proftpd Error: No matching Packages to list Although my CentOS 6 VPS does find it, ...
4
votes
4answers
5k views

Downgrade Linux Package Using Yum

I've currently got a 64-bit version of a package installed (subversion-javaHL to be exact). I need to roll this back to its 32-bit counterpart. Is there a way to do this without simply uninstalling ...
4
votes
5answers
8k views

yum “ Segmentation fault” in centos

While using yum commands in a centos server(2.6.18-194.el5PAE #1), it throws 'Segmentation fault'. [root@server2 ~]# yum check-update Loaded plugins: fastestmirror Loading mirror speeds ...
4
votes
2answers
2k views

CentOS repositories: EPEL or rpmforge, which one is better and why?

So everyone who uses CentOS knows the default repositories have their limits. I've been using rpmforge for years as a secondary repo. I usually use yum priorities to make sure rpmforge never installs ...
4
votes
2answers
3k views

Rollback YUM package

What's the best (ie foolproof and easy) mechanism for rolling back an rpm update using YUM? I've not come across the problem where I upgrade something and later find I want to downgrade it, but I'd ...
4
votes
1answer
127 views

How to prevent installation of incompatible rpm packages

I have two rpm packages wich should not get installed together. After googling around i assume there is no RequiresNot tag or something similar to specify incompatible packages in a specfile. What ...
4
votes
1answer
3k views

Yum install in chroot directory

I'm trying to install the Base group on a mounted volume. Here's the custom yum.conf that I'm using: [main] cachedir=/var/cache/yum/ debuglevel=2 logfile=/var/log/yum.log exclude=*-debuginfo ...
4
votes
1answer
3k views

yum update works but yum --security update fails to work in Fedora 12

I had already installed the yum-security before. And I was going to do an update by entering the following command: [root@localhost /]# yum update Loaded plugins: presto, priorities, ...
4
votes
1answer
63 views

How can I see what is the latest version of a package available in a specific repo if I have that package already installed/updated from another repo?

I am using CentOS 6 and I updated PHP using the Remi Repository. I would like to use yum in order to know what is the latest version available in the official CentOS repos. I tried issuing the ...
4
votes
1answer
55 views

How to get transaction history for yum?

I would like to know how to get the transaction history of yum (i.e. get the installations, deletions, etc.), hopefully ordered from most to least recent. Is there a way to accomplish this? Thanks ...
4
votes
2answers
535 views

How can I tell Puppet “If I declare class X, apply its resources before class Y”?

In my Puppet configuration I want to say "If I declare class X, apply its resources before class Y." In other words, I want to declare an ordering, but remain silent about whether or not to apply ...
4
votes
3answers
385 views

Atomic repository…in english please

Simple question, hopefully a simple answer: I am new to Linux servers, and my hosting company offered me a tip to: You may want to add the Plesk repository provided by Atomic Turtle. I know ...
4
votes
1answer
7k views

How to resolve yum errors during update - CentOS

I'm running CentOS 6.4 with Apache, and am having trouble running Easy Apache update through WHM. It fails with errors related to yum, so I decided to update yum manually. Here's the last view lines ...
4
votes
1answer
3k views

Why is my RHEL6 x86_64 server trying to install libselinux.i686?

Just did a fresh install using the RHEL 6 DVD on a test VirtualBox server: [root@bt-rhel6-1 ~]# cat /etc/redhat-release Red Hat Enterprise Linux Server release 6.1 (Santiago) I am certain it's an ...
4
votes
1answer
124 views

Managing myriad package repositories

On testing, development, and some other server and workstation environments, I use a variety of package repositories (with CentOS, for example, these include: remi, epel, rpmforge, jpackage, and ...
4
votes
1answer
381 views

What can I do to safely repair my yum packages after a bad update?

I'm running amazon linux on an EC2 micro box. Recently I ran sudo yum update --security in the hope that it would patch Heartbleed. Unfortunately I ran out of memory during the update process and some ...
4
votes
2answers
8k views

Upgrade cURL to latest on CentOS

I need to upgrade cURL to the latest version on Centos 2.6.18-164.15.1.el5.centos.plusxen #1 SMP Wed Mar 17 20:32:20 EDT 2010 x86_64 x86_64 x86_64 GNU/Linux I'm unable to find any suitable ...
3
votes
3answers
1k views

RHEL 6.3 Upgrading OpenSSH & Apache

We just ran an external security scan from 403Labs against one of our servers (RHEL 6.3 x86_64) for PCI compliance and the results appeared to mainly dictate that we had a hand full of applications ...
3
votes
2answers
457 views

CentOS 6.x — how to find required package to install?

I'm not that experience with Linux, but I'm trying to install some software on 64-bit CentOS 6.3 that requires the following packages (copying them exactly as written in the documentation stating ...
3
votes
4answers
11k views

Can I set up Fedora or Centos repos in RHEL6?

I have a RHEL6 box with no subscription to Red Hat Network. I want to install gcc using yum to resolve all the complex dependencies. Can I connect to Fedora or Centos repositories to install software? ...
3
votes
4answers
330 views

Yum repo server as archive cache

Our software stack requires some specific versions of RPM packages. Unfortunately some of these packages become deprecated over time and get removed from their repos since their maintainers don't keep ...
3
votes
3answers
2k views

How to check when yum update was last run

Is there a canonical way to find out the last time that yum update was run on a system? Our set up is that we have staging servers that run automatic updates, and provided they don't fall over, we ...
3
votes
4answers
4k views

RHEL 6.x - yum gives “ImportError: No module named cElementTree” errors

I'm making a set of changes to a group of 150 servers. All systems were able to successfully download and install a specific set of RPM's via yum, except for one. One this particular system, all yum ...