YUM is an open-source command-line package-management utility for RPM-compatible Linux operating systems.

learn more… | top users | synonyms

0
votes
3answers
515 views

yum fails installing php53-devel.x86_64

I need to recompile php on a Fedora server because I need to use the --enable-zip flag. When trying to install the devel package, I get the following message. This is after a 'yum clean all': yum ...
2
votes
2answers
2k views

grubby fatal error: unable to find a suitable template

I'm trying to fix my system after moving it from one server to another. It works perfectly with kernel booted via network, but not from the disk. Reinstalling stock CentOS 6.6 kernel shows this error:...
1
vote
2answers
193 views

Yum the same version as in a repository (automatic upgrades/downgrades)

In our infrastrcture, we have servers installed and managed by puppet. All our software is then installed from rpm. On each server is a small script that performs yum update if there is some change in ...
1
vote
2answers
866 views

Centos official base docker image running out of space

I thought docker images use the underlying filesystem to create their own filesystem. However, I am installing some packages through "rvm requirements" that results in an error. The error is ...
1
vote
2answers
343 views

No package blktrace available

I could not install blktrace in my redhat5.8 OS. yum install blktrace Loaded plugins: katello, product-id, security, subscription-manager Updating certificate-based repositories. Unable to read ...
1
vote
2answers
415 views

Install gettext-0.17-1.el5.i386.rpm on CentOS 5.8 i386 gives “/usr/bin/python is needed” error

I've removed yum by mistake. So, now I'm installing all the dependencies needed by yum manually. One of those is gettext-0.17-1.el5.i386.rpm and when I try to install it gives the following error, ...
1
vote
2answers
643 views

Yum lock file problem

When there are more than 1 copies of yum running, I get this error: Another app is currently holding the yum lock; waiting for it to exit Is there a way to make yum just exit the first time it can'...
0
votes
2answers
57 views

How can i exclude a package from getting updated in redhat using Yum

I want to exclude the package from being checked while updating the server using yum. Here is the error thrown. ---> Package libstdc++.i386 0:2.8.0-8 will be updated --> Processing ...
0
votes
2answers
458 views

Installing Redis on CentOS 6.6 final - no package available

I've added the "EPEL" repo: Loaded plugins: changelog, downloadonly, fastestmirror, presto Loading mirror speeds from cached hostfile * elrepo: repos.mia.lax-noc.com * epel: epel.gtdinternet.com * ...
0
votes
2answers
153 views

Centos Yum Repo Issues

I'm trying to enable the REMI repo by executing the below command: rpm -Uvh http://rpms.famillecollet.com/enterprise/remi-release-5.rpm as a result I keep getting: package remi-release-5.10-1.el5....
0
votes
2answers
434 views

Control the order yum dependencies are installed?

I need to install an application that has 4 dependencies (output from .spec file): Requires: PA-KBU-KBUONE-SHARED Requires: PA-KBU-KBUONE-PLI-CONF Requires: PA-KBU-KBUONE-PLA-CONF Requires: PA-KBU-...
0
votes
2answers
966 views

Yum repository configuration on Amazon EC2 instance

I'm trying to install postgis on an Amazon EC2 instance, the instance is running Red Hat, and by following this tutorial: http://wiki.postgresql.org/wiki/YUM_Installation#Configure_your_YUM_repository ...
0
votes
2answers
1k views

Cannot install php-intl on CentOS

When I run: yum install php-intl I get this error: Loaded plugins: fastestmirror Loading mirror speeds from cached hostfile * base: mirror.as29550.net * epel: ftp.nluug.nl * extras: mirror....
0
votes
2answers
718 views

php 5.3 and libxml2 nightmare

My CentOS 5.7 ships with libxml2 2.6.26 that is very outdated and also causes many problems with my current PHP 5.3.3. I need to update libxml2 to 2.7.8 version or at least 2.7.3+ i've readed many ...
0
votes
2answers
183 views

Error after running yum update mysql

I have a redhat linux server. I ran yum update mysql and it worked fine. The problem is that when I went to phpMyAdmin all of the databases were deleted. So I used "import" to import the database ...
0
votes
2answers
165 views

Fedora Core yum update cpio error

Any idea why I'm getting these errors when running: yum update http://pastie.org/private/7x4pez9duzxvmb6lgeyrgq I've never had a problem with that command in the past.
0
votes
1answer
521 views

Dependency loop while trying to install gcc on Fedora 17

I'm trying to yum install gcc but getting this message. Error: Package: glibc-common-2.15-37.fc17.i686 (@anaconda-0) Requires: glibc = 2.15-37.fc17 Removing: glibc-2.15-37.fc17.i686 (@...
0
votes
1answer
179 views

Necessary proxy exception list for RHEL updates

Anyone know if I need to allow more than *.rhn.redhat.com on 443 & 80 via a proxy exception to allow my RHEL servers to go out and grab updates ? Haven't received the hardware yet, but I'm just ...
0
votes
1answer
58 views

Use the Fedora Yum command after installation, how to configure

When i use command "yum install exlipse*"after installtion, display eclipse-cdt,but in eclipse cannot edit C/C++ project, not clear when Yum after general to eclipse do configuration
0
votes
1answer
1k views

Openoffice yum repo for RHEL 5?

We need to run Openoffice as a service so that unoconv can be used convert Word documents to PDF. Any yum repositories for Openoffice in RHEL 5 server ?
0
votes
1answer
295 views

What repo do I need for php-devel, php-pear

I'm still having problems with managing repos, so I downloaded dag's repo and installed it , but I still can't install php-devel and php-pear when I run yum install php-pear, I get the error "no ...
0
votes
1answer
951 views

linux yum through a socks v5 proxy

I can't use yum because port 80,443 are being blocked by a firewall. I setup a ssh proxy tunnel (socks v5), it works fine. I've tried to find how to use yum with a socks v5, but looks like it only ...
0
votes
1answer
24 views

yum to install fails on default empty server

I used to download Fedora from site X, for example, but lately the site has not updated itself with new packages, therefore commands used to install any of those packages report back with errors as ...
0
votes
1answer
40 views

Getting PHP5 To install

It seems I am stuck with a 4yo build of PHP (PHP4.3.9 Built: 2007) and I am trying to upgrade. Right now, it's like a traffic puzzle, or a vicious cycle, whatever you want to call it. I try to upgrade ...
0
votes
1answer
562 views

php 5.2 repository

I'm quite a noob at configuring servers. Anyway, I'm running CentOS 5 and I've been meaning to install the php-xml package for my PHP 5.2.17. This server runs proprietary software which requires PHP 5....
0
votes
1answer
1k views

Missing Dependency Errors when Installing OpenVas Server

I'm trying to install OpenVAS on Red Hat Enterprise Linux 5.5. I've successfully run yum install openvas-client, but yum install openvas-server prints the following errors: --> Finished Dependency ...
0
votes
1answer
144 views

Remote Yum mirror

I have a bunch of remote computers that must be updated to the most recent packages for RedHat 4 and RedHat 5. I am using mrepo to mirror the RHN packages, however the remote computers do not have an ...
-1
votes
1answer
34 views

Versions of Package with YUM

I want to know which versions of the same package were previously installed with YUM. For example if I have a package that it version is 4.0, I should need to know the previously versions installed
-1
votes
1answer
136 views

Solving mysql 2003 error

Hi I've just created my new linux server and have yum installed various modules which all seem to be working ok now. My trouble comes from mysql. It's installed and running but when I and connect from ...
-1
votes
1answer
1k views

YUM error. Is this a cert error

Nov 13 13:38:57 host abrt: detected unhandled Python exception in '/usr/bin/yum' Nov 13 13:38:57 host abrtd: New client connected Nov 13 13:38:57 host abrt-server[3508]: Saved Python crash dump of pid ...