YUM is an open-source command-line package-management utility for RPM-compatible Linux operating systems.

learn more… | top users | synonyms

3
votes
1answer
60 views

Automatically remove a %preun broken RPM?

We have an error in the %preun script of an RPM we distributed in the past. This has been corrected, but, now, upgrading to the newer version is failing because the previous version is not ...
3
votes
1answer
3k views

yum client doesn't see new packages though server is updated

We have an internal yum server containing several repos (copies of the RHEL repo, programs created in-house, and so on). Our internal systems are firewalled off from the internet, so they can only use ...
3
votes
2answers
199 views

Why does `rpm` show 3 httpd packages, and which one provides the real httpd?

I ran yum update on my CentOS5 webserver a few days ago. Today I just noticed that I have 3 httpd-* rpms! How can I end up with three RPMs for httpd (My other servers only have one httpd rpm). I want ...
3
votes
2answers
4k views

How to update from RHEL6.1 to RHEL6.2 ,not RHEL6.3

Now I'm using RHEL version 6.1, and would like to update to 6.2. If I use the command , yum update the OS version become 6.3. so I used the command below yum install kernel-2.6.32-220.23.1.el6 ...
3
votes
1answer
138 views

how to make yum tolerant of broken repo URLs

I have a number of CentOS instances, some of which have been used by developers and have 3rd party repos (sometimes their own) enabled. However from an administrative point of view it is handy to be ...
3
votes
1answer
146 views

Change Management Workflow Using Yum

We have a fairly strict patching process that we have to follow: Patch a development or testing machine Wait one week to see if it explodes Patch the corresponding production machine to the same ...
3
votes
1answer
453 views

RHEL/CentOS - Is it possible to update packages only up to a certain release date?

Technically speaking, if one wanted to update a RHEL or CentOS server using yum, but only up to a certain release date (i.e. don't install any updates released after X date), would it be possible and ...
3
votes
2answers
147 views

Later versions of RPMs not available through custom yum repo

I've created a custom repository following this guide. Files are being served via http (nginx). I've cd'd into the directory to create the metadata with createrepo .. I can install a package through ...
3
votes
2answers
6k views

XenServer 6.2 Yum Repository

I installed a clean XenServer 6.2 from the ISOs provided here. I want to compile a driver against this system and need to install make and sources and so on. If I do yum install make I get ...
3
votes
2answers
931 views

“Insufficient space in download directory” error on VirtualBox when using yum in Fedora virtual machine

I just did a fresh installation of Fedora on VirtualBox - gave it 8GB of hard drive space. After installing a handful of packages via yum (and nothing more) I am getting the error: Insufficient ...
3
votes
3answers
8k views

Upgrading OpenSSL in CentOS 5.3

I want to use one IP to host many domains with individual SSL certificates (requires SNI). In CentOS 5.3, the latest version of OpenSSL I can find an RPM for is 0.9.8e, which does not support SNI. I ...
3
votes
1answer
88 views

Fedora 21: Cannot Ping or Curl, but can Access Internet

We have an automatic proxy server configuration setup, and I can use a web browser but ping/curl are failing; it looks like a DNS resolution problem. When I do: URLGRABBER_DEBUG=1 yum check-update ...
3
votes
1answer
549 views

Enable the EPEL repository on AWS Elastic Beanstalk

I need to install some tools from the Extra Packages for Enterprise Linux repository (EPEL) that are not available in the default repositories of the Amazon Linux AMI. /etc/yum.repos.d/epel.repo ...
3
votes
1answer
2k views

Missing Dependency: perl(YAML::Any)

I have a problem with git, when I run yum upgrade on a centos5 server. yum upgrade output: Resolving Dependencies --> Running transaction check ---> Package git.x86_64 0:1.7.11.3-1.el5.rf ...
3
votes
1answer
770 views

Errno 14 HTTP Error 401: Authorization Required Yum

So I am having an issue with my own yum repo. Here is the setup: I have basic auth on apache running on a RHEL 6.2 machine on EC2. It holds the yum repo for both a RHEL 6 machine and a RHEL 5 machine ...
3
votes
1answer
406 views

Is there a way to see if an rpm was installed manually or installed from a repo?

Title pretty much sums it up, but I'm looking for an rpm or yum command to see if an installed package was installed from the repos (if repo, which repo?), or manually.
3
votes
2answers
2k views

RHEL5.5 yum can't see a package (xen) on repo?

hi i'm trying to install xen via yum on RHEL 5.5. When i browse the repo here: http://ftp.redhat.com/pub/redhat/linux/enterprise/5Server/en/os/SRPMS/ I can see the package i want. specifically ...
2
votes
4answers
10k views

How do I use RPM to install GCC from my CentOS distribution media?

I have a few package installation related questions concerning RPM, YUM and CentOS and getting GCC installed: I've mounted my distribution media on my CentOS 5.2 machine but I can't seem to work out ...
2
votes
4answers
4k views

Package management on Mac OS X

Can anyone recommend a package management tool like apt-get or yum for Mac OS X? I've seen that Fink has ported apt-get to Mac OS X, is this a good way to go, or are there other/better options out ...
2
votes
2answers
319 views

Find (un)used packages on CentOS/Fedora?

In short: From all the (rpm) packages installed I would like to identify the ones unused (for example since the last 6 months). In long: I have number of machines with a respectable service record. ...
2
votes
4answers
12k views

how do I update php on centOS?

I have php 5.1.6 installed on a centOS server, and I need at least 5.3.2 (but would rather install the latest available 5.* version). If I run yum update php it says it will update to ...
2
votes
2answers
14k views

CentOS Insufficient space in download directory /var/cache/yum/base/packages

I was trying to yum install libpcap when I got Error Downloading Packages: 14:libpcap-0.9.4-15.el5.i386: Insufficient space in download directory /var/cache/yum/base/packages * free 0 * ...
2
votes
4answers
122 views

Two Centos Machines. Wildly different updates

I have two CentOS linux servers. One is dev and the other is prod. Dev is internal only and prod is exposed on port 80. Both built at the same time and both configured pretty closely to the same with, ...
2
votes
1answer
4k views

Trying to remove packages with yum, however it is failing?

Trying to uninstall zarafa mail server. I use yum list installed to view the already isntalled packages. After which I use yum erase zarafa* It picks up all the packages but returns: Error in ...
2
votes
4answers
8k views

How can I keep the RHEL version static (e.g. RHEL 5.1)?

For compatibility with a program : I need to keep one of our servers in a specific version, for example rhel 5.1 I would like to keep it as updated as possible, but not to change versions. What ...
2
votes
2answers
132 views

Parametric ansible command based on facts, how to do it?

I am updating some of my ansible playbooks to run on the latest version of Fedora, that now uses dnf by default. Since most of my playbooks should run on CentOS as well, I would like my script to run ...
2
votes
5answers
8k views

Installing Python 2.7 broke “yum”

I installed Python 2.7 and pointed /usr/bin/python to /usr/local/bin/python2.7 After installing Python 2.7, I get the following error message every time I use yum > sudo yum install setuptools ...
2
votes
3answers
15k views

redhat yum install - GPG key retrieval failed

I was trying to yum install etckeeper on a Linux box. Details are as following. the installation failed at key retrieval. I am wondering why the key file is addressed as file:///etc/pki/. Isn't the ...
2
votes
2answers
3k views

On CentOS how do I get boost header files installed?

What CentOS 6 package name do I need to install boost header files: yum install boost doesn't seem to work. Is there a special compiler directive I need to use to point to the include files? Or is ...
2
votes
2answers
315 views

Centos : Configure yum to install from another machine in the network that has an outgoing connection

Using Centos 5.4 here and I have two machines on the same network but only one has access to the outside world. I want to install software using yum on one machine, and rather than download the ...
2
votes
1answer
256 views

Errors installing php extensions on Centos 7

I'm pretty sure I know what the problem is i just dont know how to fix it. Im trying to install mcrypt "yum install php-mcrypt" and i get the following error Error: Package: ...
2
votes
2answers
429 views

Why must yum update its repos on each command?

Doing anything with yum is frustratingly slow for me. For example, when searching for a package, finding it, and then trying to install it, both yum commands appear to run the exact same updates, just ...
2
votes
2answers
2k views

Installation of gearmand fails on libevent dependency

I've installed the PostgreSQL yum repo and have PostgreSQL running for some time now, but now when I try to install gearmand I get the following errors: Transaction Check Error: file ...
2
votes
2answers
1k views

How to only allow a package to be downloaded from a specific repository using Yum?

Context: We've got multiple custom-added yum repositories (on CentOS 6), and our users regularly install various/arbitrary software via yum to test things. We have a package that is available on ...
2
votes
3answers
5k views

How to force CentOS yum to use a later version of a package dependency already installed (php-common as a dependency of php-xml)

It would appear that the version I have of php-common-5.2.10-1.el5.centos is newer than the one being asked for as a dependency of php-xml when I try to install php-xml using yum install php-xml. The ...
2
votes
4answers
4k views

Updating OpenSSH to latest stable version via yum

I am running CentOS 5.7 and need to upgrade OpenSSH to the latest stable version (PCI compliance issues). However, the most recent version available via the CentOS yum repository is 4.3p2. How can I ...
2
votes
2answers
3k views

Difference between RPM (yum) and apt-get

Functional difference between the two? Packages different style or what? I'm dipping my toe in the server pool and playing with an Ubuntu install right now, which is apt-get. I'm also considering ...
2
votes
3answers
2k views

Pass --nogpgcheck to yum via puppet

How would one get a --nogpgcheck option to yum via puppet? I've tried package { 'unsigned-package': ensure => latest, install_options => ['--nogpgcheck'], } and package { ...
2
votes
2answers
2k views

Can you force yum to ignore an exclude list?

We are using a custom repository with RHEL 5.x. We were running into a ton of issues and conflicts when trying to run an update (issues with yum 32bit packages conflicting with x64 packages). To get ...
2
votes
1answer
3k views

Broken dependencies on CentOS 6.4: can install nodejs but not npm

I'm using a fresh installed CentOS 6.4 (x86-64) with the EPEL repository. $ yum install nodejs ... $ node -v v0.10.5 So far, so good, but when I try to install npm, I'll get this error message: $ ...
2
votes
2answers
2k views

yum-plugin-priorities: Which packages are excluded due to repository priority protections?

I am using multiple third party RPM repositories. Since these repos contain packages with conflicting names, I am experimenting with yum-plugin-priorities to sort out the confusion. When I run yum ...
2
votes
3answers
2k views

How can I get the git-all meta package on RHEL 6.2

I believe I'm missing some of the common git addons, such as gitk, and I suspect it is because I installed git using sudo yum install git as the information for that package lists: : The ...
2
votes
2answers
2k views

Installing lighttpd on CentOS 6.3 yum 404 errors

I have a CentOS 6.3 x86_64 server and I am trying to install lighttpd. I have installed the EPEL repo on the server using the following: rpm -Uvh ...
2
votes
1answer
743 views

yum: Difference between mysql, mysql-server and mysql-devel

What are the differences between the packages here? mysql, mysql-server and mysql-devel I am installing a SQL server to use with PHP, but I found these three packages and am not sure which to use.
2
votes
2answers
2k views

Upgrade mysql version

I am trying to upgrade mysql package to 5.5 on centos. (amazon image - ami-cc5af9a5) There is 5.1 version of mysql-libs that can not be uninstalled because postfix is dependent upon it. But I can not ...
2
votes
2answers
1k views

Installing chrome in Centos 6.2 (Final)

I need to install chrome in a dedicated centos server where I only access via ssh, it doesn't have X or any windows graphical stuff. I need it to be able to pack extensions using google-chrome ...
2
votes
3answers
1k views

Fresh install of RHEL 6.1 - yum failing to update

I'm getting some errors when trying to update some RHEL 6.1 64 bit servers with yum. I tried a fresh install of the OS and then ran yum -y upgrade and received the same errors that I was getting on my ...
2
votes
2answers
629 views

Upgrade CentOS 4.4 to 4.8

I'm new to CentOS, have mainly worked with FreeBSD. How do i update/upgrade CentOS from version 4.4 to 4.8 ? Update # yum upgrade Will this upgrade only minor or will it upgrade to 5.x ?
2
votes
1answer
1k views

Compile/Configure Options of a Yum Package (RPM)

Is it possible to get the compile options of a yum package? In this particular case, I am trying to get them for the standard BIND installation with CentOS, but if there is a generic way for YUM ...
2
votes
3answers
370 views

Can I mix yum and apt-get safely?

I understand that yum and apt-get operate on top of rpm, so that the data about installed packages in a linux system is responsability of rpm; so that neither yum nor apt-get keep their own data about ...