YUM is an open-source command-line package-management utility for RPM-compatible Linux operating systems.

learn more… | top users | synonyms

1
vote
1answer
123 views

Centos :: Can't remove / delete package

On my server I'm running PHP 5.5.1. I would like to install php-gd, but when I'm trying to install it, it always says: yum install php-gd Loaded plugins: fastestmirror Loading mirror speeds from ...
0
votes
2answers
83 views

Why yum will not modify php.ini? [closed]

Please bear with me. I think my question is so stupid, it may be the reason I cannot find the answer on the web. I need to use a PHP function called mcrypt_encrypt(). So I take a look at php.ini to ...
0
votes
2answers
2k views

How to install MariaDB rpms in CentOS 6.4 using rpm (not yum cmd) + handling mysql-libs conflicts

I need to script the install of MariaDB using the rpm command in CentOS 6.4. I can't use yum since it's going to be an offline install so there's no access to the repository. The only MySQL package ...
1
vote
4answers
3k views

Not able to install mysql/mysql-server with yum in Centos 6.4 64bit

It worked initially (yum install mysql mysql-server), and now it won't. I removed the working mysql from the repo with yum remove mysql mysql-server and tried to install from rpm source from the ...
1
vote
1answer
198 views

AWS Amazon Linux MySQL Yum Update Failure

I SSH'd into my AWS EC2 instance using an Amazon Linux AMI, and it told me to run the sudo yum update command for security updates. When I did, it ultimately failed to update MySQL. *I don't know if ...
0
votes
1answer
287 views

Automating Unbreakable Linux Network (ULN) registration

To register a RHEL 6.4 machine to the Unbreakable Linux Network (ULN), it is required to launch the uln_register command. This command opens a textual interface, where the user has to input the ULN ...
1
vote
1answer
127 views

Cannot install any package using yum

Whenever I try to install any package using yum i get the error as "Operation too slow. Less than 1 bytes/sec transfered the last 30 seconds" Can anyone tell me why is this happening to me? I have ...
3
votes
1answer
725 views

Fedora19: YUM glibc is a duplicate of glibc

I'm using Fedora 19, when I'm trying to perform a yum update, I get the following error. yum update: Failed to set locale, defaulting to C Loaded plugins: langpacks, refresh-packagekit Resolving ...
1
vote
1answer
975 views

PHP-ZMQ pecl installation error - Unable to find libzmq installation

I've run below shell command as per ZeroMQ website to install PHP-ZMQ: sudo pear channel-discover pear.zero.mq sudo pecl install pear.zero.mq/zmq-beta Below are traces for the installation: ...
1
vote
2answers
681 views

CentOS 6 missing dependencies for default PHP

I have a brand new Dedi install of CentOS 6 x86_64, nothing has been done to it but install rpmforge and htop. Other than that we are default, well as default as GoDaddy gives which is garbage ha ha. ...
2
votes
1answer
109 views

yum and command line field

I'm reading the official documentation of Red Hat 6 (Deployment Guide) where in chapter 6 about yum they use the following command to show transactions: yum history info (id) this command should ...
0
votes
3answers
1k views

newer libmysqlclient.so creates a conflicts with a php-mysql install

I have a working MySQL 5.6 server on a CentOS 6.4 I'm trying tp get PHP working as well, and to create a connection to the MySQL. As I understand I need the following components : php and php-mysql ...
2
votes
3answers
348 views

Centos: How to install all packages of one server on another?

I've done rpm -qa > file and now I want to copy the file to another server and run through it and install all these packages on the new server. I did something like this: for pkg incat file; do yum ...
2
votes
2answers
103 views

Fresh Red Hat 6.4 kickstarts out-of-date

I am using an updated rhel-x86_64-server-6.4 channel to kickstart RHEL 6.4. What can explain servers being kickstarted with an out-of-date RHEL? I would like to kickstart the server with the latest ...
0
votes
3answers
568 views

Yum configuration through a proxy necessary?

I'm trying to get my yum configuration to work again but it stops at the following: yum update--verbose Config time:0.091 Yum Version: 3.2.22 Setting up Package Sacks Loading mirror speeds ...
1
vote
1answer
227 views

yum update fails to unpack archives for nodejs dependencies on centos 6.4

I run "yum update" on my CentOS 6.4, but the Node.js package and dependencies fail with multiple errors like this: Error unpacking rpm package nodejs-fstream-0.1.23-1.el6.noarch error: unpacking of ...
1
vote
1answer
119 views

Remove old puppet repo configuration

I want to consolidate my repository into a new repository structure and I have this working in Puppet. However, the old yum repository information still remains on the nodes. Can puppet force the ...
1
vote
2answers
527 views

Can you force yum to ignore an exclude list?

We are using a custom repository with RHEL 5.x. We were running into a ton of issues and conflicts when trying to run an update (issues with yum 32bit packages conflicting with x64 packages). To get ...
1
vote
3answers
757 views

EPEL broken package : How do I reach to EPEL maintainer?

.. it looks like at least two of packages that comes from EPEL is broken: [alexus@wcmisdlin02 ~]$ sudo yum update --skip-broken Loaded plugins: refresh-packagekit, security Setting up Update Process ...
1
vote
1answer
102 views

yum - If local mirror is down, stop

I've finally gotten around to creating a local mirror, and due to a 'locked' symlink I can now run yum update on all machines and get them to pull the same packages etc so they are all in sync no ...
0
votes
2answers
1k views

Install xmlsec on CentOS

I installed xmlsec and it keeps giving me an error when I try to verify an XML document. yum install xmlsec1 yum install xmlsec1-openssl [vagrant@localhost SSO-ROR-development]$ xmlsec1 --verify ...
3
votes
2answers
386 views

CentOS 6.x — how to find required package to install?

I'm not that experience with Linux, but I'm trying to install some software on 64-bit CentOS 6.3 that requires the following packages (copying them exactly as written in the documentation stating ...
-1
votes
1answer
170 views

Fedora update fails for “filesystem” package

I have Fedora 19 currently installed and the filesystem package has shown up in the updates. I find it a little peculiar on how to actually update the filesystem package. Running transaction ...
0
votes
3answers
6k views

redhat yum install - GPG key retrieval failed

I was trying to yum install etckeeper on a Linux box. Details are as following. the installation failed at key retrieval. I am wondering why the key file is addressed as file:///etc/pki/. Isn't the ...
2
votes
1answer
333 views

Yum repo lists incorrect size for packages larger than 2GB

I'm using createrepo to create my yum repository. However, it seems to have a bug - one of my packages, which is 11GB in size, is incorrectly shown as just 956 MB when I try to do a yum install ...
0
votes
3answers
838 views

Upgrade from php53 to php53u (epel to IUS repositories) - Centos 6.4

I want to upgrade my CentOS 6.4 server from php53 (epel repository) to php53u (ius repository). I already enabled the ius repository, but am hesitant to just play around because there are production ...
1
vote
1answer
473 views

Yum install libyaml has depsolving problems

Trying to get ruby up and running on a centos 5 box. yum install libyaml-devel Loaded plugins: fastestmirror Repository base is listed more than once in the configuration Repository updates is listed ...
1
vote
1answer
134 views

How do I make groupinstall work on XenServer 6.2?

I have a XenServer system that I'm wanting to add some extra packages to. The problem I have is that XenServer is based on a stripped down CentOS 5.6 installation and the command "yum grouplist" ...
6
votes
4answers
1k views

I deleted libssl.so.10

I cannot apt-get, I deleted libssl.so.10 most commands including wget give me something to the ends of libssl.so.10: cannot open shared object file: No such file or directory is there a reliable way ...
6
votes
2answers
116 views

During yum update, Python installation is updated. Do I need to restart running programs?

As the title says. If I run yum update(It's a CentOS box) and there happens to be a Python update. What happens if other users have running Python programs. Do I need to alert them to restart the ...
0
votes
1answer
76 views

Linux - Is it possible to share same yum versionlock.list with multiple servers?

I am trying to puppetize a versionlock.list so that packages like PHP and MySQL are versionlocked no matter which machine is doing the install. However I am noticing some inconsistent behavior. On ...
-1
votes
2answers
136 views

Installing php extension with yum [closed]

I'm very new to Linux and yum. I need to install a php extension (ioncube loader) using yum, but I'm not sure how exactly this is done. I'm going off this article, which tells me I need to run the ...
2
votes
2answers
4k views

XenServer 6.2 Yum Repository

I installed a clean XenServer 6.2 from the ISOs provided here. I want to compile a driver against this system and need to install make and sources and so on. If I do yum install make I get ...
2
votes
2answers
1k views

Recover CentOS missing YUM and RPM

This is the history: I have (or had), a linux box with CentOS 5.9 and a pre installed LAMP configuration. It was working but was too out of date, for instance mysql was version 4. So I decided to ...
1
vote
2answers
653 views

Getting Linux error while installing phpmyadmin in centos

When i am trying yum install phpmyadmin then i get this error Error: Package: php-gd-5.3.3-22.el6.x86_64 (base) Requires: php-common(x86-64) = 5.3.3-22.el6 Installed: ...
4
votes
1answer
124 views

How to prevent installation of incompatible rpm packages

I have two rpm packages wich should not get installed together. After googling around i assume there is no RequiresNot tag or something similar to specify incompatible packages in a specfile. What ...
-4
votes
1answer
237 views

Downgrade Openssh on RHEL6 [closed]

Is it ok to downgrade openssh from 5.3 to 4.3 in rhel6 as we are facing compatibility issue between openssh 3.1 client and openssh 5.3 server(SCP file transfer hangs). Please we cannot upgrade ...
3
votes
1answer
105 views

How to manage a home-grown YUM package repo?

There are plenty of websites that explain how to manage a mirror of YUM repos. I want to run a repo for my home-grown packages. Is there a good way to manage such repos? What I need to do: Manage ...
0
votes
1answer
40 views

Is ius's epel the same repository as fedoralprojects?

Are the following the same repository? Thanks http://fedoraproject.org/wiki/EPEL http://dl.iuscommunity.org/pub/ius/stable/Redhat/6/x86_64/repoview/epel-release.html
0
votes
1answer
141 views

Having trouble installing php_mbstring on CentOS system

So the new CentOS VPS didn't come with mbstring enabled. Easy enough, right? I typed 'yum install php-mbstring' It then says "Error: Nothing to do." The only thing I can figure is that I'm missing ...
0
votes
1answer
142 views

Listing which repository a package will be installed from using yum [duplicate]

I am trying to run yum completely from local repositories. How do I tell if yum is using some other repositories? Is there a way to list the locations from which yum is getting the package?
1
vote
0answers
80 views

Ordering RPM virtual packages

I have following packages, built by my RPM spec: libevent backend %package -n libfoo-libevent Summary: libevent backend for FOO Provides: libfoo-backend Requires: libevent >= 1.4 libev backend ...
1
vote
2answers
874 views

Install Tomcat5 on CentOS 6.4

I'm trying to port an old application to a new server and need to install Tomcat5 on CentOS 6.4. This is apparently not a straightforward task. When I try: yum install tomcat5 tomcat5-admin-webapps ...
5
votes
1answer
7k views

How to install Apache Benchmark on CentOS?

I try to install Apache Benchmark using Is there a way to install Apache Bench (ab) without installing apache solutions on my centos but when i run yumdownloader httpd, i get error: root@local ...
-1
votes
1answer
29 views

Versions of Package with YUM

I want to know which versions of the same package were previously installed with YUM. For example if I have a package that it version is 4.0, I should need to know the previously versions installed
1
vote
1answer
47 views

Long term security risks of rarely updated nginx

We've deployed a system at a university using a stack of Postgres, Nginx and Django on (mandated) RHEL. The ITS department is now pressuring us to switch to Apache on order to benefit from regular ...
4
votes
1answer
53 views

How to get transaction history for yum?

I would like to know how to get the transaction history of yum (i.e. get the installations, deletions, etc.), hopefully ordered from most to least recent. Is there a way to accomplish this? Thanks ...
2
votes
1answer
3k views

Broken dependencies on CentOS 6.4: can install nodejs but not npm

I'm using a fresh installed CentOS 6.4 (x86-64) with the EPEL repository. $ yum install nodejs ... $ node -v v0.10.5 So far, so good, but when I try to install npm, I'll get this error message: $ ...
0
votes
3answers
936 views

Nginx yum update checksum error on CentOS5 for CentOS6 package

I'm getting checksum error when doing Yum update due to Yum looking for Nginx package from CentOS 6 repo (I'm using Centos 5.6). Below is the error: ...
2
votes
1answer
415 views

Windows Azure Centos image: Cannot upgrade to 6.4

I am using the Openlogic Centos image provided by Windows Azure. I have tried many times but when I run yum update it always said no packages marked for update, and the centos version is still 6.3. I ...