YUM is an open-source command-line package-management utility for RPM-compatible Linux operating systems.

learn more… | top users | synonyms

2
votes
0answers
104 views

yum-complete-transaction in a crazy loop

I was trying to update a server that I have with yum update and it aborted because the server ran out of memory. I killed off a few processes that were not needed and ran yum-complete-transaction but ...
2
votes
0answers
167 views

how to keep a rpm package during system upgrade?

I have a custom built rpm package which I installed manually (via rpm -Uvh / or yum localinstall). If I do an upgradee from CentOS5 to CentOS6 this package is removed and, because it missing in the ...
2
votes
0answers
1k views

Yum install on CentOS 6.2

I can't install any php extension Epel repository enabled Yum is updated yum repolist shows repo id repo name ...
1
vote
0answers
16 views

We have multiple repos having same package. IF we do yum install package, install from stable repo and yum install package-version install other repo

We've got multiple custom-added yum repositories (on CentOS 6), We have a package that is available on multiple repositories. It's named the exact same thing on two different repositories, call them ...
1
vote
0answers
96 views

CentOS 5.11: yum installs, but packages remain missing

I'm trying to figure out a very strange problem with yum on a fairly old CentOS 5.11 VPS using DirectAdmin. Executing the following command suggests the telnet package is installed: # yum install ...
1
vote
0answers
92 views

RHEL yum broken

I have RHEL which is deployed from Amazon AMI, and yum is somehow broken. I must use that AMI because of corporate software installed on it. There is no way to rollback to previous state. This is the ...
1
vote
0answers
421 views

AWS yum does not work from private subnet (does work from public)

I have a VPC with a private and a public subnet - each containing an identically built RHEL7 server. I believe the VPC is set up correctly (see following). However, the public server can use yum and ...
1
vote
0answers
35 views

Apt and package conflicts

I have spent some time researching, and as I could not find anyone with the same issue I figured I might as well ask. I have two packages X and X-1. X-1 is essentially an upgrade from the previous ...
1
vote
0answers
64 views

Library Dependency is different when checked via yum vs. rpm

I'm new here and am debugging something I've never seen before, so I'm hoping someone can show me where I'm going wrong. I've created a local yum repo for all my servers. The idea is to distribute ...
1
vote
0answers
85 views

Cannot install mysql server - Error in PREIN scriptlet in rpm package mysql55-mysql-server-5.5.32-3.el5.x86_64

I am trying to install mysql server 5.5 (or any 5.x versions) on Redhat 5.5 and am having some trouble. I can install the other mysql components but when I try to install mysql-server (or ...
1
vote
0answers
149 views

Getting a specific CentOS base image with mkimage-yum.sh

Docker's mkimage-yum.sh does indeed work (awesome little script) but it pulls 6.6 (the latest with updates). I was wondering if it's possible to specify 6.5. I believe I can use yum.conf but the yum ...
1
vote
0answers
270 views

MySQL 5.6 Community Server failed to start in CentOS 6

MySQL 5.6 Community Server failed to start on CentOS 6. Before, I have successfully installed mysql community server (file: mysql-community-release-el6-5.noarch.rpm) on my CentOS 6, the binary source ...
1
vote
0answers
80 views

How best to maintain a recent bash version on amazon linux?

I require Bash 4.2 or higher. Amazon Linux default repositories only provide Bash 4.1. I have done some searches and can not find a yum repository for recent versions of Bash. I don't want to compile ...
1
vote
0answers
79 views

How to stop meta-rpm transaction if a precondition fails?

I currently have a meta-package rpm which contains a list of dependencies on other rpm packages. I want to stop the update/install transaction of the meta-package (and all subsequent packages) if the ...
1
vote
0answers
2k views

How to install latest Tomcat7 using yum on AWS EC2?

I'd like to install the latest (7.0.53) Tomcat on an AWS EC2 instance running Amazon Linux. If I were to do "sudo yum install tomcat7 -y", I would only get version 7.0.47, as shown by " yum list ...
1
vote
0answers
344 views

Oracle's JDK RPM doesn't provide “java”

I have the Oracle RPM for the Java 7 JDK installed on an Amazon EC2 instance. The Oracle RPMs for Java 7 JDK don't "provide" java nor jre. RPM reports that it provides the following: # rpm -q jdk ...
1
vote
0answers
160 views

PHP upgrade always breaks session folder permissions

Every time I upgrade php (via yum upgrade) on my CentOS box, my /var/lib/session folder ownership becomes root:apache with 600 permissions. I use nginx as my web server. This breaks my site and ...
1
vote
0answers
152 views

How to downgrade OpenSSL on Amazon EC2

I'm using a version of the Amazon Linux AMI (v 2013.03) that comes with OpenSSL 1.0.1 installed as described here: http://aws.amazon.com/amazon-linux-ami/2013.03-release-notes/. I have an application ...
1
vote
0answers
157 views

Cannot install yum on CentOS 5.3, 64bits

I'm facing a problem with installing yum in CentOS (version 5.3, 64bits). My CentOS yum is not preinstalled, so I can't install other package that I need. I found out one article that show how to ...
1
vote
0answers
276 views

Cobbler import of RHEL6 DVD doesn't seem to create yum repo

I setup cobbler (2.4.0) and imported the RHEL6.4 DVD. It copies all of the packages over to /var/www/cobbler/ks_mirror/RHEL6.4-x86_64. It even runs createrepo and loads the metadata, etc. So you ...
1
vote
0answers
523 views

Yum History and History Undo in Centos 6

I have a Centos 6 server and I have upgraded several packages. I can, supposedly, downgrade them with yum history undo <packageName> but all I get is downgrade failed for every single package. ...
1
vote
0answers
590 views

gcc46 and no c compiler found on Amazon EC2

I've been trying to install Gearman on my EC2 instance, but when I try to ./configure gearmand, I get this: checking build system type... x86_64-unknown-linux-gnu checking host system type... ...
1
vote
0answers
78 views

Removed and then reinstalled php-common via yum. Now no virtual hosts?

Using yum I wanted to install the php-gdlibrary, however there was a dependency issue with php-common preventing me from installing php-gd. So after some digging I found this article on SO. I followed ...
1
vote
0answers
1k views

“yum clean” hangs - what to try next?

I run a number of CentOS servers. I was recently doing the occasional yum update but this failed on a handful of the servers. On most I have been able to move forward by doing: # yum clean all # rm ...
1
vote
0answers
170 views

Performing yum update on an OpenVZ host

My company runs a handful of OpenVZ servers (HN) and hosts all the server as containers on these HNs. We have done some pentest and found out we have to do update the kernel on the HNs to resolve a ...
1
vote
0answers
1k views

Fixing problems with yum, urllib2, and missing dependencies?

I've been trying to resolve the following problem with yum / python's urllib2: [root@...]# yum Traceback (most recent call last): File "/usr/bin/yum", line 4, in ? import yum File ...
0
votes
0answers
6 views

Amazon EBS install VNC/GUI using .ebextensions yum package

Anyone have a view on whether it is possible to install a GUI and VNC server on instances created using EBS - probably via a YUM file? - is there any reason why this wouldn't work and, if not, how ...
0
votes
0answers
39 views

Installing Google Chrome on Amazon Linux

I am trying to install the latest version of Google Chrome on Amazon Linux using yum. As far as I can tell Amazon Linux is based on RHEL/Centos however, it doesn't look like Google support this ...
0
votes
0answers
16 views

How can I version control a mirrored upstream repository?

I manage many servers that span multiple environments (dev, qa, staging, and production). To help manage these, we have multiple repositories on a local webserver for our applications (e.g. app_1_el6, ...
0
votes
0answers
73 views

CLOUDLINUX 6.6 x86_64 YUM error

I am getting the following error after running a yum update which failed and then running yum-complete-transaction: Skipping the running kernel: kernel-2.6.32-531.29.2.lve1.3.11.1.el6.x86_64 --> ...
0
votes
0answers
68 views

yum + what is the message - No package ansible available

I am try to install the ansible tool on my linux red-hat version - 5.7 yum install ansible Loaded plugins: security Setting up Install Process No package ansible available. Nothing to do ansible ...
0
votes
0answers
38 views

Different versions of glibc RedHat

Before I jump into the issue, I am using RedHat 6.5 and have no access to the internet to download yum updates due to environment restrictions. All I have in this case is the CD ROM (RHEL 6.5) to ...
0
votes
0answers
58 views

Installing Redis on CentOS 6.6 final - no package available

I've added the "EPEL" repo: Loaded plugins: changelog, downloadonly, fastestmirror, presto Loading mirror speeds from cached hostfile * elrepo: repos.mia.lax-noc.com * epel: epel.gtdinternet.com * ...
0
votes
0answers
7 views

Connect a redhat server that is under a vpn to internet

I have to configure the environments of like 10 redhat servers(dbs, stash, test, dev, production), but those servers are under a VPN and they have no internet access, I can connect my company mac to ...
0
votes
0answers
40 views

install boost 1.51 package on centos 7

I'm trying to compile a program which requires boost 1.51, but the only available boost package via yum on my system is boost 1.53. I would prefer to install boost using the system's package manager, ...
0
votes
0answers
77 views

libgcc multilib version - unable to install any package with yum

System: Red Hat 6.5 I have a problem with libgcc, which is apparently installed in 2 different versions on my machine. Anyway, when I try to install literally anything, I am unable to do so, because ...
0
votes
0answers
99 views

Yum dependency issue with newer release version

I'm having an issue installing some software with yum, it shows a dependency issue even though all the packages are installed. I'm trying to install the redhead-lsb package. I get the following ...
0
votes
0answers
62 views

Solved but Confused: Fedora 19 to 20 - “Protected multilib versions: chkconfig”

Initial Problem When upgrading from Fedora 19 to 20 using this command: yum --releasever=20 --setopt=deltarpm=0 distro-sync I get the following error Error: Multilib version problems found. This ...
0
votes
0answers
70 views

yum list available - not showing all packages

I have a strange problem with yum, working on one server and not working on another server that should be identical. The symptom is that after running createrepo on a directory containing RPMs (and ...
0
votes
0answers
44 views

Lost network connectivity after a “yum -y update”

I've a server on Centos 6.5 and after a yum -y update we've lost all connectivity on it, the only access we have is on shell thru SolusVM serial console, I've tried everything (SFTP, SCP) on my reach ...
0
votes
0answers
588 views

CentOS 6: Apache 2.4 drop-in replacement for Apache 2.2 via yum?

I've a CentOS 6.6 installation with the stock Apache 2.2 package. I need to upgrade it to Apache 2.4, but I want a true drop-in replacement for the installed package, not something that goes into /opt ...
0
votes
0answers
126 views

RHEL6 yum 'ascii' codec can't decode

I went to upgrade my RHEL5 to RHEL6, without problem. I've got just a little cosmetic warning as : # yum update Modules complémentaires chargés : product-id, security, subscription-manager 'ascii' ...
0
votes
0answers
22 views

Using yum-builddep instead of yum install in Puppet

Is there a simple way to change the default behaviour of yum when installing packages to for instance instead of doing a yum install instead use yum-builddep to install only the dependencies of a ...
0
votes
0answers
372 views

No version specified, and no candidate version available for mysql

I'm trying to install MySQL using Chef on CentOS 6.5. I've got the repositories in place. -rw-r--r--. 1 root root 256 Oct 15 16:59 centos-base.repo -rw-r--r--. 1 root root 267 Oct 15 16:59 ...
0
votes
0answers
76 views

Apache tomcat server for yum repo

I have a system that currently has apache tomcat on it (RHEL 6.5). I also want to make a yum update repo on this system for other systems on the network (also RHEL 6.5). I know I can use the apache ...
0
votes
0answers
69 views

yum remove package freeze while erasing

I'm using CentOS 6.5 on a server. Some time ago, I installed from a third-party repository Newscoop CMS. Now I'm not able to remove it. yum remove newscoop Freeze at the "erasing" point, shutting ...
0
votes
0answers
92 views

Producing RPMs that conflict with all versions released by someone else?

I find myself needing to create a variant of the PostgreSQL packages that are mostly compatible with the official http://yum.postgresql.org/ packages. My packages are compatible with client apps that ...
0
votes
0answers
87 views

Install tuleap on amazon ec2 linux AMI

I'd like to know if it's possible to install tuleap on amazon ec2 linux ami. I searched the net unsuccessfully and when I try to install tuleap with yum, I got confilcts error (with httpd24, ...
0
votes
0answers
132 views

RedHat Yum Install Errors (PHP Module)

All, I am trying to use yum to install a PHP module which I expected to take all of five minutes... After quite a bit more than that I am stumped. Yum is throwing an error about a dependency missing ...
0
votes
0answers
279 views

Yum update coreutils failed

I got error update coreutils. Here is console log root@server70 [~]# yum update coreutils Loaded plugins: fastestmirror, refresh-packagekit, rhnplugin Loading mirror speeds from cached hostfile ...