Tagged Questions

YUM is an open-source command-line package-management utility for RPM-compatible Linux operating systems.

learn more… | top users | synonyms

-2
votes
0answers
21 views

removed python2, can't connect any more

I'm new to CentOS (6). I removed python with sudo yum remove python2 (big mistake, I know) and now I can't connect to my server any more. I know that I need to reinstall python, but I don't know how ...
0
votes
0answers
16 views

Skype installation on fedora 20 fails [migrated]

I'm trying to install skype version 4.3.0.37 and it keeps giving me this error: Protected multilib versions: libwayland-server-1.2.0-3.fc20.i686 != libwayland-server-1.5.0-4.el7.nux.x86_64 Error: ...
1
vote
1answer
34 views

yum install proftpd error

I used proftpd for years on this year. but I got an error when I update proftpd today. I am using CentOS 5.11. [root@server11 yum.repos.d]# yum install proftpd Dependencies Resolved ...
6
votes
1answer
75 views
+100

Redhat 7 desktop to workstation

I installed a RedHat out of an installation cd, registered my entitlements, all that stuff. As part of my subscriptions I have both Red Hat Enterprise Linux Workstation and Red Hat Enterprise Linux ...
0
votes
2answers
45 views

I broke yum — Can't do anything

I was trying to follow a tutorial for installing yaffas (zarafa-admin) and I went to install the packages and got failed checksum errors for EVERY mirror. So after about 15 mirrors, I just hit CTRL+C ...
0
votes
1answer
21 views

No package php5-intl available RHEL

I'm trying to install php5-intl on Red Hat but cannot seem to find the package. I run yum install php5-install and get the error No package php5-intl available. Is there a different repository I need? ...
0
votes
0answers
22 views

No version specified, and no candidate version available for mysql

I'm trying to install MySQL using Chef on CentOS 6.5. I've got the repositories in place. -rw-r--r--. 1 root root 256 Oct 15 16:59 centos-base.repo -rw-r--r--. 1 root root 267 Oct 15 16:59 ...
1
vote
0answers
20 views

How to stop meta-rpm transaction if a precondition fails?

I currently have a meta-package rpm which contains a list of dependencies on other rpm packages. I want to stop the update/install transaction of the meta-package (and all subsequent packages) if the ...
1
vote
2answers
98 views

EPEL Repo for CentOS 6 causing error

I've got a VM running CentOS 6 (64bit) and I'm attempting to add the EPEL repo like usual to install various packages as I do quite regularly. Today, I'm experiencing some strange errors yet I'm ...
0
votes
1answer
65 views

How to upgrade version of an installed package on CentOS 6.5

I installed libtiff by command yum install libtiff-devel.x86_64 which installed ver 3.9.4. [anthony@server ~]$ sudo yum list installed | grep "libtiff" libtiff.x86_64 ...
0
votes
1answer
32 views

yum downloadonly does not get all rpms needed for network free upgrade

I need a method to install all the rpms and their dependencies that this client needs to get a php app running. The client does not want to connect their fedora server to the internet. I tried doing ...
0
votes
1answer
47 views

Yum php-yaml install issues

We had an issue with an ansible playbook using vagrant - where formerly php-yaml was installing fine. Then, we were getting issues with our PHP repo: [vagrant@localhost ~]$ sudo yum install php-yaml ...
0
votes
0answers
26 views

Apache tomcat server for yum repo

I have a system that currently has apache tomcat on it (RHEL 6.5). I also want to make a yum update repo on this system for other systems on the network (also RHEL 6.5). I know I can use the apache ...
0
votes
2answers
37 views

How do I update YUM repositories to get Postgres9.x version?

I need to install some Postgres9.1 libs, but "yum list" only shows 8.4 version. How to "update" yum repo list to get 9.1 version? My Linux version: # cat /etc/redhat-release Red Hat Enterprise ...
-3
votes
1answer
37 views

How does “yum info” work? [closed]

I want to know how the yum info command works. I know yum info will display information about the installed package, but I really want to know which file it reads for that information. Whether it's ...
0
votes
1answer
134 views

How do I update bash on RHEL5 servers with expired contracts? [duplicate]

I have two servers with expired contracts that are both vulnerable to shellshock. I am in the process of migrating both to new servers with RHEL6 or greater depending when I get this done. That ...
0
votes
2answers
43 views

Cannot install mysql-devel on centos

Everytime I try to run sudo yum install mysql-devel I am met with the following error: Setting up Install Process Resolving Dependencies --> Running transaction check ---> Package ...
0
votes
0answers
23 views

yum remove package freeze while erasing

I'm using CentOS 6.5 on a server. Some time ago, I installed from a third-party repository Newscoop CMS. Now I'm not able to remove it. yum remove newscoop Freeze at the "erasing" point, shutting ...
0
votes
1answer
20 views

rpm package conflicts with itself in yum

I prepared custom package platform-6-1.2.3-1.x86_64. I want it to be conflicting with every OTHER plat-6 package installed in the system. Files of the package are not conflicting with the others ...
1
vote
1answer
111 views

CentOS fails to update Bash

I'm trying to patch my server against the Shellshock vulnerability issue. However, I'm unable to update Bash to a safe version, these are the results I'm getting: # yum update bash Loaded plugins: ...
0
votes
2answers
152 views

bash stuck at 3.2-24.el5 (Redhat)

I'm trying to update bash on our Red Hat Enterprise Linux Server release 5.6 server. But it won't find an update later than "3.2-24.el5". I've check and it is vulnerable for the shellshock ...
0
votes
1answer
80 views

Do CentOS 4 yum Repositories Exist Anywhere

I am trying (somewhat desperately) to convert an RHEL 4 server with no RedHat contract to CentOS 4 preparatory to upgrading it to CentOS 5 because "shellshock." I am following the instructions found ...
5
votes
1answer
2k views

Why are some CentOS 5 boxes still vulnerable to ShellShock after upgrading Bash?

I have two CentOS 5.10 boxen where I have upgraded bash to the latest version. However, in one of the boxes, bash is still vulnerable to CVE-2014-7169 (I am using the test from this ServerFault ...
0
votes
1answer
55 views

Sudo yum update errors

I recently tried installing HHVM on my Centos VPS today without luck. I then tried to update my VPS and received the following errors below. I'm quite new to the command line so I don't have a clue as ...
1
vote
0answers
30 views

yum-complete-transaction in a crazy loop

I was trying to update a server that I have with yum update and it aborted because the server ran out of memory. I killed off a few processes that were not needed and ran yum-complete-transaction but ...
-7
votes
1answer
75 views

Use puppet to update Yum repository [closed]

I have just started working on puppet and successfully installed the master server and agents. As part of my test, I am of the understanding that Puppet can replicate my configuration to the different ...
0
votes
0answers
23 views

Producing RPMs that conflict with all versions released by someone else?

I find myself needing to create a variant of the PostgreSQL packages that are mostly compatible with the official http://yum.postgresql.org/ packages. My packages are compatible with client apps that ...
2
votes
1answer
69 views

What is yum “running transaction test”?

There are many questions and answers on the internet about the "Running transaction test" notice which appears after a yum update. These questions usually concern what to do if it gets stuck. My ...
0
votes
0answers
31 views

Install tuleap on amazon ec2 linux AMI

I'd like to know if it's possible to install tuleap on amazon ec2 linux ami. I searched the net unsuccessfully and when I try to install tuleap with yum, I got confilcts error (with httpd24, ...
-2
votes
1answer
23 views

What is D option in linux yum assisted install?

When I install something with yum installer on linux, I get something like this: Is this ok [y/d/N]: _ So... what is the "D" option?
1
vote
1answer
57 views

Difference between rpm php and php54 packages from remi repo

I am doing some system automation where we need php 54. We install this from the remi repo. I can't tell what's different other than size in the two below: ...
3
votes
1answer
90 views

RHEL/CentOS - Is it possible to update packages only up to a certain release date?

Technically speaking, if one wanted to update a RHEL or CentOS server using yum, but only up to a certain release date (i.e. don't install any updates released after X date), would it be possible and ...
0
votes
2answers
125 views

Upgrade R to 3.1.1 on ec2 via yum

I have an ec2 instance with an older version (3.0.2) of R that I'm trying to update to the latest (3.1.1). This is not available in the default yum repo, but is available under EPEL. The installed ...
0
votes
0answers
91 views

RedHat Yum Install Errors (PHP Module)

All, I am trying to use yum to install a PHP module which I expected to take all of five minutes... After quite a bit more than that I am stumped. Yum is throwing an error about a dependency missing ...
0
votes
0answers
92 views

Yum update coreutils failed

I got error update coreutils. Here is console log root@server70 [~]# yum update coreutils Loaded plugins: fastestmirror, refresh-packagekit, rhnplugin Loading mirror speeds from cached hostfile ...
0
votes
1answer
57 views

rebuild yum index on aws s3

I am trying to rebuild yum repo on aws S3 after adding new packages. Here are few commands I am trying, but it is not helping. [root@chucks ~]$ createrepo --baseurl ...
2
votes
3answers
555 views

CentOS 6.5 new Kernel not active after reboot

Today I was running some yum updates and wanted to verify that everything went through fine by making sure I had a new kernel. To my surprise I noticed that CentOS was still running ...
0
votes
1answer
54 views

yum update rpm packages installed manually

I needed to install the libxml 2.7 package and for this i uninstalled yum (yum have dependencies on libxml), is there any way I can make the pass to work with yum rpm packages installed previously? I ...
0
votes
1answer
104 views

Yum problems with easy apache - The server’s system package manager, ‘YUM’, failed.?

I keep getting the following error on easy appache !! The server’s system package manager, ‘YUM’, failed. ! !! This is the command that failed: yum -y install gettext automake19 libstdc++.x86_64 ...
1
vote
2answers
958 views

CentOS 6 Yum update issue

I get this error when I try and run 'yum-complete-transaction' in shell: [root@namesvr ~]# yum-complete-transaction Loaded plugins: fastestmirror mirror speeds from cached hostfile Loading mirror ...
0
votes
1answer
23 views

How can I create a yum repository from downloaded packages? [duplicate]

How can one setup local yum repository using the downloaded rpm packages? This is a note to self. I am not sure if this good way, but I am trying nevertheless.
1
vote
1answer
48 views

Create yum variable, that is the result of a command?

To clarify, I am looking on how to store a yum variable as the RESULT of a command. The command I use to get the OS version is irrelevant to me, I'm sure there are better ways of getting it than what ...
0
votes
1answer
91 views

Spacewalk (satellite) activation refresh child channels on client

We have a (spacewalk) rhn satellite server running and several hundred machines registered with it with a few activation keys. Each of these keys have one or more child channels. We need to know how ...
-2
votes
1answer
401 views

sudo yum install httpd is throwing errors

Hello this is the command im typing and its returning the error you see, any suggestions please [ec2-user@ip-172-31-41-46 ~]$ sudo yum install httpd Loaded plugins: priorities, update-motd, ...
0
votes
1answer
143 views

Yum updates for CentOS by OpenLogic fails on Microsoft Azure

Earlier today I made a fresh install of CentOS in Azure from images provided by OpenLogic. When I try to update the system with yum update, I get: Loaded plugins: security ...
0
votes
0answers
336 views

having problems updating yum on my centos 6.5 final system

[root@spanky ~]# yum update rpmdb: read: 0x7fff4032cbd0, 512: Input/output error rpmdb: /var/lib/rpm/Providename: Input/output error rpmdb: write: 0x12e1050, 4096: Bad file descriptor error: cannot ...
1
vote
1answer
348 views

Trying to install php-devel on AWS EC2 server to compile a PHP extension, but getting errors “httpd24 conflicts with httpd-2.2.27-1.3.amzn1.x86_64”

I'm trying to install php-devel on an AWS EC2 server so I can compile a PHP extension. But I get an conflits error. --> Processing Conflict: httpd24-2.4.10-1.59.amzn1.x86_64 conflicts httpd < ...
1
vote
1answer
591 views

How to add language support on CentOS 7 (on Docker)?

I'm trying to set locale to Japanese, but CentOS image on docker doesn't include language support. bash-4.2# yum groupinstall -y "Japanese Support" Loaded plugins: fastestmirror Loading mirror speeds ...
0
votes
0answers
99 views

Remove pgdg-centos92-9.2-6.noarch.rpm or enable for install PostgreSQL in CentOS 6.5

I'm trying to install PostgreSQL 9.2.6 in CentOS 6.5 and I doing as follow: Install PostgreSQL 9.2 repository rpm -Uvh ...
10
votes
1answer
94 views

Why does yum index get corrupted?

Occasionally yum's cache gets corrupted and we see errors like this: error: db3 error(-30974) from dbenv->failchk: DB_RUNRECOVERY: Fatal error, run database recovery error: cannot open Packages ...