Tag Info

Hot answers tagged

15

Take a look at IIS7's Failed Request Tracing feature: Troubleshooting Failed Requests Using Tracing in IIS 7 Troubleshoot with Failed Request Tracing The other thing I would do is tweak your <httpErrors> setting because IIS may be swallowing an error message from further up the pipeline: <configuration> <system.webServer> ...


11

The documentation states that add_header "Adds the specified field to a response header provided that the response code equals 200, 204, 206, 301, 302, 303, 304, or 307. A value can contain variables." So it doesn't work with a 502. I forgot to add that you can use the third party headers more module to add headers to other codes. You'll probably have to ...


9

Since Nginx 1.7.5 you can use always to add a header irrespective of the response code: add_header X-Test "blahblahblah" always;


8

You need to determine the reason for the 500 error. It's usual to look in your logs for more detail and work out from there. You should also take a look at the excellent answer to this Q&A which gives sound advice on diagnosing issues.


6

I'm guessing that your .htaccess file is in DOS format and it needs to be in Unix format.


4

I have spoken to a Dev on httpd mailing list and he confirmed that this feature has not been implemented in the current code base. I have also reviewed the code myself. The state machine inside mod_proxy_balancer cannot retry on HTTP error but can only do so in case of connection error. I tried to implement it myself but its too complicated and I can easily ...


3

Restarting IIS because of a 500 response is about the same as cracking an egg with a hefty swing of a sledgehammer. You are not going to solve this problem with a restart, you are going to have to solve your problem by figuring out what is causing the 500 and correcting it. Automatically restarting the server on a 500 is not a resolution to the problem. ...


3

Open Server Manager At Server Level (not default Web site) Double click FastCGI Settings open PHP.EXE listed there Monitor changes to file php.ini activity timeout default is 60s - change to 600s or whatever


3

7 is "time up" and 14 is "EOF", so the root cause of this is probably a read timeout during the upload. The 70000 prefix means they are APR status codes. They are logged poorly here because they the core of apache is expecting a different type of error code then what is returned -- these are APR or "filter" return codes but the core of httpd is expecting a ...


3

Within your virtual host conf (or httpd.conf/apache2.conf) you can use the ErrorDocument directive, as follows: ErrorDocument 500 /errordocs/500error.php It's inadvisable to do too much in your 500 error page, as you could hit the same error condition that caused the 500 response in the first place!


3

Run a2enmod rewrite /etc/init.d/apache2 restart And it will load the rewrite module for you the error you are seeing is not because you dont have permissions to use rewrite but because its not available as can be seen from the a2dismod list output you provided (its not appearing in the list)


3

SOLVED: Alas, there is a load balancer controlling the server, and the load balancer was set up to stop connections after 10 seconds of inactivity or so. The problem is solved now. The reason the 500 did not show up in the apache's error.log is that it was the "outer" system (the load balancer) stopping the connection, not the server itself. Thank you all ...


3

I was looking for an answer for this and figured this one out: Set the ownership of the file to nobody. That is chown nobody:nobody index.php Now I'm not getting the error.


3

It's something to do with session cookies and how the site handles them. First pass, no session cookie at my end, $ wget --load-cookies cookies --save-cookies cookies --keep-session-cookies -S http://motherscarehawaii.teamvision.biz/ --2011-07-21 21:37:05-- http://motherscarehawaii.teamvision.biz/ Resolving motherscarehawaii.teamvision.biz ...


3

We use a combination of log formats in nginx and lmon to catch things like this. An NGINX log format like: log_format main '$status:$request_time:$upstream_response_time:$pipe:$body_bytes_sent $connection $remote_addr $host $remote_user [$time_local] "$request" "$http_referer" "$http_user_agent" "$http_x_forwarded_for" $upstream_addr ...


3

error_log $filename debug; will turn on debug level logging into the error log -- this will give you lots and lots of details of nginx's internal status at the time of the error, and if compiled with --with-debug (which several distros do by default) it'll give even more. Be warned that the "debug" level really does generate lots of output, to the point ...


2

Why are you using location =? I'm fairly certain that isn't what you want. On the other hand, that shouldn't be causing your redirect loop, as I understand it, but it certainly won't be helping you get what you want. Enable nginx debugging (error_log ... debug or error_log ... debug_http if you've got an nginx built correctly) to see what nginx is doing ...


2

There's not nearly enough information here to make any sort of determination about what's going on. All I can tell you is that signal 11 is a segmentation fault, which which indicates an invalid memory access attempt. Usually this is because of some programming error in the C code.


2

Like the previous person said, I'm pretty sure "signal 11″ is a segmentation fault, which would seem to indicate an invalid memory access attempt. I've found the most common issues to be: Incorrect File/Folder Permissions, Bad Code, or Incorrect Syntax in the .htaccess File, or... Incorrect php.ini Configuration Take a look at my 500 Internal Server ...


2

The server is running the PHP file. Execution of the PHP is stopping when it can't load something it's including. If you get it to ignore those errors, it'll simply error later on in execution, when it actually tries to use what it tried to load with the include. If you don't actually need what the include statements are loading, then remove them from ...


2

The location of the error log is in your config file, which is probably located at /etc/lighttpd/lighttpd.conf. Look for the server.errorlog line. If it's still set to default, the log is probably at /var/log/lighttpd/error.log.


2

Optimizing memory footprint is usually done by reducing (and limiting) these factors: count of simultaneous Apache processes (I'd recommend switching to prefork MPM, which is kindof more controllable in memory-limited environs) moving away from mod_php or php_cgi to fastcgi, mod_cfgid works fine. Reducing the count of allowed spawned php processes by ...


2

This could be an issue with your Apache LogLevel directive or it could be related to the PHP runtime error handling.


2

This is interesting because the logs state that a redirect is happening, but you do not have any rules which use the [R] flag. However, when a rule includes http://... the [R] flag is redundant, so the RewriteRule ^(.*)$ http://mydomain.com/$1 rule is the likely candidate for causing the problem. If I were you, I would try putting [R=301,L] at the end ...


2

All you need to do is add the following to your web.config OR, for those using Classic ASP, just create a web.config file in your ROOT with this code in it. <configuration> <system.webServer> <asp scriptErrorSentToBrowser="true"/> <httpErrors errorMode="Detailed"/> </system.webServer> </configuration>


2

Do you have the ability to configure the logging levels on your Tomcat web application ? If so, and you bump up the logging to debug level, you should see the error info in catalina.out, since HTTP 500 indicates an error on the server side. If you can't increase the logging levels, the next best thing I can think of is to use a tool that will show you the ...


2

First: tail -f /var/log/httpd/error_log not error.log Check your apache config file for a line with LogLevel I would suggest LogLevel error until you figure out the error. warn/debug might be too verbose


2

This is caused by the lack of the VC9 runtime on your machine. You will need to install VC9 runtime from here.


2

Whenever a web-server reports error 500 I look in the server's error log for a detailed reason. The following look useful http://mvolo.com/blogs/serverside/archive/2007/07/26/Troubleshoot-IIS7-errors-like-a-pro.aspx http://learn.iis.net/page.aspx/266/troubleshooting-failed-requests-using-tracing-in-iis-7/


2

The error is going into your log file, but not printed to the server error displayed. This is intentional, because it prevents possibly-sensitive information from being exposed to attackers. (Pathname information, database schemas, possibly something exploitable about the bug that caused the error itself....) You can either just look at the php error log ...



Only top voted, non community-wiki answers of a minimum length are eligible