New answers tagged

2

You can host a static website on Amazon S3. On a static website, individual web pages include static content. They may also contain client-side scripts. By contrast, a dynamic website relies on server-side processing, including server-side scripts such as PHP, JSP, or ASP.NET. Amazon S3 does not support server-side scripting. Ref: Hosting a ...


2

Amazon EBS snapshots are stored in Amazon S3. Data stored in S3 is replicated across multiple devices in multiple facilities. (See Amazon S3 FAQ.) While Amazon S3 defines multiple storage classes, there is no specific mention of the storage class used to store EBS snapshots. However, it would be a fair assumption that it uses Standard Storage (3 facilities, ...


0

Sorry, my fault. Updated the version to s3cmd 1.6.1 and everything is working fine now! You can download the latest version at https://sourceforge.net/projects/s3tools/files/s3cmd/


1

As far as I'm aware it's not possible, it uses S3 standard only, and you have no control over it.


0

simply run duplicity on the other box and restore from your backend as you would on your own server. ..ede/duply.net


1

Either use tail to show the last few lines or grep to filter the output based on the "Total" keyword at the beginning of the line (optionally with the extra whitespace), like: aws s3 ls s3://mybucket --recursive --human-readable --summarize|tail -n2 Or aws s3 ls s3://mybucket --recursive --human-readable --summarize|grep -e '^\s*Total'


0

Check that $HOME/.s3cfg contains the access key and secret code for s3. If not, s3cmd will try to fetch them from the env variables which is different during cron session.


1

200 is the ok response, it means the server has sent the requested resource. 304 not modified means the object is in the browser cache, the browser has checked. If you've hit reload you may be running into a browser issue, not a server issue. You've told it to reload, so it goes to the server. Try loading that resource by going into the URL and hitting ...


1

To set the cache-control headers for a filepicker.io URL you can add the following parameter: cache=true and it will set the headers to Cache-Control: max-age=315360000 For example: https://cdn.filepicker.io/api/file/h3C4wbHoTSaSltX354Ui?cache=true


3

"When you delete a bucket, there may be a delay of up to one hour before the bucket name is available for reuse in a new region or by a new bucket owner. If you re-create the bucket in the same region or with the same bucket owner, there is no delay." http://docs.aws.amazon.com/AmazonS3/latest/UG/DeletingaBucket.html


2

I've hit a few pages in Google where you can set the Header in S3 for individual objects. That's really not a productive way to do it specially since in my case we are talking of several objects. Well, "productive" or not, that is how it actually is designed to work. CloudFront does not add Cache-Control: headers. CloudFront passes-through (and ...


-1

This works for me.. aws s3 ls s3://bucket/folder/ --recursive | awk '{sz+=$3} END {print sz/1024/1024 "MB"}'


0

I just had a glance on Filestack, but not sure how it works. I guess S3 would be talking to your filestack using API.? In that case Amazon S3 has bandwidth charges, especially when it goes to Internet from AWS data center.


0

Did you set the "cache-control" header on your files in the S3 bucket? If not, the CDN will probably contact S3 on every request.


0

The answer was very simple. The restore option is meant only for Glacier storage: (http://s3tools.org/usage) This little command with inverted parameters would do the job. s3cmd sync s3://my-bucket/Weekly-Sunday/dbexports/ LOCAL_DIR


0

Seems like the prefix should be, as the plugin does not support globs (*) : prefix => "AWSLogs/828557649675/elasticloadbalancing/eu-west-1/" Full example: input { s3 { access_key_id => "my_id" secret_access_key => "my_key" bucket => "my_bucket" region => "region" prefix => ...


0

I discovered the problem. All that CloudFormation in the question is just fine and does what it's supposed to. The problem was with my run of cfn-init in the instance user-data set up in the ASG's launch configuration - that wasn't working so it wasn't executing the init stuff. Thanks to @Rob-d, your comments led me down the path to the executable-level. ...


0

Figured it out - in have two buckets in S3 - mydomain.com and www.mydomain.com. mydomain.com is where the site is, and I set www.mydomain.com to redirect to mydomain.com.s3-website-ap-southeast1.amazonaws.com... I moved the files to www.mydomain.com and removed the redirect.


-3

Instead using a CNAME you can set an A record pointing directly to the HOST_IP_ADDRESS: Type: A Record Host: www.mydomain.com Value: 54.231.242.137



Top 50 recent answers are included