Tag Info

New answers tagged

0

You can see which vulnerabilities where discovered for each version of MySQL at the CVE Database. See if your distribution has patched them already and asses your risk of using the 5.1 available to you versus some other version you might be considering. It's very likely the latest version of 5.1 has received considerable more attention than the latest ...


1

What operating system are they using? Most likely they use the versions of MySQL and Apache that are in their operating system's package repos, in which case they are on old versions of the software but are getting security fixes backported (assuming they're installing those updates). But it's definitely not a good sign that they can't give you a good ...


3

MySQL 5.1 is the currently supported and safe version on e.g. RHEL/CentOS 6 and as long as there is no project-specific reason to upgrade, no hoster on this platforms will do this. The same is true for Apache. Since RedHat etc. are backporting fixes into their versions, they are not less secure than newer releases. Lastly, if you had attacks, you need to ...


0

I solved my issue by loading the module mentioned in the error_log in my httpd.conf with PerlModule Missing::Module. I then restarted the server and got another one of those error messages with another module. I repeated those steps for 15 modules and then got it working. I don't know what caused it in the first place but I'm glad it works now.


0

OK, I fixed this, it turned out to be two other issues, which I'll record here just in case it helps someone: In my php.ini file, I had to set: display_errors = On so that it would display errors (even though I had "error_reporting = E_ALL & ~E_STRICT"). Then the error was that I was trying to use RedBean with SQLite and needed to uncomment these in ...


0

Ok guys. I finally solved it, just like I said was a very small detail (the small details are the most difficult always). The problem was with the fcgi for PHP configured in the virtual host file for nginx. In the original file (below) I said to fcgi that try find the file and if not trigger a 404 error, this was my mistake because it trigger his self ...


0

An example for a settings could be found at: http://httpd.apache.org/docs/2.2/mod/mod_alias.html http://www.nodans.com/index.cfm/2006/10/10/Apache-Directory-Aliases-and-Virtual-Directories and in short you should add something like that to the httpd.conf: Alias /web2 c:/web2 <Directory /web2> Order allow,deny Allow from all </Directory> All ...


0

This question has been asked before, and this link can provide you some answers. That's the solution: Change your DocumentRoot to the network share (drive remapping doesn’t seem to work). Example: DocumentRoot "//path/to/share" Make sure to update the DocumentRoot path in your config Edit the Apache service: On the "Log On" tab, click the "Browse" ...


1

You can use the ! target to prevent a location to be proxied: <Virtualhost *:80> DocumentRoot /path/to/parent/of/phpmyadmin ProxyPass /phpmyadmin ! ProxyPass / http://localhost:2368/ ProxyPassReverse / http://localhost:2368/ </Virtualhost> This will proxy all requests to localhost:2368, except those to phpmyadmin. ...


0

It is probably a hardware issue! The server's fuel injectors could be clogged, and/or the pilot light could have gone out. Yes, "officially" you can't have HTTP and HTTPS running on the IP on the same port. But technically that only is a problem if the fuel injectors are clogged, and/or if the pilot light has gone out. Its only because most server admins ...


1

The following has been tested on Scientific Linux: <VirtualHost *:80> DocumentRoot "/var/www/html/siteA" Alias /siteB/ "/var/www/html/siteB/" <Directory "/var/www/html/siteB/"> Order allow,deny Allow from all AllowOverride All </Directory> Alias /siteC/ "/var/www/html/siteC/" <Directory ...


0

The following works: <VirtualHost *:80> RewriteEngine on RewriteCond %{SERVER_PORT} 80 RewriteCond %{HTTP_HOST} ^forex(ample)?\.com [NC] RewriteRule ^(.*)$ https://forexample.com/abcd/xyz/ [R,NE] </VirtualHost>


0

You need to verify that all directories leading to the final directory are accessible by Apache. /home/neagoe/Work/InterWebs/Projects/testing/CustomerProjects/website/dist Most commonly, the home directory (/home/neagoe) will have 750 or 700 permission to prevent other users from accessing it. That will be a problem for Apache. If that's the case, you ...


2

Okay, first of all you can run tcpdump on your server to analyze traffic. tcpdump -s 65535 -w ~/traffic_capture.pcap Then you can read from this file with command: tcpdump -vv -r ~/traffic_capture.pcap or download it your computer and check it with wireshark. Also you can use iptables to log all of your outgoing traffic(here is rule): iptables -A ...


1

thanks for hints. I've had that issue so what I did was: under htpd.conf - Servername added " ServerName localhost:80" (there are 2 files, 1 under xampp/apache/conf & 2nd under xampp/apache/conf/original/ so I've added it into both. under htpd.conf - verified my appache if it is loading CGI module - LoadModule cgi_module modules/mod_cgi.so under ...


0

It might be outbound connection rather than inbound. Check below activity: Top command. You might want to stop other services so that it is more obvious which process is using CPU. Ping i157panamamails.com and see whether it can resolve to an IP on your server. If it does, block it on iptables. Block all outbound connections on your AWS security group ...


1

You should try iptables for a quick fix. iptables -A OUTPUT -d 202.54.1.22 -j DROP @see http://www.cyberciti.biz/tips/linux-iptables-6-how-to-block-outgoing-access-to-selectedspecific-ip-address.html On EC2, if you're running in a VPC, you can edit your ACL on-the-fly and block this IP. However, if you were indeed hacked, this is just the first step. ...


0

Further to couling's answer, in case you do wish to add your own configuration file in a Debian-type distribution without altering the existing settings, this is how I managed to do it: Put your configuration file (the name of this file must end with .conf) in the folder /etc/apache2/sites-available. Go to the sites-available directory and type sudo ...


0

My reasoning is that .php files already have an implicit handler built in to Apache, which tells the server to interpret the code as php As far as I know, there is no implicit handler, this AddHandler command is what tells apache to pass files with a .php extension to the application/x-httpd-php handler (mod_php) However, overall you are correct. It ...


2

An Apache2 snippet from this Q&A has been modified as follows: Configuration <VirtualHost IP:80> RewriteEngine on RewriteCond %{SERVER_PORT} 80 RewriteCond %{REQUEST_URI} !/somedir RewriteCond %{REQUEST_URI} !/someotherdir/somefile.php RewriteRule ^(.*)$ http://www.domain.ca/department$1 [R=301,L] </VirtualHost> Test results ...


0

I ran into the same issue. According to this thread, Alias always superseed WSGIScriptAlias. However, according to modwsgi documentation, it could be replaced by a standard Alias directive. Solution to your issue would be something like below. Note that /stuff is defined before / Alias /stuff /foo/foo/wsgi.py WSGIPythonPath /foo <Directory ...


1

You'll need to have your Active Directory administrator create a service account that holds the Kerberos Service Principles for your intranet server. The SPN or SPN's should look like <service>/<hostname> and contain all the host names and/or DNS aliases users use to access your intranet website, so something like: ...


2

docker provides isolation between apache instances, which may be interesting for many reasons (for example, if each website is administered by a different user), also allows easy relocation of instances on another server. If you don't need that you'd probably have better performance with just one instance of Apache. Isolation means that the resource usage ...


0

You can use a negative lookahead in a locationmatch block to proxy everything except healthcheck.html: http://stackoverflow.com/questions/8545680/how-to-tell-apache-to-locationmatch-opposite-of-this <LocationMatch "^(?!/healthcheck.html)"> ProxyPassMatch http://bigassawsdomainname.com:80/ </LocationMatch> (the proxypassreverse should be ...


4

For apache to listen on a non-standard port you need to add the Listen directive to httpd.conf: Listen 1500 On SELinux protected machines, this will cause apache to fail to start as SELinux will block access to all non-standard http ports. To resolve this: # semanage port -a -t http_port_t -p tcp 1500 then confirm it's added with: # semanage port ...


0

Per EEAA's comments above I setup IIS and am in the process of transferring everything needed for the site to function with connection limits. EDIT The IIS solution didn't work. It still showed a "Server Not Found" error on client computers even though from the server I could access the site using the same URL (not Localhost). Will now try another method... ...


3

As well as the reverse proxy option others have already mentioned, you could have multiple IP addresses assigned to the machine. This may cost for IPv4 (or simply not be available depending where your server is hosted) but should not if you are in a position to use IPv6 (i.e. if the people connecting to one or both or your services are going to be IPv6 ...


0

I only see 2 solutions for this: Make that script to write directly to a file. Log to syslog and pipe the log from syslog to errorlog2gelf (and send only the raw message to it). Syslog is much more flexible and will allow you to also write to a file.


-1

I am also facing the same issue that is unable to keep session. Cesar has mentioned that he has resolved the issue with apache but I am getting the same even with apache. Can someone pls help me. I have did the following setup. DNS Configuration subdomain.mydomain.com 10.10.10.10 Proxy configuration in apache at 10.10.10.10 <VirtualHost *:80> ...


-1

I believe the easyest way is to put a .bat file in startup that restarts the apache. Make sure the server logs on, because that when startup runs.


0

You CAN install CF9 64-Bit on top of a 32-Bit install but you must first backup your config files first. I'd assume creating a CAR file could be created under the 32-Bit environment and then imported into the 64-Bit but that hasn't been confirmed as of right now.


0

The event module settings should be set based off your memory usage. Looking at your memory load, these settings are set way to low. You need to estimate the use of each process using one of the many commands out there: ps aux | grep 'apache2' | awk '{print $6/1024;}' | awk '{avg += ($1 - avg) / NR;} END {print avg " MB";}' Please note there are a ...


1

I would look into 3 issues: -Session start: are you using sessions only when needed? Maybe you are starting sessions on parts that don't need them. It will waste resources and slow down your site. -Session lifetime: if the lifetime is too large or is 0, the stale sessions will fill up all disk space you have, given enough time. Take a look on ...


0

One way of solving this problem without removing your default expiration set by mod_expires is to add a <Location> block for the URL that is being redirected. Let's say you're redirecting to a versioned folder and you will periodically change that version: RewriteRule ^/approot/(.*) /approot.1.2.3.4/$1 [R=307,L] If you don't want that redirect to ...


1

If your logs aren't working as well, then you seem to be running out of disk space. Nothing in the error logs? http://php.net/manual/en/session.configuration.php Check your session lifetime - if it's too high, maybe the server keeps the files until the disk fills up. Also, check gc settings, probability, divisor and lifetime, and try to set them at ...


0

To anyone else having this issue, read the following: https://code.google.com/p/modwsgi/wiki/ConfigurationIssues I resolved my issues by appending the following in my httpd.conf: WSGISocketPrefix /var/run/wsgi


2

It sounds like the code you are using to close a session is not working, or does not exist. You need to destroy the sessions using the following: To destroy all sessions: <?php session_destroy(); ?> or use this to destroy individual pieces: <?php if(isset($_SESSION['views'])) unset($_SESSION['views']); ?> Taken from here: W3Schools PHP ...


0

I had the same problem. However, in my case it was simply due to... sites-available/default not being linked to sites-enabled/default. In apache2.conf I have: Include sites-enabled/ And my sites-enabled/default: <VirtualHost *:80> ServerAdmin webmaster@localhost DocumentRoot /var/www <Directory /> Options ...


0

You may have PHP syntax errors. Try to use php -l script-name.php to see if everything is right with your file.


20

Only a single process can listen on a particular port for the same IP address and protocol, because otherwise operating system wouldn't know which process to send the received packet to. To achieve what you want you will have to use a reverse proxy which will listen on port 80 and forward traffic to correct destination. There are multiple ways to do this. ...


41

You would need to use a reverse proxy to do this, e.g. Apache 2.4. with mod_proxy_wstunnel. Use it as a frontend and then tunnel the connections to the appropriate backend.


0

When you want two domain names to map to the same local path, the easiest thing is to just tell Apache that one is an alias for the other within the virtualhost context. I'm unable to access pastebin content, so here's an example of a config that you can adapt to your own config: <VirtualHost *:80> ServerName www.example.com ServerAlias ...


1

Instead of 'copytruncate', these lines worked for me in the logrotate file for my rails app: postrotate touch /your-rails-directory/tmp/restart.txt endscript


1

As you have created a virtual host, the SSL for the new host should be different than port 80, because you have enabled SSL for port 80 via 443. So for new virtual host, try with 636 and see.


1

According to the documentation on Apache....The directives you state will always result in denial..reasons: Directive order deny,allow analyzes deny directives FIRST then allow directives. Your deny from all directive matches everybody and thus due to #1 nobody gets access. Your 0.0.0.0 IP number will not match everybody, thus your allow statement is not ...


0

I also had the problem show up when I defined DocumentRoot before setting ServerName in my <VirtualHost ...> directive.


2

This is a really broad question and answering it properly is well beyond this simple question and answers format. What typically requires most CPU performance is in establishing the HTTPS session, the Diffie–Hellman key exchange, after which a simple and low cost symmetric encryption scheme can be used. In nearly every real world scenario the CPU ...


1

Are you hosting with someone like an online provider (example of what I use for my personal family website)? or is this being hosted behind your router where you need to port forward over? It sounds like you are hosting on your local network and trying to access your WAN IP. You will need to port forward to the server if that is the case.


0

My solution to the problem at the end is: I remove the LAMP stack with this command: sudo apt-get remove apache2 apache2-mpm-prefork apache2-utils apache2.2-common libapache2-mod-php5 libapr1 libaprutil1 libdbd-mysql-perl libdbi-perl libmysqlclient15off libnet-daemon-perl libplrpc-perl libpq5 mysql-client-5.0 mysql-common mysql-server mysql-server-5.0 ...


0

I haven't tested this, however the first thing I spotted was that in your RewriteRule lines which are like this: RewriteRule ^(.*) main.redirect.php [QSA,L] You should try adding a slash before main.redirect.php as that part of the redirect rule should be a URL, so it would become: RewriteRule ^(.*) /main.redirect.php [QSA,L]



Top 50 recent answers are included