Tag Info

New answers tagged

2

I found Chris Siebenmann's article quite insightful: Why people keep creating new package managers It boils down to a conflict of perspectives/interests between the sysadmins/OS maintainers, who want a stable and uniform environment "in" their operating system, and programmers/languages, who want faster iterations and a uniform package management across ...


0

These answers seems a bit outdated, with new versions of puppet i.e 3.7.x, class parameters can be passed using Hiera. Resource like class declaration is not considered best practice anymore. Although the second answer does use Hiera, but it is using ‘hiera’ function explicitly, which is again a not so advisable practice. The new solution would look ...


0

Impossible upgrade the postgresql-client without the postgresql package too. But, it's possible to make the postgresql service doesn't restart until the next OS reboot. Use policy-rc.d cat > ./usr/sbin/policy-rc.d <<EOF #!/bin/sh exit 101 EOF chmod a+x ./usr/sbin/policy-rc.d Just remember to delete policy-rc.d if you want restart PostgreSQL ...


0

I think same steps as Linux machines, Install HTTP or FTP server (I would use Apache HTTPD), and do a rsync from official mirrors. Regards


0

Sometimes ago I wrote a low level/dirty automation Fabric script (fabfile) to meet similar requirements, you can check it at: https://gist.github.com/lgaggini/2be3c5bb47b8ce9267bd


0

I filed a support ticket with AWS and the issue is no longer occurring. I believe they refreshed/fixed some of the packages.


2

Relevant post with some answers and a related bug report. https://askubuntu.com/questions/41605/trouble-downloading-packages-list-due-to-a-hash-sum-mismatch-error https://bugs.launchpad.net/ubuntu/+source/apt/+bug/972077 TLDR; 1) it's an issue with the amazon mirror and 2) this is a common workaround that is generally considered "ok" but annoying.


0

Apt-get knows the packages were installed automatically as dependencies. You should mark them as 'manual' to let apt-get know you want them to remain installed: apt-mark manual [packages]


1

I don't know if it will work for every possible upgrade scenario, but I just tested this, and the upgrade worked without any replication problems: # /etc/mysql/conf.d/binlog_ignoredb_mysql.cnf.disabled # Rename this to end in .cnf prior to performing `apt-get upgrade`. # Otherwise, its attempts to `ALTER TABLE users` will cause replication errors. # After ...


-1

echo "deb http://repo.mongodb.org/apt/ubuntu "$(lsb_release -sc)"/mongodb-org/3.0 multiverse" | sudo tee /etc/apt/sources.list.d/mongodb-org-3.0.list Add the repository using the above code. Then run update command sudo apt-get update And then give a command to install mongodb giving all the parameters forcefully yes using sudo apt-get install ...


0

It turns out namespacing was the problem. In order for this to work I need the MODULE 'apt' to be called. By specifying include apt or class { 'apt': } in the class profiles::apt, it tries to include or call itself. Changing to class { '::apt': } (absolute name) fixes the problem.


1

it would be nice to know what commands broke your replication, but I suppose, the mysql_upgrade script would be that rogue. If yes, you can rebuild the mysql package, adding to the post install script a --skip-write-binlog (this is not needed after 5.6.7) But normally I never would just apt-get upgrade a server which is in production, stop the slave, ...



Top 50 recent answers are included