Tag Info

New answers tagged

0

The best you could reasonably do would be to work with your internet providers to try and get a topologically close connection to a CDN, such as Akamai. (eg. have a Akamai node at your internet exchange.) Not sure how useful that would be, but considering that the bulk of commodity data is from things like video, it may be worthwhile. You may also get some ...


0

No. The point of using SSL is not just encrypting the data, so that noone could see your password, or validating that you are really logging in to your bank account and not some scammer. It is a privacy tool as well. When using SSL noone is able to see what kind of content you are transfering (although from IP they still may be able to guess which site). ...


0

The Goolge image proxy is caching. You can easily test this by embedding an image into an e-mail and send it to an Gmail account you have control over. Reload the page a few times (with dropped cache of course). The cache gets hit, your server will not receive any request. It's unclear if the same cached URL/file gets served to multiple users. Maybe this ...


2

Nginx interprets a bunch of headers when used as a reverse proxy to honor HTTP intermediate caches specifications. This means the following headers, if present in your app replies, will change caching behaviour as explained : The “X-Accel-Expires” header field sets caching time of a response in seconds. The zero value disables caching for a ...


4

Sending Last-Modified headers in your app replies is a start but it seems you don't handle If-Modified-Since properly on incoming requests because your app should reply 304 Not Modified and not 200 OK. Changing the directive on nginx only impact requests served directly by nginx i.e. static ressources unless you configure it as a reverse proxy cache. In this ...


0

Since you have not mentioned anything about your cache configuration in Nginx, I'm going to assume you did not set a cache, and this would explain why your If-Modified-Since header has no effect for dynamic responses. When it comes to static resources, Nginx has a really easy way to determine how to handle If-Modified-Since: it compares the time in the ...


3

Let us read the manual page for the underlying library call: Programs can use posix_fadvise() to announce an intention to access file data in a specific pattern in the future, thus allowing the kernel to perform appropriate optimizations. The advice applies to a (not necessarily existent) region starting at offset and extending for len bytes (or ...


1

Perhaps you can try this workaround for your problem include on your configuration file a file named expiration.conf In your expiration.conf write: Header set Expires "Tue, 28 Apr 2015 20:00:00 GMT" And reload apache. Of course you should create your date dinamically each day.


2

Stealing Explaining the ideas from VBart and sendmoreinfo Please don't use insecure FTP, especially for doing an action on permission-sensitive directory. The alternative is: Use SSH with normal user and give sudo permission to particular script who doing nginx-cache clearance. For example put this script in /opt/clear-cache.sh. #!/bin/sh rm -rf ...


0

Try disabling server-side includes in HTML files by commenting out the following line and then restarting Apache to see if that's what's causing it. AddOutputFilter INCLUDES .html


2

The issue with Lukas's solution is HttpRewriteModule , which automatically turns everything with http(s) at the front into a 302. If you instead do the rewrite in two stages - the second one 'break' - it should work. e.g. rewrite ^(.*)$ "://registry.npmjs.org$1" break; rewrite ^(.*)$ "http$1" break; proxy_pass http://proxy.abc.lan:1234; I suspect there's ...


0

Why install an additional cache when the server you have already has one integrated? I am not using Magento but similar to Wordpress I am sure it uses many cookies. Varnish will strip all of those unless you tell it to. From my experience you should disable Varnish and enable the Nginx cache to avoid many headaches. proxy_buffer on; Make sure to ...


0

MISS: resource not in cache, served from origin server From: https://support.cloudflare.com/hc/en-us/articles/200168266-What-do-the-various-CloudFlare-cache-responses-HIT-Expired-etc-mean-


2

You can use a map for this. Place it in a separate file which is included from the server's http block, and then whenever it changes, reload nginx. An example: map $request_uri $my_no_cache { default 1; /b.php?q=123 0; } To use it, place this in the relevant server or location: fastcgi_no_cache $my_no_cache; fastcgi_cache_bypass ...



Top 50 recent answers are included