Tag Info

New answers tagged

0

What worked for me was adding a symlink in the CentOS server like this: ln -s /usr/lib/locale/en_US.utf8 /usr/lib/locale/UTF-8 Once you do that commands like this work: export LC_CTYPE=UTF-8 If you don't, this last command fails with this error: -bash: warning: setlocale: LC_CTYPE: cannot change locale (UTF-8): No such file or directory Now, an even ...


0

I've installed CentOS 7.0 and Oracle Linux 7.0 as domU in XenServer 6.2 SP1 with latest hotfixes. No problem at all. I've used the Install DVD ISO though. Make sure you choose "Other Media" when installing using the DVD. The stock kernel 3.10 certainly has the xen guest support (pvops) and will detect the xen hypervisor, unplug the emulated NICs and Disks ...


1

I cannot assure your error is because of SE Linux context issue, but try changing context using following command chcon -Rt public_content_t /var/ftp/pub To Display the context ls -Z /var/ftp/pub Additionally set Boolean value as follows setsebool -p ftp_home_dir 1 setsebool -p allow_ftpd_full_access 1 After all restart the service service vsftpd ...


1

To get a recent long-term support kernel purpose-built for CentOS 6, consider using kernel-lt from ELrepo.


0

This is highly not recommended because it changes a basic building block of the distribution and will certainly create unpredictable behavior in your system. If you want to do it for fun, compile the kernel from scratch (there are many tutorials showing how to do that). My suggestion is to use CentOS 7 which offers kernel 3.x thoroughly tested with all the ...


0

I used rpm2cpio to convert the only suitable .rpm file I found into a cpio archive on standard out. $ rpm2cpio php-mcrypt-5.4.16-1.el6.x86_64.rpm | cpio -idmv I then copied mcrypt.so an mcrypt.ini to the proper folders for the PHP 5.4 install. Voilá, mcrypt works now!


1

Unfortunately, the CentOS SCL collection for php54 does not include php54-mcrypt. You can take the SRPM for the php-mcrypt-5.4 and modify the spec to change the package name, install location, etc. In other others, create your own package (check rpmbuild). Or you could also use rcollet's repository as an alternative.


0

There may be several reasons for this, which is nicely described in Parallels article http://kb.sp.parallels.com/en/120785 Also, I suggest you to re-register the php with fcgi module through command line and see if that helps.


0

It's a bad idea to uninstall yum (specially because all those dependencies will trigger more and more packages that need to be removed), but that does not break the RPM database, which still contains all packages you have installed. If you need libxml 2.7 for a specific software, one option is to manually compile it and install in a different directory, ...


4

You're using mod_php, so Apache is also handling your PHP workloads at the same time. Since PHP needs lots of RAM (well, most like this do, including mod_perl), you'll see higher RAM usage than serving just static files.


1

Is that the entire script? There's no 'shebang' line add #!/bin/bash to the first line if it isn't there already. Also did you mark the file executable?


1

The remi repository, from which you installed PHP, is disabled. Enable it and try again.


0

Moving/replacing the http_public folder can be achieved with simple mv or ln -s commands or equivalent while your http server keeps running. You can do some scripting to significantly reduce the downtime, but check carefully the return codes of your commands in the script if you automate the process. That said, if you want to achieve no downtime, you ...


1

No, you must update the schema yourself. Check the PowerDNS website for information on upgrades. Some changes are backward compatible and don't require you to update the schema every time.


0

setfacl -m d:u:dev_ssh:rx /home/site Make sure the filesystem containing /home/site has been mounted with the acl option. Source: CentOS Access Control List docs.


1

You also installed some packages from the remi repository, but you disabled -- and removed! -- that repository. I'm going to guess that you actually want to keep the newer version of MySQL that you got from remi, and advise you to put the repo back and enable it.


0

I don't know much about your configuration, but experienced a similar use case myself, where the opscenter only had data from the local datastax agent. My initial setup was: 3 cassandra nodes, all 3 running opscenter and datastax-agent, with the agent configured for the local node. It seems that this was wrong, as the agents needed to be configured with ...


0

This may point you in the right direction SMTP Tweak You may want to prevent users from bypassing your mail server to send mail. This is common practice for spammers. This feature allows you to configure your server so that the mail transport agent (MTA), Mailman mailing list software, and root user are the only accounts able to connect to ...


1

Easiest thing to do at this point - get rid of the webtatic packages. yum --disablerepo=webtatic distro-sync Should get you on the right track for starters. EDIT: how to disable webtatic permanently: sed -i '/\[webtatic\]/,/^$/ s/\(enabled=\)1/\10/p' $(grep -rlF [webtatic] /etc/yum.repos.d/*.repo) And then do yum distro-sync and go over the results ...


0

Typically I'd just run it with --skip-broken So your system is now probably in an utterly fucked state. This extra 'webtatic' repo you use is likely related to that. I would at this point wipe the box and start from scratch.


1

According to top, it looks like something is using up a good amount of CPU. Update your post with the process list according to top. More than likely, something is pulling a lot of I/O on the server and exhausting RAM as most of your swap is cached (so, recently used). The load should not be that high on a healthy server.


1

Start by tracing what is taking too long with Chrome/IE developer tools (network tab). Confirming that the slowness is happening for all requests irrespective of type, trace the path from end user to your server (traceroute) looking for any excessive delays. Test from multiple places. On the server, check the number of open connections (netstat -antp | ...


1

You didn't install the EPEL 7 repository. That's the EPEL 6 repository. Remove it and try again. Better yet, install nginx from their own repositories to ensure that you stay up to date with critical and less critical upstream fixes.


0

That doesn't seem right as the nginx version in in the EPEL repository for RHEL7 x86_64 is 1.6.1. Try yum clean all; yum update and repeat the installation process. If it still fails, try to specify a different mirror (as the one you're using seems out of sync).


0

I would propose adding the nginx repo sudo rpm -Uvh http://nginx.org/packages/centos/7/noarch/RPMS/nginx-release-centos-7-0.el7.ngx.noarch.rpm That should solve your problem. Cheers.


0

You're using rpm and centos packages on an Ubuntu machine. This is not going to work at all. On top of that you're using plesk, which is sort-of considered malware around here.


0

Are you running apc? If not, I'd install that and see if the situation improves. I'd also look at the php fcgi configurations. Since php is run separately from apache under fcgi, I don't believe your problems are with apache.


0

When giving remote instructions to end-users and customers, I instruct them to use poweroff to shutdown and power the system off. If they want a warm reboot, I suggest that they use the reboot command. I suppose one could say that issuing Ctrl-Alt-Delete also accomplishes this ;)


0

I am not sure about which version this error was reported. But as per my knowledge this was a error in versions below 9.5 Root cause was with faulty sw-cp-server package. And the fix was there in a Parallels KB article. I would be glad to redirect users there: http://kb.sp.parallels.com/en/8338


9

Using a load balancer is a good idea. If the site is important enough to worry about a few seconds of downtime, it's important enough to worry about fault tolerance. That aside, if this is on a UNIX system you can put Apache on hold during the rename (or symlink update, etc.): killall -STOP httpd # Pause all httpd processes mv public_html public_html_orig ...


1

Plesk stores its logs under: /var/log/sw-cp-server/error_log /usr/local/psa/admin/logs/panel.log /var/log/sw-cp-server/sw-engine.log and yes the first part we need to check if psa not running is: df -h df -ih make sure none of them is showing 100% full If the issue still there just check and make sure port 8443 is not used by any other service. ...


0

I figured out a way to make a kexec loading script that works well and will load the default kernel in grub, meaning it should load the new kernel after a kernel update. File: /usr/bin/kexec-load #!/usr/bin/env bash GRUBBY_FILE="/var/log/grubby" TMP=$(mktemp) # Command "grubby --default-kernel" has a bug/feature that fsyncs # after writting each ...


0

I would avoid using rpm and try installing it with yum instead as it tends to resolve conflicts automatically (and more sensibly). Try this: yum -y install MariaDB-*.rpm Edit: It might also be useful to run: yum remove mysql-server mysql-libs mysql-devel mysql* just for sanity sake.


0

I suggest one or more of the following: Move that client to a separate VPS. Decrease MaxClients drastically, try e.g. 10 Use nginx instead of Apache, or varnish in front of Apache Use cloudflare


0

You can restrict the 'git' user to only doing Git activities with a limited shell tool called git-shell that comes with Git. If you set this as your 'git' user’s login shell, then the 'git' user can’t have normal shell access to your server. To use this, specify git-shell instead of bash or csh for your user’s login shell. To do so, you’ll likely have to ...


0

My solution at this point is to use db_dump on the old server, and db_load on the new server. I presume I could do this all on the new server if I got an old version of the BDB libraries and compiled them in using the ---with-dbm flag. However, at this time since I have working versions in both places, this is the fastest solution for me right ...


1

This is pretty straightforward. First stage the kernel to be booted: kexec -l /boot/vmlinuz-3.10.0-123.6.3.el7.x86_64 \ --initrd=/boot/initramfs-3.10.0-123.6.3.el7.x86_64.img \ --command-line="root=/dev/mapper/centos-root ro rd.lvm.lv=centos/swap vconsole.font=latarcyrheb-sun16 rd.lvm.lv=centos/root crashkernel=auto vconsole.keymap=us rhgb quiet ...


0

I've now resolved this so I'm posting the solution in case others experience the same issue. I neglected to mention that all of our web traffic goes over HTTPS, and that appears to be the cause. During a stall I used strace and pstack to see what one of the idle Apache processes was doing. It was stuck waiting on a mutex for the SSL session cache. Looking ...


0

I know this is an older thread, but one thing I've done on my Nagios installation in addition to what the others have posted is to implement IPtables rules on each target host to only allow Nagios/NRPE traffic (port 5666) from the actual Nagios server. There's a directive in nrpe.conf that allows you to specify "allowed_hosts" that can connect to the target ...


0

A HostGator Linux Admin fixed the problem: According to HostGator: The error message was corrected by moving a file that has incorrect configuration options and then restarting the firewall: root@mic [~]# mv -v /etc/sysconfig/iptables-config /root `/etc/sysconfig/iptables-config' -> `/root/iptables-config' root@mic [~]# service firewall restart DETECTED ...


0

You might check to make sure that the system has sufficient kernel settings. I've had problems in the past where the PostgreSQL init script will try to start postmaster and have it silently fail due to insufficient shared memory settings. Normally you would see helpful messages explaining the settings that need to be changed, but the init script can hide ...


9

Symlinks and mv are your friends, however, if you really need to avoid end-users getting an error page while deploying a new version, you should have a reverse-proxy or a load-balancer in front of at least 2 backend servers (apache in your case). During the deploy, you just need to stop one backend at a time, deploy the new code, restart it and then iterate ...


0

i have the same issue vhost logs always owned by root with 640 permissions when created, a work round is to write a script to chmod or chown the permissions of the vhost log file name using a wild card on the end of the file name to capture the date format, on the end of the file then cron that script and set it once an hour or once a day, then your vhost ...


-2

I've managed to fix it by running 'package-cleanup --cleandupes' several times and then running yum update. All working okay now. Cheers


4

The way I do it is do commit my changes from my local dev environment to an online Git repository such as Github. My production environment runs off a remote repository so all I need to do is ssh to the server and run git pull to bring down the latest changes. No need to stop your webserver. If you have files in your project whose settings and/or content ...


2

I have solved such problems in the past with package-cleanup tool (install "yum-utils") with --cleandupes and then repeat yum check and yum-complete-transaction.


0

Apparently all I had to do was to setup PTR record via VPS control panel - not via Webmin. So hoster provides a tool to set PTR record and it seems that doing that manually in my own DNS server BIND has no effect (for some reason)


27

The fastest and easiest is to use a version directory such as /var/www/version/01 /var/www/version/02 and use a current symbolic link as your html_root : /var/www/html -> /var/www/version/02 This technique integrate perfectly into a revision control system (svn, git, mercurial, ...) as you can checkout branches & tags, changes the symbolic link ...


8

If you are applying changes regularly on a production system, I would take care of a structured life cycle. A good practice is Capistrano http://capistranorb.com/. This is a an open source solution for deploying software on one or more servers on several platforms and configurations. For Magento there is even a plugin: ...


0

To write the final solution: iptables -t nat -A POSTROUTING -o eth2 -j MASQUERADE iptables -A FORWARD -i eth2 -o eth1 -m state --state RELATED,ESTABLISHED -j ACCEPT iptables -A FORWARD -i eth1 -o eth2 -j ACCEPT echo > /etc/sysconfig/network-scripts/route-eth2 nano /etc/sysconfig/network-scripts/route-eth2 and enter: ADDRESS0=10.96.0.0 ...



Top 50 recent answers are included