Tag Info

New answers tagged

1

I had exactly the same issue but with Samba 4 exports and Windows 7 clients. It is definitely client side error. After some thorough troubleshooting, I simply added the registry key and it worked like a charm after hitting the F5 button once. Only had to add this registry key: DirectoryCacheLifetime = 0 ...


1

Not sure why the problem is happening, but as a workaround, have you tried to put something like touch /mnt/windowsbox/keepalive.txt or echo "I am still alive." >/mnt/windowsbox/keepalive.txt to be run via cron every minute? That way the connection should stay active.


0

May not be this... but try forward slashes "/" instead of back slashes "\" in your specification of the share location. So //10.25.214.26/cluster_storage.cluster.Cluster Update: As per the comments the below, the possible low hanging fruit of slashes was not it, but perhaps we are still dealing with a syntax issue. Take a look at the format provided here ...


0

If you are having network issues and the windows box runs 7+ please read Resilient Open Scavenger Timer [MS-SMB2] (default 300 seconds) http://blogs.msdn.com/b/openspecification/archive/2013/03/27/smb-2-x-and-smb-3-0-timeouts-in-windows.aspx more info on cifs timeouts ...


1

I managed to solve my problem. There were two components at fault: the ProviderOrder registry key, and a missing adapter package. Fault One: SMB on Windows looks at the ProviderOrder registry key under HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\NetworkProvider\Order\ to determine which implementation of SMB/CIFS to use. If there is no ...


0

I have read that you need to include these directives to your conf for windows to work. hosts allow = 127.0. x.x.x.x etc hosts deny = 0.0.0.0/0 I am having a similar issue, but haven't resolved it yet.


0

The correct path is \\data. The admin user is added in the Linux and Samba? In the Samba, use the binary smbpasswd to add the user.


1

If the packet capture shows no attempt over 445 whatsoever then that would indicate the client is trying WebDav first. This could be because WebDav higher in the Network Provider Order. To check that: Open Network Connections Advanced menu Advanced settings... Provider Order tab Ensure Microsoft Windows Network is higher than Web Client Network


0

My issue was related to: "mount error(13): Permission denied Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)" For me the solution was adding key to regedit in Window. Below is my answer in other topic: http://serverfault.com/a/619963/237340



Top 50 recent answers are included