Tag Info

Hot answers tagged

101

No, there isn't (I just checked 1 hour ago). You can comment the bind-address in my.cnf: #skip-networking #bind-address = 127.0.0.1 If you want only 2 IPs, you will then have to use a firewall.


51

Binding to 127.0.0.x won't make it available to all the devices, it will make it available locally only. If you wish to make it available to all the interfaces, you should use 0.0.0.0. If you wish to access it from more than one, but less than all the interfaces, you should bind to 0.0.0.0 and firewall off the interfaces you don't want to be accessed ...


24

I needed to have rw for user only permissions on config. This fixed it. chmod 600 ~/.ssh/config


10

Usually that comes from Selinux not giving access to the folder. do ls -alZ /var/www/ and if the html folder doesn't have the context system_u:object_r:httpd_sys_content_t, fix it with chcon chcon -v -R --type=httpd_sys_content_t /var/www/html http://wiki.centos.org/HowTos/SELinux


10

No, you cannot. The page you link to clearly states: The IP address to bind to. Only one address can be selected. If this option is specified multiple times, the last address given is used. If no address or 0.0.0.0 is specified, the server listens on all interfaces.


8

Check: http://httpd.apache.org/docs/2.2/programs/apachectl.html apachectl configtest


7

Normally what you would do is create a alias so you would have one IP bound to eth2 and one bound to eth2:1 You would configure your startup scripts as such /etc/sysconfig/network-scripts/ifcfg-eth2 DEVICE=eth2 IPADDR=65.130.27.69 ONBOOT=yes BOOTPROTO=static BROADCAST= ... etc, etc. /etc/sysconfig/network-scripts/ifcfg-eth2:1 DEVICE=eth2:1 ...


6

I realize this is an old post, but since it came up in a google search I was doing I figured I'd post some helpful information I found regarding this same error. In some cases this error message is benign. For example, I was getting it in CentOS 5 but by proxy config was perfectly legitimate and worked just fine. You can view the discussion regarding this ...


6

Hire who you trust. Trust who you hire. If you don't trust your junior with this information, then I'm wondering why he's employed there. You can't solve a social problem with a technical solution.


5

You need a ServerName directive in the <VirtualHost> block, so that Apache knows when to serve content from that virtual host.


5

This behavior is by design. Vagrant uses VirtualBox NAT mode which means using port forwarding. You can't SSH directly to your VM using NAT mode. Using 'vagrant ssh' means vagrant will do the port forwarding for you so you don't have to worry about it. I think it will connect to localhost on port 2222 by default but it will try to also sort out any port ...


5

Both ends of the spectrum have their pros and cons, as does the area in between. A. Use a standard, public AMI with dynamic system configuration at boot (+) Does not require learning how to build AMIs. (+) Does not require learning how to manage a stable of historical AMIs. (+) Easy to change and test the system configuration by editing the config and ...


5

The option you want is local_interfaces in the main part of the configuration. Section 13.1 of the spec gives some examples, and the full definitions of the option is in the alphabetical list of main options (which I can't directly link to because it doesn't have an anchor). To summarize: local_interfaces = 127.0.0.1


5


5

I also could not find the ARR icon when using the server manager. But when I went to control panel, admin tools, iis manager, the ARR icon was there.


4

Information on apache httpd.conf files can be found at - http://httpd.apache.org/docs/2.4/mod/core.html#include


4

You can do it with Include directive: Include /path/to/virtual_hosts.conf


4

Do you have any routing setup already between the boxes? You could do the following.. Router 1(left Side of diagram) interface FastEthernet0/1 ip address 192.168.56.253 255.255.255.252 no shut ip route 192.168.55.1 255.255.255.255 192.168.56.254 Router 2(right side) interface FastEthernet0/1 ip address 192.168.56.254 255.255.255.252 no ...


4

You can run arbitrary ruby code, so this probably your best approach when it comes to Windows. Also the philosophies of UNIX-like OS and Windows are so fundamentally different that there's currently no point in using chef for Windows-based environments. Use the tools MS intends you to use like SCCM and SCOM - your results are going to be much better and ...


4

As you discovered, you need to specify the more specific matches first.


3

You don't need to create two separate vhosts for this - just use the ServerAlias directive: <Virtualhost *:80> ServerName example.com ServerAlias www.example.com ... </VirtualHost>


3

You can: nginx -s reload You can: kill -HUP $NGINXPID Found by searching 'nginx reload config', first hit is the CommandLine page on the nginx wiki.


3

This is not how you reload nginx. What you are trying is starting nginx again, -c just specifies the configuration file it should use. Use service nginx reload or /etc/init.d/nginx reload to reload it.


3

If you want to eliminate the extra spaces, you can use the built-in function gsub. For example, you can add: gsub(/ /, "", $1); This will remove all spaces. If you want to remove spaces at the beginning or end of token, you can use gsub(/^ /, "", $1); gsub(/ $/, "", $1);


3

Benchmark, benchmark, benchmark. That's the only solution. There are a million things that can make a website slow. Here's what I would do: Load up Firefox with Firebug. Check the net panel for the loading times of your main request. If it gives a long time for "connecting", you may have network or bandwidth issues, or Apache cannot handle that many ...


3

You are allowing Apache to spawn up to 1500 children to serve requests (ServerLimit / MaxClients) -- It's no wonder your server load (the number of processes waiting in the run queue) is getting enormous! My first suggestions at 400 requests per second with the numbers you're quoting in your question would be "Move the MySQL server to its own box" or ...


3

There is an Apache module available which shows a detailled page with various settings and the active configuration. mod_info is disabled by default and must be enabled with ./configure --enable-info when building Apache. On Debian and Ubuntu, this module and its configuration can be enabled using sudo a2enmod info. Put the next lines in your configuration ...


3

Server Farms should be the UI branch from which it's configured. The top level of a given farm shows its ARR properties. If you haven't closed/reopened the Inetmgr GUI since installing it, you need to do that too.



Only top voted, non community-wiki answers of a minimum length are eligible