Hot answers tagged

30

Note: This message is a symptom of the problem you are trying to solve. Understanding the cause of the message will ultimately lead you to solving your problem. The message 'Connection Refused' has two main causes: Nothing is listening on the IP:Port you are trying to connect to. The port is blocked by a firewall. No process is listening. This is by ...


9

Use a Loadbalancer Software with healthcheck like Zen-Loadbalancer or HA-Proxy. There you can configure a healthcheck which pings or open a file on your Webserver and remove them from the Load-Balancing if the file is not available for example. DNS Round-robin is not made for such things because your DNS doesn't know if a server is not available. The DNS ...


6

But I don't understand, a server by definition shouldn't have any closed port and I can't find a way to see if they are. I think you are slightly mistaken. A server, by definition, serves. What it serves is chosen by the server administrator. Technically, a server can have all of its ports closed, although that wouldn't be a very useful server... unless ...


5

Just to explain: DNS Round Robin is not designed for the purpose you are using it for. It simply tells the DNS to hand out the available IP-addresses in an alternating manner; there is no feedback between the failing server and the DNS (and if there were, timing problems would prevent it to be of much help, because of the way the DNS is designed). So you can ...


3

As others have already suggested make sure your cassandra instance is running ps axu | grep cassandra If the output tells you that it is running you can check what ports it is listening on: netstat -tulpn | grep -i listen | grep <pid> where is the process id of your cassandra instance which you can get from the output of the first command. You ...


3

<property> <name>fs.defaultFS</name> <value>hdfs://localhost:8020</value> </property> You told it to bind to localhost. That's not a good idea if you want it to be accessible from other machines.


3

It looks like there is something upstream of your VPS that is blocking access except for the ports noted. You should contact your VPS provider and ask them about it.


2

By default Thrift is not up, you have to start it with nodetool enablethrift


2

The PREROUTING chain doesn't apply to local (loopback) traffic. You will need a redirect rule in the OUTPUT chain for it to work on the local system. For example: iptables -t nat -A OUTPUT -i lo -p tcp --dport 80 -j REDIRECT --to-port 8000


1

I think your guess is correct, man listen(2) says (emphasis is mine): The backlog argument defines the maximum length to which the queue of pending connections for sockfd may grow. If a connection request arrives when the queue is full, the client may receive an error with an indication of ECONNREFUSED or, if the underlying protocol supports ...


1

After a chat support session with an AWS supporter, we figured out the problem. I have expanded two volumes - /dev/sda1 and /dev/sdf. When I connected the expanded volumes to the machine, the second one was attached as a different device for some reason (/dev/sdg, If my memory serves me well). This caused some boot problems and sshd never came up. When the ...


1

just putting this dirty hacky script, I used this to debug once (you just need python 2.xx installed on the machine). This is dirty but can help anyway! Attach and mount your volume to another VM and create a file on it, eg /whatever_mount_path/you_like/cgi-bin/cmd.py ('cgi-bin' is important), with the content as below: #!/usr/bin/env python import os br='&...


1

As an ad hoc workaround (only in the regretful absence of a loadbalancer), you could accompany the server reboot with suitable configurations at one of its next hops (a switch, a router, a firewall), e.g., stop apache Make the next hop respond with explicit "not reachable" messages reboot the server Undo changes made step 2 Specifically, step 2 might ...


1

To view your firewall settings in a terminal perform the following: - sudo iptables -L -n you looking for somehting ike this # iptables -L -n Chain INPUT (policy ACCEPT) target prot opt source destination ACCEPT tcp -- anywhere anywhere tcp dpt:ssh DROP all -- anywhere anywhere if no ...


1

Port 22: Connection Refused This message indicates that a firewall is actively blocking your connection attempt or alternatively that sshd is not listening on that port. Verify that: The iptables rules applied on boot allow traffic on port 22 sshd is set to start on boot


1

Okay, to make things clear - if you are running CentOS, chances are that you are at release 5 with sendmail as the default. In that case, you will not be to connect externally, because sendmail will only listen to localhost by default. To make it listen on the main IP, you will need to disable the line in /etc/sendmail.mc from this: DAEMON_OPTIONS(`Port=...



Only top voted, non community-wiki answers of a minimum length are eligible