Tag Info

Hot answers tagged

4

Don't do it if you're using Mailbox files. If you were using Maildir you could do at least some of the work without shutting the services down. Every email that is delivered, and every IMAP access, will alter the Mailbox files. You may end up with corrupted files. The best you can do is to shut off IMAP and local delivery, while still allowing postfix to ...


3

The cpanel /etc/local_domains is probably used to configure exim, not courier. Incoming emails are delivered via smtp, not pop nor imap. So here is what happened: Remote mail servers looked for a MX server for your domain Your dns configuration is probably set up so that your cpanel server is the MX server with the best priority for your domain The remote ...


3

Where possible, use a special-use utility account for these kinds of applications. So, go with the virtual imap accounts via sasl.


2

You can easily do that with ACLs, specifically with the command maildiracl .


2

So, after telnetting my mail server, I've finally found the issue. $ telnet 10.0.0.229 143 Trying 10.0.0.229... Connected to 10.0.0.229. Escape character is '^]'. * OK [CAPABILITY IMAP4rev1 UIDPLUS CHILDREN NAMESPACE THREAD=ORDEREDSUBJECT THREAD=REFERENCES SORT QUOTA IDLE ACL ACL2=UNION STARTTLS] Courier-IMAP ready. Copyright 1998-2008 Double Precision, ...


2

You should look in your /var/log/mail.log or any mail.* files which may tell you what the problem is. In this case, the error is that there is no user home directory so Maildir is not able to create the directory where to save/read the emails. When I create users for this purpose of mailbox, I do adduser --shell /bin/false joe /sbin/nologin should be ...


2

You can move the emails around, just make sure that the email and the new directories you create are owned vmail:vmail, and remember that it will take a good long time to rebuild the indexes when you finally get things sorted out. P.S. I'd also take the opportunity to delete some of the older stuff.


1

The warning about IMAP/143 is probably because your imapd supports TLS, so the tool is connecting to plaintext IMAP, asking to escalate to TLS, and complaining about the certificate then presented. You don't say what your MTA is, and I'm no expert on courier IMAP, but with sendmail and dovecot they most definitely do not, by default, use the same ...


1

I just needed to run courier-dovecot-migrate.pl script again because i did that only some time ago. After that, everything works fine. More info - http://wiki.dovecot.org/Migration/Courier


1

Courier imapd tries to do reverse DNS and ident lookups by default. Make sure you disable these, as one or the other (or both) is the most likely cause (and doing reverse DNS lookups at connection time leads to bad security). For instance: /usr/lib/courier-imap/libexec/couriertcpd ... -nodnslookup -noidentlookup ... Check your system's startup scripts to ...


1

That is what the autodiscover mechanism is for. I assume use Outlook. You have to set up the subdomain and provide an autodiscover.xml. Here are some tips for that. For other clients there can be other ways. Thunderbird for example uses autoconfig instead.


1

Have a look at the authdaemonrc (if I remember correctly) config file. It should have the details on how it authenticates. If it's for example using ldap, see whether your ldap server is still there, if it's using mysql... Fix this and you'll probably fix your issue.


1

It is possible to have multiple IMAP servers installed in parallel. You may select which IMAP server you'd like to run by starting it via the init script. For example, to stop your courier-map issue: # /etc/init.d/courier-imap stop Note, I'm not running courier-imap so please double check on the init script name. To install dovecot: # yum -y install ...


1

Looks like the connection handler process is crashing for some reason. I'd advise the user to downgrade to the version they were previously using, or upgrade all its dependencies. Reinstalling may also help.


1

I found a Solution for this problem. http://ubuntuforums.org/showthread.php?s=fba71f803c489876a75fb08df822a930&p=11856138


1

You can find out which SSL/TLS library Courier is using by typing ldd /usr/bin/couriertls (this could be a different path on another distribution). You'll see that on Ubuntu 12.04, it's compiled against OpenSSL (as the package dependencies also indicate: see courier-ssl and courier-imap-ssl). If you want it to be compiled against GnuTLS, you'll have to ...


1

Solved my problem by removing our domain from mydestinations and allowing Postfixadmin to send a welcome message upon creation. Apparently the mail directories are created when the email arrives, so the sending of welcome message takes care of it.



Only top voted, non community-wiki answers of a minimum length are eligible